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IMPORTANT!

READ CAREFULLY BEFORE USE.

KEEP THIS GUIDE FOR FUTURE REFERENCE.

This is a User’s Guide for a series of products. Not all products support all firmware features. Screenshots 
and graphics in this book may differ slightly from your product due to differences in product features or 
web configurator brand style. Every effort has been made to ensure that the information in this manual 
is accurate. 

Note: The version number on the cover page refers to the Zyxel Device’s latest firmware 
version to which this User’s Guide applies.

Related Documentation
• Quick Start Guide 

The Quick Start Guide shows how to connect the Zyxel Device and access the Web Configurator 
wizards. (See the wizard real time help for information on configuring each screen.) It also contains a 
connection diagram and package contents list.

• CLI Reference Guide

The CLI Reference Guide explains how to use the Command-Line Interface (CLI) to configure the 
Zyxel Device.

Note: It is recommended you use the Web Configurator to configure the Zyxel Device.

• Web Configurator Online Help

Click the help icon in any screen for help in configuring that screen and supplementary information.

• Nebula Control Center (NCC) User’s Guide

This User’s Guide shows you how to manage the Zyxel Device remotely using NCC.

• More Information

Go to support.zyxel.com to find other information on the Zyxel Device.
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Document Conventions

Warnings and Notes

These are how warnings and notes are shown in this guide. 

Warnings tell you about things that could harm you or your device.

Note: Notes tell you other important information (for example, other things you may need to 
configure or helpful tips) or recommendations.

Syntax Conventions
• All models in this series may be referred to as the “Zyxel Device” in this guide.

• Product labels, screen names, field labels and field choices are all in bold font.

• A right angle bracket ( > ) within a screen name denotes a mouse click. For example, Network > 
Interface > Ethernet means you first click Network, then the Interface sub menu and finally the 
Ethernet tab to get to that screen.

Icons Used in Figures

Figures in this user guide may use the following generic icons. The Zyxel Device icon is not an exact 
representation of your device. 

Zyxel Device Generic Router Wireless Router / Access Point

Switch Firewall Server 

Internet Network Cloud Smartphone

USB Dongle
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CHAPTER 1
Introduction

1.1  Overview
Zyxel Device refers to these models as outlined below.

• USG FLEX 100H

• USG FLEX 100HP

• USG FLEX 200H

• USG FLEX 200HP

• USG FLEX 500H

• USG FLEX 700H

1.1.1  Fast-path Acceleration
Fast-path Acceleration is a way to speed up certain traffic such as NAT, IPSec VPN, Security policies 
through the Zyxel Device by bypassing the kernel. SSL VPN traffic does not use fast-path acceleration. 

1.1.2  Model Feature Differences
Note the following differences between the these models:

Table 1   Zyxel Device Model Feature Comparison 

FEATURE/MODEL USG FLEX 
100H

USG FLEX 
100HP

USG FLEX 
200H

USG FLEX 
200HP

USG FLEX 
500H

USG FLEX 
700H

DoS Prevention YES YES YES YES YES YES

IPS YES YES YES YES YES YES

Anti-Malware YES YES YES YES YES YES

App Patrol YES YES YES YES YES YES

Content Filter YES YES YES YES YES YES

SecuReporter YES YES YES YES YES YES

Reputation Filter YES YES YES YES YES YES

Sandboxing YES YES YES YES YES YES

Device Insight YES YES YES YES YES YES

IP Exception YES YES YES YES YES YES

SSL encrypted traffic YES YES YES YES YES YES

Bundled Security 
Feature License 

1 year 1 year 1 year 1 year 1 year 1 year

Management by 
Nebula Control 

YES YES YES YES YES YES
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• Not all models support all features. See Table 1 on page 17 for the specific features that your model 
supports. 

For information on interface names by model, default port or interface name mapping, and default 
interface or zone mapping please see Section 3.1.2 on page 46.

See the product’s datasheet for detailed information on a specific model.

1.2  Registration at Nebula Control Center (NCC)
Nebula Control Center (NCC) is an Internet portal that allows you to configure and monitor groups of 
Zyxel Devices in organizations. You must register your Zyxel Device at NCC to use security services and 
upgrade firmware. See Licensing > Licenses for security services available for your Zyxel Device. 

Use NCC to monitor and manage your Zyxel Device. Use the web configurator to configure the Zyxel 
Device settings.

Run the initial setup wizard to register your Zyxel Device at NCC. Or you can follow the steps below to 
register your Zyxel Device at NCC.

1 Log into NCC (https://nebula.zyxel.com) with your Zyxel Account. If you do not have a Zyxel Account, 
you should click Create an account to create one.

2 After you log in, click Go under NCC and then Let’s Start to run the NCC setup wizard. Create an 
organization and a site or select an existing site.

3 Add the Zyxel Device to this site by entering its MAC address and serial number. You’ll find the Zyxel 
Device MAC address and serial number on its label or scan the QR code using the Nebula Mobile app.

4 Configure the WAN interface that the Zyxel Device will use to connect to NCC through the Internet. 

If you did not register your Zyxel Device at NCC, you will see a reminder to register every time you log 
into the Zyxel Device web configurator with an admin account.

1.3  Licenses
When you purchase a new Zyxel Device, it comes with the Gold Security Pack license. This license is valid 
for one year.

The Gold Security Pack license consists of the following services at the time of writing. See Licensing > 
Licenses for the latest services available for your Zyxel Device. 

• Application Patrol

Table 2   Security Feature List
• Application Patrol • Intrusion Prevention System (IPS)

• DoS Prevention • Content Filtering

• Anti-Malware • Secure Socket Layer (SSL) encrypted 
traffic Inspection

https://nebula.zyxel.com
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• Sandboxing

• Web Filtering

• Anti -Malware

• Reputation Filter, including IP Reputation, URL Threat Filter, DNS Threat Filter services and External 
Blocking Lists (EBL) for these services

• SecuReporter

• Nebula Professional Pack

• Device Insight 

• IPS (Intrusion Prevention System).

1.3.1  License Priority
New licenses queue until existing licenses expire. If you buy a new Gold Security Pack, these licenses will 
be used only after licenses in the existing Gold Security Pack expire.

1.3.2  Grace Period
Service licenses have a 15-day grace period after a license expires. Services will continue to work in this 
period during which you will receive notifications to renew your licenses. New licenses are valid for 1 
year from the date of purchase.

Please note that a trial license does not have a grace period. 

1.4  Applications
These are some Zyxel Device application scenarios.

1.4.1  Security Router
Security includes a Stateful Packet Inspection (SPI) firewall.
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Figure 1   Applications: Security Router Applications: Security Router

1.4.2  VPN Connectivity
Set up VPN tunnels with other companies, branch offices, telecommuters, and business travelers to 
provide secure access to your network. AS is an Authentication Server in the below figure.

Figure 2   Applications: VPN Connectivity

1.4.3  User-Aware Access Control
Set up security policies to restrict access to sensitive information and shared resources based on the user 
who is trying to access it. In the following figure user A can access both the Internet and an internal file 
server. User B has a lower level of access and can only access the Internet. User C is not even logged in, 
so and cannot access either the Internet or the file server.
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Figure 3   Applications: User-Aware Access Control

1.4.4  Load Balancing
Set up multiple connections to the Internet on the same port, or different ports. In either case, you can 
balance the traffic loads between them.

Figure 4   Applications: Multiple WAN Interfaces

1.5  Management Overview
You can manage the Zyxel Device in the following ways.

Web Configurator

The Web Configurator allows easy Zyxel Device setup and management using an Internet browser. This 
User’s Guide provides information about the Web Configurator.
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Figure 5   Managing the Zyxel Device: Web Configurator

Command-Line Interface (CLI)

The CLI allows you to use text-based commands to configure the Zyxel Device. Access it using remote 
management (for example, SSH) or via the physical port. See the Command Reference Guide for CLI 
details. The default settings for the console port are:

FTP

Use File Transfer Protocol for firmware upgrades and configuration backup or restore.

SNMP

The device can be monitored and/or managed by an SNMP manager. See Section 26.4 on page 403.

Management Authentication

Managers must be authenticated with a username and password, using one of:

• Local Zyxel Device authentication

• An external RADIUS server

• Certificates

Table 3   Console Port Default Settings 
SETTING VALUE
Speed 115200 bps

Data Bits 8

Parity None

Stop Bit 1

Flow Control Off
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1.6  Web Configurator
The Web Configurator is an HTML-based management interface that allows easy system setup and 
management through Internet browser. Use a browser that supports HTML5, such as Microsoft Edge, 
Mozilla Firefox, or Google Chrome. 

In order to use the Web Configurator you need to allow:

• Web browser pop-up windows from your device.

• JavaScript (enabled by default).

The recommended minimum screen resolution is 1366 x 768 pixels.

Note: Screenshots and graphics in this book may differ slightly from your product due to 
differences in product features or Web Configurator brand style.

1.6.1  Web Configurator Access

1 Make sure your Zyxel Device hardware is properly connected. See the Quick Start Guide.

2 In your browser go to https://192.168.168.1. By default, the Zyxel Device automatically routes this request 
to its HTTPS server, and it is recommended to keep this setting. The Login screen appears.

3 Select a display language for the Zyxel Device’s web configurator screens in the upper right of the 
screen. The following are the languages supported at the time of writing. 
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4 Type the user name (default: “admin”) and password (default: “1234” or see the label on the back of 
the Zyxel Device).

5 Click Login. After you log in for the first time using the default user name and password, you must 
change the default admin password in the Update Admin Info screen. Enter a new password of from 1 
to 64 characters.

Make a note of your new password, enter it in the following screen, then click Apply. The Login screen 
appears again. Log in with your new password.

1.6.2  Remote Access to the Zyxel Device Networks
Your Zyxel Device keeps your networks safe while allowing external access by applying the security 
measures below:

• Two-Factor Authentication: Use two-factor authentication to have double-layer security to access a 
secured network behind the Zyxel Device. The first layer is the VPN client/Zyxel Device’s login user 
name / password. The second layer is an authorized SMS (via mobile phone number) or email 
address. See Section 25.4 on page 379 for more information on two-factor authentication.
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• IPSec VPN: You can create highly secure connections with IKEv2 or EAP authentication to access 
networks behind the Zyxel Device. For example, home workers can securely access company 
resources if they have proper authentication. See Chapter 12 on page 176 for more information on 
IPSec VPN.

1.6.3  Web Configurator Screens Overview
The Web Configurator screen is divided into these parts:

• A – title bar

• B – navigation panel

• C – main window
Figure 6   Web Configurator Screen Overview

Title Bar
Figure 7   Title Bar
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The title bar icons in the upper right corner provide the following functions.

About 

Click About to display basic information about the Zyxel Device.

Figure 8   About

Table 4   Title Bar: Web Configurator Icons 
LABEL DESCRIPTION
Language Select a display language for the Zyxel Device’s web configurator screens.

More

About: Click this to display basic information about the Zyxel Device.

Nebula: Click this to go to https://nebula.zyxel.com/ to monitor or manage your Zyxel Device 
using Nebula.

SecuReporter: Click this to go to https://secureporter.cloudcnm.zyxel.com/ for security 
analytics.

Help

Online Help: Click this to open the help page for the current screen.

Tutorial Video: Click this to go to YouTube to see related Zyxel Device configuration videos.

Community: Click this to go to https://community.zyxel.com/en/categories/security for security 
product line discussions.

Notification What’s New: Click this to open a PDF file to display what’s new in the Zyxel Device firmware.

New Features: Click this to display new features with new GUI screens. Click the link to be 
directed to the new GUI screens.

User

Change Password: This is for an admin account type only. Click this to change the account 
password. You will need to log in again using the new password.

Logout: Click this log out of the Web Configurator.

https://nebula.zyxel.com/
https://secureporter.cloudcnm.zyxel.com/
https://community.zyxel.com/en/categories/security
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This table describes the fields in this screen.

1.6.4  Navigation Panel
Use the navigation panel menu items to open status and configuration screens. Click the arrow of the 
navigation panel to hide the panel. Type an entry in the Search box to find a menu item containing that 
entry. The following sections introduce the Zyxel Device’s navigation panel menus and their screens.

Table 5   About 
LABEL DESCRIPTION
Current Version This shows the firmware version of the Zyxel Device.

Release Date This shows the date (yyyy-mm-dd) and time (hh:mm:ss) when the firmware is released.

System 
Protection 
Signature

This shows the system protection signature version of the Zyxel Device. These signatures do not 
require a license. The Zyxel Device will synch with the Cloud Helper Server every day to update 
these signatures automatically.

System protection signatures protect your Zyxel Device and local networks from web attacks, 
such as command injection, cross-site scripting and path traversal.

Command injection: This is an attack in which an attacker uses the Zyxel Device vulnerabilities 
to execute commands to control your Zyxel Device.

Cross-site scripting: This is an attack in which an attacker implants malicious scripts in a website. 
When you visit this website, the malicious scripts are sent and executed on your web browser.

Path traversal: This is an attack that allows an attacker to access files you store in the web root 
folder.
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Figure 9   Navigation Panel

Dashboard Screens

The dashboard displays general device information, system status, system resource usage, licensed 
service status, and interface status in widgets that you can re-arrange to suit your needs. See the Web 
Help for details on the dashboard.

Table 6   Dashboard Menu Screens Summary
FOLDER OR LINK TAB FUNCTION
System Collect and display the Zyxel Device system information, such as serial 

number, MAC address and CPU usage.

Security Collect and display security event statistics.
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Monitoring Screens

The monitoring screens display status and statistics information.

Table 7   Monitoring Menu Screens Summary 
FOLDER OR LINK TAB FUNCTION
Traffic Statistics

Application 
Usage

Application 
Usage

Collect and display application statistics.

Port Port Collect and display port statistics.

Interface Interface Collect and display interface statistics.

Session Monitor Session 
Monitor

Collect and display session statistics.

Security Statistics

Content Filter Content Filter Collect and display content filter statistics

Reputation Filter IP Reputation Collect and display IP reputation statistics.

DNS Threat 
Filter

Collect and display DNS threat filter statistics.

URL Threat 
Filter

Collect and display URL threat filter statistics.

IPS IPS Collect and display statistics on the intrusions that the Zyxel Device has 
detected.

Anti-Malware Anti-Malware Collect and display anti-malware statistics.

Sandbox Sandbox Displays the sandbox statistics.

SSL Inspection Summary Collect and display SSL Inspection statistics.

Certificate 
Cache List

Display traffic to destination servers using certificates.

Network Status

Interface Interface Display the status of Zyxel Device interfaces.

Device Insight Device 
Insight

Displays a list of WiFi and wired clients connected to the Zyxel Device local 
networks.

Login Users Login User List the users currently logged into the Zyxel Device.

DHCP Table DHCP Table Display a list of interfaces and their DHCP-assigned IP addresses.

VPN Status

IPSec VPN Site to Site 
VPN

Display and manage the Zyxel Device IPSec VPN connections with remote 
IPSec VPN routers that have static IP addresses or a domain names.

Remote 
Access VPN

Display and manage IPSec VPN connections from external users who want to 
access the networks behind the Zyxel Device.

SSL VPN Remote 
Access VPN

Display and manage SSL VPN connections from external users who want to 
access the networks behind the Zyxel Device.
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Configuration Screens

Use the configuration screens to configure the Zyxel Device’s features. 

Table 8   Configuration Menu Screens Summary 
FOLDER OR LINK TAB FUNCTION
Services

Licensing Licenses Displays if the Zyxel Device is registered and licenses purchased.

Signature Update Use this screen to update signatures immediately or by a schedule.

Network

Interface Interface Use this screen to:

• Create and manage Ethernet interfaces.
• Create and manage VLAN interfaces.
• Create and manage bridge interfaces.
• Configure LAG parameters.
• Configure IP address assignment and interface parameters for VTI 

(Virtual Tunnel Interface).

Trunk Create and manage trunks (groups of interfaces) for load balancing.

Port Use this screen to configure the Zyxel Device port settings.

Routing Policy Route Create and manage routing policies.

Static Route Create and manage IP static routing information.

NAT NAT Set up and manage port forwarding rules.

BWM BWM Control bandwidth for services passing through the Zyxel Device, and 
identify the conditions for bandwidth control.

ALG ALG Configure FTP pass-through settings.

VPN

IPSec VPN Site to Site VPN Configure Zyxel Device IPSec VPN connections with remote IPSec VPN 
routers that have static IP addresses or a domain names.

Remote Access VPN Configure IPSec VPN connections for external users who want to 
access the networks behind the Zyxel Device.

SSL VPN General Configure SSL VPN connections for external users who want to access 
the networks behind the Zyxel Device.

Security Policy

Policy Control Policy Control Create and manage level-3 traffic rules and apply Security Service 
profiles.

DoS Prevention DoS Prevention 
Policy

Display and manage ADP bindings.

Profile Create and manage DoS prevention profiles.

Session Control Session Control Limit the number of concurrent client NAT/security policy sessions.

Object

Address Address Create and manage host, range, and network (subnet) addresses.

Address Group Create and manage groups of addresses to apply to policies as a 
single objects.

Geo IP Update the database of country-to-IP address mappings and 
manually configure country-to-IP address mappings for geographic 
address objects that can be used in security policies.

Service Service Create and manage TCP and UDP services.

Service Group Create and manage groups of services to apply to policies as a single 
object.
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Zone Zone Configure zone templates used to define various policies.

Schedule Schedule Create one-time and recurring schedules.

Schedule Group Create and manage groups of schedules to apply to policies as a 
single object.

Security Service

App Patrol App Patrol Manage different types of traffic in this screen. Create App Patrol 
template(s) of settings to apply to a traffic flow using a security policy.

Content 
Filtering

Content Filtering Use this screen to:

• Create and manage the detailed filtering rules for HTTP(S) traffic 
scan and DNS domain scan.

• Create a list of allowed web sites that bypass HTTP(S) traffic scan 
and DNS domain scan.

• Create a list of web sites to block regardless of content filtering 
policies.

Reputation 
Filter

IP Reputation Enable IP reputation and specify what action the Zyxel Device takes 
when any IP address with bad reputation is detected.

You can also set up an allow list to identify which IPv4 addresses 
should be allowed, and a block list to identify which IPv4 addresses 
should be blocked.

DNS Threat Filter Enable DNS threat filtering and specify what action the Zyxel Device 
takes when a access attempt to a blocked Fully Qualified Domain 
Name (FQDN) is detected.

You can also set up an allow list to identify which FQDNs should be 
allowed, and a block list to identify which FQDNs should be blocked.

URL Threat Filter Enable URL filtering and specify what action the Zyxel Device takes 
when a access attempt to a blocked website is detected.

You can also set up an allow list to identify which IPv4 addresses and/
or URLs should be allowed, and a block list to identify which IPv4 
addresses and/or URLs should be blocked.

Anti-Malware Anti-Malware Enable, specify actions to take when encountering malware or 
compressed files, and set up a block list to identify files with malware 
file patterns and an allow list to identify files that should not be 
checked for malware.

Sandbox Sandbox Enable sandbox, and specify the actions the Zyxel Device takes when 
files with unknown or untrusted programs are detected.

IPS IPS Enable and configure IPS settings. Create, import, or export custom 
signatures.

Allow List Configure signatures that will be exempted from IPS inspection.

IP Exception IP Exception Use this screen to view the IP exception list for the anti-malware, 
reputation filter and IPS (Intrusion Prevention System) features.

The Zyxel Device will not intercept nor inspect the incoming packets 
that match the rules in the IP exception list for the anti-malware and/
or IPS (Intrusion Prevention System) features.

SSL Inspection Profile Decrypt HTTPS traffic for Security Service inspection. Create SSL 
Inspection templates of settings to apply to a traffic flow using a 
security policy.

Exclude List Configure services to be excluded from SSL Inspection.

Certificate Update Use this screen to update the latest certificates of servers using SSL 
connections to the Zyxel Device network.

Table 8   Configuration Menu Screens Summary (continued)
FOLDER OR LINK TAB FUNCTION
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External Block 
List

IP Reputation Set up an external block list which uses block list entries of IP addresses 
with bad reputations stored in a file on a web server that supports HTTP 
or HTTPS and is reachable from the Zyxel Device. The Zyxel Device will 
block incoming and outgoing packets from the black list entries in this 
file.

DNS Threat Filter/URL 
Threat Filter

Set up an external block list which uses block list entries of blocked 
Fully Qualified Domain Names (FQDN) or blocked URLs stored in a file 
on a web server that supports HTTP or HTTPS and is reachable from the 
Zyxel Device. The Zyxel Device will block incoming and outgoing 
packets from the black list entries in this file.

User & Authentication

User/Group User Create and manage users.

Group Create and manage groups of users.

Setting Manage default settings for all users, general settings for user sessions, 
and rules to force user authentication.

User 
Authentication

AAA Configure the default authentication server (Local/LDAP/AD/RADIUS) 
to use for user authentication.

Two-factor 
Authentication

Configure Google Authenticator to access a secured network behind 
the Zyxel Device via the web configurator or SSH connection.

System

Settings Settings Use this screen to configure:

• The Zyxel Device host name.
• System time settings.
• Remote access to the Zyxel Device settings.
• The web configurator language display settings.

DNS & DDNS DNS Configure the DNS server and address records for the Zyxel Device.

DDNS Define and manage the Zyxel Device’s DDNS domain names.

SNMP SNMP Configure SNMP communities and services.

Notification Mail Server Configure a mail server with authentication to send reports and 
password expiration notification emails.

Alert Enable to have the Zyxel Device send reports and password expiration 
notification mails.

Certificate My Certificates Create and manage the Zyxel Device’s certificates.

Trusted Certificates Import and manage certificates from trusted sources.

Advanced System Parameters Edit default Zyxel Device parameters such as UDP/ICMP timeout, ARP 
spoofing, device insight and LLDP.

Log & Report

Log / Events Log / Events Use this screen to view the Zyxel Device logs.

Log Setting Log Settings Configure the system log, email logs, and remote syslog servers.

SecuReporter SecuReporter Enable SecuReporter logging and access the SecuReporter security 
analytics portal that collects and analyzes logs from your Zyxel Device 
in order to identify anomalies, alert on potential internal or external 
threats, and report on network usage.

Email Daily 
Report

Email Daily Report Select statistics to email in a daily report.

Table 8   Configuration Menu Screens Summary (continued)
FOLDER OR LINK TAB FUNCTION
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Maintenance Screens

Use the maintenance screens to manage configuration and firmware files, run diagnostics, and reboot 
or shut down the Zyxel Device.

1.6.5  Tables and Lists
Web Configurator tables and lists are flexible with several options for how to display their entries.

Click a column heading to sort the table’s entries according to that column’s criteria.

Figure 10   Sorting Table Entries by a Column’s Criteria

Click the Resize icon ( ) to adjust how to display column entries. If you manually adjusted the width of 
the columns, click Reset to return them to the original widths. If you have a big monitor and want to see 
complete information in each column field, click Fit Content. If your monitor is not so big and you want 
to see all columns in the screen, click Fit View. 

Figure 11   Fit Content 

Table 9   Maintenance Menu Screens Summary 
FOLDER OR LINK TAB FUNCTION
Maintenance

Firmware/File 
Manager

Configuration File Manage and upload configuration files for the Zyxel Device.

Firmware 
Management

View the current firmware version and upload firmware.

Diagnostics Diagnostics Collect diagnostic information.

Packet Capture Capture packets for analysis.

CPU/Memory 
Status

View CPU and memory usage statistics.

System Log View the files of diagnostic information the Zyxel Device has collected 
and stored on a connected USB storage device.

Network Tool Identify problems with the connections. You can use Ping or 
Traceroute to help you identify problems.

Reboot/
Shutdown

Reboot/Shutdown Restart or turn off the Zyxel Device.
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Figure 12   Fit View

Click the column icon ( ) for more options about how to display the entries. The options available 
vary depending on the type of fields in the column. You can select which columns to display by 
selecting or clearing the check box.The tables have icons for working with table entries.

Figure 13   Common Table Icons

1.6.6  Error Messages
Some screens may display an error message if there is a parsing or time-out error. Use Test in 
Maintenance > Firmware/File Manager > Configuration to see if the currently running configuration file 
has an error. 

Figure 14   Parsing Error

Figure 15   Timeout Error
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CHAPTER 2
Initial Setup Wizard

2.1  Initial Setup Wizard Overview 
When you log into the Web Configurator for the first time or when you reset the Zyxel Device to its 
default configuration, the Initial Setup Wizard screen displays. This wizard helps you configure Internet 
connection settings and activate subscription services.

Note: You must register your Zyxel Device at Nebula Control Center (NCC) to use security 
services and upgrade firmware. NCC is an Internet portal that allows you to monitor 
and manage groups of Zyxel Devices in organizations.

This chapter provides information on configuring the Web Configurator's Initial Setup Wizard. See the 
feature-specific chapters in this User’s Guide for background information. 

You will be logged out of the Zyxel Device initial setup wizard after 1440 minutes. The settings you 
configured will be saved. Log into the Zyxel Device again if you have not finished configuring the initial 
setup wizard settings.

Click Next to continue the wizard. Click Finish at the end of the wizard to complete the wizard.

2.1.1  Terms of Use/Privacy Policy/Firmware Upgrade Notification
Click the links to see:

• What data Zyxel collects from you and how it is used

• Zyxel privacy policy.

Please also read the firmware upgrade notification carefully.

To use SecuReporter and sandbox, you need to allow Zyxel to collect data from you. 

Select I have read and agree with the items above. SecuReporter and sandbox will be enabled 
automatically when you select the check box.

Click Next to configure the Zyxel Device settings with the initial setup wizard.

Note: You cannot proceed with the initial setup wizard if you do not select the check box.
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Figure 16   Terms of Use/Privacy Policy/Mandatory Firmware Upgrade Notification

2.2  Connect to the Internet
Use this screen to set the interface’s type of encapsulation and method of IP address assignment.

The screens vary depending on the encapsulation type. Refer to information provided by your ISP to 
know what to enter in each field.

Go to Network > Interface after you log into the web configurator if you want to change the interface 
settings.

Note: Enter the Internet access information exactly as your ISP gave it to you. Leave a field 
blank if you don’t have that information.

2.2.1  Interface Type - DHCP
Use this screen to configure your IP address settings. 

• Interface Type: This displays the type of Internet connection you are configuring. Select DHCP if your 
ISP did not assign you a fixed IP address.

• Port: Select a port to apply the Internet connection settings to.

• IP Address: This field is read-only when you set Interface Type to DHCP.

• DHCP Option 60: DHCP Option 60 is used by the Zyxel Device for identification to the DHCP server 
using the VCI (Vendor Class Identifier) on the DHCP server. The Zyxel Device adds it in the initial DHCP 
discovery message that a DHCP client broadcasts in search of an IP address. The DHCP server can 
assign different IP addresses or options to clients with the specific VCI or reject the request from clients 
without the specific VCI.

Type a string using up to 63 of these characters a-zA-Z0-9!\"#$%&'()*+,-./:;<=>?@[]^_`{}to identify this 
Zyxel Device to the DHCP server. For example, Zyxel-TW.

• VLAN Tag: Enable to tag the traffic going out from the Zyxel Device.
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• VLAN ID: Enter a VLAN ID. This 12-bit number uniquely identifies each VLAN. Allowed values are 1-4080.

• Connection Test: Click Connection Test to check that you can access the Internet. If you cannot, click 
Back and confirm that you entered the settings correctly. If you have, check that you got the correct 
settings from your ISP or network administrator.

Figure 17   Interface Type - DHCP

2.2.2  Interface Type - Static
Use this screen to configure your IP address settings. 

• Interface Type: This displays the type of Internet connection you are configuring. Select Static if your 
ISP assigned you a fixed IP address.

• Port: Select a port to apply the Internet connection settings to.

• WAN IP: Enter your (static) public IP address.

• Subnet Mask: Enter the subnet mask for this WAN connection's IP address.

• Default Gateway: Enter the IP address of the router through which this WAN connection will send 
traffic (the default gateway). 

• First / Second DNS Server: These fields display if you selected static IP address assignment. The Domain 
Name System (DNS) maps a domain name to an IP address and vice versa. Enter a DNS server's IP 
address(es). The DNS server is extremely important because without it, you must know the IP address 
of a computer before you can access it. The Zyxel Device uses these (in the order you specify here) to 
resolve domain names for VPN, DDNS and the time server. Leave the field as 0.0.0.0 if you do not want 
to configure DNS servers. 

• VLAN Tag: Enable to tag the traffic going out from the Zyxel Device.

• VLAN ID: Enter a VLAN ID. This 12-bit number uniquely identifies each VLAN. Allowed values are 1-4080.

• Connection Test: Click Connection Test to check that you can access the Internet. If you cannot, click 
Back and confirm that you entered the settings correctly. If you have, check that you got the correct 
settings from your ISP or network administrator.
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Figure 18   Interface Type - Static

2.2.2.1  Possible Errors
• Check that the cable is connected from the WAN port (port 1 or port 2) to the Internet.

• Check that the interface is connected to the device you’re using for Internet access such as a 
broadband router, and that the router is turned on. 

• If your Zyxel Device was not able to obtain an IP address, check that your Internet access information 
uses DHCP as the WAN connection type. If it fails again, check with your Internet service provider or 
administrator for correct WAN settings.

• If your Zyxel Device was not able to use the IP address entered, check that you enter correctly the IP 
address, subnet mask and gateway IP address exactly as given. If it fails again, check with your 
Internet service provider or administrator for the correct IP address, subnet mask and gateway 
address and other WAN settings.

2.2.3  Interface Type - PPPoE
Use this screen to configure your IP address settings. 

• Interface Type: This displays the type of Internet connection you are configuring. Select PPPoE for a 
dial-up connection according to the information from your ISP.

• Port: Select a port to apply the Internet connection settings to.

• User Name: Enter the user name given to you by your ISP. You can use up to 64 single-byte 
characters, including 0-9a-zA-Z-_@$ . /+ # ; :%\~^&*() " = {}[]|? ,< ' >'. The user name must begin with 
0-9a-zA-Z-_@$ . /+. Spaces are not allowed.

• Password: Enter the password associated with the user name. You can use up to 63 single-byte 
characters, including 0-9a-zA-Z-_@$ . /+ # ; :%\~^&*() "= {}[]|! ,<'>'. Spaces are not allowed. This field 
cannot be blank.

• VLAN Tag: Enable to tag the traffic going out from the Zyxel Device

• VLAN ID: Enter a VLAN ID. This 12-bit number uniquely identifies each VLAN. Allowed values are 1-4080.
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• Connection Test: Click Connection Test to check that you can access the Internet. If you cannot, click 
Back and confirm that you entered the settings correctly. If you have, check that you got the correct 
settings from your ISP or network administrator.

Figure 19   Interface Type - PPPoE

2.2.3.1  Possible Errors
Make sure that your Internet access information uses PPPoE as the WAN connection type. Re-enter your 
PPPoE user name and password exactly as given. If it fails again, check with your Internet service 
provider or administrator for correct WAN settings and user credentials. 

2.3  System Time
It’s important to have correct date and time values in the logs. The Zyxel Device can automatically 
update the time and date by detecting your time zone and whether Daylight Savings is in effect in that 
time zone.

If your Zyxel Device cannot get the correct date and time, it may not able to connect to a time server. 
Check the time server settings in System > Settings after you log into the Zyxel Device.
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Figure 20   System Time

2.4  Device Registration
Device registration includes:

• Adding your Zyxel Device to a site in an organization at NCC

• Activating Zyxel Device service licenses

If you previously activated your service licenses at another Zyxel portal such as myZyxel.com or Circle, 
you can still use all Zyxel Device services except for SecuReporter and remote support through Nebula. 
Add your Zyxel Device to a site in an organization at NCC to be able to use these features also.

If you did not previously activate your service licenses at another Zyxel portal such as myZyxel.com or 
Circle, then you must add your Zyxel Device to a site in an organization at NCC in order to activate your 
Zyxel Device service licenses, including SecuReporter, perform firmware upgrades and avail of remote 
support through Nebula.

After you successfully register your Zyxel Device, security services supported by your model will be 
activated automatically.

Click the Register button in this screen to add your Zyxel Device to a site in an organization at Nebula. 
There are two ways to add your Zyxel Device to a site at NCC.

• Automatically add it by scanning the QR code to use the Nebula Mobile app.

• Manually add it by entering the Zyxel Device’s serial number and LAN MAC address at NCC. See the 
label at the back of the Zyxel Device for this information.

https://nebula.zyxel.com/
https://nebula.zyxel.com/
https://nebula.zyxel.com/
https://nebula.zyxel.com/
https://nebula.zyxel.com/
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Note: The Zyxel Device must be connected to the Internet in order to connect to NCC.

Click Refresh or use the Licensing > Licenses screen after you log into the web configurator to have the 
Zyxel Device connect to NCC to update its registration status.

The Registration Status field may display Registered or Not registered.

• Registered: Your Zyxel Device has been successfully added to a site in  NCC.

• Not registered: Your Zyxel Device has not been successfully added to a site in NCC. Make sure the 
Zyxel Device is connected to the Internet. Wait a few minutes, then click Refresh to synchronize again.

Figure 21   Register Device 

2.4.1  Exit the Wizard
The Exit button displays if the Zyxel Device is not connected to the Internet when you are at the Device 
Registration step. You will be redirected to the Zyxel Device login page after you click Exit.

If you did not previously activate your service licenses at another Zyxel portal, then you must add your 
Zyxel Device to a site in an organization at NCC in order to activate your Zyxel Device service licenses, 
including SecuReporter, perform firmware upgrades and avail of remote support through Nebula.

https://nebula.zyxel.com/
https://nebula.zyxel.com/
https://nebula.zyxel.com/
https://nebula.zyxel.com/
https://nebula.zyxel.com/
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Figure 22   Exit Wizard 

Make sure to go to Licensing > Licenses and follow the instructions to register your Zyxel Device once 
your Zyxel Device is connected to the Internet. Please note that you will only see the following screen if 
you log in using an admin account.

Figure 23   Licensing > Licenses 

You will also see a warning message to remind you to register your Zyxel Device every time you log into 
the web configurator. Please note that you will only see the warning message if you log in using an 
admin account.
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Figure 24   Register Warning Message 

2.5  License Summary
After you successfully register your Zyxel Device, security services supported by your model will be 
activated automatically.

Go to Licensing > Licenses after you log into the web configurator if you want to check the Zyxel Device 
services status.

Figure 25   Service Activation

Click Refresh and wait a few moments for the registration information to update in this screen. If the 
page does not refresh, make sure the Internet connection is working and click Refresh again. To check 
your Internet connection, try to access the Internet from a computer connected to a LAN port on the 
Zyxel Device. If you cannot, then check your Internet access settings on the Zyxel Device.
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The Status column may display Activated or Expired.

• Activated: The service license is enabled.

• Expired: The service license has expired. Go to NCC > Organization-wide > License & Inventory to 
renew your license.

2.6  Finish
The following screen displays when you finish the initial setup wizard. Click Finish to log into the Zyxel 
Device web configurator to configure the Zyxel Device settings. Click the Nebula Control Center (NCC) 
hyperlink to go to NCC to monitor and manage your Zyxel Device.

Figure 26   Finish
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CHAPTER 3
Hardware, Interfaces and 

Zones

3.1  Hardware Overview
This section describes the front and rear panels for each model.

The following table summarizes the port features of the Zyxel Device by model.

For information on interface names by model, default port or interface name mapping, and default 
interface or zone mapping please see Section  on page 60.

3.1.1  Multi-Gigabit
Multi-Gigabit Ethernet ports automatically allow connections up to the speed of the connected network 
device (100M, 1G, 2.5G, 5G, or 10G), and you just need to use a CAT 5e or CAT 6 Ethernet cable. You 
must use CAT 6A or better Ethernet cables to achieve 10G speeds.

The following table shows which models have which Multi-Gigabit ports. 

Table 10   USG FLEX Series Port Comparison Table

USG FLEX MODELS USG FLEX 
100H

USG FLEX 
100HP

USG FLEX 
200H

USG FLEX 
200HP

USG FLEX 
500H

USG FLEX 
700H

USB 3.0 Ports 1 1 1 1 1 1

10 Gbps SFP+ interface - - - - - 2

PoE+ Port - 1 - 1 2 2

10/100/1000 Mbps Ethernet 
Ports

8 8 6 6 8 8

Multi-Gigabit Ethernet Ports - - 2 2 4 4

Console Port 1 (RJ45) 1 (RJ45) 1 (RJ45) 1 (RJ45) 1 (RJ45) 1 (RJ45)

Table 11   USG FLEX Series Multi-Gigabit Port Comparison

USG FLEX MODELS USG FLEX 
200H

USG FLEX 
200HP USG FLEX 500H USG FLEX 700H

2.5 Gbps Multi-Gigabit 
Ethernet Ports

P1, P2 P1, P2 P1, P2, P3, P4 P1, P2

10 Gbps Multi-Gigabit 
Ethernet Ports

P3, P4
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See the following table for the cables required and distance limitation to attain the corresponding 
speed.

3.1.2  Default Physical Port – Interface Mapping
You connect cables to the physical ports. You configure interfaces in the web configurator or 
command line interface (CLI).

The following table shows the default interfaces for each physical port.

Note: You change the default zone for all interfaces in Network > Interface and Object > 
Zone.

The following shows the default zone for each interface. 

• ge1 and ge2 are WAN

• ge3 and ge4 are LAN

• ‘-’ ports have no default zone, so you must configure a zone for them in Network > Interface and 
Object > Zone

3.1.3  PoE
The Zyxel Device is a Power Sourcing Equipment (PSE) because it provides a source of power through its 
Ethernet ports. Each device that receives power through an Ethernet port is a Powered Device (PD). A 
Powered Device (PD) is a device that receives power through PoE, such as an IP camera, a wireless 
router, an IP telephone or a general outdoor router.

Note: Do not connect the Zyxel Device PoE+ port to a non-Powered Device. If you need to 
connect a non-Powered Device to the Zyxel Device PoE+ port, make sure to disable 
PoE in Network > Interface > Port first.

Table 12   Cable Types
CABLE TRANSMISSION SPEED MAXIMUM DISTANCE BANDWIDTH CAPACITY
Category 5 100M 100 m 100 MHz

Category 5e 1G 100 m 100 MHz

Category 6 1G / 10G 100 m:1G
37-50 m:10G 250 MHz

Category 6a 10G 100 m 500 MHz

Category 7 10G 100 m 600 MHz

Table 13   Default Physical Port – Interface Mapping 
PORT / INTERFACE P1 P2 P3 P4 P5 P6 P7 P8 P9 P10 P11 P12 P13 P14

USG FLEX 100H ge1 ge2 ge3 ge3 ge3 ge3 ge4 ge4

USG FLEX 100HP ge1 ge2 ge3 ge3 ge3 ge3 ge4 ge4

USG FLEX 200H ge1 ge2 ge3 ge3 ge3 ge3 ge4 ge4

USG FLEX 200HP ge1 ge2 ge3 ge3 ge3 ge3 ge4 ge4

USG FLEX 500H ge1 ge2 ge3 ge3 ge3 ge3 ge4 ge4 ge4 ge4 - -

USG FLEX 700H ge1 ge2 ge3 ge3 ge3 ge3 ge4 ge4 ge4 ge4 - - - -
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The following example figure shows a Zyxel Device supplying PoE (Power over Ethernet) to PDs that are 
not within reach of a power outlet.

Figure 27   PoE Application

The Zyxel Device can adjust the power supplied to each PD according to the PoE standard the PD 
supports. PoE standards are:

• IEEE 802.3af Power over Ethernet (PoE)

• IEEE 802.3at Power over Ethernet (PoE+)

The following table describes the PoE features of the Zyxel Device by PoE standard.

Table 14   Zyxel Device PoE Features
POE FEATURES USG FLEX 100HP USG FLEX 200HP USG FLEX 500H USG FLEX 700H
IEEE 802.3 at PoE+ Port 8 Port 2 Port 3-4 Port 3-4

Power Management Mode Consumption 
Classification 
(default)

Consumption 
Classification 
(default)

Consumption 
Classification 
(default)

Consumption 
Classification 
(default)

PoE Power Budget 30W 30W 30W 30W

Table 15   PoE Standards
POE FEATURES POE POE+
IEEE Standard IEEE 802.3af IEEE 802.3at

PoE Type Type 1 Type 2

Switch Port Power

IEEE Power Classification Class 0, 1, 2, 3 Class 4

Maximum Power Per Port 15.4 W 30 W

Port Voltage Range 44 - 57 V 50 - 57 V

Cables
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3.1.4  Front Panels
The LED indicators are located on the front panel.

Figure 28   USG FLEX 100H Front Panel

Figure 29   USG FLEX 100HP Front Panel

Figure 30   USG FLEX 200H Front Panel

Figure 31   USG FLEX 200HP Front Panel

Figure 32   USG FLEX 500H Front Panel

Figure 33   USG FLEX 700H Front Panel

Twisted Pairs Used 2-pair 2-pair

Supported Cables Cat3 or Cat5 Cat5 or better

Table 15   PoE Standards
POE FEATURES POE POE+



 Chapter 3 Hardware, Interfaces and Zones

USG FLEX H Series User’s Guide

49

The following table describes the front panel LEDs.

Table 16   LED Descriptions 
LED COLOR STATUS DESCRIPTION
PWR/SYS Green Off The Zyxel Device is not ready or has failed.

On The Zyxel Device is ready and running.

Blinking The Zyxel Device is booting or upgrading firmware

Red On The Zyxel Device has an error or has failed.

Blinking The Zyxel Device is returning to factory defaults.

USER Green On There are accounts with User Type set as admin logged into the Zyxel 
Device.

Blinking New firmware is available or your license has expired.

Amber On There are IP addresses locked out of the Zyxel Device.

Off USER LED is not enabled in System > Settings.

PoE (PoE1/PoE2) Green On The PoE connected to this port is in AT mode (PoE AT enabled).

Amber On The PoE connected to this port is in AF mode (PoE AF enabled)

Off No PoE is connected to this port (PoE disabled).

P1-P8 (USG FLEX 
100H, USG FLEX 
100HP)

P3-P8 (USG 
FLEX200, USG 
FLEX 200HP)

P5-P12 (USG FLEX 
500H, USG FLEX 
700H)

Amber On This port has a successful 10/100 Mbps link.

Blinking The Zyxel Device is sending or receiving packets on this port at 10/100 
Mbps.

Green On This port has a successful 1 Gbps link.

Blinking The Zyxel Device is sending or receiving packets on this port at 1 Gbps.

Off There is no connection on this port.

P1, P2 (USG FLEX 
200, USG FLEX 
200HP)

P1-P4 (USG FLEX 
500H)

Sky Blue On This port has a successful 2.5 Gbps link.

Blinking The Zyxel Device is sending or receiving packets on this port at 2.5 Gbps.

Green On This port has a successful 1 Gbps link.

Blinking The Zyxel Device is sending or receiving packets on this port at 1 Gbps.

Amber On This port has a successful 100 Mbps link.

Blinking The Zyxel Device is sending or receiving packets on this port at 100 
Mbps.

Off There is no connection on this port.

P3, P4 (USG FLEX 
700H)

Blue On This port has a successful 10 Gbps link.

Blinking The Zyxel Device is sending or receiving packets on this port at 10 Gbps.

Purple On This port has a successful 5 Gbps link.

Blinking The Zyxel Device is sending or receiving packets on this port at 5 Gbps.

Sky Blue On This port has a successful 2.5 Gbps link.

Blinking The Zyxel Device is sending or receiving packets on this port at 2.5 Gbps.

Green On This port has a successful 1 Gbps link.

Blinking The Zyxel Device is sending or receiving packets on this port at 1 Gbps.

Amber On This port has a successful 100 Mbps link.

Blinking The Zyxel Device is sending or receiving packets on this port at 100 
Mbps.

Off There is no connection on this port.



Chapter 3 Hardware, Interfaces and Zones

USG FLEX H Series User’s Guide

50

The following table describes the ports on the front panel.

3.1.5  Rear Panels
The connection ports are located on the rear panel.

P13, P14 SPF+ 
(USF FLEX 700H)

Blue On This port has a successful 10 Gbps link.

Blinking The Zyxel Device is sending or receiving packets on this port at 10 Gbps.

Green On This port has a successful 1 Gbps link.

Blinking The Zyxel Device is sending or receiving packets on this port at 1 Gbps.

Off There is no connection on this port.

Table 17   Front Panel Ports 
LABEL DESCRIPTION
REBOOT Press the button for about 5 seconds to reboot the Zyxel Device.

RESET Press the button in for about 7 seconds (or until the PWR/SYS LED starts to blink), then release it 
to return the Zyxel Device to the default configuration (the Login Password on the back label or 
1234, the LAN IP address is 192.168.168.1 and so on). 

Note: All configuration files including those you saved on the Zyxel Device will be 
deleted.

Press the button in for more than 30 seconds, then release it to return the Zyxel Device to 
factory defaults. The Zyxel Device PWR/SYS LED will blink green while booting up.

USB Connect a storage device for system logs and storage.

P1-P8 (USG FLEX 
200H/USG FLEX 
200HP)

P1-P12 (USG FLEX 
500H/USG FLEX 
700H)

These are 1G/2.5G/10G RJ-45 Ethernet ports.

P13-P14 (USG 
FLEX 700H)

These are 10G SFP+ ports.

CONSOLE You can use the console port to manage the Zyxel Device using CLI commands. You will be 
prompted to enter your user name and password. See the Command Reference Guide for 
more information about the CLI.

When configuring using the console port, you need a computer equipped with 
communications software configured to the following parameters:

• Speed 115200 bps
• Data Bits 8
• Parity None
• Stop Bit 1
• Flow Control Off

Table 16   LED Descriptions (continued)
LED COLOR STATUS DESCRIPTION
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Figure 34   USG FLEX 100H Rear Panel

Figure 35   USG FLEX 100HP Rear Panel

Figure 36   USG FLEX 200H Rear Panel

Figure 37   USG FLEX 200HP Rear Panel

Figure 38   USG FLEX 500H Rear Panel

Figure 39   USG FLEX 700H Rear Panel

Note: Make sure you connect the Zyxel Device's power cord to a socket-outlet with an 
earthing connection or its equivalent.
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The following table describes the items on the rear panel.

Note: Use an 8-wire Ethernet cable to run your Gigabit Ethernet connection at 1000 Mbps. 
Using a 4-wire Ethernet cable limits your connection to 100 Mbps. Note that the 
connection speed also depends on what the Ethernet device at the other end can 
support.

3.1.6  Console Port Pin Connectors
The RJ-45 connector pins are as follows.

Figure 40   RJ-45 Connector Pins 

The DB-9 connector pins are as follows.

Table 18   Rear Panel Items 
LABEL DESCRIPTION
Power Use the included power cord to connect the power socket to a power outlet. Turn the power 

switch on if your Zyxel Device has a power switch.

Console You can use the console port to manage the Zyxel Device using CLI commands. You will be 
prompted to enter your user name and password. See the Command Reference Guide for 
more information about the CLI.

When configuring using the console port, you need a computer equipped with 
communications software configured to the following parameters:

• Speed 115200 bps
• Data Bits 8
• Parity None
• Stop Bit 1
• Flow Control Off

P1-P8 (USG FLEX 
100H, USG FLEX 
100HP)

Theses are 1G RJ-45 Ethernet ports.

Fan The fans are for cooling the Zyxel Device. Make sure they are not obstructed to allow maximum 
ventilation.

Lock Attach a lock-and-cable from the Kensington lock (the small, metal-reinforced, oval hole) to a 
permanent object, such as a pole, to secure the Zyxel Device in place.



 Chapter 3 Hardware, Interfaces and Zones

USG FLEX H Series User’s Guide

53

Figure 41   DB-9 Connector Pins 

These are the cable pinouts for RJ-45 to DB-9. 

These are the signal names. 

Table 19   Cable Pinouts for RJ-45 to DB-9
SIGNAL CONSOLE PORT RJ-45 PIN DB-9 PIN SIGNAL

RTS 1 8 CTS

DTR 2 6 DSR

TxD 3 2 RxD

GND 4 5 GND

GND 5 5 GND

RxD 6 3 TxD

DSR 7 4 DTR

CTS 8 7 RTS

1, 9 NC

Table 20   Signal Names
SIGNAL SIGNAL NAME
RXD Receive Data

TXD Transmit Data

DTR Data Terminal Ready

GND Ground

DSR Data Set Ready

RTS Request to Send

CTS Clear to Send

RI Ring Indicator

NC Not Connected 
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3.2  Installation Scenarios
The Zyxel Device can be:

• Placed on a desktop.

• Wall-mounted on a wall.

• Rack-mounted on a standard EIA rack.

The following table summarizes the installation scenarios of the Zyxel Device by model.

WARNING! Do NOT block the ventilation holes on the Zyxel Device. 
Allow 100 mm clearance for the ventilation holes to prevent your Zyxel 
Device from overheating. Do not store things on the Zyxel Device. Do 
not place a Zyxel Device on another high temperature device. 
Overheating could affect the performance of your Zyxel Device, or 
even damage it.

3.2.1  Desktop Installation Procedure

1 Make sure the Zyxel Device is clean and dry.

2 Remove the adhesive backing from the rubber feet.

3 Attach the rubber feet to each corner on the bottom of the Zyxel Device. These rubber feet help 
protect the Zyxel Device from shock or vibration, and allow air circulation.

Table 21   USG FLEX Series Installation Comparison Table

USG FLEX MODELS
USG FLEX 100H/USG FLEX 100HP/

USG FLEX 200H/USG FLEX 200HP
USG FLEX 
500H

USG FLEX 
700H

Rubber feet for desktop 
placement

Yes Yes Yes

Wall Mounting Yes No No

Rack Mounting Yes Yes Yes
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Figure 42   Attaching Rubber Feet

4 Set the Zyxel Device on a smooth, level surface strong enough to support the weight of the Zyxel Device 
and the connected cables. Make sure there is a power outlet nearby.

Note: Make sure to use the rubber feet when stacking the Zyxel Devices on a desk.

3.2.2  Rack-mounting
Use the following steps to mount the Zyxel Device on an EIA standard size, 19-inch rack or in a wiring 
closet with other equipment using a rack-mounting kit. Make sure the rack will safely support the 
combined weight of all the equipment it contains and that the position of the ZyWALL does not make 
the rack unstable or top-heavy. Take all necessary precautions to anchor the rack securely before 
installing the unit.

Use a #2 Phillips screwdriver to install the screws.

Note: Failure to use the proper screws may damage the unit.

1 Align one bracket with the holes on one side of the Zyxel Device and secure it with the included bracket 
screws (smaller than the rack-mounting screws).

2 Attach the other bracket in a similar fashion.
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Figure 43   Attach Brackets

3 After attaching both mounting brackets, position the Zyxel Device in the rack and match up the bracket 
holes with the rack holes. Secure the Zyxel Device to the rack with the rack-mounting screws.

Figure 44   Mount on Rack

Note: Make sure there is at least 100 mm of clearance at the sides and 100 mm in the rear to 
allow air circulation and the attachment of cables and the power cord. When stacking 
in a rack, make sure there is at least 40 mm of clearance between Zyxel Devices.

3.2.3  Wall-mounting
Do the following to attach your Zyxel Device to a wall.

The following table lists the distance “X” between mounting holes for each model: 

1 Drill into a wall two holes 3 mm – 4 mm (0.12" – 0.16") wide, 20 mm – 30 mm (0.79” – 1.18”) deep and a 
distance X (see the preceding table) apart. Place two screw anchors in the holes.

Table 22   Distance “X” Between FLEX Mounting Holes
MODEL NAME DISTANCE “X”
USG FLEX 100H 174 mm (6.85”)

USG FLEX 100HP 174 mm (6.85”)

USG FLEX 200H 174 mm (6.85”)

USG FLEX 200HP 206 mm (8.11”)
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Figure 45   Wall Mounting Screw Specifications 

2 Screw two screws with 6 mm – 8 mm (0.24" – 0.31") wide heads into the screw anchors. Do not screw the 
screws all the way in to the wall; leave a small gap between the head of the screw and the wall.

The gap must be big enough for the screw heads to slide into the screw slots and the connection cables 
to run down the back of the Zyxel Device.

Note: Make sure the screws are securely fixed to the wall and strong enough to hold the 
weight of the Zyxel Device with the connection cables.

3 Use the holes on the bottom of the Zyxel Device to hang the Zyxel Device on the screws.
Figure 46   Wall Mounting
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Note: Wall-mount the Zyxel Device horizontally. The Zyxel Device's side panels with ventilation 
slots should not be facing up or down as this position is less safe.

Make sure there is 100 mm of clearance at the sides and 1 – 1.5 mm distance between 
the screw head and the wall to allow air circulation and the attachment of cables and 
the power cord.

3.3  Power Cord Lock
Follow the steps below to use the power cord lock to secure the power cord connected to the Zyxel 
Device.

3.3.1  For USG FLEX 100H, USG FLEX 100HP, USG FLEX 200H, USG FLEX 200HP, 
USG FLEX 500H

1 Use a screw driver to remove the power cord lock and the screw from the Zyxel Device.

2 Attach the Zyxel Device power cord through the power cord lock.
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3 Connect the power cord to the Zyxel Device power socket.

4 Use the screw driver to secure the power cord lock and the screw with the power cord to the hole next 
to the power socket.

3.3.2  For USG FLEX 700H

1 Insert Cable Clamp A into the case hole.
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2 Connect the power cord to the Zyxel Device power socket.

3 Open Cable Clamp B and attach it to the power cord. Make sure Cable Clamp B covers the head of 
the power cord.

4 Close Cable Clamp B to secure the power cord to the power socket.
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CHAPTER 4
Dashboard

4.1  Overview
Use the Dashboard screens to check status information about the Zyxel Device.

4.1.1  What You Can Do in this Chapter
Use the main Dashboard screen to see the Zyxel Device’s general device information, system status, and 
system resource usage. You can also display other status screens for more information.

Use the Dashboard screens to view the following.

• System Information Screen on page 62

• Virtual Device Screen on page 64

• Resource Usage Screen on page 64

• Bandwidth on page 65

• Client Usage Screen on page 66

• The Latest Logs Screen on page 66

• The Security Screen on page 67

4.2  The System Screen
The System screen displays when you log into the Zyxel Device or click System in the navigation panel. 
The System screen displays general device information, system resource usage, and interface status in 
widgets that you can re-arrange to suit your needs. You can also click the refresh icon ( ) to refresh 
individual widgets.
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Figure 47   Dashboard > System

4.2.1  System Information Screen
The System Information screen displays Zyxel Device’s system and model name, serial number, MAC 
address and firmware version shown in the below screen.

Figure 48   Dashboard > System > System Information

The table describes the fields in this screen. 

Table 23   Dashboard > System > System Information
LABEL DESCRIPTION
Host Name This field displays the name used to identify the Zyxel Device on any network. Click 

the link and open the Host Name screen where you can edit and make changes to 
the system and domain name.

Serial Number This field displays the serial number of this Zyxel Device. The serial number is used for 
device tracking and control.

MAC Address This field displays the MAC addresses used by the Zyxel Device. Each physical port 
has one MAC address. The first MAC address is assigned to physical port 1, the 
second MAC address is assigned to physical port 2, and so on.
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Firmware This field displays the version number and date of the firmware the Zyxel Device is 
currently running. Click the link to open the File Manager screen where you can 
upload firmware. 

Uptime This field displays how long the Zyxel Device has been running since it last restarted 
or was turned on.

System Time This field displays the current date and time in the Zyxel Device. The format is yyyy-
mm-dd hh:mm:ss.

Boot Status This field displays details about the Zyxel Device’s startup state.

OK - Boot success: The Zyxel Device has started up successfully.

OK - Firmware update at yyyy/mm/dd hh:mm: This displays the date and time when 
the Zyxel Device last updated the firmware successfully.

OK - Factory default at yyyy/mm/dd hh:mm: This displays the date and time when 
the Zyxel Device was last reset to the factory default settings and rebooted 
successfully.

OK - User reboot at yyyy/mm/dd hh:mm: This displays the date and time when the 
Zyxel Device last rebooted successfully.

OK - Reset default configuration at yyyy/mm/dd hh:mm: This occurs when the Zyxel 
Device starts for the first time or you reset the Zyxel Device to the factory default 
settings.

OK - System recovery at yyyy/mm/dd hh:mm: This displays the date and time when 
the Zyxel Device last underwent system recovery and rebooted successfully.

OK - Apply configuration xxxx.conf at at yyyy/mm/dd hh:mm: This displays the date 
and time when the Zyxel Device last applied the configuration file and rebooted 
successfully.

OK - Switch to (1st|2nd) partition at yyyy/mm/dd hh:mm: This displays the date and 
time when the Zyxel Device last rebooted using firmware in the backup partition.

OK - Reset admin password at yyyy/mm/dd hh:mm: This displays the date and time 
when the Zyxel Device reset the admin password using the “atkz-g” command and 
rebooted successfully.

WARN - Fallback to lastgood configuration: The Zyxel Device was unable to apply 
the startup-config.conf configuration file and fell back to the lastgood.conf 
configuration file. See Section 28.1.3 on page 438 for more information on 
configuration file flow at restart.

WARN - Fallback to lastgood configuration after firmware update at yyyy/mm/dd 
hh:mm: This displays the date and time when the Zyxel Device was last unable to 
apply the startup-config.conf configuration file after firmware update and fell back 
to the lastgood.conf configuration file. See Section 28.1.3 on page 438 for more 
information on configuration file flow at restart.

ERROR - Fallback to system default configuration: The Zyxel Device was unable to 
apply the lastgood.conf configuration file and fell back to the system default 
configuration file (system-default.conf). See Section 28.1.3 on page 438 for more 
information on configuration file flow at restart.

ERROR - Fallback to system default configuration after firmware update at yyyy/mm/
dd hh:mm: This displays the date and time when the Zyxel Device was unable to 
apply the lastgood.conf configuration file after the firmware update and fell back 
to the system default configuration file (system-default.conf). See Section 28.1.3 on 
page 438 for more information on configuration file flow at restart.

Table 23   Dashboard > System > System Information
LABEL DESCRIPTION
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4.2.2  Virtual Device Screen
The Virtual Device screen displays Zyxel Device’s ports and connections status.

Figure 49   Dashboard > System > Virtual Device

The following table describes the labels in this screen.

4.2.3  Resource Usage Screen
Click the bar to see a graphic on that resource.

Table 24   Dashboard > System > Virtual Device
LABEL DESCRIPTION
Virtual Device This field displays details about the status of the Zyxel Device’s ports and connections. An 

unconnected interface or slot appears grayed out. Hover your cursor over a connected 
interface or slot to display status details.

The following labels display when you hover your cursor over a connected interface or slot.

Name This field displays the name of each interface. 

Status This field displays the current status of each interface or device installed in a slot. The possible 
values depend on what type of interface it is.

Inactive - The Ethernet interface is disabled.

Down - The Ethernet interface does not have any physical ports associated with it or the 
Ethernet interface is enabled but not connected.

Speed / Duplex - The Ethernet interface is enabled and connected. This field displays the port 
speed and duplex setting (Full or Half).

The status for a WLAN card is none.

For cellular (mobile broadband) interfaces, see Section 7.5 on page 126 for the status that can 
appear.

For the auxiliary interface:

Inactive - The auxiliary interface is disabled.

Connected - The auxiliary interface is enabled and connected. 

Disconnected - The auxiliary interface is not connected. 

Interface This field displays the zone to which the interface is currently assigned.

IP Address/
Mask

This field displays the current IP address and subnet mask assigned to the interface. If the 
interface is a member of an active virtual router, this field displays the IP address it is currently 
using. This is either the static IP address of the interface (if it is the master) or the management 
IP address (if it is a backup).
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Figure 50   Dashboard > System > Resources Usage

The table describes the fields in the screen. 

4.2.4  Bandwidth
This screen displays a line graph of packet statistics for each interface.

Figure 51   Dashboard > System > Bandwidth 

This table describes the fields in the above screen.

Table 25   Dashboard > System > Resource Usage
LABEL DESCRIPTION
CPU This field displays what percentage of the Zyxel Device’s processing capability is 

currently being used. Click this field to display a chart of the Zyxel Device’s recent 
CPU usage. CPU usage may appear temporarily high when creating graphic-
intensive statistics and reports. You may ignore it, and observe the long-term usage.

Flash This field displays what percentage of the Zyxel Device’s onboard flash memory is 
currently being used.

Memory This field displays what percentage of the Zyxel Device’s RAM is currently being used. 
Click this field to display a chart of the Zyxel Device’s recent memory usage.

Sessions This field shows how many sessions, established and non-established, that pass 
through/from/to/within the Zyxel Device. Click this field to display a chart of Zyxel 
Device’s recent session usage.

Table 26   Dashboard > Tx/Rx Statistics
LABEL DESCRIPTION

Mbps The y-axis represents the speed of transmission or reception.

Time The x-axis shows the time period over which the transmission or reception occurred.
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4.2.5  Client Usage Screen
This screen displays the number of users logged into the Zyxel Device and a summary of the DHCP 
settings status. Click the links to go to the Login Users or the DHCP Table screen.

Figure 52   Dashboard > System > Client Usage 

This table describes the fields in the above screen.

4.2.6  The Latest Logs Screen
In this screen click The Latest Logs to go to Log & Report > Log / Events.

Figure 53   Dashboard > System > The Latest Logs 

The table describes the fields in the screen.

Table 27   Dashboard > DHCP Table 
LABEL DESCRIPTION
Login Users This field displays the number of users that are currently logged into the Zyxel Device.

DHCP Lease This field displays the number of IP addresses that are leased for clients.

Reservation This field displays the number of IP addresses that are reserved for the MAC 
addresses.

DHCP Server This field displays the number of interface that the DHCP server is enabled on the 
Zyxel Device.

Table 28   Dashboard > System > The Latest Log
LABEL DESCRIPTION
# This is the entry’s rank in the list of alert logs.

Time This field displays the date and time the log was created.
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4.3  The Security Screen
Use the Security screen to check security status information about the Zyxel Device. If a license has 
expired, you will see a reminder in this screen. You need to renew the license in order to keep using the 
feature. Click Buy Now to go to Marketplace to purchase a new license. Click See Details to go to the 
Zyxel web page to find more information on licenses for your Zyxel Device.

Figure 54   Dashboard > Security

This screen gives the following information:

• The amount of scanned traffic

Category This field displays the type of log generated. 

Message This field displays the actual log message.

Source This field displays the source address (if any) in the packet that generated the log.

Destination This field displays the destination address (if any) in the packet that generated the 
log. 

Priority This field displays the severity of the log. 

Table 28   Dashboard > System > The Latest Log
LABEL DESCRIPTION
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• The number of scanned connections for URL threat filtering

• The number of scanned files for anti-malware

• The number of scanned connections for IPS

• The number of scanned files for sandbox.

• Top 5 applications that are used the most

• Top 5 Categories that are detected the most

Click the Refresh icon to update the information in the window right away.
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CHAPTER 5
Monitor

5.1  Overview
Use the Monitor screens to check status and statistics information.

5.1.1  What You Can Do in this Chapter
Use the Monitor screens for the following.

• Use the Traffic Statistics > Application Usage (Section 5.2 on page 71) screen to view application 
statistics.

• Use the Traffic Statistics > Port (Section 5.3 on page 72) screen to view the packets statistics for each 
port selected for monitoring.

• Use the Traffic Statistics > Interface (Section 5.4 on page 73) screen to view the packets statistics for 
each interface selected for monitoring.

• Use the Traffic Statistics > Session Monitor screen (see Section 5.5 on page 74) to view sessions by user 
or service.

• Use the Security Statistics > Content Filter screen (Section 5.6 on page 76) to start or stop data 
collection and view content filter statistics.

• Use the Security Statistics > Reputation Filter screens (Section 5.7 on page 78) to view statistics of IP 
reputation, DNS threat filtering and URL threat filtering.

• Use the Security Statistics > IPS screen (Section 5.8 on page 82) to start or stop data collection and 
view IPS statistics.

• Use the Security Statistics > Anti-Malware (Section 5.9 on page 83) screen to view anti-malware 
statistics.

• Use the Security Statistics > Sandbox screen (Section 5.10 on page 85) to view sandbox statistics.

• Use the Security Statistics > SSL Inspection screen (Section 5.11 on page 86) to see a report on SSL 
Inspection and a certificate cache list.

• Use the Network Status > Interface screen (see Section 5.5 on page 74) to view the interface packets 
statistics.

• Use the Network Status > Device Insight screen (see Section 5.13 on page 90) to view the status of the 
clients connected to the Zyxel Device.

• Use the Network Status > Login Users screen (Section 5.14 on page 93) to look at a list of the users 
currently logged into the Zyxel Device.

• Use the Network Status > DHCP Table screen (see Section 5.15 on page 94) to view a list of interfaces 
and their DHCP-assigned IP addresses.

• Use the VPN Status > IPSec VPN > Site to Site VPN screen (Section 5.16.1 on page 96) to display and 
manage active IPSec SAs.

• Use the VPN Status > IPSec VPN > Remote Access VPN screen (Section 5.16.2 on page 97) to display 
and manage remote access VPN clients.
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• Use the VPN Status > SSL VPN > Remote Access VPN screen (Section 5.17 on page 98) to list the users 
currently logged into the SSL VPN client portal. You can also log out individual users and delete 
related session information.

5.2  The Application Usage Screen 
This screen provides a convenient way to monitor the use of various applications by hosts in the network.

If a license has expired, you will see a reminder in this screen. You need to renew the license in order to 
keep using the feature. Click Buy Now to go to Marketplace to purchase a new license. Click See 
Details to go to the Zyxel web page to find more information on licenses for your Zyxel Device. 

Click Traffic Statistics > Application Usage to display the following screen. This screen displays usage by 
application type or the IP addresses of hosts in your network.

Figure 55   Traffic Statistics > Usage by Application 
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Figure 56   Traffic Statistics > Usage by Host IP 

The following table describes the labels in this screen.

5.3  The Port Statistics Screen
Use this screen to look at packets statistics for each Gigabit Ethernet port. Ports are physical ports to 
which you connect cables. 

To access this screen, click Traffic Statistics > Port.

Table 29   Traffic Statistics > Application Usage
LABEL DESCRIPTION
Last 24 Hours Summary If you want to view more data than the past 24 hours in SecuReporter, click View 

More. You should already have a SecuReporter account.

Pie Chart Click an item in the pie chart for more detailed information.

Refresh Click this button to update the report display.

Flush Data Click this button to discard all of the screen’s statistics for inactive sessions. Flushing 
data only removes traffic logs from ended sessions. Active sessions remain 
unaffected. Click Refresh to update the report display.

Top Usage by Select to display usage by application or host IP address.

Application If you selected by application, then this is the name of the application identified.

Category This is the category the application belongs to.

Usage This is how much traffic the application has used.

%Usage This is the percentage of traffic the application has used.

Client IP address If you selected by host IP address, then this is the IP address of the host identified.

Client Description This is the name of the host identified.

MAC Address This is the MAC address of the host device.

Usage This is how much traffic the host has used.

%Usage This is the percentage of traffic the host has used.
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Figure 57   Traffic Statistics > Port 

Select a port to monitor.

Figure 58   Traffic Statistics > Port

The following table describes the labels in this screen.

5.4  The Interface Statistics Screen
Use this screen to look at packets statistics for each interface. Interfaces are used within the system 
operationally. You use them in configuring various features. 

To access this screen, click Traffic Statistics > Interface.

Table 30   System Statistics > Port
LABEL DESCRIPTION
Monitor Port Select a port from the drop-down list box to view the port packets statistics.

Poll Interval Enter how often you want this window to be updated automatically, and click 
Refresh.

TX This line represents traffic transmitted from the Zyxel Device on the physical port 
since it was last connected.

RX This line represents the traffic received by the Zyxel Device on the physical port since 
it was last connected.
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Figure 59   Traffic Statistics > Port 

Select an interface to monitor.

Figure 60   Traffic Statistics > Interface

The following table describes the labels in this screen.

5.5  The Session Monitor Screen
The Session Monitor screen displays all established sessions that pass through the Zyxel Device for 
debugging or statistical analysis. It is not possible to manage sessions in this screen. The following 
information is displayed.

• User who started the session

• Protocol or service port used

• Source address

• Destination address

• Number of bytes received (so far)

• Number of bytes transmitted (so far)

Table 31   Traffic Statistics > Interface
LABEL DESCRIPTION
Monitor Interface Select an interface from the drop-down list box to view the interface packets 

statistics.

Poll Interval Enter how often you want this window to be updated automatically, and click 
Refresh.

TX This line displays the transmission speed, in bytes per second, on the interface in the 
one-second interval before the screen updated.

RX This line displays the reception speed, in bytes per second, on the interface in the 
one-second interval before the screen updated.
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• Duration (so far)

You can look at all established sessions that passed through the Zyxel Device by user, service, source IP 
address, or destination IP address. You can also filter the information by user, protocol / service or service 
group, source address, and/or destination address and view it by user.

Click Traffic Statistics > Session Monitor to display the following screen.

Figure 61   Traffic Statistics > Session Monitor

The following table describes the labels in this screen. 

Table 32   Traffic Statistics > Session Monitor 
LABEL DESCRIPTION
View Select how you want the established sessions that passed through the Zyxel Device to be 

displayed. Choices are:

• sessions by user - display all active sessions grouped by user
• sessions by services - display all active sessions grouped by service or protocol
• sessions by source IP - display all active sessions grouped by source IP address
• sessions by source region - display all active sessions grouped by source IP address
• sessions by destination IP - display all active sessions grouped by destination IP address
• sessions by destination region - display all active sessions grouped by destination IP address
• all sessions - filter the active sessions by the User, Service, Source IP, and Destination IP, and 

display each session individually (sorted by user).

Clear Session Select a session, then click this button to remove the selected session.

Clear All Sessions Click this button to remove all sessions.

Refresh Click this button to update the information on the screen. The screen also refreshes 
automatically when you open and close the screen.

Search Type an item in the search box, then click this to display all sessions in the table below 
according to the item you typed.

Clear All Click this to remove all items found in the search.

Filter

Click the Filter icon  , click + to display Add Filter, pick a filter, then click Search to display 
specific sessions according to the filter selected. You may select multiple filters, but just one of 
each type, configured one at a time. 

The User, Service, Source Address, Destination Address, Source Country and Destination 
Country fields display if you view all sessions.

# This field is the rank of each record. The names are sorted by the name of user in active session. 
You can use the pull down menu on the right to choose sorting method.
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5.6  The Content Filter Screen
Click Security Statistics > Content Filter to display the following screens. The Zyxel Device content filtering 
includes HTTP(S) traffic scan and DNS domain scan. The HTTP(S) traffic scan allows the Zyxel Device to 
block access to specific websites, by inspecting the URL or Server Name Indication (SNI) that the user’s 
web browser sends to the web server. The DNS domain scan allows the Zyxel Device to block access to 
specific websites by inspecting DNS queries made by users on your network. If the website in the DNS 
query contains prohibited material, then the Zyxel Device replies to the DNS query with a IP address that 
points to the block page.

If a license has expired, you will see a reminder in this screen. You need to renew the license in order to 
keep using the feature. Click Buy Now to go to Marketplace to purchase a new license. Click See 
Details to go to the Zyxel web page to find more information on licenses for your Zyxel Device. 

These screens display some basic statistics on HTTP(S) traffic scan and DNS domain scan.

User This field displays the user in each active session. 

If you are looking at the sessions by users (or all sessions) report, click + or - to display or hide 
details about a user’s sessions.

Services This field displays the protocol used in each active session. 

If you are looking at the sessions by services report, click + or - to display or hide details about 
a protocol’s sessions.

Source This field displays the source IP address and port in each active session. 

If you are looking at the sessions by source IP report, click + or - to display or hide details about 
a source IP address’s sessions.

Destination This field displays the destination IP address and port in each active session. 

If you are looking at the sessions by destination IP report, click + or - to display or hide details 
about a destination IP address’s sessions.

Rx This field displays the amount of information received by the source in the active session.

Tx This field displays the amount of information transmitted by the source in the active session.

Duration This field displays the length of the active session in hours, minutes, seconds format.

Table 32   Traffic Statistics > Session Monitor (continued)
LABEL DESCRIPTION
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Figure 62   Security Statistics > Content Filter 

The following table describes the labels in this screen.

Table 33   Security Statistics > Content Filter
LABEL DESCRIPTION
Last 24 Hours Summary If you want to view more data than the past 24 hours in SecuReporter, click View More. 

You should already have a SecuReporter account.

Pie Chart Click an item in the pie chart for more detailed information.

Top entry by Use this field to have the following (read-only) table display the top content filter log 
entries by Blocked Category, Blocked Source IP, Blocked URL, Allowed Category, 
Allowed Source IP, or Allowed URL. This table displays the most common, recent 
content filter logs. See the log screen for less common content filter logs or use a syslog 
server to record all content filter logs. 

Select Blocked Category to list the web site categories the Zyxel Device has blocked.

Select Blocked Source IP to list the source IP addresses of the web sites the Zyxel Device 
has blocked.

Select Blocked URL to list the URLs of the web sites the Zyxel Device has blocked.

Select Allowed Category to list the web site categories the Zyxel Device has allowed.

Select Allowed Source IP to list the source IP addresses of the web sites the Zyxel Device 
has allowed.

Select Allowed URL to list the URLs of the web sites the Zyxel Device has allowed.

Refresh Click this button to update the report display.

Flush Data Click this button to discard all of the screen’s statistics. Click Refresh to update the 
report display.

Time This column displays the date and time when the users access the URL or FQDN.

Action This column displays whether the Zyxel Device blocks or passes the accessed URL or 
FQDN.

URL/Domain This column displays the URL or domain name of the web site accessed.

Profile This column displays the content filter profile the website belongs to.
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5.7  The Reputation Filter Screens
Click Security Statistics > Reputation Filter to display the following screens. These screens display 
reputation filter statistics.

The Zyxel Device reputation filter includes IP reputation, DNS threat filter and URL threat filter. 

If a license has expired, you will see a reminder in this screen. You need to renew the license in order to 
keep using the feature. Click Buy Now to go to Marketplace to purchase a new license. Click See 
Details to go to the Zyxel web page to find more information on licenses for your Zyxel Device. 

5.7.1  IP Reputation
This screen displays IP reputation statistics. IP reputation checks the reputation of an IP address from a 
database.

Figure 63   Security Statistics > Reputation Filter > IP Reputation

Category This column displays the category the accessed web site belongs to.

Source IP This column displays the source IP address of the web site the Zyxel Device has 
checked.

Destination IP This column displays the destination IP address at which the traffic of the web site the 
Zyxel Device has checked is sent.

Table 33   Security Statistics > Content Filter
LABEL DESCRIPTION
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The following table describes the labels in this screen.

5.7.2  DNS Threat Filter
This screen displays DNS threat filter statistics. DNS threat filtering inspects DNS queries made by clients on 
your network and compares the queries against a database of blocked or allowed Fully Qualified 
Domain Names (FQDNs).

Table 34   Security Statistics > Reputation Filter > IP Reputation
LABEL DESCRIPTION
Last 24 Hours Summary If you want to view more data than the past 24 hours in SecuReporter, click View More. 

You should already have a SecuReporter account.

Pie Chart Click an item in the pie chart for more detailed information.

Top Entries By Use this field to have the following (read-only) table display the top IP reputation log 
entries by Category, Infected/Victim Host or Malicious IP. This table displays the most 
common, recent IP reputation logs. See the log screen for less common IP reputation 
logs or use a syslog server to record all IP reputation logs. 

Select Category to list the most common categories of packets that the Zyxel Device has 
detected.

Select Infected/Victim Host to list the most common IP addresses of the infected hosts.

Select Malicious IP to list the most common IPv4 addresses with bad reputation that 
have sent packets to the Zyxel Device.

Refresh Click this button to update the report display.

Flush Data Click this button to discard all of the screen’s statistics. Click Refresh to update the report 
display.

IP Reputation Events

Time This field displays the date and time the entry was created.

+ Allow List Select an entry and click this to add it to the IP reputation allow list.

Malicious IP This field displays the IPv4 address with bad reputation.

Infected/Victim Host This field displays the IP address of the infected host.

Threat Category This field displays the category of the entry.

Threat Level This field displays the threat level of the entry.

Occurrence This field displays how many times the Zyxel Device has detected the event described in 
the entry.
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Figure 64   Security Statistics > Reputation Filter > DNS Threat Filter 

The following table describes the labels in this screen.

Table 35   Security Statistics > Reputation Filter > DNS Threat Filter
LABEL DESCRIPTION
Last 24 Hours Summary If you want to view more data than the past 24 hours in SecuReporter, click View More. 

You should already have a SecuReporter account.

Pie Chart Click an item in the pie chart for more detailed information.

Top Entries By Use this field to have the following (read-only) table display the top DNS threat filter log 
entries by Category, Source IP or DNS Name. This table displays the most common, 
recent DNS threat filter logs. See the log screen for less common DNS threat filter logs or 
use a syslog server to record all DNS threat filter logs. 

Select Category to list the most common categories of packets that the Zyxel Device has 
detected.

Select Source IP to list the most common source IP addresses of traffic.

Select DNS Name to list the most common FQDNs of the infected websites.

Refresh Click this button to update the report display.

Flush Data Click this button to discard all of the screen’s statistics. Click Refresh to update the report 
display.

DNS Threat Filter Events

Time This field displays the date and time the entry was created.

+ Allow List Select an entry and click this to add it to the DNS filtering allow list.

DNS Name This field displays the FQDN of an infected website.

Category This field displays the category of the entry.

Source IP This field displays the source IP address of traffic that you want to trace.
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5.7.3  URL Threat Filter
This screen displays URL threat filter statistics. URL threat filtering compares access to specific URLs 
against a database of blocked or allowed sites.

Figure 65   Security Statistics > Reputation Filter > URL Threat Filter 

The following table describes the labels in this screen.

Table 36   Security Statistics > Reputation Filter > URL Threat Filter
LABEL DESCRIPTION
Last 24 Hours Summary If you want to view more data than the past 24 hours in SecuReporter, click View More. 

You should already have a SecuReporter account.

Pie Chart Click an item in the pie chart for more detailed information.

Top Entries By Use this field to have the following (read-only) table display the top URL threat filter log 
entries by Category, URL or Source IP. This table displays the most common, recent URL 
threat filter logs. See the log screen for less common URL threat filter logs or use a syslog 
server to record all URL threat filter logs. 

Select Category to list the most common categories of packets that the Zyxel Device has 
detected.

Select URL to list the most common URLs of the infected websites.

Select Source IP to list the most common source IP addresses of traffic.

Refresh Click this button to update the report display.

Flush Data Click this button to discard all of the screen’s statistics. Click Refresh to update the report 
display.

URL Threat Filter Events

Time This field displays the date and time the entry was created.

+ Allow List Select an entry and click this to add it to the URL Threat filtering allow list.

URL This field displays the URL of an infected website.
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5.8  The IPS Screen
Click Security Statistics > IPS to display the following screen. This screen displays IPS (Intrusion Prevention 
System) statistics. An IPS system can detect malicious or suspicious packets and respond instantaneously 
by rejecting or dropping the packets. The Zyxel Device IPS protects your network against network-based 
intrusions.

If a license has expired, you will see a reminder in this screen. You need to renew the license in order to 
keep using the feature. Click Buy Now to go to Marketplace to purchase a new license. Click See 
Details to go to the Zyxel web page to find more information on licenses for your Zyxel Device. 

Figure 66   Security Statistics > IPS 

The following table describes the labels in this screen.

Category This field displays the category of the entry.

Source IP This field displays the source IP address of traffic that you want to trace.

Destination IP This field displays the destination IP address of traffic.

Table 36   Security Statistics > Reputation Filter > URL Threat Filter
LABEL DESCRIPTION

Table 37   Security Statistics > IPS
LABEL DESCRIPTION
Last 24 Hours Summary If you want to view more data than the past 24 hours in SecuReporter, click View More. 

You should already have a SecuReporter account.

Pie Chart Click an item in the pie chart for more detailed information.
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5.9  The Anti-Malware Screen
Click Security Statistics > Anti-Malware to display the following screen. This screen displays anti-malware 
statistics.

If a license has expired, you will see a reminder in this screen. You need to renew the license in order to 
keep using the feature. Click Buy Now to go to Marketplace to purchase a new license. Click See 
Details to go to the Zyxel web page to find more information on licenses for your Zyxel Device. 

Top Entries By Use this field to have the following (read-only) table display the top IPS log entries by 
Signature Name, Source IP or Destination IP. This table displays the most common, recent 
IPS logs. See the log screen for less common IPS logs or use a syslog server to record all 
IPS logs. 

Select Signature Name to list the most common signatures that the Zyxel Device has 
detected. 

Select Source IP to list the source IP addresses from which the Zyxel Device has detected 
the most intrusion attempts. 

Select Destination IP to list the most common destination IP addresses for intrusion 
attempts that the Zyxel Device has detected.

Refresh Click this button to update the report display.

Flush Data Click this button to discard all of the screen’s statistics. Click Refresh to update the report 
display.

Time This column displays the date and time IPS blocked this IP address.

+ Allow List Select an entry and click this to add the signature to the IPS allow list.

Signature ID This column displays when you display the unique value given to each intrusion 
detected. 

Signature Name This column displays the name to identify the type of intrusion pattern. 

Type This column displays the categories of intrusions.

Severity This column displays the level of threat that the intrusions may pose. 

Source IP This column displays the source IP address of the intrusion attempts.

Destination IP This column displays the destination IP address at which intrusion attempts were 
targeted.

Table 37   Security Statistics > IPS
LABEL DESCRIPTION



Chapter 5 Monitor

USG FLEX H Series User’s Guide

84

Figure 67   Security Statistics > Anti-Malware 

The following table describes the labels in this screen.

Table 38   Security Statistics > Anti-Malware  
LABEL DESCRIPTION
Last 24 Hours Summary If you want to view more data than the past 24 hours in SecuReporter, click View 

More. You should already have a SecuReporter account.

Pie Chart Click an item in the pie chart for more detailed information.

Top Entries By Use this field to have the following (read-only) table display the top anti-malware 
log entries by Virus Name, Source IP, and Destination IP. This table displays the 
most common, recent anti-malware logs. See the log screen for less common 
anti-malware logs or use a syslog server to record all anti-malware logs. 

Select Virus Name to list the most common viruses that the Zyxel Device has 
detected. 

Select Source IP to list the source IP addresses from which the Zyxel Device has 
detected the most virus-infected files. 

Select Destination IP to list the most common destination IP addresses for virus-
infected files that Zyxel Device has detected. 

Refresh Click this button to update the report display.

Flush Data Click this button to discard all of the screen’s statistics. Click Refresh to update 
the report display.

Anti-Malware Statistics Events

Time This field displays the date and time the entry was created.

+ Allow List Select an entry and click this to add it to the anti-malware allow list.

Virus name This column displays when you display the entries by Virus Name. This displays the 
name of a detected virus. 

Hash This column displays a hash value, MD5 (Message Digest 5)of the detected virus 
file.

MD5 is hash algorithms used to authenticate packet data.
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5.10  The Sandbox Screen
Click Security Statistics > Sandbox to display the following screen. This screen displays sandbox statistics.

If a license has expired, you will see a reminder in this screen. You need to renew the license in order to 
keep using the feature. Click Buy Now to go to Marketplace to purchase a new license. Click See 
Details to go to the Zyxel web page to find more information on licenses for your Zyxel Device. 

Figure 68   Security Statistics > Sandbox

The following table describes the labels in this screen.

Source IP This column displays when you display the entries by Source IP. It shows the 
source IP address of virus-infected files that the Zyxel Device has detected.

Destination IP This column displays when you display the entries by Destination IP. It shows the 
destination IP address of virus-infected files that the Zyxel Device has detected.

Table 38   Security Statistics > Anti-Malware  (continued)
LABEL DESCRIPTION

Table 39   Security Statistics > Sandbox 
LABEL DESCRIPTION
Last 24 Hours Summary If you want to view more data than the past 24 hours in SecuReporter, click View More. 

You should already have a SecuReporter account.

Pie Chart Click an item in the pie chart for more detailed information.
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5.11  The SSL Inspection Screens
The Zyxel Device uses SSL Inspection to decrypt SSL traffic, then sends it to Security Service engines for 
inspection, and then finally encrypts traffic that passes inspection and forwards it.

5.11.1  The Summary Screen
Click Security Statistics > SSL Inspection > Summary to display the following screen. This screen shows the 
number of SSL sessions inspected, blocked and passed.

Top Entries By Use this field to have the following (read-only) table display the top sandbox log entries 
by Destination IP, Source IP and Type. This table displays the most common, recent 
sandbox logs. See the log screen for less common sandbox logs or use a syslog server to 
record all sandbox logs.

Select Source IP to list the source IP addresses from which the Zyxel Device has detected 
the most files with unknown or untrusted programs and codes.

Select Destination IP to list the most common destination IP addresses for files with 
unknown or untrusted programs and codes that Zyxel Device has detected.

Select Type to display if the file type of the detected file with unknown or untrusted 
programs and codes.

Refresh Click this button to update the report display.

Flush Data Click this button to discard all of the screen’s statistics. Click Refresh to update the report 
display.

When the statistics stored reach the limit, new statistics automatically overwrite existing 
statistics, starting with the oldest statistics first.

Sandbox Events

Time This field displays the time the file is scanned by the Zyxel Device.

Type This field displays the file type of the detected file with unknown or untrusted programs 
and codes.

File Name This column displays the file name of the detected virus file.

Hash This column displays a hash value, MD5 (Message Digest 5, of the detected file with 
unknown or untrusted programs and codes.

MD5 is a hash algorithm used to authenticate packet data.

Source IP This column displays the source IP address of the file the Zyxel Device has checked.

Destination IP This column displays the destination IP address at which the traffic of the file the Zyxel 
Device has checked is sent.

Table 39   Security Statistics > Sandbox (continued)
LABEL DESCRIPTION
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Figure 69   Security Statistics > SSL Inspection > Summary

The following table describes the labels in this screen. 

Table 40   Security Statistics > SSL Inspection > Summary 
LABEL DESCRIPTION
General Settings

Refresh Click this button to update the report display.

Flush Data Click this button to discard all of the screen’s statistics. Click Refresh to update the 
report display.

Status

Maximum Concurrent 
Sessions

This shows the maximum number of simultaneous SSL Inspection sessions allowed for 
your Zyxel Device model.

 Concurrent Sessions This shows the actual number of simultaneous SSL Inspection sessions in progress.

Summary

Total This is the total of SSL sessions inspected and number of sessions blocked and number 
of sessions passed since data was last flushed or the Zyxel Device last rebooted after 
Collect Statistics was enabled.

Inspected This shows the total number of SSL sessions inspected since data was last flushed or the 
Zyxel Device last rebooted after Collect Statistics was enabled

Decrypted (Kbytes) This shows the number of kilobytes (KB) of data that was decrypted for Security 
Service inspection.

Encrypted (Kbytes) This shows the number of kilobytes (KB) of data that was re-encrypted after Security 
Service inspection and then forwarded.

Blocked This shows the number of SSL sessions blocked.

Passed This shows the number of SSL sessions passed.
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5.11.2  The Certificate Cache List Screen
A certificate identifies the source of SSL traffic. Use this screen to decide which sources can be excluded 
from SSL inspection. Traffic in an Exclude List is not intercepted by SSL inspection.

Click Security Statistics > SSL Inspection > Certificate Cache List to display a screen that shows details on 
SSL traffic identified by its certificate and an option to add that traffic to the Exclude List.

Figure 70   Security Statistics > SSL Inspection > Certificate Cache List 

The following table describes the labels in this screen.

5.12  The Interface Screen
This screen lists all of the Zyxel Device’s interfaces and their information.

Click Network Status > Interface to display the following screen.

Table 41   Security Statistics > SSL Inspection > Certificate Cache List  
LABEL DESCRIPTION
Time This is the latest date (yyyy-mm-dd) and time (hh-mm-ss) that the record in the 

certificate cache list was met.

Add to Exclude list Select and item in the list and click this icon to add the common name (CN) to the 
Exclude List.

Common Name This displays the common name in the certificate of the SSL traffic destination server.

Server Name Indication Server Name Indication (SNI) is the domain name entered in the browser, FTP client, 
etc. to begin the SSL session with the server. It allows multiple SSL sessions to the same 
IP address and port number with different certificates from different SNI. This field 
displays the SNI for this SSL session.

SSL Version This field shows the SSL version. TLS1.0/1.1/1.2 are currently supported. 

Destination This displays the IP address and port number of the SSL traffic destination server.

Valid Time This displays the cache item expiry time in seconds. The cache item is deleted when 
the remaining time expires.
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Figure 71   Network Status > Interface

The following table describes the labels in this screen. 

Table 42   Network Status > Interface
LABEL DESCRIPTION
Refresh Click this to update the information in this screen.

Name This field displays the name of each interface.

Port/Binding 
(External/Internal)

This field displays the physical port number that is binded to the interface. An interface is 
binded to a port when the interface is bounded to the physical port.

Members (Bridge) When you create a bridge interface, the Zyxel Device removes the members' entries from the 
routing table and adds the bridge interface's entries to the routing table. This field displays the 
bridge interface's members

Type This field displays the type of connection the interface is using.
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5.13  The Device Insight Screen
Use Device Insight to collect status and basic information of the clients connected to the Zyxel Device 
internal interfaces or IPSec VPN or Astra clients with or without VPN Zyxel Client software installed. The 
clients shown may include clients connected to the Zyxel Device:

• Using wired connections.

• Through access points (APs) using wired connections.

• Through access points (APs) using WiFi connections.

Status This field displays the current status of each interface. The possible values depend on what 
type of interface it is.

For Ethernet interfaces:

• Inactive - The Ethernet interface is disabled.
• Down - The Ethernet interface does not have any physical ports associated with it or the 

Ethernet interface is enabled but not connected.
• Speed / Duplex - The Ethernet interface is enabled and connected. This field displays the 

port speed and duplex setting (Full or Half).

For the auxiliary interface:

• Inactive - The auxiliary interface is disabled.
• Connected - The auxiliary interface is enabled and connected. 
• Disconnected - The auxiliary interface is not connected. 

For virtual interfaces, this field always displays Up. If the virtual interface is disabled, it does not 
appear in the list.

For VLAN and bridge interfaces, this field always displays Up. If the VLAN or bridge interface is 
disabled, it does not appear in the list.

For PPP interfaces:

• Connected - The PPP interface is connected.
• Disconnected - The PPP interface is not connected.

If the PPP interface is disabled, it does not appear in the list.

Zone This field displays the zone to which the interface is assigned.

IP Addr/Netmask This field displays the current IP address and subnet mask assigned to the interface. If the IP 
address and subnet mask are 0.0.0.0, the interface is disabled or did not receive an IP address 
and subnet mask via DHCP.

If this interface is a member of an active virtual router, this field displays the IP address it is 
currently using. This is either the static IP address of the interface (if it is the master) or the 
management IP address (if it is a backup).

VLAN ID 
(External/Internal)

This field displays the VLAN ID which is a 12-bit number that uniquely identifies each VLAN.

IP Assignment This field displays how the interface gets its IP address.

• Static - This interface has a static IP address.
• DHCP Client - This interface gets its IP address from a DHCP server.

Service This field lists which services the interface provides to the network. Examples include DHCP 
relay, DHCP server and DDNS. This field displays n/a if the interface does not provide any 
services to the network.

Table 42   Network Status > Interface
LABEL DESCRIPTION
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• Through built-in access points using WiFi connections.

• Using SecuExtender (IPSec VPN clients).

Device Insight collects client information including:

• Hostname

• IP address and MAC address

• Operating system

• Category, such as mobile phones or computers

• Connected interface

Note: To collect clients’ information using Device Insight, the clients must be in the same IP 
subnet in the LAN/VLAN/DMZ networks behind the Zyxel Device. Information from 
clients that are in different IP subnets in the LAN/VLAN/DMZ networks might not be 
collected correctly as traffic must pass through another router or a layer-3 switch to the 
Zyxel Device.

In the graphic below, A is a client connected to the Zyxel Device using a wired connection. B is a client 
connected to the Zyxel Device through an AP using a wired connection. C is a client connected to the 
Zyxel Device through an AP using a WiFi connection. 

Figure 72   Clients’ Device Insight Example

Click Network Status > Device Insight to show the following screen.
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If a license has expired, you will see a reminder in this screen. You need to renew the license in order to 
keep using the feature. Click Buy Now to go to Marketplace to purchase a new license. Click See 
Details to go to the Zyxel web page to find more information on licenses for your Zyxel Device. 

Figure 73   Network Status > Device Insight

The following table describes the labels in this screen. 

Table 43   Network Status > Device Insight 
LABEL DESCRIPTION
Edit Double-click an entry or select it and click Edit to modify the entry’s settings in the 

Description field.

Remove Select an entry and click Remove to remove a client from the table that’s no longer 
connected to your network.

For example, guest A visited your company over a month ago. Guest A used his 
cellphone to connect to your Zyxel Device networks. His cellphone was identified 
and shown in the Device Insight table. Guest A has left for over a month and you’re 
sure he will not return in the near future. You can use the Remove button to remove 
his device from this table. Guest A’s device will be identified and shown in the table 
again if he connects to your Zyxel Device networks in the future.

Please note that clients that are blocked cannot be removed. Make sure to unblock 
clients before you remove them.

Add to block list Select an entry and click Add to block list to stop the selected client from 
connecting to the Zyxel Device.

Remove from block list Select an entry and click Remove from block list to allow the selected client to 
connect to the Zyxel Device.

Feedback Select an entry and click Feedback to report on a client that is wrongly identified 
regarding its Category, Operating System or Type.

Status This field displays the status of the clients.

Online ( )- The connection between the client and the Zyxel Device is up.

Offline ( )- The connection between the client and the Zyxel Device is down.

Block ( )- The client is blocked from the connection to the Zyxel Device.

MAC Address This field displays the MAC address of the client.

MAC Vendor This displays the MAC address Organizationally Unique Identifier (OUI). The OUI is the 
first three octets in a MAC address and uniquely identifies the manufacturer of a 
network device.

IP Address This field displays the IP address of the client.

Hostname This field displays the name used to identify this device on the network.

Description This field displays the descriptive name of the client.
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5.14  The Login Users Screen
Use this screen to see a list of users currently logged into the Zyxel Device. To access this screen, click 
Network Status > Login Users.

Connected to This field displays the interface to which a client is connected directly to on the Zyxel 
Device.

Connected to This field displays the interface to which a client is connected directly to on the Zyxel 
Device.

Operating System (OS) This field displays the operating system of the client.

OS Version This field displays the version of the operating system of the client.

Type This field displays the model names of the client.

First-seen This field displays the time when the client first sends traffic to the Zyxel Device since 
the Zyxel Device last reboot.

Last-seen This field displays the time when the client last sends traffic to the Zyxel Device.

User This field displays the type of user account the client uses. See Section 25.1.1 on 
page 359 for more information the user account types.

Auth method This field displays the authentication method that is used to authenticate the client.

Astra Group & Role This field displays the group name and role (admin or member) of the client on Astra.

• admin: The Astra web portal is a platform that provides security services to 
computer or mobile devices. It is managed by an admin.

• member: A member is a person whose computer or mobile device the admin 
wishes to protect using Astra. You can add your mobile device or a member’s 
mobile device using this Astra web portal account.

Astra Agent Version This field displays the version of Astra.

Client Firewall Status This field displays the firewall status on the client’s computer or mobile device, such 
as a smartphone. The field is blank is if there is no firewall on the client.

• Enabled: The firewall is enabled on the client.
• Disabled: The firewall is disabled on the client.

Astra License Status This field displays the current Astra license status of the client.

The following displays for a license you subscribed to from the Astra Portal.

• Activated: The Astra license is enabled.
• Inactive: The Astra license is not enabled.
• Overdue: The payment for the Astra license has failed, and the license will be 

canceled 15 days after the overdue date. During this period, attempts will be 
made to process the credit card payment.

• Cancel: The Astra license will be canceled after the expiration date.
• None: A standard or trial license has not been enabled.

The following displays for a license you purchased offline. You’ll need to use the 
license key to activate the license online.

• Activated: The Astra license is enabled.
• Grace period: After a license expires, you have 15 days grace period during 

which you can extend your current license.
• Expired: The Astra license has expired.
• None: A standard or trial license has not been enabled.

Table 43   Network Status > Device Insight (continued)
LABEL DESCRIPTION
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Figure 74   Network Status > Login Users

The following table describes the labels in this screen.

5.15  The DHCP Table Screen
Use this screen to look at a list of interfaces and their DHCP-assigned IP addresses. To access this screen, 
click Network Status > DHCP Table.

Table 44   Network Status > Login Users 
LABEL DESCRIPTION
Force Logout Select a user row and click this icon to end a user’s session.

# This field is a sequential value and is not associated with any entry.

User ID This field displays the user name of each user who is currently logged in to the Zyxel 
Device.

Role This field displays the types of user accounts the Zyxel Device uses. If the user type is ext-
user (external user), this field will show its external-group information when you move your 
mouse over it. 

If the external user matches two external-group objects, both external-group object 
names will be shown.

See Section 25.1.2 on page 360 for more information on the user accounts.

From This field displays the IP address of the computer used to log in to the Zyxel Device.

Login Time This field displays how long a user account has logged into the Zyxel Device.

Type This field displays the way the user logged into the Zyxel Device. The user can log into the 
Zyxel Device using HTTP, HTTPS, SSH, FTP and console.

Tunnel IP This field displays the IP address of the VPN tunnel a user account is using to access the 
Zyxel Device. 

This field displays 0.0.0.0 if a user account is not accessing the Zyxel Device through a VPN 
tunnel.

Reauth/Lease Time This field displays the amount of reauthentication time remaining and the amount of 
lease time remaining for each user. See Section 25.1.3 on page 362 for more information 
on the reauthentication time and lease time.
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Figure 75   Network Status > DHCP Table

The following table describes the labels in this screen. 

Table 45   Network Status > DHCP Table 
LABEL DESCRIPTION
Current DHCP List

Interface Select a Zyxel Device interface that has DHCP enabled to show to which devices it has 
assigned DHCP IP addresses.

Add Click this to add an entry that maps a static IP to a MAC address.

Release Select an entry and click on this button to let other devices use the dynamic DHCP that is 
currently assigned to the selected entry.

Unreserve Select an entry and click on this button to set the entry from a static DHCP entry to a 
dynamic DHCP entry. The IP address is assigned to a DHCP client.

Refresh Click this button to update the mapping between IP addresses and MAC addresses.

Column header Click a column’s heading cell to sort the table entries by the column entry. Click the 
heading cell again to reverse the sort order.

Interface This field identifies the interface that assigned an IP address to a DHCP client.

IP Address This field displays the IP address currently assigned to a DHCP client or reserved for a 
specific MAC address. Click the column’s heading cell to sort the table entries by IP 
address. Click the heading cell again to reverse the sort order.

Host Name This field displays the name used to identify this device on the network (the computer 
name). The Zyxel Device learns these from the DHCP client requests. None shows here for 
a static DHCP entry.

A host name cannot exceed 255 characters. Valid characters are [0-9][a-z][A-
Z][_(){}<>^`+/:!*#@&=$\?.~%,|;-'"].

Note: You cannot have duplicate host names for static (reserved) IP addresses.
MAC Address This field displays the MAC address to which the IP address is currently assigned or for 

which the IP address is reserved. The MAC address format can be "xx:xx:xx:xx:xx:xx" or "xx-
xx-xx-xx-xx-xx"
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5.16  The IPSec VPN Screen
Click a column’s heading cell to sort the table entries by that column’s criteria. Click the heading cell 
again to reverse the sort order.

5.16.1  The Site to Site VPN Screen
Use this screen to display and to manage active IPSec SAs.

To access this screen, click VPN Status > IPSec VPN > Site to Site VPN. The following screen appears. 

Figure 76   VPN Status > IPSec VPN > Site to Site VPN

Each field is described in the following table.

Expire Time This displays the date and time the DHCP-assigned address will be renewed.

Description This field displays a description of the DHCP client to identify it. The description cannot 
exceed 64 characters. Valid characters are [0-9][a-z][A-Z][_ -].

Note: You can only edit the description for clients with static (reserved) IP 
addresses.

Status This field displays the connection status of the DHCP client. Reserved means a static DHCP 
entry. - means a dynamic DHCP entry.

Table 45   Network Status > DHCP Table (continued)
LABEL DESCRIPTION

Table 46   VPN Status > IPSec VPN > Site to Site VPN
LABEL DESCRIPTION
Disconnect Select an IPSec SA and click this button to disconnect it.

Refresh Select an IPSec SA and click this button to update its status.

# This field is a sequential value, and it is not associated with a specific SA.

Name This field only displays the client names if they’re using EAP or X-auth for 
authentication.

If a client is connected to the Zyxel Device without using Extended Authentication 
Protocol (EAP) or X-Auth, this field will be empty.

Remote Gateway This field displays the IP address of the remote gateway.

Remote ID This field displays the ID of the remote gateway.

My Address This field displays the IP address of the Zyxel Device.

Policy Route This field displays the content of the local and remote policies for this IPSec SA. The IP 
addresses, not the address objects, are displayed.
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5.16.2  The Remote Access VPN Screen
Use this screen to display or disconnect remote access VPN clients that are connected to the Zyxel 
Device. The remote access VPN clients must have SecuExtender or use supported computer or mobile 
operating systems; see Section 12.4 on page 196 for more information.

To access this screen, click VPN Status > IPSec VPN > Remote Access VPN. The following screen appears. 

Figure 77   VPN Status > IPSec VPN > Remote Access VPN

Each field is described in the following table.

Uptime This field displays how many seconds the IPSec SA has been active. This field displays 
N/A if the IPSec SA uses manual keys.

Rekey This field displays how many seconds remain in the SA life time, before the Zyxel 
Device automatically disconnects the IPSec SA. This field displays N/A if the IPSec SA 
uses manual keys.

Inbound (Bytes) This field displays the amount of traffic that has gone through the IPSec SA from the 
remote IPSec router to the Zyxel Device since the IPSec SA was established.

Outbound (Bytes) This field displays the amount of traffic that has gone through the IPSec SA from the 
Zyxel Device to the remote IPSec router since the IPSec SA was established.

Table 46   VPN Status > IPSec (continued)VPN > Site to Site VPN
LABEL DESCRIPTION

Table 47   VPN Status > IPSec VPN > Remote Access VPN 
LABEL DESCRIPTION
Disconnect Select a remote access VPN client and click this button to disconnect it.

Refresh Click Refresh to update this screen.

# This field is a sequential value, and it is not associated with a specific remote access 
VPN client.

Username This field displays the name of the remote access VPN client.

Assigned IP This field displays the IP address the user used to establish this remote access VPN 
connection.

Remote IP This field displays the IP address of the remote IPSec router the remote access VPN 
client is connected to.

Up Time This field displays how many seconds the remote access VPN client has been active. 
This field displays N/A if the remote access VPN client uses manual keys.

Reauth/Lease Time This field displays the amount of reauthentication time remaining and the amount of 
lease time remaining for each remote access VPN client.

Inbound (Bytes) This field displays the number of bytes received by the Zyxel Device on this 
connection. 

Outbound (Bytes) This field displays the number of bytes transmitted by the Zyxel Device on this 
connection. 



Chapter 5 Monitor

USG FLEX H Series User’s Guide

98

5.17  The SSL VPN Screen 
The Zyxel Device keeps track of the SSL VPN clients who are currently logged into the Zyxel Device. Use 
this screen to:

• View a list of active SSL VPN connections.

• Log out individual users and delete related session information.

Once a user logs out, the corresponding entry is removed from the screen.

The SSL VPN clients must have SecuExtender or use supported computer or mobile operating systems; 
see Section 13.2 on page 202 for more information.

Click VPN Status > SSL VPN > Remote Access VPN to display the following screen.

Figure 78   VPN Status > SSL VPN > Remote Access VPN 

The following table describes the labels in this screen.

5.17.1  Regular Expressions in Searching IPSec SAs
A question mark (?) lets a single character in the VPN connection or policy name vary. For example, use 
“a?c” (without the quotation marks) to specify abc, acc and so on. 

Wildcards (*) let multiple VPN connection or policy names match the pattern. For example, use “*abc” 
(without the quotation marks) to specify any VPN connection or policy name that ends with “abc”. A 
VPN connection named “testabc” would match. There could be any number (of any type) of 
characters in front of the “abc” at the end and the VPN connection or policy name would still match. A 
VPN connection or policy name named “testacc” for example would not match. 

Table 48   VPN Status > SSL VPN > Remote Access VPN
LABEL DESCRIPTION
Disconnect Select a connection and click this button to terminate the user’s connection and delete 

corresponding session information from the Zyxel Device. 

Refresh Click Refresh to update this screen. 

# This field is a sequential value, and it is not associated with a specific SSL.

Username This field displays the account user name used to establish this SSL VPN connection. 

Assigned IP This field displays the IP address the user used to establish this SSL VPN connection.

Remote IP This field displays the remote SSL VPN router the SSL VPN is connected to.

Up Time This field displays how many seconds the SSL VPN client has been active. This field 
displays N/A if the SSL VPN client uses manual keys.

Reauth/Lease Time This field displays the amount of reauthentication time remaining and the amount of 
lease time remaining for each SSL VPN client.

Inbound (Bytes) This field displays the number of bytes received by the Zyxel Device on this connection. 

Outbound (Bytes) This field displays the number of bytes transmitted by the Zyxel Device on this 
connection. 
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A * in the middle of a VPN connection or policy name has the Zyxel Device check the beginning and 
end and ignore the middle. For example, with “abc*123”, any VPN connection or policy name starting 
with “abc” and ending in “123” matches, no matter how many characters are in between.

The whole VPN connection or policy name has to match if you do not use a question mark or asterisk.
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CHAPTER 6
Licensing

6.1  Licensing Overview
Use the Licensing screens to register your Zyxel Device and manage its service subscriptions.

• Use the Licenses screen to refresh Zyxel Device registration. Go to nebula.zyxel.com to register your 
Zyxel Device and activate a service, such as content filtering.

• Use the Signature Update screen to download the latest signatures for your licensed services.

Please note that you cannot use the security services and upgrade firmware if your Zyxel Device is not 
registered at NCC or the services do not have a license. Your Zyxel Device and network will be exposed 
to threats and attacks. We strongly recommend you to register your Zyxel Device and purchase a 
license at NCC to better protect your Zyxel Device and network.

6.1.1  What you Need to Know
This section introduces the topics covered in this chapter.

Subscription Services Available

See Licensing > Signature Update for the subscription services that your Zyxel Device supports. You can 
extend a service at NCC > Organization-wide > License & Inventory.

Signature Update
• You need a valid service registration to update the Application Patrol signatures, IPS signatures and IP 

Reputation signatures.

• Schedule signature updates for a day and time when your network is least busy to minimize disruption 
to your network. 

Note: The Zyxel Device does not have to reboot when you upload new signatures.

Features Available Without a License

You can use the following Zyxel Device features without a license:

Table 49   Features Available Without a License
MONITOR CONFIGURATION MAINTENANCE
System Statistics Network Maintenance

Network Status VPN

VPN Status Security Policy

Object

User & Authentication



 Chapter 6 Licensing

USG FLEX H Series User’s Guide

101

6.1.2  The Licenses Screen
Use this screen to display the status of your service registrations and upgrade licenses. Go to NCC to 
register your Zyxel Device or purchase a license.

Click Licensing > Licenses to display the following screen.

Figure 79   Licensing > Licenses (Registered) 

The Licenses screen may show different services depending on the licenses you purchase or activate. 

The following table describes the labels in this screen.

System

Log & Report (except SecuReporter)

Table 49   Features Available Without a License
MONITOR CONFIGURATION MAINTENANCE

Table 50   Licensing > Licenses 
LABEL DESCRIPTION
Device Registration Status This field display the Zyxel Device registration status on NCC.

• Registered: Your Zyxel Device has successfully registered at NCC.
• Not Registered: Your Zyxel Device is not registered at NCC. Make sure you’re 

connected to the Internet. Wait a few minutes then click Refresh to update the 
registration status.

Refresh Click this and wait for a few moments for the license and device registration status 
to update. The license and device registration status are updated automatically 
once every day.

Purchase License Click Purchase License to go to Marketplace to renew Zyxel Device licenses.

Licenses Information

Service This lists the name of services or service modules that are available on the Zyxel 
Device. 

Reputation Filter This is a license to recognize packets coming from suspect IPv4 addresses.
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You will see the following screen if:

• Your Zyxel Device is not registered at NCC.

• You’re logging into the Zyxel Device using an admin account.

Scan the QR code or click Nebula under Note to register your Zyxel Device at NCC. Please note that you 
need to register your Zyxel Device at NCC to upgrade firmware and use security services.

Application Patrol This is a license to use signatures to manage the use of various applications on the 
network.

Web Filtering This is a license to a database that can block websites by category, such as 
Gambling.

Anti-Malware This is a license for signatures to detect virus patterns in files. 

SecuReporter This is a license that allows SecuReporter to collect and analyze logs from your Zyxel 
Device in order to identify anomalies, notify you of potential internal or external 
threats, and report on network usage. SecuReporter retains logs for up to 1 year.

IPS This is a license to detect Intrusion Prevention System attacks.

Device Insight This is a license to detect and manage client devices in the Zyxel Device local 
network and DMZ.

Sandboxing This is a license to provide an isolated environment to scan traffic from the WAN 
that comes with unknown files or untrusted programs.

Nebula Base/Plus/
Professional Pack

This is a license that allows you to use NCC to monitor and manage groups of Zyxel 
Devices in organizations. See the NCC User’s Guide for more information on Nebula 
Base, Plus and Professional pack license.

Status This field displays whether a service license is enabled at NCC (Activated) or 
expired (Expired). It displays the remaining grace period if your license has Expired. 
It displays Not Licensed if there isn’t a license to be activated for this service.

Expiration Date This field displays the date your service license expires or the date the grace period 
expires if the license has already expired.

You can continue to use IPS, Application Patrol, Anti-Malware and Web Filtering 
during the grace period. After the grace period ends, all of these features are 
disabled.

Table 50   Licensing > Licenses (continued)
LABEL DESCRIPTION
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Figure 80   Licensing > Licenses (Not Registered)

6.1.3  The Signature Update Screen
Click Licensing > Signature Update to display the following screen.

Figure 81   Licensing > Signature Update 

The following table describes the labels in this screen.

Table 51   Licensing > Signature Update  
LABEL DESCRIPTION
Feature This field displays the name of the services available on the Zyxel Device.

Type This field displays the type of service engine used by the Zyxel Device. 

Current Version This field displays the signatures version number currently used by the Zyxel Device. This 
number gets larger as new signatures are added.
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6.1.4  Signature Update
Click the Update icon ( ) of a service to display the following screen. Use this screen to view the service 
update status.

Figure 82   Licensing > Signature Update > Update > Update 

6.1.5  Auto Update
Click the Schedule icon ( ) of a service to display the following screen.

Release Date This field displays the date and time the set was released.

Last Sync This field displays the date and time the Zyxel Device last checked for new signatures.

Action Click the Update icon ( )to have the Zyxel Device immediately check for new 
signatures. If new signatures are found, they are then downloaded to the Zyxel Device.

Click the Schedule icon ( ) to have the Zyxel Device automatically check for new 
signatures regularly at the time and day specified. You should select a time when your 
network is not busy for minimal interruption.

Table 51   Licensing > Signature Update (continued) 
LABEL DESCRIPTION
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Figure 83   Licensing > Signature Update > Schedule > Auto Update 

The following table describes the labels in this screen.

Table 52   Licensing > Signature Update > Schedule > Auto Update  
LABEL DESCRIPTION
Auto Update Enable to have the Zyxel Device automatically check for new signatures regularly at 

the time and day specified.

You should select a time when your network is not busy for minimal interruption.

Every N Hours Select this option to have the Zyxel Device check for new signatures every specified (N) 
hour.

Daily Select this option to have the Zyxel Device check for new signatures every day at the 
specified time. The time format is the 12 hour clock. 

Weekly Select this option to have the Zyxel Device check for new signatures once a week on 
the day and at the time specified.

OK Click this button to save your changes to the Zyxel Device. 
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CHAPTER 7
Interfaces

7.1  Interface Overview
Use the Interface screens to configure the Zyxel Device’s interfaces. You can also create interfaces on 
top of other interfaces. 

• Ports are the physical ports to which you connect cables.

• Interfaces are used within the system operationally. You use them in configuring various features. An 
interface also describes a network that is directly connected to the Zyxel Device. For example, You 
connect the LAN network to the LAN interface. 

7.1.1  What You Can Do in this Chapter
• Use the Interface (Section 7.2 on page 112) screen to view a summary of the Zyxel Device interface 

settings.

• Use the Internal/External Interface (Section 7.3 on page 115) screens to configure Ethernet and VLAN   
interfaces.

Ethernet interfaces are the foundation for defining other interfaces and network policies.

VLAN interfaces receive and send tagged frames. The Zyxel Device automatically adds or removes 
the tags as needed. Each VLAN can only be associated with one Ethernet interface.

• Use the Bridge (Section 7.5 on page 126) screens to combine two or more network segments into a 
single network.

• Use the Trunk (Section 7.8 on page 137) screen to configure load balancing.

• Use the Port screen (Section 7.9 on page 141) to configure Zyxel Device port settings.

7.1.2  What You Need to Know 

Interface Characteristics

Interfaces generally have the following characteristics (although not all characteristics apply to each 
type of interface).

• An interface is a logical entity through which (layer-3) packets pass.

• An interface is bound to a physical port or another interface.

• Many interfaces can share the same physical port.

• An interface belongs to at most one zone.

• Many interfaces can belong to the same zone.

Types of Interfaces

You can create several types of interfaces in the Zyxel Device.
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• Setting interfaces to the same port role forms a port group. Port groups creates a hardware 
connection between physical ports at the layer-2 (data link, MAC address) level. Port groups are 
created when you use the Interface > Port screen to set multiple physical ports to be part of the same 
interface.

Note: Some models have Individual ports. You cannot group Individual ports together or with 
other ports. 

• Ethernet interfaces are the foundation for defining other interfaces and network policies.

• VLAN interfaces receive and send tagged frames. The Zyxel Device automatically adds or removes 
the tags as needed. Each VLAN can only be associated with one Ethernet interface.

• Bridge interfaces create a software connection between Ethernet or VLAN interfaces at the layer-2 
(data link, MAC address) level. Unlike port groups, bridge interfaces can take advantage of some 
security features in the Zyxel Device. You can also assign an IP address and subnet mask to the 
bridge.

• Trunk interfaces manage load balancing between interfaces.

• PPPoE interfaces support Point-to-Point Protocols (PPP). ISP accounts are required for PPPoE interfaces.

• VPN Tunnel Interface (VTI) encrypts or decrypts IPv4 traffic from or to the interface according to the IP 
routing table. 

Port groups and trunks have a lot of characteristics that are specific to each type of interface. The other 
types of interfaces, including Ethernet, VLAN and bridge, have a lot of similar characteristics. These 
characteristics are listed in the following table and discussed in more detail below.

Note: The format of interface names other than the Ethernet and ppp interface names is 
strict. Each name consists of 2-4 letters (interface type), followed by a number (x). For 
most interfaces, x is limited by the maximum number of the type of interface. For VLAN 
interfaces, x is defined by the number you enter in the VLAN name field. For example, 
Ethernet interface names are wan1, wan2, lan1, lan2, dmz; VLAN interfaces are vlan0, 
vlan1, vlan2...and so on.

Table 53   Models with Individual Ports
MODEL  INDIVIDUAL PORTS
USG FLEX 500H P1, P2

USG FLEX 700H P1, P2, P13, P14

Table 54   Interface Characteristics  
CHARACTERISTICS ETHERNET ETHERNET VLAN VLAN PPPOE BRIDGE
Type external internal external internal external general

Configurable Zone Yes Yes Yes Yes Yes Yes

Static IP address Yes Yes Yes Yes Yes Yes

DHCP client (GUI) Yes No Yes No N/A Yes

DHCP client / server/relay(CLI) Yes Yes Yes Yes N/A Yes

Bandwidth Restrictions Yes Yes Yes Yes Yes Yes

Packet size (MTU) Yes Yes Yes Yes Yes Yes

Connectivity Check Yes Yes Yes Yes Yes Yes
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Relationships Between Interfaces

In the Zyxel Device, interfaces are usually created on top of other interfaces. Only Ethernet interfaces 
are created directly on top of the physical ports or port groups. The relationships between interfaces are 
explained in the following table.

IP Address Assignment

Most interfaces have an IP address and a subnet mask. 

Figure 84   Example: Entry in the Routing Table Derived from Interfaces

This information is used to create an entry in the routing table.

For example, if the Zyxel Device gets a packet with a destination address of 100.100.25.25, it routes the 
packet to interface lan1. If the Zyxel Device gets a packet with a destination address of 200.200.200.200, 
it routes the packet to interface wan1.

Table 55   Relationships Between Different Types of Interfaces 
INTERFACE RESTRICTION REQUIRED PORT / INTERFACE
Ethernet interface N/A physical port

VLAN interface You cannot configure a VLAN interface and an 
Ethernet interface on the same port

physical port

bridge interface When you configure a bridge interface, you cannot 
set the bridge interface on an interface that is 
already used by other bridge or VLAN interfaces.

Ethernet interface*

VLAN interface*

trunk When you configure a trunk interface, you cannot 
set the trunk interface on an interface that is already 
used by other bridge or LAG interfaces.

External/General Ethernet interface

VLAN interface

LAG interface

PPPoE interface

bridge interface

PPPoE interface N/A Ethernet interface*

VLAN interface*

bridge interface

Table 56   Example: Routing Table Entries for Interfaces 
IP ADDRESS(ES) DESTINATION
100.100.1.1/16 lan1

200.200.200.1/24 wan1
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In most interfaces, you can enter the IP address and subnet mask manually. In PPPoE interfaces, 
however, the subnet mask is always 255.255.255.255 because it is a point-to-point interface. For these 
interfaces, you can only enter the IP address.

In many interfaces, you can also let the IP address and subnet mask be assigned by an external DHCP 
server on the network. In this case, the interface is a DHCP client. Virtual interfaces, however, cannot be 
DHCP clients. You have to assign the IP address and subnet mask manually.

In general, the IP address and subnet mask of each interface should not overlap, though it is possible for 
this to happen with DHCP clients.

In the example above, if the Zyxel Device gets a packet with a destination address of 5.5.5.5, it might 
not find any entries in the routing table. In this case, the packet is dropped. However, if there is a default 
router to which the Zyxel Device should send this packet, you can specify it as a gateway in one of the 
interfaces. For example, if there is a default router at 200.200.200.100, you can create a gateway at 
200.200.200.100 on ge2. In this case, the Zyxel Device creates the following entry in the routing table.

The gateway is an optional setting for each interface. If there is more than one gateway, the Zyxel 
Device uses the gateway with the lowest metric, or cost. If two or more gateways have the same metric, 
the Zyxel Device uses the one that was set up first (the first entry in the routing table). In PPPoE interfaces, 
the other computer is the gateway for the interface by default. In this case, you should specify the 
metric.

If the interface gets its IP address and subnet mask from a DHCP server, the DHCP server also specifies 
the gateway, if any.

DHCP Settings

Dynamic Host Configuration Protocol (DHCP, RFC 2131, RFC 2132) provides a way to automatically set 
up and maintain IP addresses, subnet masks, gateways, and some network information (such as the IP 
addresses of DNS servers) on computers on the network. This reduces the amount of manual 
configuration you have to do and usually uses available IP addresses more efficiently.

In DHCP, every network has at least one DHCP server. When a computer (a DHCP client) joins the 
network, it submits a DHCP request. The DHCP servers get the request; assign an IP address; and provide 
the IP address, subnet mask, gateway, and available network information to the DHCP client. When the 
DHCP client leaves the network, the DHCP servers can assign its IP address to another DHCP client.

In the Zyxel Device, some interfaces can provide DHCP services to the network. In this case, the 
interface can be a DHCP relay or a DHCP server.

As a DHCP relay, the interface routes DHCP requests to DHCP servers on different networks. You can 
specify more than one DHCP server. If you do, the interface routes DHCP requests to all of them. It is 
possible for an interface to be a DHCP relay and a DHCP client simultaneously.

As a DHCP server, the interface provides the following information to DHCP clients.

Table 57   Example: Routing Table Entry for a Gateway 
IP ADDRESS(ES) DESTINATION
0.0.0.0/0 200.200.200.100
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• IP address - If the DHCP client’s MAC address is in the Zyxel Device’s static DHCP table, the interface 
assigns the corresponding IP address. If not, the interface assigns IP addresses from a pool, defined by 
the starting address of the pool and the pool size.

The Zyxel Device cannot assign the first address (network address) or the last address (broadcast 
address) on the subnet defined by the interface’s IP address and subnet mask. For example, in the first 
entry, if the subnet mask is 255.255.255.0, the Zyxel Device cannot assign 50.50.50.0 or 50.50.50.255. If 
the subnet mask is 255.255.0.0, the Zyxel Device cannot assign 50.50.0.0 or 50.50.255.255. Otherwise, it 
can assign every IP address in the range, except the interface’s IP address.

If you do not specify the starting address or the pool size, the interface the maximum range of IP 
addresses allowed by the interface’s IP address and subnet mask. For example, if the interface’s IP 
address is 9.9.9.1 and subnet mask is 255.255.255.0, the starting IP address in the pool is 9.9.9.2, and the 
pool size is 253.

• Subnet mask - The interface provides the same subnet mask you specify for the interface. See IP 
Address Assignment on page 108.

• Gateway - The interface provides the same gateway you specify for the interface. See IP Address 
Assignment on page 108.

• DNS servers - The interface provides IP addresses for up to three DNS servers that provide DNS services 
for DHCP clients. You can specify each IP address manually (for example, a company’s own DNS 
server), or you can refer to DNS servers that other interfaces received from DHCP servers (for example, 
a DNS server at an ISP). These other interfaces have to be DHCP clients.

It is not possible for an interface to be the DHCP server and a DHCP client simultaneously.

WINS

WINS (Windows Internet Naming Service) is a Windows implementation of NetBIOS Name Server (NBNS) 
on Windows. It keeps track of NetBIOS computer names. It stores a mapping table of your network’s 
computer names and IP addresses. The table is dynamically updated for IP addresses assigned by 
DHCP. This helps reduce broadcast traffic since computers can query the server instead of 
broadcasting a request for a computer name’s IP address. In this way WINS is similar to DNS, although 
WINS does not use a hierarchy (unlike DNS). A network can have more than one WINS server. Samba 
can also serve as a WINS server.

PPPoE Overview

Point-to-Point Protocol over Ethernet (PPPoE, RFC 2516) is usually used to connect two computers over 
phone lines or broadband connections. PPPoE is often used with cable modems and DSL connections. It 
provides the following advantages:

• The access and authentication method works with existing systems, including RADIUS.

• You can access one of several network services. This makes it easier for the service provider to offer 
the service

• PPPoE does not usually require any special configuration of the modem.

Table 58   Example: Assigning IP Addresses from a Pool 
START IP ADDRESS POOL SIZE RANGE OF ASSIGNED IP ADDRESS
50.50.50.33 5 50.50.50.33 - 50.50.50.37

75.75.75.1 200 75.75.75.1 - 75.75.75.200

99.99.1.1 1023 99.99.1.1 - 99.99.4.255

120.120.120.100 100 120.120.120.100 - 120.120.120.199
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Introduction to VLANs

A Virtual Local Area Network (VLAN) divides a physical network into multiple logical networks. The 
standard is defined in IEEE 802.1q.

Figure 85   Example: Before VLAN

In this example, there are two physical networks and three departments A, B, and C. The physical 
networks are connected to hubs, and the hubs are connected to the router.

Alternatively, you can divide the physical networks into three VLANs.

Figure 86   Example: After VLAN

Each VLAN is a separate network with separate IP addresses, subnet masks, and gateways. Each VLAN 
also has a unique identification number (ID). The ID is a 12-bit value that is stored in the MAC header. The 
VLANs are connected to switches, and the switches are connected to the router. (If one switch has 
enough connections for the entire network, the network does not need switches A and B.)

• Traffic inside each VLAN is layer-2 communication (data link layer, MAC addresses). It is handled by 
the switches. As a result, the new switch is required to handle traffic inside VLAN 2. Traffic is only 
broadcast inside each VLAN, not each physical network.

• Traffic between VLANs (or between a VLAN and another type of network) is layer-3 communication 
(network layer, IP addresses). It is handled by the router.

This approach provides a few advantages.

• Increased performance - In VLAN 2, the extra switch should route traffic inside the sales department 
faster than the router does. In addition, broadcasts are limited to smaller, more logical groups of users.

• Higher security - If each computer has a separate physical connection to the switch, then broadcast 
traffic in each VLAN is never sent to computers in another VLAN.
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• Better manageability - You can align network policies more appropriately for users. For example, you 
can create different content filtering rules for each VLAN (each department in the example above), 
and you can set different bandwidth limits for each VLAN. These rules are also independent of the 
physical network, so you can change the physical network without changing policies.

In this example, the new switch handles the following types of traffic:

• Inside VLAN 2.

• Between the router and VLAN 1.

• Between the router and VLAN 2.

• Between the router and VLAN 3.

In the Zyxel Device, each VLAN is called a VLAN interface. As a router, the Zyxel Device routes traffic 
between VLAN interfaces, but it does not route traffic within a VLAN interface. All traffic for each VLAN 
interface can go through only one Ethernet interface, though each Ethernet interface can have one or 
more VLAN interfaces.

Note: Each VLAN interface is created on top of only one Ethernet interface.

Otherwise, VLAN interfaces are similar to other interfaces in many ways. They have an IP address, subnet 
mask, and gateway used to make routing decisions. They restrict bandwidth and packet size. They can 
provide DHCP services, and they can verify the gateway is available.

7.2  Interface Screen
Use this screen to view your Zyxel Device interface settings. To access this screen, click Network > 
Interface > Interface.
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Figure 87   Network > Interface > Interface

Each field is described in the following table.

Table 59   Network > Interface > Interface  
LABEL DESCRIPTION
External

Add Click this to add a new entry.

Edit Select an entry and click Edit to open a screen where you can modify the entry’s settings. 

Remove To remove a virtual interface, select it and click Remove. The Zyxel Device confirms you 
want to remove it before doing so.

Reference This field displays the objects this entry uses. 

Active To turn on an entry, select it and click Activate. The Status light changes accordingly.

Inactive To turn off an entry, select it and click Inactivate. The Status light changes accordingly.

Connect To dial-up to a PPPoE interface, select it and click Connect.

Disconnect To disconnect from a PPPoE interface, select it and click Disconnect.

Status This icon is lit when the entry is active and dimmed when the entry is inactive.

Name This field displays the name of the interface.

Zone This displays the zone to which this interface belongs. An interface can only be in one zone.

Description This field displays the description of the interface.

IP/Netmask This field displays the current IP address and the subnet mask of the interface. If this field is 
empty, the interface does not have an IP address yet.
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VLAN ID This field displays the VLAN ID which is a 12-bit number that uniquely identifies each VLAN.

Type This field displays the interface type: Ethernet or VLAN.

Ports This field displays the port the interface is using.

Reference This field displays how many objects this entry uses.

Internal

Add Click this to add a new entry.

Edit Select an entry and click Edit to open a screen where you can modify the entry’s settings. 

Remove To remove a virtual interface, select it and click Remove. The Zyxel Device confirms you 
want to remove it before doing so.

Reference This field displays the objects this entry uses. 

Active To turn on an entry, select it and click Activate. The Status light changes accordingly.

Inactive To turn off an entry, select it and click Inactivate. The Status light changes accordingly.

Status This icon is lit when the entry is active and dimmed when the entry is inactive.

Name This field displays the name of the interface.

Zone This displays the zone to which this interface belongs. An interface can only be in one zone.

Description This field displays the description of the interface.

IP/Netmask This field displays the current IP address and the subnet mask of the interface. If this field is 
empty, the interface does not have an IP address yet.

VLAN ID This field displays the VLAN ID which is a 12-bit number that uniquely identifies each VLAN.

Type This field displays the interface type.

Ports This field displays the port the interface is using.

Reference This field displays how many objects this entry uses.

Bridge

Add Click this to add a new entry.

Edit Select an entry and click Edit to open a screen where you can modify the entry’s settings. 

Remove To remove a virtual interface, select it and click Remove. The Zyxel Device confirms you 
want to remove it before doing so.

Reference This field displays the objects this entry uses. 

Active To turn on an entry, select it and click Activate. The Status light changes accordingly.

Inactive To turn off an entry, select it and click Inactivate. The Status light changes accordingly.

Status This icon is lit when the entry is active and dimmed when the entry is inactive.

Name This field displays the name of the interface.

Zone This displays the zone to which this interface belongs. An interface can only be in one zone.

Description This field displays the description of the interface.

IP/Netmask This field displays the current IP address and the subnet mask of the interface. If this field is 
empty, the interface does not have an IP address yet.

Members This field displays the Ethernet interfaces and VLAN interfaces in the bridge interface. It is 
blank for virtual interfaces.

Reference This field displays how many objects this entry uses.

VTI

Edit Select an entry and click Edit to open a screen where you can modify the entry’s settings. 

Remove To remove a virtual interface, select it and click Remove. The Zyxel Device confirms you 
want to remove it before doing so.

Table 59   Network > Interface > Interface  (continued)
LABEL DESCRIPTION
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7.3  External Interface
Use this screen to configure the external interface settings for connecting to an external network (like 
the Internet). The Zyxel Device automatically adds an external interface to the default WAN trunk.

7.3.1  External Ethernet Add/Edit
Unlike other types of interfaces, you cannot create new Ethernet interfaces nor can you delete any of 
them. If an Ethernet interface does not have any physical ports assigned to it, the Ethernet interface is 
effectively removed from the Zyxel Device, but you can still configure it.

Ethernet interfaces are similar to other types of interfaces in many ways. They have an IP address, subnet 
mask, and gateway used to make routing decisions. They restrict the amount of bandwidth and packet 
size. They can provide DHCP services, and they can verify the gateway is available.

Use Ethernet interfaces to control which physical ports exchange routing information with other routers 
and how much information is exchanged through each one. The more routing information is 
exchanged, the more efficient the routers should be. However, the routers also generate more network 
traffic, and some routing protocols require a significant amount of configuration and management.

Reference This field displays the objects this entry uses. 

Active To turn on an entry, select it and click Activate. The Status light changes accordingly.

Inactive To turn off an entry, select it and click Inactivate. The Status light changes accordingly.

Status This icon is lit when the entry is active and dimmed when the entry is inactive.

Name This field displays the name of the interface.

Zone This displays the zone to which this interface belongs. An interface can only be in one zone.

Table 59   Network > Interface > Interface  (continued)
LABEL DESCRIPTION
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Figure 88   Network > Interface > Interface > External > Add (General)

Figure 89   Network > Interface > Interface > External > Add (PPPoE Add)
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Figure 90   Network > Interface > Interface > External > Add (Connectivity Check & Advanced)

These screen’s fields are described in the table below.

Table 60   Network > Interface > Interface > External > Add
LABEL DESCRIPTION
General Settings

Enable Interface Select this to enable this interface. Clear this to disable this interface.

Interface Properties

Role Select to which type of network you will connect this interface. When you select Internal or 
External the rest of the screen’s options automatically adjust to correspond. The Zyxel 
Device automatically adds default route and SNAT settings for traffic it routes from internal 
interfaces to external interfaces; for example LAN to WAN traffic.

Internal is for connecting to a local network. Other corresponding configuration options: 
DHCP server and DHCP relay. The Zyxel Device automatically adds default SNAT settings for 
traffic flowing from this interface to an external interface.

External is for connecting to an external network (like the Internet). The Zyxel Device 
automatically adds this interface to the default WAN trunk. 

Interface Type Select the type of interface you want to configure.

Name Specify a name for the interface. It can use alphanumeric characters, hyphens, and 
underscores, and it can be up to 11 characters long.

Port This is the name of the Ethernet interface’s physical port.
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Zone Select the zone to which this interface is to belong. You use zones to apply security settings 
such as security policy, IPS, remote management, anti-malware, and application patrol. 
Make sure to select the correct zone as otherwise traffic may be blocked by a security 
policy.

MAC Address Have the interface use either the factory assigned default MAC address, a manually 
specified MAC address, or clone the MAC address of another device or computer. 

Use Default MAC 
Address

Select this option to have the interface use the factory assigned default MAC address. By 
default, the Zyxel Device uses the factory assigned MAC address to identify itself.

Overwrite 
Default MAC 
Address

Select this option to have the interface use a different MAC address. Enter a MAC address 
in the format "xx:xx:xx:xx:xx:xx" or "xx-xx-xx-xx-xx-xx". Once it is successfully configured, the 
address will be copied to the configuration file. It will not change unless you change the 
setting or upload a different configuration file. 

VLAN ID This field displays when you select the VLAN Interface Type. Enter the VLAN ID. This 12-bit 
number uniquely identifies each VLAN. Allowed values are 1 - 4094. (0 and 4095 are 
reserved.)

Description Enter a description of this interface. You can use alphanumeric and ()+/:=?!*#@$_%- 
characters, and it can be up to 60 characters long. Spaces are allowed, but the string 
can’t start with a space.

Address Assignment These IP address fields configure an IPv4 IP address on the interface itself. If you change this 
IP address on the interface, you may also need to change a related address object for the 
network connected to the interface. For example, if you use this screen to change the IP 
address of your LAN interface, you should also change the corresponding LAN subnet 
address object.

Unassigned Select this if you don’t want to specify an IP address for this interface.

Get 
Automatically 
(DHCP)

Select this to make the interface a DHCP client and automatically get the IP address, 
subnet mask, and gateway address from a DHCP server.

Use Fixed IP 
Address

Select this if you want to specify the IP address, subnet mask, and gateway manually.

PPPoE  Select this for a dial-up connection according to the information from your ISP. The 
following fields appear in the Add PPPoE screen.

Authentication 
Type

Select an authentication protocol for outgoing connection requests.

• Chap: Your Zyxel Device accepts CHAP only.
• PAP: Your Zyxel Device accepts PAP only.
• MSCHAP: Your Zyxel Device accepts MSCHAP only.
• MSCHAP-V2: Your Zyxel Device accepts MSCHAP-V2 only.

User Name Enter the user name give to you by your ISP. You can use up to 30 single-byte characters, 
including 0-9a-zA-Z@._-

Password Enter the password associated with the user name. You can use 4 to 63 single-byte 
characters, including 0-9a-zA-Z’(){}<>^‘+/:!*#@&=$\.~%,|;-”

Retype Retype the password you entered in the Password field to confirm.

Service Name Enter the service name from your service provider. PPPoE uses a service name to identify 
and reach the PPPoE server. You can use up to 30 single-byte characters, including 0-9a-
zA-Z._-

Compression Select On to turn on stac compression. Select Off to turn of stac compression. Stac 
compression is data compression technique capable of compressing data by a factor of 
about four. 

User Idle Timeout Enter the idle timeout in seconds that elapses before the router automatically disconnects 
from the PPPoE server.

WAN IP Enter the IP address of the WAN interface through which this connection will send traffic.

Gateway IP Enter the IP address of the router through which this WAN connection will send traffic.

Table 60   Network > Interface > Interface > External > Add
LABEL DESCRIPTION
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IP Address This option appears when Interface Type is internal. Enter the IP address for this interface.

Subnet Mask This option appears when Interface Type is internal. Enter the subnet mask of this interface in 
dot decimal notation. The subnet mask indicates what part of the IP address is the same for 
all computers on the network.

Connectivity Check The interface can regularly check the connection to the gateway you specified to make 
sure it is still available. You specify how often the interface checks the connection, how 
long to wait for a response before the attempt is a failure, and how many consecutive 
failures are required before the Zyxel Device stops routing to the gateway. The Zyxel Device 
resumes routing to the gateway the first time the gateway passes the connectivity check.

Enable Select this to turn on the connection check.

Check Method Select the method that the gateway allows. 

Select icmp to have the Zyxel Device regularly ping the gateway you specify to make sure 
it is still available. 

Select tcp to have the Zyxel Device regularly perform a TCP handshake with the gateway 
you specify to make sure it is still available. 

Check Period Enter the number of seconds between connection check attempts.

Check Timeout Enter the number of seconds to wait for a response before the attempt is a failure.

Check Fail 
Tolerance

Enter the number of consecutive failures before the Zyxel Device stops routing through the 
gateway.

Check These 
Addresses

Specify one or two domain names or IP addresses for the connectivity check.

You can type an IPv4 address in one field and a domain name in the other. For example, 
type “192.168.1.2” in the top filed and “www.zyxel.com” in the bottom field.

Check Succeeds 
When

This field applies when you specify two domain names or IP addresses for the connectivity 
check.

Select Any if you want the check to pass if at least one of the domain names or IP 
addresses responds.

Select All if you want the check to pass only if both domain names or IP addresses respond.

Advanced Settings

DHCP Option 60 This field appears when Role is set to External. The setting you configure here will only work 
when Address Assignment is set to Get Automatically.

DHCP Option 60 is used by the Zyxel Device for identification to the DHCP server using the 
VCI (Vendor Class Identifier) on the DHCP server. The Zyxel Device adds it in the initial DHCP 
discovery message that a DHCP client broadcasts in search of an IP address. The DHCP 
server can assign different IP addresses or options to clients with the specific VCI or reject 
the request from clients without the specific VCI.

Type a string using up to 63 of these characters [a-zA-Z0-9!\"#$%&\'()*+,-./:;<=>?@\[]^_`{}] 
to identify this Zyxel Device to the DHCP server. For example, Zyxel-TW.

MTU This is the Maximum Transmission Unit. Type the maximum size of each data packet, in bytes, 
that can move through this interface. If a larger packet arrives, the Zyxel Device divides it 
into smaller fragments. Allowed values are 576-1500. Usually, this value is 1500.

Default SNAT This field appears when Role is set to External.

Select this to have the Zyxel Device use the IP address of the outgoing interface as the 
source IP address of the packets it sends out through its WAN trunks. The Zyxel Device 
automatically adds SNAT settings for traffic it routes from internal interfaces to external 
interfaces.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 60   Network > Interface > Interface > External > Add
LABEL DESCRIPTION
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7.4  Internal Interface
Use this screen to configure the internal interface settings for connecting to a local network. Other 
corresponding configuration options are DHCP server and DHCP relay. The Zyxel Device automatically 
applies the default SNAT settings to traffic flowing from an internal interface to an external interface.

7.4.1  Internal Ethernet Add/Edit
Unlike other types of interfaces, you cannot create new Ethernet interfaces nor can you delete any of 
them. If an Ethernet interface does not have any physical ports assigned to it, the Ethernet interface is 
effectively removed from the Zyxel Device, but you can still configure it.

Ethernet interfaces are similar to other types of interfaces in many ways. They have an IP address, subnet 
mask, and gateway used to make routing decisions. They restrict the amount of bandwidth and packet 
size. They can provide DHCP services, and they can verify the gateway is available.

Use Ethernet interfaces to control which physical ports exchange routing information with other routers 
and how much information is exchanged through each one. The more routing information is 
exchanged, the more efficient the routers should be. However, the routers also generate more network 
traffic, and some routing protocols require a significant amount of configuration and management.
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Figure 91   Network > Interface > Interface > Internal > Add /Edit(Ethernet)
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These screen’s fields are described in the table below.

Table 61   Network > Interface > Interface > Internal > Add (Ethernet)  
LABEL DESCRIPTION
General Settings

Enable Interface Select this to enable this interface. Clear this to disable this interface.

Interface Properties

Role Select to which type of network you will connect this interface. When you select Internal or 
External the rest of the screen’s options automatically adjust to correspond. The Zyxel 
Device automatically adds default route and SNAT settings for traffic it routes from internal 
interfaces to external interfaces; for example LAN to WAN traffic.

Internal is for connecting to a local network. Other corresponding configuration options: 
DHCP server and DHCP relay. The Zyxel Device automatically adds default SNAT settings for 
traffic flowing from this interface to an external interface.

External is for connecting to an external network (like the Internet). The Zyxel Device 
automatically adds this interface to the default WAN trunk. 

Interface Type Select the type of interface you want to configure.

Name Specify a name for the interface. It can use alphanumeric characters, hyphens, and 
underscores, and it can be up to 11 characters long.

Port This is the name of the Ethernet interface’s physical port.

Zone Select the zone to which this interface is to belong. You use zones to apply security settings 
such as security policy, IPS, remote management, anti-malware, and application patrol. 
Make sure to select the correct zone as otherwise traffic may be blocked by a security 
policy.

MAC Address This field is read-only. This is the MAC address that the Ethernet interface uses.

Description Enter a description of this interface. You can use alphanumeric and ()+/:=?!*#@$_%- 
characters, and it can be up to 60 characters long. Spaces are allowed, but the string 
can’t start with a space.

IP Address 
Assignment

This option appears when Interface Type is external.

These IP address fields configure an IPv4 IP address on the interface itself. If you change this 
IP address on the interface, you may also need to change a related address object for the 
network connected to the interface. For example, if you use this screen to change the IP 
address of your LAN interface, you should also change the corresponding LAN subnet 
address object.

Get 
Automatically

This option appears when Interface Type is external. Select this to make the interface a 
DHCP client and automatically get the IP address, subnet mask, and gateway address from 
a DHCP server.

Use Fixed IP 
Address

This option appears when Interface Type is external. Select this if you want to specify the IP 
address and subnet mask manually.

DHCP Server

Enable Select this to enable the DHCP server on the Zyxel Device.

Mode Select what type of DHCP service the Zyxel Device provides to the network. Choices are:

DHCP - the Zyxel Device assigns IP addresses and provides subnet mask, gateway, and DNS 
server information to the network. The Zyxel Device is the DHCP server for the network.

Relay - the Zyxel Device routes DHCP requests to one or more DHCP servers you specify. The 
DHCP server(s) may be on another network. You can have at most four DHCP relay servers 
at the same time.
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Start IP Enter the IP address from which the Zyxel Device begins allocating IP addresses. If you want 
to assign a static IP address to a specific computer, use the Static DHCP Table.

If this field is blank, the Pool Size must also be blank. In this case, the Zyxel Device can assign 
every IP address allowed by the interface’s IP address and subnet mask, except for the first 
address (network address), last address (broadcast address) and the interface’s IP address.

Pool Size Enter the number of IP addresses to allocate. This number must be at least one and is limited 
by the interface’s Subnet Mask. For example, if the Subnet Mask is 255.255.255.0 and Start IP 
is 10.10.10.10, the Zyxel Device can allocate 10.10.10.10 to 10.10.10.254, or 245 IP addresses.

If this field is blank, the Start IP must also be blank. In this case, the Zyxel Device can assign 
every IP address allowed by the interface’s IP address and subnet mask, except for the first 
address (network address), last address (broadcast address) and the interface’s IP address.

First DNS Server
Second DNS 
Server
Third DNS Server

Specify the IP addresses up to three DNS servers for the DHCP clients to use. Use one of the 
following ways to specify these IP addresses.

Custom Defined - enter a static IP address.

ZyWALL - the DHCP clients use the IP address of this interface and the Zyxel Device works as 
a DNS relay.

First WINS Server
Second WINS 
Server

Type the IP address of the WINS (Windows Internet Naming Service) server that you want to 
send to the DHCP clients. The WINS server keeps a mapping table of the computer names 
on your network and the IP addresses that they are currently using.

Default Router If you set this interface to DHCP Server, you can select to use either the interface’s IP 
address or another IP address as the default router. This default router will become the 
DHCP clients’ default gateway.

To use another IP address as the default router, select Custom Defined and enter the IP 
address.

Lease Time Specify how long each computer can use the information (especially the IP address) 
before it has to request the information again. 

DHCP Extended 
Options

This table is available if you selected DHCP server.

Configure this table if you want to send more information to DHCP clients through DHCP 
packets.

Add Click this to create an entry in this table. See Section 7.4.2 on page 124.

Edit Select an entry in this table and click this to modify it.

Remove Select an entry in this table and click this to delete it.

PXE Server PXE (Preboot eXecution Environment) allows a client computer to use the network to boot 
up and install an operating system via a PXE-capable Network Interface Card (NIC).

PXE is available for computers on internal interfaces to allow them to boot up using boot 
software on a PXE server. The Zyxel Device acts as an intermediary between the PXE server 
and the computers that need boot software.

The PXE server must have a public IPv4 address. You must enable DHCP Server on the Zyxel 
Device so that it can receive information from the PXE server.

PXE Boot Loader 
File

A boot loader is a computer program that loads the operating system for the computer. 
Type the exact file name of the boot loader software file, including filename extension, that 
is on the PXE server. If the wrong filename is typed, then the client computers cannot boot.

Relay Server 1

Address Enter the IP address of a DHCP server for the network. 

Upstream 
Interface

This field is optional. Select up to two interface(s)to use for the Zyxel Device to forward/
receive DHCP packets to/from the DHCP server. 

Relay Server 2

Address This field is optional. Enter the IP address of another DHCP server for the network. 

Table 61   Network > Interface > Interface > Internal > Add (Ethernet)  (continued)
LABEL DESCRIPTION
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7.4.2  Add/Edit DHCP Extended Options
When you configure an interface as a DHCPv4 server, you can additionally add DHCP extended 
options which have the Zyxel Device to add more information in the DHCP packets. The available fields 
vary depending on the DHCP option you select in this screen. To open the screen, click Network > 
Interface > Internal > Edit, select DHCP Mode in the DHCP Server section, and then click Add or Edit in the 
DHCP Extended Options table.

Upstream 
Interface

This field is optional. Select up to two interface(s)to use for the Zyxel Device to forward/
receive DHCP packets to/from the DHCP server. 

Advanced Settings

Connectivity Check The interface can regularly check the connection to the gateway you specified to make 
sure it is still available. You specify how often the interface checks the connection, how 
long to wait for a response before the attempt is a failure, and how many consecutive 
failures are required before the Zyxel Device stops routing to the gateway. The Zyxel Device 
resumes routing to the gateway the first time the gateway passes the connectivity check.

Enable Select this to turn on the connection check.

Check Method Select the method that the gateway allows. 

Select icmp to have the Zyxel Device regularly ping the gateway you specify to make sure 
it is still available. 

Select tcp to have the Zyxel Device regularly perform a TCP handshake with the gateway 
you specify to make sure it is still available. 

Check Period Enter the number of seconds between connection check attempts.

Check Timeout Enter the number of seconds to wait for a response before the attempt is a failure.

Check Fail 
Tolerance

Enter the number of consecutive failures before the Zyxel Device stops routing through the 
gateway.

Check These 
Addresses

Specify one or two domain names or IP addresses for the connectivity check.

You can type an IPv4 address in one field and a domain name in the other. For example, 
type “192.168.1.2” in the top filed and “www.zyxel.com” in the bottom field.

Check Succeeds 
When

This field applies when you specify two domain names or IP addresses for the connectivity 
check.

Select Any if you want the check to pass if at least one of the domain names or IP 
addresses responds.

Select All if you want the check to pass only if both domain names or IP addresses respond.

Interface Parameters

MTU This is the Maximum Transmission Unit. Type the maximum size of each data packet, in bytes, 
that can move through this interface. If a larger packet arrives, the Zyxel Device divides it 
into smaller fragments. Allowed values are 576-1500. Usually, this value is 1500.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 61   Network > Interface > Interface > Internal > Add (Ethernet)  (continued)
LABEL DESCRIPTION
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Figure 92   Network > Interface > Internal > Edit > Add/Edit Extended Options 

The following table describes labels that can appear in this screen.

The following table lists the available DHCP extended options (defined in RFCs) on the Zyxel Device. See 
RFCs for more information.

Table 62   Network > Interface > Internal > Edit > Add/Edit Extended Options 
LABEL DESCRIPTION
Option This field displays the name of the selected DHCP option. Select which DHCP option that you 

want to add in the DHCP packets sent through the interface.

Code This field displays the code number of the selected DHCP option. If you selected User Defined 
in the Option field, enter a number for the option. This field is mandatory.

Type This is the type of the selected DHCP option. If you selected User Defined in the Option field, 
select an appropriate type for the value that you will enter in the next field. Only advanced 
users should configure User Defined. 

Value Enter the value for the selected DHCP option. For example, if you selected TFTP Server Name 
(66) and the type is TEXT, enter the DNS domain name of a TFTP server here. This field is 
mandatory.

First IP Address, 
Second IP 
Address, Third IP 
Address

If you selected Time Server (4), NTP Server (41), SIP Server (120), CAPWAP AC (138), or TFTP 
Server (150), you have to enter at least one IP address of the corresponding servers in these 
fields. The servers should be listed in order of your preference.

First Enterprise ID, 
Second Enterprise 
ID

If you selected VIVC (124) or VIVS (125), you have to enter at least one vendor’s 32-bit 
enterprise number in these fields. An enterprise number is a unique number that identifies a 
company. 

First Class, Second 
Class

If you selected VIVC (124), enter the details of the hardware configuration of the host on which 
the client is running, or of industry consortium compliance.

First Information, 
Second 
Information

If you selected VIVS (125), enter additional information for the corresponding enterprise 
number in these fields.

OK Click this to close this screen and update the settings to the previous Edit screen.

Cancel Click Cancel to close the screen.

Table 63   DHCP Extended Options 
OPTION NAME CODE DESCRIPTION
Time Offset 2 This option specifies the offset of the client's subnet in seconds from Coordinated 

Universal Time (UTC).

Time Server 4 This option specifies a list of Time servers available to the client.
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7.5  Bridge Interface
This section introduces bridges and bridge interfaces and then explains the screens for bridge interfaces.

Domain Name 15 This option specifies the domain name that the client should use when resolving 
hostnames through the Domain Name System.

Interface MTU 26 This option specifies the MTU (Maximum Transmission Unit) to use on this interface, 
with an available range of 68 to 65535 bytes for IPv4 packets.

NTP Server 42 This option specifies a list of the NTP servers available to the client by IP address.

Netbios Scope 47 This option specifies the NetBIOS over TCP/IP scope parameter for the client.

DHCP Server 
Identifier

54 This option specifies the IP address of the DHCP server.

TFTP Server Name 66 This option is used to identify a TFTP server when the “sname” field in the DHCP 
header has been used for DHCP options. The minimum length of the value is 1. 

Bootfile 67 This option is used to identify a bootfile when the “file” field in the DHCP header 
has been used for DHCP options. The minimum length of the value is 1. 

SIP Server 120 This option carries either an IPv4 address or a DNS domain name to be used by 
the SIP client to locate a SIP server.

VIVC 124 Vendor-Identifying Vendor Class option

A DHCP client may use this option to unambiguously identify the vendor that 
manufactured the hardware on which the client is running, the software in use, or 
an industry consortium to which the vendor belongs.

VIVS 125 Vendor-Identifying Vendor-Specific option

DHCP clients and servers may use this option to exchange vendor-specific 
information.

CAPWAP AC 138 CAPWAP Access Controller addresses option

The Control And Provisioning of Wireless Access Points Protocol allows a Wireless 
Termination Point (WTP) to use DHCP to discover the Access Controllers to which it 
is to connect. This option carries a list of IPv4 addresses indicating one or more 
CAPWAP ACs available to the WTP. 

TFTP Server 150 The option contains one or more IPv4 addresses that the client may use. The 
current use of this option is for downloading configuration from a VoIP server via 
TFTP; however, the option may be used for purposes other than contacting a VoIP 
configuration server.

Table 63   DHCP Extended Options (continued)
OPTION NAME CODE DESCRIPTION
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Bridge Overview

A bridge creates a connection between two or more network segments at the layer-2 (MAC address) 
level. In the following example, bridge X connects four network segments.

When the bridge receives a packet, the bridge records the source MAC address and the port on which 
it was received in a table. It also looks up the destination MAC address in the table. If the bridge knows 
on which port the destination MAC address is located, it sends the packet to that port. If the destination 
MAC address is not in the table, the bridge broadcasts the packet on every port (except the one on 
which it was received).

In the example above, computer A sends a packet to computer B. Bridge X records the source address 
0A:0A:0A:0A:0A:0A and port 2 in the table. It also looks up 0B:0B:0B:0B:0B:0B in the table. There is no entry 
yet, so the bridge broadcasts the packet on ports 1, 3, and 4.

If computer B responds to computer A, bridge X records the source address 0B:0B:0B:0B:0B:0B and port 4 
in the table. It also looks up 0A:0A:0A:0A:0A:0A in the table and sends the packet to port 2 accordingly.

Bridge Interface Overview

A bridge interface creates a software bridge between the members of the bridge interface. It also 
becomes the Zyxel Device’s interface for the resulting network.

The Zyxel Device can bridge traffic between some interfaces while it routes traffic for other interfaces. 
The bridge interfaces also support functions like interface bandwidth parameters, DHCP settings, and 
connectivity check. To use the whole Zyxel Device as a transparent bridge, add all of the Zyxel Device’s 
interfaces to a bridge interface. 

A bridge interface may consist of the following members:

Table 64   Example: Bridge Table After Computer A Sends a Packet to Computer B 
MAC ADDRESS PORT
0A:0A:0A:0A:0A:0A 2

Table 65   Example: Bridge Table After Computer B Responds to Computer A 
MAC ADDRESS PORT
0A:0A:0A:0A:0A:0A 2

0B:0B:0B:0B:0B:0B 4
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• Zero or one VLAN interfaces (and any associated virtual VLAN interfaces)

• Any number of Ethernet interfaces (and any associated virtual Ethernet interfaces)

When you create a bridge interface, the Zyxel Device removes the members’ entries from the routing 
table and adds the bridge interface’s entries to the routing table. For example, this table shows the 
routing table before and after you create bridge interface br0 (250.250.250.0/23) between lan1 and 
vlan1. 

In this example, virtual Ethernet interface lan1:1 is also removed from the routing table when lan1 is 
added to br0. Virtual interfaces are automatically added to or remove from a bridge interface when 
the underlying interface is added or removed.

7.5.1  Bridge Add/Edit 
This screen lets you configure IP address assignment, interface bandwidth parameters, DHCP settings, 
and connectivity check for each bridge interface. To access this screen, click Network > Interface > 
Interface > Bridge > Add/Edit. The following screen appears.

Table 66   Example: Routing Table Before and After Bridge Interface br0 Is Created 
IP ADDRESS(ES) DESTINATION IP ADDRESS(ES) DESTINATION
210.210.210.0/24 lan1 221.221.221.0/24 vlan0

210.211.1.0/24 lan1:1 230.230.230.192/26 wan2

221.221.221.0/24 vlan0 241.241.241.241/32 dmz

222.222.222.0/24 vlan1 242.242.242.242/32 dmz

230.230.230.192/26 wan2 250.250.250.0/23 br0

241.241.241.241/32 dmz

242.242.242.242/32 dmz
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Figure 93   Network > Interface > Interface > Bridge > Add / Edit

Each field is described in the table below.

Table 67   Network > Interface > Interface > Bridge > Add/Edit 
LABEL DESCRIPTION
General Settings

Enable Interface Select this to enable this interface. Clear this to disable this interface.

Interface Properties

Name This field is read-only if you are editing the interface. Enter the name of the bridge interface. 
The format is brx, where x is 0 - 11. For example, br0, br3, and so on.

Zone Select the zone to which the interface is to belong. You use zones to apply security settings 
such as security policy, IPS, remote management, anti-malware, and application patrol.

Description Enter a description of this interface. You can use alphanumeric and ()+/:=?!*#@$_%- 
characters, and it can be up to 60 characters long. Spaces are allowed, but the string 
can’t start with a space.

Address Assignment



Chapter 7 Interfaces

USG FLEX H Series User’s Guide

130

Unassigned Select this if you don’t want to specify an IP address for this interface.

Get 
Automatically

Select this if this interface is a DHCP client. In this case, the DHCP server configures the IP 
address, subnet mask, and gateway automatically.

Use Fixed IP 
Address

Select this if you want to specify the IP address, subnet mask, and gateway manually.

WAN IP This field is enabled if you select Use Fixed IP Address.

Enter the IP address for this interface.

Subnet Mask This field is enabled if you select Use Fixed IP Address.

Enter the subnet mask of this interface in dot decimal notation. The subnet mask indicates 
what part of the IP address is the same for all computers on the network.

Gateway IP This field is enabled if you select Use Fixed IP Address.

Enter the IP address of the gateway. The Zyxel Device sends packets to the gateway when 
it does not know how to route the packet to its destination. The gateway should be on the 
same network as the interface.

Member 
Configuration

Available This field displays Ethernet interfaces and VLAN interfaces that can become part of the 
bridge interface. An interface is not available in the following situations:

• There is a virtual interface on top of it
• It is already used in a different bridge interface

Select one, and click the >> arrow to add it to the bridge interface. Each bridge interface 
can only have one VLAN interface.

Member This field displays the interfaces that are part of the bridge interface. Select one, and click 
the << arrow to remove it from the bridge interface.

Connectivity Check The interface can regularly check the connection to the gateway you specified to make 
sure it is still available. You specify how often the interface checks the connection, how 
long to wait for a response before the attempt is a failure, and how many consecutive 
failures are required before the Zyxel Device stops routing to the gateway. The Zyxel Device 
resumes routing to the gateway the first time the gateway passes the connectivity check.

Enable Select this to turn on the connection check.

Check Method Select the method that the gateway allows. 

Select icmp to have the Zyxel Device regularly ping the gateway you specify to make sure 
it is still available. 

Select tcp to have the Zyxel Device regularly perform a TCP handshake with the gateway 
you specify to make sure it is still available. 

Check Period Enter the number of seconds between connection check attempts.

Check Timeout Enter the number of seconds to wait for a response before the attempt is a failure.

Check Fail 
Tolerance

Enter the number of consecutive failures before the Zyxel Device stops routing through the 
gateway.

Check These 
Addresses

Specify one or two domain names or IP addresses for the connectivity check.

You can type an IPv4 address in one field and a domain name in the other. For example, 
type “192.168.1.2” in the top filed and “www.zyxel.com” in the bottom field.

Table 67   Network > Interface > Interface > Bridge > Add/Edit (continued)
LABEL DESCRIPTION
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7.6  VTI Interface
IPSec VPN Tunnel Interface (VTI) encrypts or decrypts IPv4 traffic from or to the interface according to 
the IP routing table. 

VTI allows static routes to send traffic over the VPN. The IPSec tunnel endpoint is associated with an 
actual (virtual) interface. Therefore many interface capabilities such as Policy Route, Static Route, Trunk, 
and BWM can be applied to the IPSec tunnel as soon as the tunnel is active

IPSec VTI simplifies network management and load balancing. Create a trunk using VPN tunnel 
interfaces for load balancing. In the following example configure VPN tunnels with static IP addresses or 
DNS on both Zyxel Devices (or IPSec routers at the end of the tunnel). Also configure VTI and a trunk on 
both Zyxel Devices.

Check Succeeds 
When

This field applies when you specify two domain names or IP addresses for the connectivity 
check.

Select Any if you want the check to pass if at least one of the domain names or IP 
addresses responds.

Select All if you want the check to pass only if both domain names or IP addresses respond.

Advanced Settings

DHCP Option 60 This field appears when Role is set to External. The setting you configure here will only work 
when Address Assignment is set to Get Automatically.

DHCP Option 60 is used by the Zyxel Device for identification to the DHCP server using the 
VCI (Vendor Class Identifier) on the DHCP server. The Zyxel Device adds it in the initial DHCP 
discovery message that a DHCP client broadcasts in search of an IP address. The DHCP 
server can assign different IP addresses or options to clients with the specific VCI or reject 
the request from clients without the specific VCI.

Type a string using up to 63 of these characters [a-zA-Z0-9!\"#$%&\'()*+,-./
:;<=>?@\[\\\]^_`{}] to identify this Zyxel Device to the DHCP server. For example, Zyxel-TW.

MTU This is the Maximum Transmission Unit. Type the maximum size of each data packet, in bytes, 
that can move through this interface. If a larger packet arrives, the Zyxel Device divides it 
into smaller fragments. Allowed values are 576-1500. Usually, this value is 1500.

Default SNAT This field appears when Role is set to External.

Select this to have the Zyxel Device use the IP address of the outgoing interface as the 
source IP address of the packets it sends out through its WAN trunks. The Zyxel Device 
automatically adds SNAT settings for traffic it routes from internal interfaces to external 
interfaces.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 67   Network > Interface > Interface > Bridge > Add/Edit (continued)
LABEL DESCRIPTION
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Figure 94   VTI and Trunk for VPN Load Balancing

7.6.1  Restrictions for IPSec Virtual Tunnel Interface
• IPv4 traffic only

• IPSec tunnel mode only. A shared keyword must not be configured when using tunnel mode.

• With a VTI VPN you do not add local or remote LANs to your VPN configuration.

• For a VTI VPN you should only have one local and one remote WAN.

• A dynamic peer is not supported

• The IPSec VTI is limited to IP unicast and multicast traffic only.

7.6.2  VTI Edit
This screen lets you configure IP address assignment and interface parameters for VTI.

Note: You should have created a route-based VPN tunnel for a VPN Tunnel Interface scenario 
first.

To access this screen, click the Network > Interface > Interface > VTI > Edit. The following screen appears.
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Figure 95   Network > Interface > Interface > VTI > Add/Edit

Each field is described in the table below. 

Table 68   Network > Interface > Interface > VTI > Add/Edit 
LABEL DESCRIPTION
General Settings

Enable Interface Slide the switch to the right to enable VTI.

Interface Properties

Interface Name This field displays the name of the VPN tunnel interface. This field is read-only.

VPN Rule This field displays the scenario rule the VPN tunnel interface is using.

Zone Select a zone. Make sure that the zone you select does not have traffic blocked by a 
security feature such as a security policy.

IP Address Enter the IP address for this interface.

Connectivity Check The interface can regularly check the connection to the gateway you specified to make 
sure it is still available. You specify how often the interface checks the connection, how long 
to wait for a response before the attempt is a failure, and how many consecutive failures 
are required before the Zyxel Device stops routing to the gateway. The Zyxel Device 
resumes routing to the gateway the first time the gateway passes the connectivity check.

Enable Select this to turn on the connection check.
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7.7  Trunk Overview 
Use trunks for WAN traffic load balancing to increase overall network throughput and reliability. Load 
balancing divides traffic loads between multiple interfaces. This allows you to improve quality of service 
and maximize bandwidth utilization for multiple ISP links. 

Maybe you have two Internet connections with different bandwidths. You could set up a trunk that uses 
weighted round robin load balancing so time-sensitive traffic (like video) usually goes through the 
higher-bandwidth interface. For other traffic, you might want to use least load first load balancing to 
even out the distribution of the traffic load.

Suppose ISP A has better connections to Europe while ISP B has better connections to Australia. You 
could use policy routes and trunks to have traffic for your European branch office primarily use ISP A and 
traffic for your Australian branch office primarily use ISP B. 

Or maybe one of the Zyxel Device's interfaces is connected to an ISP that is also your Voice over IP 
(VoIP) service provider. You can use policy routing to send the VoIP traffic through a trunk with the 
interface connected to the VoIP service provider set to active and another interface (connected to 
another ISP) set to passive. This way VoIP traffic goes through the interface connected to the VoIP 
service provider whenever the interface’s connection is up.

Throughput is the moving average of traffic passing through the Zyxel Device in the last 10 seconds 
updated every 1 second.

Check Method Select the method that the gateway allows. 

Select icmp to have the Zyxel Device regularly ping the gateway you specify to make sure 
it is still available. 

Select tcp to have the Zyxel Device regularly perform a TCP handshake with the gateway 
you specify to make sure it is still available. 

Check Period Enter the number of seconds between connection check attempts.

Check Timeout Enter the number of seconds to wait for a response before the attempt is a failure.

Check Fail 
Tolerance

Enter the number of consecutive failures before the Zyxel Device stops routing through the 
gateway.

Check These 
Addresses

Specify one or two domain names or IP addresses for the connectivity check.

You can type an IPv4 address in one field and a domain name in the other. For example, 
type “192.168.1.2” in the top filed and “www.zyxel.com” in the bottom field.

Check Succeeds 
When

This field applies when you specify two domain names or IP addresses for the connectivity 
check.

Select Any if you want the check to pass if at least one of the domain names or IP 
addresses responds.

Select All if you want the check to pass only if both domain names or IP addresses respond.

MTU This is the Maximum Transmission Unit. Type the maximum size of each data packet, in bytes, 
that can move through this interface. If a larger packet arrives, the Zyxel Device divides it 
into smaller fragments. Allowed values are 576-1500.

OK Click OK to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 68   Network > Interface > Interface > VTI > Add/Edit (continued)
LABEL DESCRIPTION
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Load Balancing Algorithms 

The following sections describe the load balancing algorithms the Zyxel Device can use to decide which 
interface the traffic (from the LAN) should use for a session. The available bandwidth you configure on 
the Zyxel Device refers to the actual bandwidth provided by the ISP and the measured bandwidth refers 
to the bandwidth an interface is currently using. 

Least Load First 

The least load first algorithm uses the current (or recent) outbound bandwidth utilization of each trunk 
member interface as the load balancing index(es) when making decisions about to which interface a 
new session is to be distributed. The outbound bandwidth utilization is defined as the measured 
outbound throughput over the available outbound bandwidth. 

Here the Zyxel Device has two WAN interfaces connected to the Internet. The configured available 
outbound bandwidths for WAN 1 and WAN 2 are 512K and 256K respectively.

Figure 96   Load Balancing Least Load First Example

The outbound bandwidth utilization is used as the load balancing index. In this example, the measured 
(current) outbound throughput of WAN 1 is 412K and WAN 2 is 198K. The Zyxel Device calculates the 
load balancing index as shown in the table below. 

Since WAN 2 has a smaller load balancing index (meaning that it is less utilized than WAN 1), the Zyxel 
Device will send the subsequent new session traffic through WAN 2.

Weighted Round Robin 

Round Robin scheduling services queues on a rotating basis and is activated only when an interface has 
more traffic than it can handle. A queue is given an amount of bandwidth irrespective of the incoming 
traffic on that interface. This queue then moves to the back of the list. The next queue is given an equal 
amount of bandwidth, and then moves to the end of the list; and so on, depending on the number of 
queues being used. This works in a looping fashion until a queue is empty.

Table 69   Least Load First Example 

INTERFACE
OUTBOUND LOAD BALANCING INDEX 

(M/A)AVAILABLE (A) MEASURED (M) 
WAN 1 512 K 412 K 0.8

WAN 2 256 K 198 K 0.77
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The Weighted Round Robin (WRR) algorithm is best suited for situations when the bandwidths set for the 
two WAN interfaces are different. Similar to the Round Robin (RR) algorithm, the Weighted Round Robin 
(WRR) algorithm sets the Zyxel Device to send traffic through each WAN interface in turn. In addition, the 
WAN interfaces are assigned weights. An interface with a larger weight gets more chances to transmit 
traffic than an interface with a smaller weight.

For example, in the figure below, the configured available bandwidth of WAN1 is 1M and WAN2 is 512K. 
You can set the Zyxel Device to distribute the network traffic between the two interfaces by setting the 
weight of wan1 and wan2 to 2 and 1 respectively. The Zyxel Device assigns the traffic of two sessions to 
wan1 and one session's traffic to wan2 in each round of 3 new sessions.

Figure 97   Weighted Round Robin Algorithm Example

Spillover

The spillover load balancing algorithm sends network traffic to the first interface in the trunk member list 
until the interface’s maximum allowable load is reached, then sends the excess network traffic of new 
sessions to the next interface in the trunk member list. This continues as long as there are more member 
interfaces and traffic to be sent through them.

Suppose the first trunk member interface uses an unlimited access Internet connection and the second 
is billed by usage. Spillover load balancing only uses the second interface when the traffic load exceeds 
the threshold on the first interface. This fully utilizes the bandwidth of the first interface to reduce Internet 
usage fees and avoid overloading the interface.

In this example figure, the upper threshold of the first interface is set to 800K. The Zyxel Device sends 
network traffic of new sessions that exceed this limit to the secondary WAN interface.

Figure 98   Spillover Algorithm Example

• Use the Trunk summary screen (Section 7.8 on page 137) to view the list of configured trunks and 
which load balancing algorithm each trunk uses.

• Use the Add Trunk screen (Section 7.8.1 on page 138) to configure the member interfaces for a trunk 
and the load balancing algorithm the trunk uses.
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• Use the Add System Default screen (Section 7.8.2 on page 140) to configure the load balancing 
algorithm for the system default trunk.

7.7.1  What You Need to Know
• Add WAN interfaces to trunks to have multiple connections share the traffic load. 

• If one WAN interface’s connection goes down, the Zyxel Device sends traffic through another 
member of the trunk. 

• For example, you connect one WAN interface to one ISP and connect a second WAN interface to a 
second ISP. The Zyxel Device balances the WAN traffic load between the connections. If one 
interface's connection goes down, the Zyxel Device can automatically send its traffic through 
another interface.

You can also use trunks with policy routing to send specific traffic types through the best WAN interface 
for that type of traffic. 

• If that interface’s connection goes down, the Zyxel Device can still send its traffic through another 
interface.

• You can define multiple trunks for the same physical interfaces. 

1 LAN user A logs into server B on the Internet. The Zyxel Device uses wan1 to send the request to server B. 

2 The Zyxel Device is using active/active load balancing. So when LAN user A tries to access something on 
the server, the request goes out through wan2.

3 The server finds that the request comes from wan2’s IP address instead of wan1’s IP address and rejects 
the request.

If link sticking had been configured, the Zyxel Device would have still used wan1 to send LAN user A’s 
request to the server and server would have given the user A access.

7.8  The Trunk Summary Screen
Click Network > Interface > Trunk to open the Trunk screen. The following screen lists the configured 
trunks and the load balancing algorithm that each is configured to use.
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Figure 99   Network > Interface > Trunk

The following table describes the items in this screen. 

7.8.1  Configuring a User-Defined Trunk
Click Network > Interface > Trunk, in the User-Defined Trunk table click the Add (or Edit) icon to open the 
following screen. Use this screen to create or edit a WAN trunk entry.

Table 70   Network > Interface > Trunk 
LABEL DESCRIPTION
Trunk Selection Select whether the Zyxel Device is to use the default system WAN trunk or one of the user 

configured WAN trunks as the default trunk for routing traffic from internal interfaces to 
external interfaces.

Add Click this to create a new user-configured trunk.

Edit Double-click an entry or select it and click Edit to open a screen where you can modify 
the entry’s settings. 

Remove To remove a user-configured trunk, select it and click Remove. The Zyxel Device confirms 
you want to remove it before doing so.

Reference This field displays the objects this entry uses. 

Name This field displays the label that you specified to identify the trunk.

Algorithm This field displays the load balancing method the trunk is set to use. 

Members This field displays the interfaces that belong to the trunk.

Reference This field displays which settings use the entry. 
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Figure 100   Network > Interface > Trunk > User-Defined Trunk > Add (or Edit)     

Each field is described in the table below. 

Table 71   Network > Interface > Trunk > Add/Edit 
LABEL DESCRIPTION
Name This is read-only if you are editing an existing trunk. When adding a new trunk, enter a 

descriptive name for this trunk. The value in this field cannot exceed 11 characters. The 
valid characters are [a-z][A-Z][_-].

Load Balancing 
Algorithm

Select a load balancing method to use from the drop-down list box. 

Select Weighted Round Robin to balance the traffic load between interfaces based on 
their respective weights. An interface with a larger weight gets more chances to transmit 
traffic than an interface with a smaller weight. For example, if the weight ratio of wan1 and 
wan2 interfaces is 2:1, the Zyxel Device chooses wan1 for 2 sessions’ traffic and wan2 for 1 
session’s traffic in each round of 3 new sessions.

Select Least Load First to send new session traffic through the least utilized trunk member.

Select Spillover to send network traffic through the first interface in the group member list 
until there is enough traffic that the second interface needs to be used (and so on).

Load Balancing 
Index(es)

This field is available if you selected to use the Least Load First or Spillover method.

Select Outbound, Inbound, or Outbound + Inbound to set the traffic to which the Zyxel 
Device applies the load balancing method. Outbound means the traffic traveling from an 
internal interface (ex. LAN) to an external interface (ex. WAN). Inbound means the 
opposite.

Add Click this to create a WAN trunk entry.

Edit Select an entry and click Edit to modify the entry’s settings. 

Remove To remove a member interface, select it and click Remove. The Zyxel Device confirms you 
want to remove it before doing so.

Name Select an interface name from the drop-down list box.
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7.8.2  Configuring the System Default Trunk 
Go to Network > Interface > Trunk > Default Trunk, select the default trunk entry and click Edit to open 
the following screen. Use this screen to change the load balancing algorithm and view the bandwidth 
allocations for each member interface.

Note: The new session is allocated to each member interface equally and is not allowed to 
be changed for the default trunk. 

Figure 101   Network > Interface > Trunk > Default Trunk > Edit

Each field is described in the table below.

Mode Click this table cell and select Active to have the Zyxel Device always attempt to use this 
connection.

Select Passive to have the Zyxel Device only use this connection when all of the 
connections set to active are down. You can only set one of a group’s interfaces to passive 
mode.

Parameter This field displays with the weighted round robin load balancing algorithm. Specify the 
weight (1~10) for the interface. The weights of the different member interfaces form a ratio. 
This ratio determines how much traffic the Zyxel Device assigns to each member interface. 
The higher an interface’s weight is (relative to the weights of the interfaces), the more 
sessions that interface should handle.

Apply Click this button to save your changes to the Zyxel Device. 

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 71   Network > Interface > Trunk > Add/Edit (continued)
LABEL DESCRIPTION

Table 72   Network > Interface > Trunk > Default Trunk > Edit 
LABEL DESCRIPTION
Name This field displays the name of the selected system default trunk.

Load Balancing 
Setting

This field displays the load balancing method use for the default trunk.

Weighted Round Robin (wrr) balances the traffic load between interfaces based on their 
respective weights. An interface with a larger weight gets more chances to transmit traffic 
than an interface with a smaller weight. For example, if the weight ratio of wan1 and 
wan2 interfaces is 2:1, the Zyxel Device chooses wan1 for 2 sessions’ traffic and wan2 for 1 
session’s traffic in each round of 3 new sessions.

The table lists the trunk’s member interfaces. This table is read-only.
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7.9  Port
Use this screen to configure port settings. Click Network > Interface > Port in the navigation panel to 
display the configuration screen.

Interface This column displays the name of the member interfaces. 

Mode This field displays Active if the Zyxel Device always attempt to use this connection.

This field displays Passive if the Zyxel Device only use this connection when all of the 
connections set to active are down. Only one of a group’s interfaces can be set to 
passive mode.

Parameter This field displays with the weighted round robin load balancing algorithm. Specify the 
weight (1~10) for the interface. The weights of the different member interfaces form a 
ratio. s

Apply Click Apply to save your changes to the Zyxel Device. 

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 72   Network > Interface > Trunk > Default Trunk > Edit (continued)
LABEL DESCRIPTION
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Figure 102   Network > Interface > Port

Each field is described in the following table.

Table 73   Network > Interface > Port
LABEL DESCRIPTION
Virtual Device This shows which ports are up or down on the Zyxel Device. Hover over a port to see port 

details such as name, status , interface and IP address.

Configuration Select an entry to configure the speed negotiation setting of the Ethernet connection on 
this port and PoE if the port supports it.

Name This field displays the name of the port.

Status This field displays the speed and the duplex mode of the Ethernet connection on the port.

Type This field displays the cable type that is used on the port.
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Setting Select the speed and the duplex mode of the Ethernet connection on this port. Choices 
are Auto Negotiate, 10Mpbs, 100Mbps, 1Gpbs and 2.5Gbps.

Selecting Auto Negotiate allows one port to negotiate with a peer port automatically to 
obtain the connection speed (of up to 1000M) and duplex mode that both ends support. 
When auto-negotiation is turned on, a port on the Zyxel Device negotiates with the peer 
automatically to determine the connection speed and duplex mode. If the peer port does 
not support auto-negotiation or turns off this feature, the Zyxel Device determines the 
connection speed by detecting the signal on the cable and using half duplex mode. When 
the Zyxel Device’s auto-negotiation is turned off, a port uses the pre-configured speed and 
duplex mode when making a connection, thus requiring you to make sure that the settings 
of the peer port are the same in order to connect.

Interface This field displays the interface for the port.

PoE If the port supports PoE, then this field displays if PoE is enabled on the port.

Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.

Save Changes Click this icon to save the changes in this row.

Cancel Changes Click this icon to cancel the changes in this row. 

Table 73   Network > Interface > Port
LABEL DESCRIPTION
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CHAPTER 8
Routing

8.1  Policy and Static Routes Overview
Use policy routes and static routes to override the Zyxel Device’s default routing behavior in order to 
send packets through the appropriate interface or VPN tunnel. 

For example, the next figure shows a computer (A) connected to the Zyxel Device’s LAN interface. The 
Zyxel Device routes most traffic from A to the Internet through the Zyxel Device’s default gateway (R1). 
You create one policy route to connect to services offered by your ISP behind router R2. You create 
another policy route to communicate with a separate network behind another router (R3) connected 
to the LAN.

Figure 103   Example of Policy Routing Topology

8.1.1  What You Can Do in this Chapter
• Use the Policy Route screens (see Section 8.2 on page 146) to list and configure policy routes. 

• Use the Static Route screens (see Section 8.3 on page 151) to list and configure static routes.

8.1.2  What You Need to Know

Policy Routing

Traditionally, routing is based on the destination address only and the Zyxel Device takes the shortest 
path to forward a packet. IP Policy Routing (IPPR) provides a mechanism to override the default routing 
behavior and alter the packet forwarding based on the policy defined by the network administrator. 
Policy-based routing is applied to incoming packets on a per interface basis, prior to the normal routing.
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How You Can Use Policy Routing
• Source-Based Routing – Network administrators can use policy-based routing to direct traffic from 

different users through different connections.

• Cost Savings – IPPR allows organizations to distribute interactive traffic on high-bandwidth, high-cost 
paths while using low-cost paths for batch traffic.

• Load Sharing – Network administrators can use IPPR to distribute traffic among multiple paths.

• NAT - The Zyxel Device performs NAT by default for traffic going to or from the WAN interfaces. A 
routing policy’s SNAT allows network administrators to have traffic received on a specified interface 
use a specified IP address as the source IP address.

Note: The Zyxel Device automatically uses SNAT for traffic it routes from internal interfaces to 
external interfaces. For example LAN to WAN traffic.

Static Routes

The Zyxel Device usually uses the default gateway to route outbound traffic from computers on the LAN 
to the Internet. To have the Zyxel Device send data to devices not reachable through the default 
gateway, use static routes. 

Policy Routes Versus Static Routes
• Policy routes are more flexible than static routes. You can select more criteria for the traffic to match 

and can also use schedules, NAT, and bandwidth management.

• Policy routes take priority over static routes. If you need to use a routing policy on the Zyxel Device 
and propagate it to other routers, you could configure a policy route and an equivalent static route.

DiffServ 

QoS is used to prioritize source-to-destination traffic flows. All packets in the same flow are given the 
same priority. CoS (class of service) is a way of managing traffic in a network by grouping similar types of 
traffic together and treating each type as a class. You can use CoS to give different priorities to different 
packet types. 

DiffServ (Differentiated Services) is a class of service (CoS) model that marks packets so that they 
receive specific per-hop treatment at DiffServ-compliant network devices along the route based on the 
application types and traffic flow. Packets are marked with DiffServ Code Points (DSCPs) indicating the 
level of service desired. This allows the intermediary DiffServ-compliant network devices to handle the 
packets differently depending on the code points without the need to negotiate paths or remember 
state information for every flow. In addition, applications do not have to request a particular service or 
give advanced notice of where the traffic is going.

DSCP Marking and Per-Hop Behavior 

DiffServ defines a new DS (Differentiated Services) field to replace the Type of Service (TOS) field in the IP 
header. The DS field contains a 2-bit unused field and a 6-bit DSCP field which can define up to 64 
service levels. The following figure illustrates the DS field. 

DSCP is backward compatible with the three precedence bits in the ToS octet so that non-DiffServ 
compliant, ToS-enabled network device will not conflict with the DSCP mapping.

DSCP (6 bits) Unused (2 bits)
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The DSCP value determines the forwarding behavior, the PHB (Per-Hop Behavior), that each packet 
gets across the DiffServ network. Based on the marking rule, different kinds of traffic can be marked for 
different kinds of forwarding. Resources can then be allocated according to the DSCP values and the 
configured policies.

NAT and SNAT

NAT (Network Address Translation - NAT, RFC 1631) is the translation of the IP address in a packet in one 
network to a different IP address in another network. Use SNAT (Source NAT) to change the source IP 
address in one network to a different IP address in another network.

Assured Forwarding (AF) PHB for DiffServ

Assured Forwarding (AF) behavior is defined in RFC 2597. The AF behavior group defines four AF classes. 
Inside each class, packets are given a high, medium or low drop precedence. The drop precedence 
determines the probability that routers on the network will drop packets when congestion occurs. If 
congestion occurs between classes, the traffic in the higher class (smaller numbered class) is generally 
given priority. Combining the classes and drop precedence produces the following twelve DSCP 
encodings from AF11 through AF43. The decimal equivalent is listed in brackets.

8.2  Policy Route Screen
Click Network > Routing to open the Policy Route screen. Use this screen to see the configured policy 
routes and turn policy routing based bandwidth management on or off.

A policy route defines the matching criteria and the action to take when a packet meets the criteria. 
The action is taken only when all the criteria are met. The criteria can include the user name, source 
address and incoming interface, destination address, schedule, IP protocol (ICMP, UDP, TCP, etc.) and 
port.

The actions that can be taken include:

• Routing the packet to a different gateway, outgoing interface, VTI interface, or trunk.
Figure 104   Network > Routing > Policy Route     

Table 74   Assured Forwarding (AF) Behavior Group
CLASS 1 CLASS 2 CLASS 3 CLASS 4

Low Drop Precedence AF11 (10) AF21 (18) AF31 (26) AF41 (34)

Medium Drop Precedence AF12 (12) AF22 (20) AF32 (28) AF42 (36)

High Drop Precedence AF13 (14) AF23 (22) AF33 (30) AF43 (38)
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The following table describes the labels in this screen.

Table 75   Network > Routing > Policy Route 
LABEL DESCRIPTION
Use IPv4 Policy Route 
to Override Direct 
Route

Select this to have the Zyxel Device forward packets that match a policy route according 
to the policy route instead of sending the packets directly to a connected network. 

Add Click this to create a new entry. Select an entry and click Add to create a new entry after 
the selected entry.

Edit Double-click an entry or select it and click Edit to open a screen where you can modify 
the entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to 
remove it before doing so.

Active Select one or more policies, then click this to enable the selected policies. The Status light 
changes accordingly.

Inactive Select one or more policies, then click this to disable the selected policies. The Status light 
changes accordingly.

Move to Select a policy, click this, enter a new location up to and including the last policy number, 
then press [ENTER] to move it to the new location. Policies are checked in order  
beginning from the first.

Search Type an item in the search box, then click this to display all sessions in the table below 
according to the item you typed.

Clear All Click this to remove all items found in the search.

Filter

Click the Filter icon , click + to expand Policy Match, pick a filter, then click Find to 
display specific sessions according to the filter selected. You may select multiple filters, 
but just one of each type, configured one at a time.  

Status This icon is lit when the entry is active, red when the next hop’s connection is down, and 
dimmed when the entry is inactive.

Priority This is the row number of the policy. Policies are checked in order beginning from the first.

User This is the name of the user (group) object from which the packets are sent. any means all 
users.

Schedule This is the name of the schedule object. any means the route is active at all times if 
enabled.

Incoming This is the interface on which the packets are received.

Source This is the name of the source IP address (group) object, including geographic address 
and FQDN (group) objects. any means all IP addresses.

Destination This is the name of the destination IP address (group) object, including geographic and 
FQDN (group) address objects. any means all IP addresses.
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8.2.1  Policy Route Edit Screen
Click Network > Routing to open the Policy Route screen. Then click the Add or Edit icon. The Add Policy 
Route or Policy Route Edit screen opens. Use this screen to configure or edit a policy route.

DSCP Code This is the DSCP value of incoming packets to which this policy route applies. 

any means all DSCP values or no DSCP marker. 

default means traffic with a DSCP value of 0. This is usually best effort traffic 

The “af” entries stand for Assured Forwarding. The number following the “af” identifies one 
of four classes and one of three drop preferences. See Assured Forwarding (AF) PHB for 
DiffServ for more details.

Service This is the name of the destination service object. any means all destination services.

Source Port This is the name of the source service object. any means all source services.

Next-Hop This is the next hop to which packets are directed. It helps forward packets to their 
destinations and can be an IP address of a router or a VTI interface.

DSCP Marking This is how the Zyxel Device handles the DSCP value of the outgoing packets that match 
this route. If this field displays a DSCP value, the Zyxel Device applies that DSCP value to 
the route’s outgoing packets.

preserve means the Zyxel Device does not modify the DSCP value of the route’s outgoing 
packets. 

default means the Zyxel Device sets the DSCP value of the route’s outgoing packets to 0.

The “af” choices stand for Assured Forwarding. The number following the “af” identifies 
one of four classes and one of three drop preferences. See Assured Forwarding (AF) PHB 
for DiffServ for more details.

SNAT This is the source IP address that the route uses.

It displays none if the Zyxel Device does not perform NAT for this route.

Hits This is the number of sessions with traffic that matched the policy criteria. 

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 75   Network > Routing > Policy Route (continued)
LABEL DESCRIPTION
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Figure 105   Network > Routing > Policy Route > Add/Edit

The following table describes the labels in this screen.

Table 76   Network > Routing > Policy Route > Add/Edit 
LABEL DESCRIPTION
Enable Select this to activate the rule.

Name Enter a name to identify this rule. 

Description Enter a descriptive name consists of 1 to 60 single-byte characters, including a-zA-Z0-9. 
Special characters and spaces are allowed.

Criteria

User Select a user name or user group from which the packets are sent. 

Incoming Select where the packets are coming from; any, an interface, a tunnel, an SSL VPN, or the 
Zyxel Device itself. For an interface, a tunnel, or an SSL VPN, you also need to select the 
individual interface, VPN tunnel, or SSL VPN connection.

Source Address Select a source IP address object, including geographic address and FQDN (group) 
objects, from which the packets are sent.
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Destination Address Select a destination IP address object, including geographic address and FQDN (group) 
objects, to which the traffic is being sent. If the next hop is a dynamic VPN tunnel and you 
enable Auto Destination Address, the Zyxel Device uses the local network of the peer 
router that initiated an incoming dynamic IPSec tunnel as the destination address of the 
policy instead of your configuration here.

DSCP Code Select a DSCP code point value of incoming packets to which this policy route applies or 
select User Define to specify another DSCP code point. The lower the number the higher 
the priority with the exception of 0 which is usually given only best-effort treatment.

any means all DSCP value or no DSCP marker. 

default means traffic with a DSCP value of 0. This is usually best effort traffic 

The “af” choices stand for Assured Forwarding. The number following the “af” identifies one 
of four classes and one of three drop preferences. See Assured Forwarding (AF) PHB for 
DiffServ for more details.

User-Defined 
DSCP Code

Use this field to specify a custom DSCP code point when you select User Define in the 
previous field.

Schedule Select a schedule to control when the policy route is active. none means the route is active 
at all times if enabled.

Service Select a destination service or service group to identify the type of traffic to which this 
policy route applies.

Source Port Select a source service or service group to identify the source port of packets to which the 
policy route applies.

Next-Hop

Type Select Auto to have the Zyxel Device use the routing table to find a next-hop and forward 
the matched packets automatically.

Select Interface to route the matched packets through the specified outgoing interface to 
a gateway (which is connected to the interface).

Select gateway to route the matched IPv6 packets through a 6to4 tunnel to the packets’ 
destination.

Select gateway-ip to route the matched packets to the next-hop router or switch you 
specified in the Host IP Address field. You have to set up the next-hop router or switch as a 
HOST address object first.

Select trunk to route the matched packets through the interfaces in the trunk group based 
on the load balancing algorithm. 

Interface This field displays when you select Interface in the Type field. Select an interface to have 
the Zyxel Device send traffic that matches the policy route through the specified interface.

Service This field displays when you select gateway in the Type field. IP6to4-Relay service enables 
IPv6 packets to cross IPv4 networks; see Section 8.1.2 on page 144 for more information.

Host IP Address This field displays when you select gateway-ip in the Type field. Select a HOST address 
object. The gateway is an immediate neighbor of your Zyxel Device that will forward the 
packet to the destination. The gateway must be a router or switch on the same segment as 
your Zyxel Device's interface(s).

Trunk This field displays when you select trunk in the Type field. Select a trunk group to have the 
Zyxel Device send the packets via the interfaces in the group.

Table 76   Network > Routing > Policy Route > Add/Edit (continued)
LABEL DESCRIPTION



 Chapter 8 Routing

USG FLEX H Series User’s Guide

151

8.3  Static Route Screen
Click Network > Routing > Static Route to open the Static Route screen. This screen displays the 
configured static routes.

Figure 106   Network > Routing > Static Route

The following table describes the labels in this screen.

DSCP Marking Set how the Zyxel Device handles the DSCP value of the outgoing packets that match this 
route.

Select one of the pre-defined DSCP values to apply or select User Define to specify another 
DSCP value. The “af” choices stand for Assured Forwarding. The number following the “af” 
identifies one of four classes and one of three drop preferences. See Assured Forwarding 
(AF) PHB for DiffServ for more details.

Select preserve to have the Zyxel Device keep the packets’ original DSCP value. 

Select default to have the Zyxel Device set the DSCP value of the packets to 0.

User-Defined 
DSCP Marking

Use this field to specify a custom DSCP value.

Address Translation Use this section to configure NAT for the policy route. This section does not apply to policy 
routes that use a VPN tunnel as the next hop.

Source Network 
Address Translation

Select none to not use NAT for the route.

Select outgoing-interface to use the IP address of the outgoing interface as the source IP 
address of the packets that matches this route. 

To use SNAT for a virtual interface that is in the same WAN trunk as the physical interface to 
which the virtual interface is bound, the virtual interface and physical interface must be in 
different subnets.

Otherwise, select a pre-defined address (group) to use as the source IP address(es) of the 
packets that match this route.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 76   Network > Routing > Policy Route > Add/Edit (continued)
LABEL DESCRIPTION

Table 77   Network > Routing > Static Route 
LABEL DESCRIPTION
Add Click this to create a new static route.

Edit Double-click an entry or select it and click Edit to open a screen where you can modify the 
entry’s settings. 
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8.3.1  Static Route Add/Edit Screen
Click Network > Routing > Static Route > Add/Edit to display the next screen. Use this screen to configure 
the required information for a static route.

Figure 107   Network > Routing > Static Route > Add

The following table describes the labels in this screen.  

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to 
remove it before doing so.

Name This is the name of the static route entry.

Destination This is the destination IP address. 

Next-Hop This is the IP address of the next-hop gateway or the interface through which the traffic is 
routed. The gateway is a router or switch on the same segment as your Zyxel Device's 
interface(s). The gateway helps forward packets to their destinations.

Metric This is the route’s priority among the Zyxel Device’s routes. The smaller the number, the 
higher priority the route has.

Table 77   Network > Routing > Static Route (continued)
LABEL DESCRIPTION

Table 78   Network > Routing > Static Route > Add 
LABEL DESCRIPTION
Name Enter a name to identify this rule. You can use up to 30 single-byte characters, including 0-9a-

zA-Z. The first character cannot be a number.

Destination This parameter specifies the IP network address of the final destination. Routing is always 
based on network number. 

If you need to specify a route to a single host, enter the specific IP address here.

Next Hop

Gateway Select the radio button and enter the IP address of the next-hop gateway. The gateway is a 
router or switch on the same segment as your Zyxel Device's interface(s). The gateway helps 
forward packets to their destinations.

Gateway 
Object

Select the radio button to route the matched IPv6 packets through a 6to4 tunnel to the 
packets’ destination.
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Interface Select the radio button and a predefined interface through which the traffic is sent.

Metric Metric represents the “cost” of transmission for routing purposes. IP routing uses hop count as 
the measurement of cost, with a minimum of 1 for directly connected networks. Enter a 
number that approximates the cost for this link. The number need not be precise, but it must 
be 0~127. In practice, 2 or 3 is usually a good number. 

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 78   Network > Routing > Static Route > Add (continued)
LABEL DESCRIPTION
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CHAPTER 9
NAT

9.1  NAT Overview
NAT (Network Address Translation - NAT, RFC 1631) is the translation of the IP address of a host in a 
packet. For example, the source address of an outgoing packet, used within one network is changed to 
a different IP address known within another network. Use Network Address Translation (NAT) to make 
computers on a private network behind the Zyxel Device available outside the private network. If the 
Zyxel Device has only one public IP address, you can make the computers in the private network 
available by using ports to forward packets to the appropriate private IP address. 

Suppose you want to assign ports 21-25 to one FTP, Telnet and SMTP server (A in the example), port 80 to 
another (B in the example) and assign a default server IP address of 192.168.1.35 to a third (C in the 
example). You assign the LAN IP addresses and the ISP assigns the WAN IP address. The NAT network 
appears as a single host on the Internet.

Figure 108   Multiple Servers Behind NAT Example

9.1.1  What You Can Do in this Chapter
Use the NAT screens (see Section 9.2 on page 157) to view and manage the list of NAT rules and see their 
configuration details. You can also create new NAT rules and edit or delete existing ones. 

9.1.2  What You Need to Know
NAT is also known as virtual server, port forwarding, or port translation.

Well-known Ports

Port numbers range from 0 to 65535, but only port numbers 0 to 1023 are reserved for privileged services 
and designated as well-known ports. The following list specifies the ports used by the server process as its 
contact ports. See Section 15.2 on page 236 (Object > Service) for more information about service 
objects.
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• Well-known ports range from 0 to 1023.

• Registered ports range from 1024 to 49151.

• Dynamic ports (also called private ports) range from 49152 to 65535.

NAT Loopback

Suppose an NAT 1:1 rule maps a public IP address to the private IP address of a LAN SMTP email server to 
give WAN users access. NAT loopback allows other users to also use the rule’s original IP to access the 
mail server. 

Table 79   Well-known Ports
PORT TCP/UDP DESCRIPTION
1 TCP TCP Port Service Multiplexer (TCPMUX)

20 TCP FTP - Data

21 TCP FTP - Control

22 TCP SSH Remote Login Protocol

23 TCP Telnet

25 TCP Simple Mail Transfer Protocol (SMTP)

42 UDP Host Name Server (Nameserv)

43 TCP WhoIs

53 TCP/UDP Domain Name System (DNS)

67 UDP BOOTP/DHCP server

68 UDP BOOTP/DHCP client

69 UDP Trivial File Transfer Protocol (TFTP)

79 TCP Finger

80 TCP HTTP

110 TCP POP3

119 TCP Newsgroup (NNTP)

123 UDP Network Time Protocol (NTP)

135 TCP/UDP RPC Locator service

137 TCP/UDP NetBIOS Name Service

138 UDP NetBIOS Datagram Service

139 TCP NetBIOS Datagram Service

143 TCP Interim Mail Access Protocol (IMAP)

161 UDP SNMP

179 TCP Border Gateway Protocol (BGP)

389 TCP/UDP Lightweight Directory Access Protocol (LDAP)

443 TCP HTTPS

445 TCP Microsoft - DS

636 TCP LDAP over TLS/SSL (LDAPS)

953 TCP BIND DNS

990 TCP FTP over TLS/SSL (FTPS)

995 TCP POP3 over TLS/SSL (POP3S)
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For example, a LAN user’s computer at IP address 192.168.1.89 queries a public DNS server to resolve the 
SMTP server’s domain name (xxx.LAN-SMTP.com in this example) and gets the SMTP server’s mapped 
public IP address of 1.1.1.1.

Figure 109   LAN Computer Queries a Public DNS Server    

The LAN user’s computer then sends traffic to IP address 1.1.1.1. NAT loopback uses the IP address of the 
Zyxel Device’s LAN interface (192.168.1.1) as the source address of the traffic going from the LAN users to 
the LAN SMTP server. 

Figure 110   LAN to LAN Traffic

The LAN SMTP server replies to the Zyxel Device’s LAN IP address and the Zyxel Device changes the 
source address to 1.1.1.1 before sending it to the LAN user. The return traffic’s source matches the 
original destination address (1.1.1.1). If the SMTP server replied directly to the LAN user without the traffic 
going through NAT, the source would not match the original destination address which would cause the 
LAN user’s computer to shut down the session. 
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Figure 111   LAN to LAN Return Traffic    

9.2  The NAT Screen
The NAT summary screen provides a summary of all NAT rules and their configuration. In addition, this 
screen allows you to create new NAT rules and edit and delete existing NAT rules. To access this screen, 
login to the Web Configurator and click Network > NAT. The following screen appears, providing a 
summary of the existing NAT rules.

Figure 112   Network > NAT

The following table describes the labels in this screen. 

192.168.1.21

LAN

192.168.1.89

Source 1.1.1.1

SMTP

NAT

Source 192.168.1.21

SMTP

Table 80   Network > NAT 
LABEL DESCRIPTION
Add Click this to create a new entry.

Edit Double-click an entry or select it and click Edit to open a screen where you can modify the 
entry’s settings. 
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9.2.1  The NAT Add/Edit Screen
The NAT Add/Edit screen lets you create new NAT rules and edit existing ones. To open this window, 
open the NAT summary screen. (See Section 9.2 on page 157.) Then, click on an Add icon or Edit icon to 
open the following screen.

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to 
remove it before doing so.

Activate To turn on an entry, select it and click Activate.

Inactivate To turn off an entry, select it and click Inactivate.

Move To change a rule’s position in the numbered list, select the rule and click Move to display a 
field to type a number for where you want to put that rule and press [ENTER] to move the 
rule to the number that you typed. 

The ordering of your rules is important as they are applied in order of their numbering.

Status This icon is lit when the entry is active and dimmed when the entry is inactive.

Priority This field displays the priority for the entry. The smaller the number, the higher the priority.

Name This field displays the name of the entry.

Mapping Type This field displays what kind of NAT this entry performs: Virtual Server, 1:1 NAT, or Many 1:1 
NAT.

Interface This field displays the interface on which packets for the NAT entry are received.

Source IP This field displays the source IP address (or address object) of traffic that matches this NAT 
entry. It displays any if there is no restriction on the source IP address.

External IP This field displays the original destination IP address (or address object) of traffic that 
matches this NAT entry. It displays any if there is no restriction on the original destination IP 
address.

Internal IP This field displays the new destination IP address for the packet.

Protocol This field displays the service used by the packets for this NAT entry. It displays any if there is 
no restriction on the services.

External Port This field displays the original destination port(s) of packets for the NAT entry. This field is 
blank if there is no restriction on the original destination port.

Internal Port This field displays the new destination port(s) for the packet. This field is blank if there is no 
restriction on the original destination port.

Apply Click Apply to save your changes to the Zyxel Device. 

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 80   Network > NAT (continued)
LABEL DESCRIPTION
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Figure 113   Network > NAT > Add

The following table describes the labels in this screen.

Table 81   Network > NAT > Add 
LABEL DESCRIPTION
Enable Rule Use this option to turn the NAT rule on or off.

Rule Name Type in the name of the NAT rule. The name is used to refer to the NAT rule. You may use 1-
31 alphanumeric characters, underscores(_), or dashes (-), but the first character cannot 
be a number. This value is case-sensitive.

Classification Select what kind of NAT this rule is to perform.

Virtual Server - This makes computers on a private network behind the Zyxel Device 
available to a public network outside the Zyxel Device (like the Internet). 

1:1 NAT - If the private network server will initiate sessions to the outside clients, select this to 
have the Zyxel Device translate the source IP address of the server’s outgoing traffic to the 
same public IP address that the outside clients use to access the server. 

Many 1:1 NAT - If you have a range of private network servers that will initiate sessions to 
the outside clients and a range of public IP addresses, select this to have the Zyxel Device 
translate the source IP address of each server’s outgoing traffic to the same one of the 
public IP addresses that the outside clients use to access the server. The private and public 
ranges must have the same number of IP addresses. 

One many 1:1 NAT rule works like multiple 1:1 NAT rules, but it eases configuration effort 
since you only create one rule.

Incoming Interface Select the interface on which packets for the NAT rule must be received. It can be an 
Ethernet, VLAN or bridge interface.
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Source IP Specify the source IP address of the packets received by this NAT rule’s specified incoming 
interface.

any - Select this to use all of the incoming interface’s IP addresses including dynamic 
addresses or those of any virtual interfaces built upon the selected incoming interface. 

User Defined - Select this to manually enter an IP address in the User Defined field. For 
example, you could enter a static IP address. 

Host address - select a address object to use the IP address it specifies.

External IP Specify the destination IP address of the packets received by this NAT rule’s specified 
incoming interface. The specified IP address will be translated to the Internal IP address.

any - Select this to use all of the incoming interface’s IP addresses including dynamic 
addresses or those of any virtual interfaces built upon the selected incoming interface. 

User Defined - Select this to manually enter an IP address in the User Defined field. For 
example, you could enter a static public IP assigned by the ISP without having to create a 
virtual interface for it. 

Host address - select a host address object to use the IP address it specifies. The list also 
includes address objects based on interface IPs. So for example you could select an 
address object based on a WAN interface even if it has a dynamic IP address.

Internal IP Select to which translated destination IP address this NAT rule forwards packets. 

User Defined - this NAT rule supports a specific IP address, specified in the User Defined field.

HOST address - the drop-down box lists all the HOST address objects in the Zyxel Device. If 
you select one of them, this NAT rule supports the IP address specified by the address 
object.

External IP Subnet/
Range

This field displays for Many 1:1 NAT. Select the destination IP address subnet or IP address 
range that this NAT rule supports. The original and mapped IP address subnets or ranges 
must have the same number of IP addresses.

Internal IP Subnet/
Range

This field displays for Many 1:1 NAT. Select to which translated destination IP address subnet 
or IP address range this NAT rule forwards packets. The original and mapped IP address 
subnets or ranges must have the same number of IP addresses.

Port Mapping Type Use the drop-down list box to select how many original destination ports this NAT rule 
supports for the selected destination IP address (Original IP). Choices are:

any - this NAT rule supports all the destination ports.

Port - this NAT rule supports one destination port.

Ports - this NAT rule supports a range of destination ports. You might use a range of 
destination ports for unknown services or when one server supports more than one service. 

Service - this NAT rule supports a service such as FTP (see Object > Service > Service) 

service-group - this NAT rule supports a group of services such as all service objects related 
to DNS (see Object > Service > Service Group) 

Protocol Type This field is available if Mapping Type is Port or Ports. Select the protocol (TCP, UDP, or Any) 
used by the service requesting the connection.

External Port This field is available if Mapping Type is Port. Enter the external destination port this NAT rule 
supports.

Internal Port This field is available if Mapping Type is Port. Enter the translated destination port if this NAT 
rule forwards the packet.

External Start Port This field is available if Mapping Type is Ports. Enter the beginning of the range of original 
destination ports this NAT rule supports.

External End Port This field is available if Mapping Type is Ports. Enter the end of the range of original 
destination ports this NAT rule supports.

Table 81   Network > NAT > Add (continued)
LABEL DESCRIPTION



 Chapter 9 NAT

USG FLEX H Series User’s Guide

161

Note: If you set the User-Defined External IP to the IP address of the web configurator and set 
the External Port to 80 or 443, this rule will conflict with the Zyxel Device’s default HTTP 
server port. 

A warning message will pop out when you click OK. If you click No in the warning 
message, the rule will apply to the Zyxel Device. You will not be able to access the web 
configurator through this interface.

Internal Start Port This field is available if Mapping Type is Ports. Enter the beginning of the range of translated 
destination ports if this NAT rule forwards the packet.

Internal End Port This field is available if Mapping Type is Ports. Enter the end of the range of translated 
destination ports if this NAT rule forwards the packet. The original port range and the 
mapped port range must be the same size.

Enable NAT 
Loopback

Enable NAT loopback to allow users connected to any interface (instead of just the 
specified Incoming Interface) to use the NAT rule’s specified External IP address to access 
the Internal IP device. For users connected to the same interface as the Internal IP device, 
the Zyxel Device uses that interface’s IP address as the source address for the traffic it 
sends from the users to the Internal IP device.

For example, if you configure a NAT rule to forward traffic from the WAN to a LAN server, 
enabling NAT loopback allows users connected to other interfaces to also access the 
server. For LAN users, the Zyxel Device uses the LAN interface’s IP address as the source 
address for the traffic it sends to the LAN server. See NAT Loopback on page 155 for more 
details.

If you do not enable NAT loopback, this NAT rule only applies to packets received on the 
rule’s specified incoming interface.

Security Policy By default the security policy blocks incoming connections from external addresses. After 
you configure your NAT rule settings, click the Security Policy link to configure a security 
policy to allow the NAT rule’s traffic to come in.

The Zyxel Device checks NAT rules before it applies To-Zyxel Device security policies, so To-
Zyxel Device security policies, do not apply to traffic that is forwarded by NAT rules. The 
Zyxel Device still checks other security policies, according to the source IP address and 
mapped IP address.

Apply Click Apply to save your changes to the Zyxel Device. 

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 81   Network > NAT > Add (continued)
LABEL DESCRIPTION
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CHAPTER 10
BWM (Bandwidth 

Management) 

10.1  Overview
Bandwidth management provides a convenient way to manage the use of various services on the 
network. It manages general protocols (for example, HTTP and FTP) and applies traffic prioritization to 
enhance the performance of delay-sensitive applications like voice and video.

10.1.1  What You Can Do in this Chapter
Use the BWM screens (see Section 10.2 on page 164) to control bandwidth for services passing through 
the Zyxel Device, and to identify the conditions that define the bandwidth control.

10.1.2   What You Need to Know
When you allow a service, you can restrict the bandwidth it uses. It controls TCP and UDP traffic. Use 
policy routes to manage other types of traffic (like ICMP).

Note: Bandwidth management in policy routes has priority over TCP and UDP traffic policies.

If you want to use a service, make sure both the security policy allow the service’s packets to go through 
the Zyxel Device.

Note: The Zyxel Device checks security policies before it checks bandwidth management 
rules for traffic going through the Zyxel Device.

Bandwidth management examines every TCP and UDP connection passing through the Zyxel Device. 
Then, you can specify, by port, whether or not the Zyxel Device continues to route the connection.

Connection and Packet Directions 

Bandwidth management looks at the connection direction, that is, from which interface the connection 
was initiated and to which interface the connection is going. 

A connection has upload and download packet flows. The Zyxel Device controls the bandwidth of 
traffic of each flow as it is going out through an interface or IPSec VPN tunnel. 

• The upload traffic flows from the connection initiator to the connection responder. 

• The download traffic flows from the connection responder to the connection initiator. 

For example, a LAN1 to WAN connection is initiated from LAN1 and goes to the WAN.
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• Upload traffic goes from a LAN1 device to a WAN device. Bandwidth management is applied before 
sending the packets out a WAN interface on the Zyxel Device. 

• Download traffic comes back from the WAN device to the LAN1 device. Bandwidth management is 
applied before sending the traffic out a LAN1 interface. 

Figure 114   LAN1 to WAN Connection and Packet Directions     

Upload and Download Bandwidth Limits

You can limit an application’s upload or download bandwidth. This limit keeps the traffic from using up 
too much of the upload interface’s bandwidth. This way you can make sure there is bandwidth for other 
applications. When you apply a bandwidth limit to upload or download traffic, each member of the 
upload zone can send up to the limit. Take a LAN1 to WAN policy for example. 

• Upload traffic is limited to 200 kbps. The connection initiator is on the LAN1 so upload means the traffic 
traveling from the LAN1 to the WAN. Each of the WAN zone’s two interfaces can send the limit of 200 
kbps of traffic. 

• Download traffic is limited to 500 kbps. The connection initiator is on the LAN1 so download means the 
traffic traveling from the WAN to the LAN1.

Figure 115   LAN1 to WAN, Upload 200 kbps, Download 500 kbps    

Bandwidth Management Priority
• The Zyxel Device gives bandwidth to higher-priority traffic first, until it reaches its configured 

bandwidth rate.

• Then lower-priority traffic gets bandwidth. 

• The Zyxel Device uses a priority queueing  scheduler to divide bandwidth among traffic flows with the 
same priority.

DownloadUpload
500 kbps200 kbps
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• The Zyxel Device automatically treats traffic with bandwidth management disabled as priority 7 (the 
lowest priority). 

Configured Rate Effect

In the following table the configured rates total less than the available bandwidth and maximize 
bandwidth usage is disabled, both servers get their configured rate.   

Priority and Over Allotment of Bandwidth Effect

Server A has a configured rate that equals the total amount of available bandwidth and a higher 
priority. You should regard extreme over allotment of traffic with different priorities (as shown here) as a 
configuration error. Even though the Zyxel Device still attempts to let all traffic get through and not be 
lost, regardless of its priority, server B gets almost no bandwidth with this configuration.  

Limit the Bandwidth for a Specific VLAN

If you want to limit the bandwidth for a specific VLAN, set the VLAN as the incoming interface and VPN 
as the outgoing interface. Then, set the bandwidth limit for this BWM rule.

10.2  The Bandwidth Management Configuration
The Bandwidth management screens control the bandwidth allocation for TCP and UDP traffic. You can 
use incoming interface, outgoing interface, user, source, destination information, application, and 
service type as criteria to create a sequence of specific conditions, similar to the sequence of rules used 
by firewalls, to specify how the Zyxel Device allocates bandwidth for the matching packets.

Click Network > BWM to open the following screen. This screen allows you to enable/disable bandwidth 
management and add, edit, and remove user-defined bandwidth management policies.

The default bandwidth management policy is the one with the priority of “default”. It is the last policy 
the Zyxel Device checks if traffic does not match any other bandwidth management policies you have 
configured. You cannot remove, activate, deactivate or move the default bandwidth management 
policy.

Table 82   Configured Rate Effect
POLICY CONFIGURED RATE MAX. BANDWIDTH USAGE PRIORITY ACTUAL RATE

A 300 kbps No 1 300 kbps

B 200 kbps No 1 200 kbps

Table 83   Priority and Over Allotment of Bandwidth Effect
POLICY CONFIGURED RATE MAX. BANDWIDTH USAGE PRIORITY ACTUAL RATE

A 1000 kbps Yes 1 999 kbps

B 1000 kbps Yes 2 1 kbps
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Figure 116    Network > Bandwidth Management

The following table describes the labels in this screen. See Section 10.2.1 on page 166 for more 
information as well.  

Table 84    Network > Bandwidth Management 
LABEL DESCRIPTION
Enable Click to slide the switch to the right to activate bandwidth management on the Zyxel 

Device. 

Add Click this to create a new entry. Select an entry and click Add to create a new entry after 
the selected entry.

Edit Select an entry and click this to be able to modify it. 

Remove Select an entry and click this to delete it.

Activate To turn on an entry, select it and click Activate.

Inactivate To turn off an entry, select it and click Inactivate.

Move to To change an entry’s position in the numbered list, select it and click Move to display a 
field to type a number for where you want to put that entry and press [ENTER] to move 
the entry to the number that you typed.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the entry is 
inactive. The status icon is not available for the default bandwidth management policy.

Pri (Priority) This field displays a sequential value for each bandwidth management policy and it is 
not associated with a specific setting.

This field displays default for the default bandwidth management policy.

Name This is the name of the BWM rule.

Description This field displays additional information about this policy.

User This is the type of user account to which the policy applies. If any displays, the policy 
applies to all user accounts.

Incoming Interface This is the source interface of the traffic to which this policy applies.

Outgoing Interface This is the destination interface of the traffic to which this policy applies.

Source This is the source address or address group, including geographic address and FQDN 
(group) objects, for whom this policy applies. If any displays, the policy is effective for 
every source.

Destination This is the destination address or address group, including geographic address and FQDN 
(group) objects, for whom this policy applies. If any displays, the policy is effective for 
every destination.
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10.2.1  The Bandwidth Management Add/Edit Screen
The Network > BWM > Add/Edit screen allows you to create a new condition or edit an existing one. 

To access this screen, go to the Network > BWM screen (see Section 10.2 on page 164), and click either 
the Add icon or an Edit icon.

Figure 117   Network > BWM > Edit (For the Default Policy)

Service App and the service name displays if you selected Application Object for the service 
type. An Application Object is a pre-defined service. 

Obj and the service name displays if you selected Service Object for the service type. A 
Service Object is a customized pre-defined service or another service. Mouse over the 
service object name to view the corresponding IP protocol number.

BWM Download/
Upload/Pri

This field shows the amount of bandwidth the traffic can use.

Download - This is how much inbound bandwidth, in megabits per second, this policy 
allows the matching traffic to use. Inbound refers to the traffic the Zyxel Device sends to a 
connection’s initiator. If 0 displays here, it means the download traffic has reached the 
maximum capacity the Zyxel Device can transmit.

Upload - This is how much outbound bandwidth, in megabits per second, this policy 
allows the matching traffic to use. Outbound refers to the traffic the Zyxel Device sends 
out from a connection’s initiator. If 0 displays here, it means the upload traffic has 
reached the maximum capacity the Zyxel Device can transmit.

Pri - This is the priority for the inbound or outbound traffic that matches this policy. The 
smaller the number, the higher the priority. Traffic with a higher priority is given bandwidth 
before traffic with a lower priority.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 84    Network > Bandwidth Management (continued)
LABEL DESCRIPTION
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Figure 118    Network > BWM  > Add/Edit

The following table describes the labels in this screen.  

Table 85    Network > BWM  > Add/Edit 
LABEL DESCRIPTION
Configuration

Enable Select this check box to turn on this policy.

Name Enter a name to identify the BWM rule. You may use 1-31 alphanumeric characters, 
underscores (_), or dashes (-), but the first character cannot be a number. This value is 
case-sensitive.

Description Enter a description of this policy. It is not used elsewhere. You can use alphanumeric and 
()+/:+?!*#@$_%- characters, and it can be up to 60 characters long.

Criteria Use this section to configure the conditions of traffic to which this policy applies.

Incoming Interface Select the source interface of the traffic to which this policy applies.

Outgoing Interface Select the destination interface of the traffic to which this policy applies.

Source Select a source address or address group, including geographic address and FQDN 
(group) objects, for whom this policy applies. Use Create new Object if you need to 
configure a new one. Select any if the policy is effective for every source.

Destination Select a destination address or address group, including geographic address and FQDN 
(group) objects, for whom this policy applies. Use Create new Object if you need to 
configure a new one. Select any if the policy is effective for every destination.
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Service Type Select Service Object or Application Group if you want a specific service (defined in a 
service object) or application patrol service to which the policy applies.

Service Object This field is available if you selected Service Object as the service type.

Select a service or service group to identify the type of traffic to which this policy applies. 
any means all services.

Application Group This field is available if you selected Application Group as the service type.

Select an application to identify the specific traffic to which this policy applies.

If you select BitTorrent, it includes the services listed below at the time of writing:

• BitTorrent
• BitTorrent_FileTransfer
• BitTorrent_Application
• BitTorrent_Bundle

User Select a user name or user group to which to apply the policy. Use Create new Object if 
you need to configure a new user account. Select any to apply the policy for every user.

Traffic Shaping Configure these fields to set the amount of bandwidth the matching traffic can use.

Download Limit 
Mbps

Type how much inbound bandwidth, in megabits per second, this policy allows the traffic 
to use. Inbound refers to the traffic the Zyxel Device sends to a connection’s initiator. 

Select Unlimited to apply bandwidth management for the matching traffic which is the 
maximum amount your Zyxel Device can transmit.

Select Limited to apply bandwidth management for matching traffic, and enter a number  
from 1 to 10,000 Mbps.

Note: Traffic matching a Limited policy may “borrow” all unused bandwidth on 
the inbound interface. 

If the sum of the bandwidths for routes using the same next hop is higher than the actual 
transmission speed, lower priority traffic may not be sent if higher priority traffic uses all of 
the actual bandwidth.

Upload Limit Mbps Type how much outbound bandwidth, in megabits per second, this policy allows the 
traffic to use. Outbound refers to the traffic the Zyxel Device sends out from a connection’s 
initiator. 

Select Unlimited to apply bandwidth management for the matching traffic which is the 
maximum amount your Zyxel Device can transmit.

Select Limited to apply bandwidth management for matching traffic, and enter a number  
from 1 to 10,000 Mbps. 

Note: Traffic matching a Limited policy may “borrow” all unused bandwidth on 
the upload interface. 

If the sum of the bandwidths for routes using the same next hop is higher than the actual 
transmission speed, lower priority traffic may not be sent if higher priority traffic uses all of 
the actual bandwidth.

Table 85    Network > BWM  > Add/Edit (continued)
LABEL DESCRIPTION
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10.2.2  Adding Objects for the BWM Policy
Objects are parameters to which the Policy rules are built upon. You can add/edit User and Address 
objects for the BWM policy. Click Network > BWM > Add > Create New Object > Add User to see the 
following screen.

10.2.2.1  User Objects
Figure 119   Network > BWM  > Create New Object > Add User

The following table describes the fields in the above screen. 

Priority Choose a number between 0 and 7 to set the priority for traffic that matches this policy. 
The smaller the number, the higher the priority. 0 is for real-time traffic such as video, and 7 
is for lowest priority traffic such as background traffic.

Traffic with a higher priority is given bandwidth before traffic with a lower priority. When 
traffic with higher priority has reached the full bandwidth, the traffic with lower priority can 
use the remaining bandwidth.

The Zyxel Device uses priority queueing  scheduler to divide bandwidth between traffic 
flows with the same priority.

The number in this field is ignored if the download and upload limits are both set to 
Unlimited.

Related Setting

Log Select whether to have the Zyxel Device generate a log (log), log and alert (log alert) or 
neither (no) when any traffic matches this policy.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 85    Network > BWM  > Add/Edit (continued)
LABEL DESCRIPTION

Table 86   Network > BWM  > Create New Object > Add User 
LABEL DESCRIPTION
User Name Type a user or user group object name of the rule.

User Type Select a user type from the drop down menu. The user types are Admin, Limited admin, 
User, Guest, Ext-user, Ext-group-user.

Password Type a password for the user object. The password can consist of alphanumeric 
characters, the underscore, and some punctuation marks (+-/*= :; .! @$&%#~ ‘ \ () ), and it 
can be up to eight characters long.

Retype Retype the password to confirm.
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10.2.2.2  User Group Objects
Figure 120   Network > BWM  > Create New Object > Add User Group

The following table describes the fields in the above screen. 

Description Enter a description of this policy. It is not used elsewhere. You can use alphanumeric and 
()+/:+?!*#@$_%- characters, and it can be up to 60 characters long.

Save Click Save to save the setting.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 86   Network > BWM  > Create New Object > Add User (continued)
LABEL DESCRIPTION

Table 87    Network > BWM  > Create New Object > Add User Group 
LABEL DESCRIPTION
Name Type a user group name of the object.

Description Enter a description of this policy. It is not used elsewhere. You can use alphanumeric and 
()+/:+?!*#@$_%- characters, and it can be up to 60 characters long.

Member List Select the users or user groups that will be in this user group.

Save Click Save to save the setting.

Cancel Click Cancel to return the screen to its last-saved settings. 
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10.2.2.3  Address Objects
Figure 121   Network > BWM > Create New Object > Add Address

The following table describes the fields in the above screen.

10.2.2.4  Address Group Objects
Figure 122   Network > BWM > Create New Object > Add Address Group

Table 88    Network > BWM  > Create New Object > Add Address 
LABEL DESCRIPTION
Name Enter a name for the Address object of the rule.

Address Type Select an Address Type from the drop down menu on the right. The Address Types are 
Host, Range, Subnet, Interface IP, Interface Subnet, and Interface Gateway.

IP Address Enter an IP address for the Address object.

Save Click Save to save the setting.

Cancel Click Cancel to return the screen to its last-saved settings. 
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The following table describes the fields in the above screen.

10.3  Example: Prioritize a Specific Application
You are a client on the Zyxel Device LAN. You use Teams to communicate with your colleagues and 
have video meetings often at work. You want to create a bandwidth management rule to prioritize 
traffic for Teams so that you can always use Teams without any delay.

This example uses the parameters given below.

1 Go to Network > BWM . Click Add to create a bandwidth management rule using the parameters given 
in Table 90 on page 172. 

2 Select Teams under Application Group.

3 Click Apply to save your changes.

Table 89   Network > BWM  > Create New Object > Add Address Group 
LABEL DESCRIPTION
Name Type an address group name of the object.

Description Enter a description of this object. It is not used elsewhere. You can use alphanumeric and 
()+/:+?!*#@$_%- characters, and it can be up to 60 characters long.

Member List Select the address objects that will be in this user group.

Save Click Save to save the setting.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 90   BWM Example
DESCRIPTION SERVICE TYPE SERVICE OBJECT GUARANTEED BANDWIDTH
Teams Application Group Teams Download 20 mbps/ Priority: 1

Upload: 20 mbps/ Priority: 1
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4 The traffic for Teams is now at the highest priority to use the Zyxel Device bandwidth.
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CHAPTER 11
ALG

11.1  ALG Overview
Application Layer Gateway (ALG) allows File Transfer Protocol (FTP) to operate properly through the 
Zyxel Device’s NAT.

The ALG feature is only needed for traffic that goes through the Zyxel Device’s NAT. 

11.1.1  What You Need to Know

Application Layer Gateway (ALG), NAT and Security Policy

The Zyxel Device can function as an Application Layer Gateway (ALG) to allow certain NAT un-friendly 
applications (such as FTP) to operate properly through the Zyxel Device’s NAT and security policy. The 
Zyxel Device dynamically creates an implicit NAT session and security policy session for the application’s 
traffic from the WAN to the LAN. The ALG on the Zyxel Device supports all of the Zyxel Device’s NAT 
mapping types.

ALG

Some applications cannot operate through NAT (are NAT unfriendly) because they embed IP addresses 
and port numbers in their packets’ data payload. The Zyxel Device examines and uses IP address and 
port number information embedded in the FTP traffic’s data stream. When a device behind the Zyxel 
Device uses an application for which the Zyxel Device has FTP pass through enabled, the Zyxel Device 
translates the device’s private IP address inside the data stream to a public IP address. It also records 
session port numbers and allows the related sessions to go through the security policy so the 
application’s traffic can come in from the WAN to the LAN. 

ALG and Trunks

If you send your ALG-managed traffic through an interface trunk and all of the interfaces are set to 
active, you can configure routing policies to specify which interface the ALG-managed traffic uses.

You could also have a trunk with one interface set to active and a second interface set to passive. The 
Zyxel Device does not automatically change ALG-managed connections to the second (passive) 
interface when the active interface’s connection goes down. When the active interface’s connection 
fails, the client needs to re-initialize the connection through the second interface (that was set to 
passive) in order to have the connection go through the second interface.
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FTP ALG

File Transfer Protocol (FTP) is an Internet file transfer service that operates on the Internet and over TCP/IP 
networks. A system running the FTP server accepts commands from a system running an FTP client. The 
service allows users to send commands to the server for uploading and downloading files. 

The FTP ALG allows TCP packets with a specified port destination to pass through. If the FTP server is 
located on the LAN, you must also configure NAT (port forwarding) and security policies if you want to 
allow access to the server from the WAN.

11.1.2  Before You Begin
You must also configure the security policy and enable NAT in the Zyxel Device to allow sessions initiated 
from the WAN.

11.2  The ALG Screen
Click Network > ALG to open the ALG screen. Use this screen to:

• Turn ALGs off or on.

• Configure the port numbers to which they apply. 

Note: If the Zyxel Device provides an ALG for a service, you must enable the ALG in order to 
use the application patrol on that service’s traffic. 

Figure 123   Network > ALG

The following table describes the labels in this screen.

Table 91   Network > ALG 
LABEL DESCRIPTION
Enable FTP ALG Turn on the FTP ALG to detect FTP (File Transfer Program) traffic and help build FTP 

sessions through the Zyxel Device’s NAT. Enabling the FTP ALG also allows you to use the 
application patrol to detect FTP traffic.

Enable FTP 
Transformations

Select this option to have the Zyxel Device modify IP addresses and port numbers 
embedded in the FTP data payload to match the Zyxel Device’s NAT environment. 

Clear this option if you have an FTP device or server that will modify IP addresses and 
port numbers embedded in the FTP data payload to match the Zyxel Device’s NAT 
environment.

FTP Signaling Port If you are using a custom TCP port number (not 21) for FTP traffic, enter it here. 
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CHAPTER 12
IPSec VPN

12.1  Virtual Private Networks (VPN) Overview
A virtual private network (VPN) provides secure communications between sites without the expense of 
leased site-to-site lines. A secure VPN is a combination of tunneling, encryption, authentication, access 
control and auditing. It is used to transport traffic over the Internet or any insecure network that uses 
TCP/IP for communication.

IPSec VPN

Internet Protocol Security (IPSec) VPN connects IPSec routers or remote users using IPSec client software. 
This standards-based VPN offers flexible solutions for secure data communications across a public 
network. IPSec is built around a number of standardized cryptographic techniques to provide 
confidentiality, data integrity and authentication at the IP layer. The Zyxel Device can also combine 
multiple IPSec VPN connections into one secure network. Here local Zyxel Device X uses an IPSec VPN 
tunnel to remote (peer) Zyxel Device Y to connect the local (A) and remote (B) networks.

Figure 124   IPSec VPN Example

Internet Key Exchange (IKE): IKEv1 and IKEv2

The Zyxel Device supports IKEv1 and IKEv2 for IPv4 traffic. IKE (Internet Key Exchange) is a protocol used 
in setting up security associations that allows two parties to send data securely.

IKE uses certificates or pre-shared keys for authentication and a Diffie–Hellman key exchange to set up 
a shared session secret from which encryption keys are derived. A security policy for each peer must be 
manually created.

IPSec VPN consists of two phases: Phase 1 and Phase 2. Phase 1's purpose is to establish a secure 
authenticated communication channel by using the Diffie–Hellman key exchange algorithm to 
generate a shared secret key to encrypt IKE communications. This negotiation results in one single bi-
directional ISAKMP Security Association (SA). The authentication can be performed using either pre-
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shared key (shared secret), signatures, or public key encryption. Phase 1 operates in either Main Mode 
or Aggressive Mode. Main Mode protects the identity of the peers, but Aggressive Mode does not.

During Phase 2, the remote IPSec routers use the secure channel established in Phase 1 to negotiate 
Security Associations for IPSec. The negotiation results in a minimum of two unidirectional security 
associations (one inbound and one outbound). Phase 2 uses Quick Mode (only). Quick mode occurs 
after IKE has established the secure tunnel in Phase 1. It negotiates a shared IPSec policy, derives shared 
secret keys used for the IPSec security algorithms, and establishes IPSec SAs. Quick mode is also used to 
renegotiate a new IPSec SA when the IPSec SA lifetime expires.

Some differences between IKEv1 and IKEv2 include:

• IKEv2 uses less bandwidth than IKEv1. IKEv2 uses one exchange procedure with 4 messages. IKEv1 uses 
two phases with Main Mode (9 messages) or Aggressive Mode (6 messages) in phase 1. 

• IKEv2 supports Extended Authentication Protocol (EAP) authentication, and IKEv1 supports X-Auth. 
EAP is important when connecting to existing enterprise authentication systems. 

• IKEv2 always uses NAT traversal and Dead Peer Detection (DPD), but they can be disabled in IKEv1 
using Zyxel Device firmware (the default is on).

• Configuration payload (includes the IP address pool in the VPN setup data) is supported in IKEv2 (off 
by default), but not in IKEv1.

• Narrowed is supported in IKEv2, but not in IKEv1. Narrowed has the SA apply only to IP addresses in 
common between the Zyxel Device and the remote IPSec router.

• The IKEv2 protocol supports connectivity checks which is used to detect whether the tunnel is still up 
or not. If the check fails (the tunnel is down), IKEv2 can re-establish the connection automatically. The 
Zyxel Device uses firmware to perform connectivity checks when using IKEv1.

12.2  IPSec VPN Background Information
Here is some more detailed IPSec VPN background information.

12.2.1  IKE SA Overview
The IKE SA provides a secure connection between the Zyxel Device and remote IPSec router.

It takes several steps to establish an IKE SA. The negotiation mode determines how many. There are two 
negotiation modes for IKEv1--main mode and aggressive mode. Main mode provides better security, 
while aggressive mode is faster.

Note: Both routers must use the same negotiation mode.

These modes are discussed in more detail in Negotiation Mode. Main mode is used in various examples 
in the rest of this section.

The Zyxel Device supports IKEv1 and IKEv2. See Section 12.1 on page 176 for more information.

IP Addresses of the Zyxel Device and Remote IPSec Router

To set up an IKE SA, you have to specify the IP addresses of the Zyxel Device and remote IPSec router. 
You can usually enter a static IP address or a domain name for either or both IP addresses. Sometimes, 
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your Zyxel Device might offer another alternative, such as using the IP address of a port or interface, as 
well.

You can also specify the IP address of the remote IPSec router as 0.0.0.0. This means that the remote 
IPSec router can have any IP address. In this case, only the remote IPSec router can initiate an IKE SA 
because the Zyxel Device does not know the IP address of the remote IPSec router. This is often used for 
telecommuters.

IKE SA Proposal

The IKE SA proposal is used to identify the encryption algorithm, authentication algorithm, and Diffie-
Hellman (DH) key group that the Zyxel Device and remote IPSec router use in the IKE SA. In main mode, 
this is done in steps 1 and 2, as illustrated next.

Figure 125   IKE SA: Main Negotiation Mode, Steps 1 - 2: IKE SA Proposal  

The Zyxel Device sends one or more proposals to the remote IPSec router. (In some devices, you can 
only set up one proposal.) Each proposal consists of an encryption algorithm, authentication algorithm, 
and DH key group that the Zyxel Device wants to use in the IKE SA. The remote IPSec router selects an 
acceptable proposal and sends the accepted proposal back to the Zyxel Device. If the remote IPSec 
router rejects all of the proposals, the Zyxel Device and remote IPSec router cannot establish an IKE SA.

Note: Both routers must use the same encryption algorithm, authentication algorithm, and DH 
key group.

In most Zyxel Devices, you can select one of the following encryption algorithms for each proposal. The 
algorithms are listed in order from weakest to strongest.

• Data Encryption Standard (DES) is a widely used method of data encryption. It applies a 56-bit key to 
each 64-bit block of data.

• Triple DES (3DES) is a variant of DES. It iterates three times with three separate keys, effectively tripling 
the strength of DES.

• Advanced Encryption Standard (AES) is a newer method of data encryption that also uses a secret 
key. AES applies a 128-bit key to 128-bit blocks of data. It is faster than 3DES.

Some Zyxel Devices also offer stronger forms of AES that apply 192-bit or 256-bit keys to 128-bit blocks of 
data.

In most Zyxel Devices, you can select one of the following authentication algorithms for each proposal. 
The algorithms are listed in order from weakest to strongest.

One or more proposals, each one consisting of:
- encryption algorithm

- authentication algorithm
- Diffie-Hellman key group

1

2X Y
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• MD5 (Message Digest 5) produces a 128-bit digest to authenticate packet data.

• SHA1 (Secure Hash Algorithm) produces a 160-bit digest to authenticate packet data.

• SHA256 (Secure Hash Algorithm) produces a 256-bit digest to authenticate packet data.

• SHA512 (Secure Hash Algorithm) produces a 512-bit digest to authenticate packet data.

See Diffie-Hellman (DH) Key Exchange on page 179 for more information about DH key groups.

Diffie-Hellman (DH) Key Exchange

The Zyxel Device and the remote IPSec router use DH public-key cryptography to establish a shared 
secret. The shared secret is then used to generate encryption keys for the IKE SA and IPSec SA. In main 
mode, this is done in steps 3 and 4, as illustrated next. 

Figure 126   IKE SA: Main Negotiation Mode, Steps 3 - 4: DH Key Exchange  

DH public-key cryptography is based on DH key groups. Each key group is a fixed number of bits long. 
The longer the key, the more secure the encryption, but also the longer it takes to encrypt and decrypt 
information. For example, DH2 keys (1024 bits) are more secure than DH1 keys (768 bits), but DH2 keys 
take longer to encrypt and decrypt.

Authentication

Before the Zyxel Device and remote IPSec router establish an IKE SA, they have to verify each other’s 
identity. This process is based on pre-shared keys and router identities.

In main mode, the Zyxel Device and remote IPSec router authenticate each other in steps 5 and 6, as 
illustrated below. The identities are also encrypted using the encryption algorithm and encryption key 
the Zyxel Device and remote IPSec router selected in previous steps.

Figure 127   IKE SA: Main Negotiation Mode, Steps 5 - 6: Authentication (continued) 

You have to create (and distribute) a pre-shared key. The Zyxel Device and remote IPSec router use it in 
the authentication process, though it is not actually transmitted or exchanged.

Diffie-Hellman key exchange

Step 5:
pre-shared key

Zyxel Device identity, consisting of
- ID type
Step 6:

pre-shared key
Remote IPSec router identity, consisting of

- ID type

3

4X Y
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Note: The Zyxel Device and the remote IPSec router must use the same pre-shared key.

Router identity consists of ID type. The ID type can be domain name, IP address, or email address. The 
content is only used for identification. Any domain name or email address that you enter does not have 
to actually exist. Similarly, any domain name or IP address that you enter does not have to correspond 
to the Zyxel Device’s or remote IPSec router’s properties.

The Zyxel Device and the remote IPSec router have their own identities, so both of them must store two 
sets of information, one for themselves and one for the other router. Local ID type refers to the content 
that applies to the router itself, and remote ID type refers to the content that applies to the other router.

Note: The Zyxel Device’s local and remote ID content must match the remote IPSec router’s 
remote and local ID content, respectively.

For example, in the next table, the Zyxel Device and the remote IPSec router authenticate each other 
successfully. In contrast, in the following table, the Zyxel Device and the remote IPSec router cannot 
authenticate each other and, therefore, cannot establish an IKE SA.

It is also possible to configure the Zyxel Device to ignore the identity of the remote IPSec router. In this 
case, you usually leave the remote ID type field empty. This is less secure, so you should only use this if 
your Zyxel Device provides another way to check the identity of the remote IPSec router (for example, 
extended authentication) or if you are troubleshooting a VPN tunnel.

12.2.2  Additional Topics for IKE SA
This section provides more information about IKE SA.

Negotiation Mode

There are two negotiation modes for IKEv1--main mode and aggressive mode. Main mode provides 
better security, while aggressive mode is faster.

Main mode takes six steps to establish an IKE SA.

Table 92   VPN Example: Matching ID Type and Content 
ZYXEL DEVICE REMOTE IPSEC ROUTER
Local ID type: tom@yourcompany.com Local ID type: 1.1.1.2

Peer ID type: 1.1.1.2 Peer ID type: tom@yourcompany.com

Table 93   VPN Example: Mismatching ID Type and Content
ZYXEL DEVICE REMOTE IPSEC ROUTER
Local ID type: tom@yourcompany.com Local ID type: 1.1.1.2

Peer ID type: 1.1.1.20 Peer ID type: tom@yourcompany.com

5

6X Y
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Steps 1 - 2: The Zyxel Device sends its proposals to the remote IPSec router. The remote IPSec router 
selects an acceptable proposal and sends it back to the Zyxel Device.

Steps 3 - 4: The Zyxel Device and the remote IPSec router exchange pre-shared keys for authentication 
and participate in a Diffie-Hellman key exchange, based on the accepted DH key group, to establish a 
shared secret.

Steps 5 - 6: Finally, the Zyxel Device and the remote IPSec router generate an encryption key (from the 
shared secret), encrypt their identities, and exchange their encrypted identity information for 
authentication.

In contrast, aggressive mode only takes three steps to establish an IKE SA. Aggressive mode does not 
provide as much security because the identity of the Zyxel Device and the identity of the remote IPSec 
router are not encrypted. It is usually used in remote-access situations, where the address of the initiator 
is not known by the responder and both parties want to use pre-shared keys for authentication. For 
example, the remote IPSec router may be a telecommuter who does not have a static IP address.

VPN, NAT, and NAT Traversal

In the following example, there is another router (A) between router X and router Y.

Figure 128   VPN/NAT Example

If router A does NAT, it might change the IP addresses, port numbers, or both. If router X and router Y try 
to establish a VPN tunnel, the authentication fails because it depends on this information. The routers 
cannot establish a VPN tunnel.

Most routers like router A now have an IPSec pass-thru feature. This feature helps router A recognize VPN 
packets and route them appropriately. If router A has this feature, router X and router Y can establish a 
VPN tunnel as long as the active protocol is ESP. (See Active Protocol on page 182 for more information 
about active protocols.)

If router A does not have an IPSec pass-thru or if the active protocol is AH, you can solve this problem by 
enabling NAT traversal. In NAT traversal, router X and router Y add an extra header to the IKE SA and 
IPSec SA packets. If you configure router A to forward these packets unchanged, router X and router Y 
can establish a VPN tunnel.

You have to do the following things to set up NAT traversal.

• Enable NAT traversal on the Zyxel Device and remote IPSec router.

• Configure the NAT router to forward packets with the extra header unchanged. (See the field 
description for detailed information about the extra header.)

The extra header may be UDP port 500 or UDP port 4500, depending on the standard(s) the Zyxel Device 
and remote IPSec router support.

AX Y
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Certificates

It is possible for the Zyxel Device and remote IPSec router to authenticate each other with certificates. In 
this case, you do not have to set up the pre-shared key, local identity, or remote identity because the 
certificates provide this information instead.

• Instead of using the pre-shared key, the Zyxel Device and remote IPSec router check the signatures 
on each other’s certificates. Unlike pre-shared keys, the signatures do not have to match.

• The local and peer ID type and content come from the certificates.

Note: You must set up the certificates for the Zyxel Device and remote IPSec router first.

IPSec SA Overview

Once the Zyxel Device and remote IPSec router have established the IKE SA, they can securely 
negotiate an IPSec SA through which to send data between computers on the networks.

Note: The IPSec SA stays connected even if the underlying IKE SA is not available anymore.

This section introduces the key components of an IPSec SA.

Local Network and Remote Network

In an IPSec SA, the local network, the one(s) connected to the Zyxel Device, may be called the local 
policy. Similarly, the remote network, the one(s) connected to the remote IPSec router, may be called 
the remote policy.

Active Protocol

The active protocol controls the format of each packet. It also specifies how much of each packet is 
protected by the encryption and authentication algorithms. IPSec VPN includes two active protocols, 
AH (Authentication Header, RFC 2402) and ESP (Encapsulating Security Payload, RFC 2406).

Note: The Zyxel Device and remote IPSec router must use the same active protocol.

Usually, you should select ESP. AH does not support encryption, and ESP is more suitable with NAT.

Encapsulation

There are two ways to encapsulate packets. Usually, you should use tunnel mode because it is more 
secure. Transport mode is only used when the IPSec SA is used for communication between the Zyxel 
Device and remote IPSec router (for example, for remote management), not between computers on 
the local and remote networks.

Note: The Zyxel Device and remote IPSec router must use the same encapsulation.

These modes are illustrated below.

Figure 129   VPN: Transport and Tunnel Mode Encapsulation

Original Packet IP Header TCP Header Data
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In tunnel mode, the Zyxel Device uses the active protocol to encapsulate the entire IP packet. As a 
result, there are two IP headers:

• Outside header: The outside IP header contains the IP address of the Zyxel Device or remote IPSec 
router, whichever is the destination.

• Inside header: The inside IP header contains the IP address of the computer behind the Zyxel Device 
or remote IPSec router. The header for the active protocol (AH or ESP) appears between the IP 
headers.

In transport mode, the encapsulation depends on the active protocol. With AH, the Zyxel Device 
includes part of the original IP header when it encapsulates the packet. With ESP, however, the Zyxel 
Device does not include the IP header when it encapsulates the packet, so it is not possible to verify the 
integrity of the source IP address.

IPSec SA Proposal and Perfect Forward Secrecy

An IPSec SA proposal is similar to an IKE SA proposal (see IKE SA Proposal), except that you also have the 
choice whether or not the Zyxel Device and remote IPSec router perform a new DH key exchange every 
time an IPSec SA is established. This is called Perfect Forward Secrecy (PFS).

If you enable PFS, the Zyxel Device and remote IPSec router perform a DH key exchange every time an 
IPSec SA is established, changing the root key from which encryption keys are generated. As a result, if 
one encryption key is compromised, other encryption keys remain secure.

If you do not enable PFS, the Zyxel Device and remote IPSec router use the same root key that was 
generated when the IKE SA was established to generate encryption keys.

The DH key exchange is time-consuming and may be unnecessary for data that does not require such 
security.

PFS is ignored in initial IKEv2 authentication but is used when re-authenticating.

12.2.3  Additional Topics for IPSec SA
This section provides more information about IPSec SA in your Zyxel Device.

Authentication and the Security Parameter Index (SPI)

For authentication, the Zyxel Device and remote IPSec router use the SPI, instead of pre-shared keys, ID 
type and content. The SPI is an identification number.

Note: The Zyxel Device and remote IPSec router must use the same SPI.

Transport Mode Packet IP Header AH/ESP 
Header

TCP Header Data

Tunnel Mode Packet IP Header AH/ESP 
Header

IP Header TCP Header Data

Figure 129   VPN: Transport and Tunnel Mode Encapsulation
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IPSec VPN Example Scenario

Here is an example site-to-site IPSec VPN scenario.

Figure 130   Site-to-site IPSec VPN Example

12.2.4  What You Can Do in this Chapter
• Use the Site to Site VPN screen (see Section 12.3 on page 185) to view a summary of the VPN rules.

• Use the Site to Site VPN Add/Edit screens (see Section 12.3.2 on page 191 and Section 12.3.2 on page 
191) to create a VPN rule using the wizard or create a customized VPN rule with advanced settings.

• Use the Remote Access VPN screen (see Section 12.4 on page 196) to create a remote access VPN 
rule.

12.2.5  What You Need to Know
An IPSec VPN tunnel is usually established in two phases. Each phase establishes a security association 
(SA), a contract indicating what security parameters the Zyxel Device and the remote IPSec router will 
use. The first phase establishes an Internet Key Exchange (IKE) SA between the Zyxel Device and remote 
IPSec router. The second phase uses the IKE SA to securely establish an IPSec SA through which the Zyxel 
Device and remote IPSec router can send data between computers on the local network and remote 
network. This is illustrated in the following figure.

Figure 131   VPN: IKE SA and IPSec SA

In this example, a computer in network A is exchanging data with a computer in network B. Inside 
networks A and B, the data is transmitted the same way data is normally transmitted in the networks. 
Between routers X and Y, the data is protected by tunneling, encryption, authentication, and other 
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security features of the IPSec SA. The IPSec SA is secure because routers X and Y established the IKE SA 
first.

Application Scenarios

The Zyxel Device’s application scenarios make it easier to configure your VPN connection settings. 

12.3  The Site to Site VPN Screen
Click VPN > Site to Site VPN to open the Site to Site VPN screen. The Site to Site VPN screen lists the VPN 
connection associated VPN gateway(s), and various settings. In addition, it also lets you activate or 
deactivate and connect or disconnect each VPN connection (each IPSec SA). Click a column’s 
heading cell to sort the table entries by that column’s criteria. Click the heading cell again to reverse 
the sort order.

Table 94   IPSec VPN Application Scenarios 
SITE-TO-SITE SITE-TO-SITE WITH DYNAMIC PEER

Choose this if the remote IPSec router has a 
static IP address or a domain name. 

This Zyxel Device can initiate the VPN tunnel. 

The remote IPSec router can also initiate the 
VPN tunnel if this Zyxel Device has a static IP 
address or a domain name. 

Choose this if the remote IPSec router has a 
dynamic IP address. 

You don’t specify the remote IPSec router’s 
address, but you specify the remote policy 
(the addresses of the devices behind the 
remote IPSec router).

This Zyxel Device must have a static IP address 
or a domain name.

Only the remote IPSec router can initiate the 
VPN tunnel. 
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Figure 132   VPN > IPSec VPN > Site to Site VPN

Each field is discussed in the following table.

12.3.1  The Site to Site VPN Add/Edit Screen- Wizard
The Site to Site VPN Add/Edit Gateway screen allows you to create a new VPN connection policy or edit 
an existing one. To access this screen, go to the VPN > Site to Site VPN screen, and click either the Add 
icon or an Edit icon. Select Site-to-Site in VPN > Site to Site VPN> Add/Edit > Scenario > Type to create a 
VPN rule using the wizard.

Table 95   VPN > IPSec VPN > Site to Site VPN Site to Site VPN 
LABEL DESCRIPTION
Monitor The graph shows the number of connected and disconnected VPNs. 

Add Click this to create a new entry.

Edit Double-click an entry or select it and click Edit to open a screen where you can modify the 
entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove it 
before doing so.

Active To turn on an entry, select it and click Activate.

Inactive To turn off an entry, select it and click Inactivate.

Connect To connect an IPSec SA, select it and click Connect.

Disconnect To disconnect an IPSec SA, select it and click Disconnect.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the entry is 
inactive.

The connect icon is lit when the interface is connected and dimmed when it is disconnected.

Name This field displays the name of the VPN rule.

Outgoing 
Interface

This field displays the interface IP address or DNS name the VPN connection uses to transmit 
packets.

Remote 
Gateway

This field displays the remote IPSec device IP address or DNS name in use for this VPN 
connection. 

Type This field displays the type (route based or policy based) the VPN rule is using.

Type This field displays if the VPN rule is configured through wizard or a customized rule.

Local This field displays the IP address of the computer on your network.

Remote This field displays the IP address of the computer behind the remote IPSec device.
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12.3.1.1  Scenario
Use this screen to configure the VPN connection name and select the scenario that best describes your 
intended VPN connection. 

Figure 133   VPN > Site to Site VPN > Add/Edit > Scenario

Each field is described in the following table.

Table 96   VPN > Site-to-Site VPN > Add/Edit > Scenario
LABEL DESCRIPTION
Name Type the name used to identify this rule. You may use 1-31 single-byte characters, 

including 0-9a-zA-Z, underscores (_), or dashes (-), but the first character cannot be a 
number. This value is case-sensitive.

IKE Version Select IKEv1 or IKEv2. IKEv1 applies to IPv4 traffic only. IKEv2 applies to both IPv4 and IPv6 
traffic. IKE (Internet Key Exchange) is a protocol used in setting up security associations 
that allows two parties to send data securely. See Section 12.1 on page 176 for more 
information on IKEv1 and IKEv2.

Type Select Site-to-Site to configure the VPN rule using the wizard.

Select Custom to configure the VPN rule with customized settings.

Behind NAT None/ Local Site: The remote IPSec device has a static IP address or a domain name. This 
Zyxel Device can initiate the VPN tunnel.

Remote Site: The remote IPSec device has a dynamic IP address. Only the remote IPSec 
device can initiate the VPN tunnel.
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12.3.1.2  Network
Use this screen to configure the Zyxel Device interface and remote IPSec device settings.

Figure 134   VPN > Site to Site VPN > Add/Edit > Network 

Each field is described in the following table.

12.3.1.3  Authentication
Use this screen to configure the authentication type and settings.

Table 97   VPN > Site-to-Site VPN > Add/Edit > Network
LABEL DESCRIPTION
My Address Select an interface or enter the IPv4 address or domain name of the interface the VPN 

connection uses to transmit packets out of  the Zyxel Device.

Peer Gateway Address Enter the WAN IPv4 address or domain name of the remote IPSec device to identify the 
remote IPSec router by its IP address or domain name.

Zone Select a zone for the IPSec policy. 

Go to Security Policy > Policy Control to make sure that a security policy will not block 
traffic going to the zone you select.



 Chapter 12 IPSec VPN

USG FLEX H Series User’s Guide

189

Figure 135   VPN > Site to Site VPN > Add/Edit > Authentication

Each field is described in the following table.

12.3.1.4  Policy & Routing
Use this screen to configure the IP addresses of the computer on your network and the computer 
behind the remote IPSec device.

Figure 136   VPN > Site to Site VPN > Add/Edit > Policy & Routing (Route-Based)

Table 98   VPN > Site-to-Site VPN > Add/Edit > Authentication   Authentication
LABEL DESCRIPTION
Pre-Shared Key Select this to have the Zyxel Device and remote IPSec router use a pre-shared key 

(password) of up to 128 characters to identify each other when they negotiate the IKE 
SA. Type the pre-shared key in the field to the right. The pre-shared key can be:

• 8 to 128 single-byte characters, including [0-9][a-z][A-Z]['(){}<>^`+/:!*_#@&=$\.~%,|;-
"]

The Zyxel Device and remote IPSec router must use the same pre-shared key.

Click the eye icon to see the pre-shared key in readable plain text.

Certificate Alternatively, select Certificate to use one of the Zyxel Device certificates for 
authentication.
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Figure 137   VPN > Site to Site VPN > Add/Edit > Policy & Routing (Policy-Based)

Each field is described in the following table.

12.3.1.5  Summary
Use this screen to view a summary of the VPN tunnel configurations. You can click Edit to change the 
VPN tunnel configuration settings.

Table 99   VPN > Site-to-Site VPN > Add/Edit > Policy & Routing
LABEL DESCRIPTION
Type Select Route-Based to create a VPN rule that encrypts traffic based on the static route 

settings.

Select Policy-Based to create a VPN rule that encrypts traffic based on the IPv4 
addresses you set in Local Subnet and Remote Subnet.

Local Subnet Type the IP address of a computer on your network that can use the tunnel. You can also 
specify a subnet. This must match the remote IP address configured on the remote IPSec 
device.

Remote Subnet Type the IP address of a computer behind the remote IPSec device. You can also specify 
a subnet. This must match the local IP address configured on the remote IPSec device.
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Figure 138   VPN > Site to Site VPN > Add/Edit > Summary

12.3.2  The Site to Site VPN Add/Edit Screen- Custom
The Site to Site VPN Add/Edit Gateway screen allows you to create a new VPN connection policy or edit 
an existing one. To access this screen, go to the VPN > Site to Site VPN screen, and click either the Add 
icon or an Edit icon. Select Custom in VPN > Site to Site VPN> Add/Edit > Scenario > Type to create a 
customized VPN rule with advanced settings. 

See Section 12.1 on page 176 for more information on phase 1 and phase 2 settings; see Section 12.2 on 
page 177 for more information on IKE SA proposals.
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Figure 139   VPN > Site to Site VPN > Add/Edit > Scenario > Type > Custom 

Each field is described in the following table.

Table 100   VPN > Site-to-Site VPN > Add/Edit > Scenario > Type > Custom
LABEL DESCRIPTION
General Settings

Enable Slide the switch to the right to activate this VPN connection

Name Type the name used to identify this rule. You may use 1-31 single-byte characters, 
including 0-9a-zA-Z, underscores (_), or dashes (-), but the first character cannot be a 
number. This value is case-sensitive.

IKE Version Select IKEv1 or IKEv2. IKEv1 applies to IPv4 traffic only. IKEv2 applies to both IPv4 and IPv6 
traffic. IKE (Internet Key Exchange) is a protocol used in setting up security associations 
that allows two parties to send data securely. See Section 12.1 on page 176 for more 
information on IKEv1 and IKEv2.

Type Select Route-Based to create a VPN rule that encrypts traffic based on the static route 
settings.

Select Policy-Based to create a VPN rule that encrypts traffic based on the Local and 
Remote IPv4 addresses you set in Policy in Phase 2 Settings.

Network

My Address Type the IP address of a computer on your network that can use the tunnel. You can also 
specify a subnet. This must match the remote IP address configured on the remote IPSec 
device.



 Chapter 12 IPSec VPN

USG FLEX H Series User’s Guide

193

Peer Gateway 
Address

Select Domain Name/IP to enter the domain name or the IP address of the remote IPSec 
router.

Select Dynamic Address if the remote IPSec router has a dynamic IP address (and does 
not use DDNS). 

Zone Select a zone for the IPSec policy. 

Go to Security Policy > Policy Control to make sure that a security policy will not block 
traffic going to the zone you select.

Authentication

Pre-Shared Key Select this to have the Zyxel Device and remote IPSec router use a pre-shared key 
(password) of up to 128 characters to identify each other when they negotiate the IKE 
SA. Type the pre-shared key in the field to the right. The pre-shared key can be:

• 8 to 128 single-byte characters, including [0-9][a-z][A-Z]['(){}<>^`+/:!*_#@&=$\.~%,|;-
"]

The Zyxel Device and remote IPSec router must use the same pre-shared key.

Click the eye to see the pre-shared key in readable plain text.

Certificate Alternatively, select Certificate to use one of the Zyxel Device certificates for 
authentication.

Advanced Settings

Local ID Type Enter one of the followings to identify the Zyxel Device during authentication.

IPv4 - the Zyxel Device is identified by an IP address

DNS - the Zyxel Device is identified by a domain name

E-mail - the Zyxel Device is identified by the string specified in this field

Remote ID Type Enter one of the followings to identify the remote IPSec router during authentication.

IPv4 - the remote IPSec router is identified by an IP address

DNS - the remote IPSec router is identified by a domain name

E-mail - the remote IPSec router is identified by the string specified in this field

If the Zyxel Device and remote IPSec router use certificates, there is one more choice.

Subject Name - the remote IPSec router is identified by the subject name in the certificate

Phase 1 Settings

Table 100   VPN > Site-to-Site VPN > Add/Edit (continued)> Scenario > Type > Custom
LABEL DESCRIPTION
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SA Life Time Set how often the Zyxel Device renegotiates the IKE SA. A short SA life time increases 
security, but renegotiation temporarily disconnects the VPN tunnel.

The value you set for the SA life time in Phase 1 Settings should be greater than or equal to 
the value you set for the SA life time in Phase 2 Settings.

Add Click this to add an entry.

Edit Select an entry and click this to edit the entry.

Remove Select an entry and click this to remove the entry.

Encryption Select which key size and encryption algorithm to use in the IPSec SA. Choices are:

des-cbc - a 56-bit key with the DES encryption algorithm

3des-cbc - a 168-bit key with the DES encryption algorithm

aes128-cbc - a 128-bit key with the AES encryption algorithm

aes192-cbc - a 192-bit key with the AES encryption algorithm

aes256-cbc - a 256-bit key with the AES encryption algorithm

The Zyxel Device and the remote IPSec router must both have at least one proposal that 
uses use the same encryption and the same key. 

Longer keys are more secure, but require more processing power, resulting in increased 
latency and decreased throughput.

Authentication Select which hash algorithm to use to authenticate packet data in the IPSec SA. Choices 
are hmac-md5, hmac-sha1, hmac-sha256, hmac-sha384 and hmac-sha512. SHA is 
generally considered stronger than MD5, but it is also slower.

The Zyxel Device and the remote IPSec router must both have a proposal that uses the 
same authentication algorithm. 

Diffie-Hellman 
Groups

Select which Diffie-Hellman key group (DHx) you want to use to create encryption keys. 
Choices are DH2, DH5, DH14, DH15, DH16, DH19, DH20, DH21, DH28, DH29, and DH30.

The longer the key, the more secure the encryption, but also the longer it takes to encrypt 
and decrypt information. The Zyxel Device and the remote IPSec router must use the 
same DH key group. See Section 12.2 on page 177 for more information on DH key group.

Different operating systems may support different DH key groups. Check your operating 
system documentation.

• For Windows VPN clients, Zyxel SecuExtender perpetual VPN clients versions 
3.8.203.61.32 and earlier support DH1 to DH14.

• For macOS VPN clients, Zyxel SecuExtender subscription VPN clients versions 1.2.0.7 
and later support DH14 to DH21. For Windows VPN clients, Zyxel SecuExtender 
subscription VPN clients versions 5.6.80.007 and later support DH14 to DH21.

• Windows versions 7, 10, 11 built-in IKEv2 VPN clients support DH2 by default.
• macOS versions 14.2 and later built-in IKEv2 VPN clients support DH14 by default.
• iOS versions 10.15 and later built-in IKEv2 VPN clients support DH14 by default.

Advanced Settings

DPD Delay Configure this field if you want the Zyxel Device to make sure the remote IPSec router is 
there before it transmits data through the IKE SA. The remote IPSec router must support 
Dead Peer Detection (DPD).

Set how many seconds the Zyxel Device will wait before sending a message to the 
remote IPSec router it there has been no traffic. If the remote IPSec router responds, the 
Zyxel Device transmits the data. If the remote IPSec router does not respond, the Zyxel 
Device shuts down the IKE SA.

This field applies for IKEv1 only. DPD is always performed when you use IKEv2.

UDP Encapsulation Enable to encrypt a UDP connection.

Table 100   VPN > Site-to-Site VPN > Add/Edit (continued)> Scenario > Type > Custom
LABEL DESCRIPTION
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Phase 2 Settings

Auto

Nailed-Up Select this if you want the Zyxel Device to be the hub site in the network.

Responder Only

Add Click this to add an entry.

Edit Select an entry and click this to edit the entry.

Remove Select an entry and click this to remove the entry.

Local Enter the address corresponding to the local network.

Remote Enter the address corresponding to the remote network.

Protocol Select the protocol required to use this translation. Choices are: TCP, UDP, ICMP, GRE or 
Any.

Active Protocol Select which protocol you want to use in the IPSec SA. 

ESP (RFC 2406) - provides encryption and the same services offered by AH, but its 
authentication is weaker. The Zyxel Device and remote IPSec router must use the same 
active protocol.

Encapsulation Select which type of encapsulation the IPSec SA uses.

Tunnel - this mode encrypts the IP header information and the data. The Zyxel Device and 
remote IPSec router must use the same encapsulation.

SA Life Time Set how often the Zyxel Device renegotiates the IKE SA. A short SA life time increases 
security, but renegotiation temporarily disconnects the VPN tunnel.

The value you set for the SA life time in Phase 2 Settings should be lesser than or equal to 
the value you set for the SA life time in Phase 1 Settings.

Add Click this to add an entry.

Edit Select an entry and click this to edit the entry.

Remove Select an entry and click this to remove the entry.

Encryption Select which key size and encryption algorithm to use in the IPSec SA. Choices are:

des-cbc - a 56-bit key with the DES encryption algorithm

3des-cbc - a 168-bit key with the DES encryption algorithm

aes128-cbc - a 128-bit key with the AES encryption algorithm

aes192-cbc - a 192-bit key with the AES encryption algorithm

aes256-cbc - a 256-bit key with the AES encryption algorithm

The Zyxel Device and the remote IPSec router must both have at least one proposal that 
uses use the same encryption and the same key. 

Longer keys are more secure, but require more processing power, resulting in increased 
latency and decreased throughput.

Authentication Select which hash algorithm to use to authenticate packet data in the IPSec SA. Choices 
are hmac-md5, hmac-sha1, hmac-sha256, hmac-sha384 and hmac-sha512. SHA is 
generally considered stronger than MD5, but it is also slower.

The Zyxel Device and the remote IPSec router must both have a proposal that uses the 
same authentication algorithm. 

Table 100   VPN > Site-to-Site VPN > Add/Edit (continued)> Scenario > Type > Custom
LABEL DESCRIPTION
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12.4  The Remote Access VPN Screen 
Configure the settings in this screen to create a new or edit an existing remote access VPN rule to 
securely access the Zyxel Device local networks from anywhere. See Section 12.1 on page 176 for more 
information on phase 1 and phase 2 settings; see Section 12.2 on page 177 for more information on IKE 
SA proposals.

SecuExtender is a Zyxel subscription-based VPN client. A remote access VPN client must have 
SecuExtender VPN client installed on his device and uses a supported computer operating system.

Make sure the settings configured on the IPSec VPN client matches the settings you configured on the 
Zyxel Device.

Click VPN > IPSec VPN > Remote Access VPN to open the following screen.

Diffie-Hellman 
Groups

Select which Diffie-Hellman key group (DHx) you want to use to create encryption keys. 
Choices are DH2, DH5, DH14, DH15, DH16, DH19, DH20, DH21, DH28, DH29, and DH30.

The longer the key, the more secure the encryption, but also the longer it takes to encrypt 
and decrypt information. The Zyxel Device and the remote IPSec router must use the 
same DH key group. See Section 12.2 on page 177 for more information on DH key group.

Different operating systems may support different DH key groups. Check your operating 
system documentation.

• For Windows VPN clients, Zyxel SecuExtender perpetual VPN clients versions 
3.8.203.61.32 and earlier support DH1 to DH14.

• For macOS VPN clients, Zyxel SecuExtender subscription VPN clients versions 1.2.0.7 
and later support DH14 to DH21. For Windows VPN clients, Zyxel SecuExtender 
subscription VPN clients versions 5.6.80.007 and later support DH14 to DH21.

• Windows versions 7, 10, 11 built-in IKEv2 VPN clients support DH2 by default.
• macOS versions 14.2 and later built-in IKEv2 VPN clients support DH14 by default.
• iOS versions 10.15 and later built-in IKEv2 VPN clients support DH14 by default.

Apply Click Apply to save your settings to the Zyxel Device.

Cancel Click Cancel to return to the profile summary page without saving any changes.

Table 100   VPN > Site-to-Site VPN > Add/Edit (continued)> Scenario > Type > Custom
LABEL DESCRIPTION
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Figure 140   VPN > IPSec VPN > Remote Access VPN
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The following table describes the labels in this screen.

Table 101   VPN > IPSec VPN > Remote Access VPN 
LABEL DESCRIPTION
Enable Click the switch to enable the remote access VPN rule.

Get 
SecuExtender 
VPN Client 
Software

Click to download SecuExtender to your computer. The supported operating systems for 
SecuExtender are:

• Windows 10 (64-bit) and later versions.
• macOS 10.15 and later versions.

VPN 
configuration 
script download

Click to download a VPN configuration script to send to clients using IPSec VPN clients built 
into the operating systems.

To use the download script, the built-in IPSec VPN clients need to use the following 
operating systems:

• Clients using Windows 7 and later, iOS and macOS built-in IPSec VPN clients can import 
the VPN configuration script to configure a remote access VPN rule automatically. Click 
the link to download the script and send it to them.

• Clients using Android should download the latest version strongSwan VPN client, then 
import the script to configure a remote access VPN rule automatically. Click the link to 
download the script and send it to them.

• Clients using built-in IPSec VPN clients earlier than Windows 7 cannot use the script. They 
must configure a remote access VPN rule manually. Send the Pre-Shared Key and the 
Zyxel Device interface IP or domain name to them.

Incoming Interface

Interface Select an interface from the drop-down list box for incoming traffic to your Zyxel Device.

Domain Name/IP Enter the domain name if you are using DDNS to assign the interface a dynamic IP address 
(for example, vpn.zyxel.com). 

Enter the IPv4 address if you are using a static IP address.

Certificate for VPN 
Validation

Auto Select Auto to have the Zyxel Device generate a certificate from the current remote 
access VPN settings. This is the certificate the Zyxel Device uses to identify itself when setting 
up the VPN tunnel.

Manual Select Manual to use an existing certificate from the drop-down list box.

Local Network

Full Tunnel Select Full Tunnel to encrypt all traffic through the VPN.

Select Allow Client VPN Traffic Through WAN to allow only traffic encrypted by the Zyxel 
Device from the remote client to the Internet.

Split Tunnel Select Split Tunnel to only encrypt traffic going to networks behind the Zyxel Device. 

Enter an IPv4 address in CIDR notation, for example, type 192.168.1.1/24. Traffic going to the 
Internet from this IP address is encrypted. Traffic going to the Internet from the remote client 
does not go through the Zyxel Device is not encrypted.

Client Network

IP Address Pool Enter an IPv4 address in CIDR notation, for example, type 192.168.1.1/24. The IP address 
pool is used to assign IP addresses to the VPN clients.

The SSL VPN IP pool should not overlap with IP addresses on the Zyxel Device's local 
networks and the SSL user's network.
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First DNS Server Specify the IP address of the DNS server whose information the Zyxel Device sends to the 
remote users. This allows them to access devices on the local network using domain names 
instead of IP addresses.

ZyWALL- the VPN clients use the IP address of the interface you specified in the SSL VPN rule 
and the Zyxel Device works as a DNS relay.

Custom Defined- enter a static IPv4 address

Second DNS 
Server

Enter a secondary DNS server IP address that is checked if the first one is unavailable.

Authentication

Primary/
Secondary Server

Select a specified RADIUS server from the drop-down list box for the Zyxel Device to use for 
authentication.

User Select a user or user group to associate the user or user group to this remote access IPSec 
VPN policy.

Advanced Settings

SA Life Time Set how often the Zyxel Device renegotiates the IKE SA. A short SA life time increases 
security, but renegotiation temporarily disconnects the VPN tunnel.

The value you set for the SA life time in Phase 2 Settings should be lesser than or equal to the 
value you set for the SA life time in Phase 1 Settings.

Add Click this to add an entry.

Edit Select an entry and click this to edit the entry.

Remove Select an entry and click this to remove the entry.

Encryption Select which key size and encryption algorithm to use in the IPSec SA. Choices are:

des-cbc - a 56-bit key with the DES encryption algorithm

3des-cbc - a 168-bit key with the DES encryption algorithm

aes128-cbc - a 128-bit key with the AES encryption algorithm

aes192-cbc - a 192-bit key with the AES encryption algorithm

aes256-cbc - a 256-bit key with the AES encryption algorithm

The Zyxel Device and the remote IPSec router must both have at least one proposal that 
uses use the same encryption and the same key. 

Longer keys are more secure, but require more processing power, resulting in increased 
latency and decreased throughput.

Authentication Select which hash algorithm to use to authenticate packet data in the IPSec SA. Choices 
are hmac-md5, hmac-sha1, hmac-sha256, hmac-sha384 and hmac-sha512. SHA is 
generally considered stronger than MD5, but it is also slower.

The Zyxel Device and the remote IPSec router must both have a proposal that uses the 
same authentication algorithm. 

Table 101   VPN > IPSec VPN > Remote Access VPN (continued)
LABEL DESCRIPTION
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Diffie-Hellman 
Groups

Select which Diffie-Hellman key group (DHx) you want to use to create encryption keys. 
Choices are DH2, DH5, DH14, DH15, DH16, DH19, DH20, DH21, DH28, DH29, and DH30.

The longer the key, the more secure the encryption, but also the longer it takes to encrypt 
and decrypt information. The Zyxel Device and the remote IPSec router must use the same 
DH key group. See Section 12.2 on page 177 for more information on DH key group.

Different operating systems may support different DH key groups. Check your operating 
system documentation.

• For Windows VPN clients, Zyxel SecuExtender perpetual VPN clients versions 
3.8.203.61.32 and earlier support DH1 to DH14.

• For macOS VPN clients, Zyxel SecuExtender subscription VPN clients versions 1.2.0.7 and 
later support DH14 to DH21. For Windows VPN clients, Zyxel SecuExtender subscription 
VPN clients versions 5.6.80.007 and later support DH14 to DH21.

• Windows versions 7, 10, 11 built-in IKEv2 VPN clients support DH2 by default.
• macOS versions 14.2 and later built-in IKEv2 VPN clients support DH14 by default.
• iOS versions 10.15 and later built-in IKEv2 VPN clients support DH14 by default.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 101   VPN > IPSec VPN > Remote Access VPN (continued)
LABEL DESCRIPTION
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CHAPTER 13
SSL VPN 

13.1  Overview
Use SSL VPN to allow users to use a web browser for secure remote user login. The remote users do not 
need a VPN router or VPN client software. 

13.1.1  What You Can Do in this Chapter
Use the VPN > SSL VPN screens (see Section 13.2 on page 202) to configure a SSL access policy. 

13.1.2  What You Need to Know

Full Tunnel Mode 

In full tunnel mode, a virtual connection is created for remote users with private IP addresses in the same 
subnet as the local network. This allows them to access network resources in the same way as if they 
were part of the internal network. 

Figure 141   Network Access Mode: Full Tunnel Mode

Split Tunnel Mode

In split tunnel mode, only the traffic going to the networks behind the Zyxel Device is encrypted. Traffic 
going to the Internet from the remote client does not go through the Zyxel Device and is not encrypted.
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Figure 142   Network Access Mode: Split Tunnel Mode

SSL VPN Policy

An SSL VPN policy allows the Zyxel Device to perform the following tasks: 

• limit user access to specific applications or file sharing server on the network.

• allow user access to specific networks. 

• assign private IP addresses and provide DNS/WINS server information to remote users to access 
internal networks.

SSL Access Policy Objects

The SSL access policies reference the following objects. If you update this information, in response to 
changes, the Zyxel Device automatically propagates the changes through the SSL policies that use the 
object(s). When you delete an SSL policy, the objects are not removed.

Please note that you cannot delete an object that is referenced by other settings.

13.2  The SSL VPN Screen 
Configure the settings in this screen to create a new or edit an existing SSL access policy. 

Table 102   Objects  

OBJECT TYPE OBJECT 
SCREEN DESCRIPTION

User Accounts User Account/ 
User Group

Configure a user account or user group to which you want to apply this SSL 
access policy. 

Application SSL 
Application

Configure an SSL application object to specify the type of application and the 
address of the local computer, server, or web site SSL users are to be able to 
access.

IP Pool Address Configure an address object that defines a range of private IP addresses to 
assign to user computers so they can access the internal network through a 
VPN connection. 

Server 
Addresses

Address Configure address objects for the IP addresses of the DNS and WINS servers that 
the Zyxel Device sends to the VPN connection users.

VPN Network Address Configure an address object to specify which network segment users are 
allowed to access through a VPN connection. 
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SecuExtender is a Zyxel subscription-based VPN client. A remote access VPN client must have 
SecuExtender VPN client installed on his device and uses a supported computer operating system. The 
supported computer operating systems are:

• Window 10 (64-bit) and later versions.

• macOS 10.15 and later versions.

Make sure the settings configured on the SSL VPN client matches the settings you configured on the 
Zyxel Device.

Click VPN > SSL VPN to open the following screen.
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Figure 143   VPN > SSL VPN    
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The following table describes the labels in this screen. 

Table 103   VPN > SSL VPN 
LABEL DESCRIPTION
Enable Click the switch to enable the SSL access policy.

Download Click to download a VPN configuration script to send to clients using SecuExtender VPN 
client or OpenVPN Connect VPN client.

The supported operating systems for SecuExtender are:

• Windows 10 (64-bit) and later versions.
• macOS 10.15 and later versions.

Incoming Interface

Interface Select an interface from the drop-down list box for incoming traffic to your Zyxel Device.

DNS Name Enter the domain name (for example, vpn.zyxel.com) if you’re using DDNS to assign the 
interface a dynamic IP address.

Server Port Specify the server port of the Zyxel Device for full tunnel mode SSL VPN access. Leave this 
field to default settings unless it conflicts with another interface.

Local Network

Full Tunnel Select Full Tunnel to encrypt all traffic through the VPN.

Select Allow Client VPN Traffic Through WAN to allow only traffic encrypted by the Zyxel 
Device from the remote client to the Internet.

Split Tunnel Select Split Tunnel to only encrypt traffic going to networks behind the Zyxel Device. 

Enter an IPv4 address in CIDR notation, for example, type 192.168.1.1/24. Traffic going to the 
Internet from this IP address is encrypted. Traffic going to the Internet from the remote client 
does not go through the Zyxel Device is not encrypted.

Client Network

IP Address Pool Enter an IPv4 address in CIDR notation, for example, type 192.168.1.1/24. The IP address 
pool is used to assign IP addresses to the VPN clients.

The SSL VPN IP pool should not overlap with IP addresses on the Zyxel Device's local 
networks and the SSL user's network.

First DNS Server Specify the IP address of the DNS server whose information the Zyxel Device sends to the 
remote users. This allows them to access devices on the local network using domain names 
instead of IP addresses.

ZyWALL- the VPN clients use the IP address of the interface you specified in the SSL VPN rule 
and the Zyxel Device works as a DNS relay.

Custom Defined- enter a static IPv4 address

Second DNS 
Server

Enter a secondary DNS server IP address that is checked if the first one is unavailable.

Authentication

Primary/
Secondary Server

Select a specified RADIUS server from the drop-down list box for the Zyxel Device to use for 
authentication.

User Select a user or user group to associate the user or user group to this SSL access policy.

Advanced Settings
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Generate 
Certificate

Click the button to have the Zyxel Device generate a certificate from the current SSL VPN 
settings. This is the certificate the Zyxel Device uses to identify itself when setting up the SSL 
VPN tunnel.

If you change the SSL VPN settings, the Generate Certificate button displays. Click 
Generate Certificate to generate a new certificate from the new SSL VPN settings. Please 
note that VPN clients cannot connect to the SSL VPN tunnel while the Zyxel Device is 
generating certificate.

If you change the SSL VPN settings and generate a new certificate from the new SSL VPN 
settings, all connected SSL VPN clients have to update their SSL VPN settings so their SSL VPN 
settings match the Zyxel Device SSL VPN settings.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to exit this screen without saving.

Table 103   VPN > SSL VPN (continued)
LABEL DESCRIPTION
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CHAPTER 14
Security Policy

14.1  Overview
A security policy is a template of security settings that can be applied to specific traffic at specific times. 
The policy can be applied:

• to a specific direction of travel of packets (from / to) 

• to a specific source and destination address objects

• to a specific type of traffic (services)

• to a specific user or group of users

• at a specific schedule

The policy can be configured:

• to allow or deny traffic that matches the criteria above 

• send a log or alert for traffic that matches the criteria above 

• to apply the actions configured in the profiles (application patrol, content filter, IDP, anti-malware, 
email security) to traffic that matches the criteria above 

The security policies can also limit the number of user sessions.

The following example shows the Zyxel Device’s default security policies behavior for a specific direction 
of travel of packets. WAN to LAN traffic and how stateful inspection works. A LAN user can initiate an SSH 
session from within the LAN zone and the Zyxel Device allows the response. However, the Zyxel Device 
blocks incoming SSH traffic initiated from the WAN zone and destined for the LAN zone. 

Figure 144   Default Directional Security Policy Example       

14.2  What You Can Do in this Chapter
• Use the Policy Control screens (Section 14.3 on page 209) to enable or disable policies, asymmetrical 

routes, and manage and configure policies. 



Chapter 14 Security Policy

USG FLEX H Series User’s Guide

208

• Use the DoS Prevention screens (Section 14.4 on page 216) to detect traffic with protocol anomalies 
and take appropriate action.

14.2.1  What You Need to Know

Stateful Inspection

The Zyxel Device uses stateful inspection in its security policies. The Zyxel Device restricts access by 
screening data packets against defined access rules. It also inspects sessions. For example, traffic from 
one zone is not allowed unless it is initiated by a computer in another zone first.

Zones

A zone is a group of interfaces. Group the Zyxel Device’s interfaces into different zones based on your 
needs. You can configure security policies for data passing between zones or even between interfaces. 

Default Directional Security Policy Behavior

Security Policies can be grouped based on the direction of travel of packets to which they apply. Here 
is the The Zyxel Device has default Security Policy behavior for traffic going through the Zyxel Device in 
various directions. 

To-Device Policies 

Policies with Device as the To Zone apply to traffic going to the Zyxel Device itself. By default: 

• The Security Policy allows only LAN, or WAN computers to access or manage the Zyxel Device.

• The Zyxel Device allows DHCP traffic from any interface to the Zyxel Device.

• The Zyxel Device drops most packets from the WAN zone to the Zyxel Device itself and generates a 
log except for AH, ESP, GRE, HTTPS, IKE, NATT. 

When you configure a Security Policy rule for packets destined for the Zyxel Device itself, make sure it 
does not conflict with your service control rule. The Zyxel Device checks the security policy before the 
service control rules for traffic destined for the Zyxel Device. 

Table 104   Directional Security Policy Behavior
FROM ZONE TO ZONE BEHAVIOR
From any to Device DHCP traffic from any interface to the Zyxel Device is allowed.

From LAN1 to any (other than 
the Zyxel Device)

Traffic from the LAN1 to any of the networks connected to the Zyxel Device is 
allowed. 

From LAN2 to any (other than 
the Zyxel Device)

Traffic from the LAN2 to any of the networks connected to the Zyxel Device is 
allowed. 

From LAN1 to Device Traffic from the LAN1 to the Zyxel Device itself is allowed.

From LAN2 to Device Traffic from the LAN2 to the Zyxel Device itself is allowed.

From WAN to Device The default services listed in To-Device Policies are allowed from the WAN to the 
Zyxel Device itself. All other WAN to Zyxel Device traffic is dropped.

From any to any Traffic that does not match any Security policy is dropped. This includes traffic 
from the WAN to any of the networks behind the Zyxel Device.

This also includes traffic to or from interfaces that are not assigned to a zone 
(extra-zone traffic).
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A From Any To Device direction policy applies to traffic from an interface which is not in a zone.

Global Security Policies

Security Policies with from any and/or to any as the packet direction are called global Security Policies. 
The global Security Policies are the only Security Policies that apply to an interface that is not included in 
a zone. The from any policies apply to traffic coming from the interface and the to any policies apply to 
traffic going to the interface.

Security Policy Rule Criteria

The Zyxel Device checks the schedule, user name (user’s login name on the Zyxel Device), source IP 
address and object, destination IP address and object, IP protocol type of network traffic (service) and 
Security Service profile criteria against the Security Policies (in the order you list them). When the traffic 
matches a policy, the Zyxel Device takes the action specified in the policy. 

User Specific Security Policies

You can specify users or user groups in Security Policies. For example, to allow a specific user from any 
computer to access a zone by logging in to the Zyxel Device, you can set up a policy based on the user 
name only. If you also apply a schedule to the Security Policy, the user can only access the network at 
the scheduled time. A user-aware Security Policy is activated whenever the user logs in to the Zyxel 
Device and will be disabled after the user logs out of the Zyxel Device.

14.3  The Security Policy Screen

Asymmetrical Routes

If an alternate gateway on the LAN has an IP address in the same subnet as the Zyxel Device’s LAN IP 
address, return traffic may not go through the Zyxel Device. This is called an asymmetrical or “triangle” 
route. This causes the Zyxel Device to reset the connection, as the connection has not been 
acknowledged.

You can have the Zyxel Device permit the use of asymmetrical route topology on the network (not reset 
the connection). However, allowing asymmetrical routes may let traffic from the WAN go directly to the 
LAN without passing through the Zyxel Device. A better solution is to use virtual interfaces to put the Zyxel 
Device and the backup gateway on separate subnets. Virtual interfaces allow you to partition your 
network into logical sections over the same interface. See the chapter about interfaces for more 
information.

By putting LAN 1 and the alternate gateway (A in the figure) in different subnets, all returning network 
traffic must pass through the Zyxel Device to the LAN. The following steps and figure describe such a 
scenario.

1 A computer on the LAN1 initiates a connection by sending a SYN packet to a receiving server on the 
WAN.

2 The Zyxel Device reroutes the packet to gateway A, which is in Subnet 2. 
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3 The reply from the WAN goes to the Zyxel Device. 

4 The Zyxel Device then sends it to the computer on the LAN1 in Subnet 1. 

Figure 145   Using Virtual Interfaces to Avoid Asymmetrical Routes    

14.3.1  Configuring the Security Policy Control Screen
Click Security Policy > Policy Control to open the Policy Control screen. Use this screen to enable or 
disable the security policies and asymmetrical routes, set a maximum number of sessions per host, and 
display the configured Security Policies. Specify from which zone packets come and to which zone 
packets travel to display only the policies specific to the selected direction. Note the following.

• Besides configuring the security policies, you also need to configure NAT rules to allow computers on 
the WAN to access LAN devices. 

• The Zyxel Device applies NAT (Destination NAT) settings before applying the security policies. So for 
example, if you configure a NAT entry that sends WAN traffic to a LAN IP address, when you configure 
a corresponding security policy to allow the traffic, you need to set the LAN IP address as the 
destination. 

• The ordering of your policies is very important as policies are applied in sequence.

The following screen shows the Policy Control summary screen.

Figure 146   Security Policy > Policy Control      
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The following table describes the labels in this screen. 

Table 105   Security Policy > Policy Control 
LABEL DESCRIPTION
General Settings Enable or disable the policy control feature on the Zyxel Device.

Allow 
Asymmetrical 
Route

If an alternate gateway on the LAN has an IP address in the same subnet as the Zyxel Device’s 
LAN IP address, return traffic may not go through the Zyxel Device. This is called an 
asymmetrical or “triangle” route. This causes the Zyxel Device to reset the connection, as the 
connection has not been acknowledged.

Select this check box to have the Zyxel Device permit the use of asymmetrical route topology 
on the network (not reset the connection). 

Note: Allowing asymmetrical routes may let traffic from the WAN go directly to the 
LAN without passing through the Zyxel Device. A better solution is to use virtual 
interfaces to put the Zyxel Device and the backup gateway on separate 
subnets. 

Add Click this to create a new entry. Select an entry and click Add to create a new entry after the 
selected entry.

Edit Double-click an entry or select it and click Edit to open a screen where you can modify the 
entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms if you want to 
remove it before doing so.

Active To turn on an entry, select it and click Activate.

Inactive To turn off an entry, select it and click Inactivate.

Move to To change a policy’s position in the numbered list, select the policy and click Move to display a 
field to type a number for where you want to put that policy and press [ENTER] to move the 
policy to the number that you typed.

The ordering of your policies is important as they are applied in order of their numbering.

Copy to You can create a new policy by copying an existing one to a new position, and then editing it. 
Select an existing policy and click Copy to display a field to type a number for where you want 
to put that policy, then press [ENTER] to copy the policy to the number that you typed.

After copying it, edit it to change it from the one copied.

Search Type an item in the search box, then click this to display all sessions in the table below 
according to the item you typed.

Clear All Click this to remove all items found in the search.

Filter

Click the Filter icon , click + to expand Policy Match, pick a filter, then click Find to display 
specific sessions according to the filter selected. You may select multiple filters, but just one of 
each type, configured one at a time. 

The following read-only fields summarize the policies you have created that apply to traffic traveling in the 
selected packet direction. 

Status This icon is lit when the entry is active and dimmed when the entry is inactive.

Priority This is the position of your Security Policy in the global policy list (including all through-Zyxel 
Device and to-Zyxel Device policies). The ordering of your policies is important as policies are 
applied in sequence. Default displays for the default Security Policy behavior that the Zyxel 
Device performs on traffic that does not match any other Security Policy. 
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14.3.2  The Policy Control Add/Edit Screen
In the Policy Control screen, click the Edit or Add icon to display the Policy Control Edit or Add screen. 

Name This is the name of the Security policy. 

From / To This is the direction of travel of packets. Select from which zone the packets come and to 
which zone they go.

Security policies are grouped based on the direction of travel of packets to which they apply. 
For example, from LAN to LAN means packets traveling from a computer or subnet on the LAN 
to either another computer or subnet on the LAN. 

From any displays all the security policies for traffic going to the selected To Zone.

To any displays all the security policies for traffic coming from the selected From Zone.

From any to any displays all of the security policies.

To ZyWALL policies are for traffic that is destined for the Zyxel Device and control which 
computers can manage the Zyxel Device.

Source This displays the IPv4 source address object, including geographic address and FQDN (group) 
objects, to which this Security Policy applies.

Destination This displays the IPv4 destination address object, including geographic address and FQDN 
(group) objects, to which this Security Policy applies.

Service This displays the service object to which this security policy applies.

User This is the user name or user group name to which this security policy applies.

Schedule This field tells you the schedule object that the policy uses. none means the policy is active at all 
times if enabled.

Action This field displays whether the security policy silently discards packets without notification 
(deny), permits the passage of packets (allow) or drops packets with notification (reject)

Log Select whether to have the Zyxel Device generate a log (log), log and alert (log alert) or not 
(no) when the policy is matched to the criteria listed above.

Profile This field shows you which security service profiles (application patrol, content filter and SSL 
inspection) apply to the policy control rule. Click the icon to edit the profile directly.

Table 105   Security Policy > Policy Control (continued)
LABEL DESCRIPTION



 Chapter 14 Security Policy

USG FLEX H Series User’s Guide

213

Figure 147   Security Policy > Policy Control > Add    

The following table describes the labels in this screen.

Table 106   Security Policy > Policy Control > Add 
LABEL DESCRIPTION
Enable Select this check box to activate the policy control. 

Name Type a name with 1 to 30 single-byte characters to identify the policy, including a-zA-Z0-9. 
Special characters and spaces are not allowed.

Description Enter a descriptive name of 1 to 30 single-byte characters for the policy, including spaces and 0-
9a-zA-Z!”#$%()*+,-/:;=?@_

&.<>[\]^‘{|} are not allowed.

From

To

For through-Zyxel Device policies, select the direction of travel of packets to which the policy 
applies.

any means all interfaces.

ZyWALL means packets destined for the Zyxel Device itself.

Source Select an IPv4 address or address group object, including geographic address and FQDN 
(group) objects, to apply the policy to traffic coming from it. Select any to apply the policy to all 
traffic coming from IPv4 addresses. 

Destination Select an IPv4 address or address group, including geographic address and FQDN (group) 
objects, to apply the policy to traffic going to it. Select any to apply the policy to all traffic going 
to IPv4 addresses. 

Service Select a service or service group from the drop-down list box. 



Chapter 14 Security Policy

USG FLEX H Series User’s Guide

214

14.3.3  Example: Allow a Server to Ping the Zyxel Device Without Creating 
Logs

A server on the LAN pings the Zyxel Device every 15 seconds to check if the Zyxel Device is connected 
to the Internet. The Zyxel Device creates a log every time the server pings it. You want to allow the server 
to ping the Zyxel Device without creating so many logs.

This example uses the parameters given below.

User This field is not available when you are configuring a to-Zyxel Device policy.

Select a user name or user group to which to apply the policy. The Security Policy is activated 
only when the specified user logs into the system and the policy will be disabled when the user 
logs out.

Otherwise, select any and there is no need for user logging.

Note: If you specified a source IP address (group) instead of any in the field below, the 
user’s IP address should be within the IP address range.

Schedule Select a schedule that defines when the policy applies. Otherwise, select none and the policy is 
always effective.

Action Use the drop-down list box to select what the Security Policy is to do with packets that match this 
policy.

Select deny to silently discard the packets without sending a TCP reset packet or an ICMP 
destination-unreachable message to the sender.

Select reject to discard the packets and send a TCP reset packet or an ICMP destination-
unreachable message to the sender.

Select allow to permit the passage of the packets. 

Log matched 
traffic

Select whether to have the Zyxel Device generate a log (log), log and alert (log alert) or not (no) 
when the policy is matched to the criteria listed above.

Profile Use this section to apply anti- x profiles (created in the Security Services screens) to traffic that 
matches the criteria above. You must have created a profile first; otherwise none displays. 

Use Log to generate a log (log), log and alert (log alert) or not (no) for all traffic that matches 
criteria in the profile.

Application 
Patrol

Select an Application Patrol profile from the list box; none displays if no profiles have been 
created in the Security Service > App Patrol screen.

Content 
Filter

Select a Content Filter profile from the list box; none displays if no profiles have been created in 
the Security Service > Content Filter screen.

SSL 
Inspection

Select an SSL Inspection profile from the list box; none displays if no profiles have been created in 
the Security Service > SSL Inspection screen.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 106   Security Policy > Policy Control > Add (continued)
LABEL DESCRIPTION

Table 107   Address Object Configuration Example
NAME ADDRESS TYPE IP ADDRESS
Server Host 2.2.2.2
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1 Go to Object > Address > Address and click Add.

2 Configure the settings using the parameters given in Table 107 on page 214. Click Apply to save your 
changes.

3 Go to Security Policy > Policy Control and click Add.

4 Configure the settings using the parameters given in Table 108 on page 215. Set Log to no so when the 
server pings the Zyxel Device, the Zyxel Device will not create logs. Click Apply to save your changes.

Table 108   Security Policy Configuration Example
NAME FROM TO SOURCE DESTINATION SERVICE ACTION LOG
LAN_to_Device LAN ZyWALL Server Any Ping Allow No
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14.4  DoS Prevention Overview
DoS attacks can flood your Internet connection with invalid packets and connection request, using so 
much bandwidth and so many resources that Internet access becomes unavailable. The goal of DoS 
attacks is not to steal information, but to disable a device or network on the Internet.

DoS prevention protects against anomalies based on violations of protocol standards (RFCs – Requests 
for Comments) and abnormal flows such as port scans. This section introduces DoS prevention profiles 
and applying a DoS prevention profile to a traffic direction.

Traffic Anomalies

Traffic anomaly policies look for abnormal behavior or events such as port scanning, sweeping or 
network flooding. They operate at OSI layer-3 and layer-4. Traffic anomaly policies may be updated 
when you upload new firmware.

Note: First, create a DoS prevention profile in the In the Security Policy > DoS Prevention > 
Profile screen. Then, apply the profile to traffic originating from a specific zone in the 
Security Policy > DoS Prevention >DoS Prevention Policy screen.
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14.4.1  The DoS Prevention Policy Screen
Click Security Policy > DoS Prevention > DoS Prevention Policy to display the next screen.

Figure 148   Security Policy > DoS Prevention > DoS Prevention Policy

The following table describes the labels in this screen.

Table 109   Security Policy > DoS Prevention > DoS Prevention Policy
LABEL DESCRIPTION
General Settings

Enable Anomaly Detection 
and Prevention

Select this to enable traffic anomaly and protocol anomaly detection and 
prevention.

Add Select an entry and click Add to append a new row beneath the one selected. ADP 
policies are applied in order (Priority) shown in this screen

Edit Select an entry and click this to be able to modify it. 

Remove Select an entry and click this to delete it. 

Active To turn on an entry, select it and click Activate.

Inactive To turn off an entry, select it and click Inactivate.

Move To change an entry’s position in the numbered list, select it and click Move to display 
a field to type a number for where you want to put that entry and press [ENTER] to 
move the entry to the number that you typed. 

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the 
entry is inactive.

Priority This is the rank in the list of anomaly profile policies. The list is applied in order of 
priority.

Name This is the name of the anomaly profile policy.
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14.4.2  The DoS Prevention Profile Screen
Create new DoS prevention profiles in the Security Policy > DoS Prevention > Profile screens.

When creating DoS prevention profiles. you may find that certain policies are triggering too many false 
positives or false negatives. A false positive is when valid traffic is flagged as an attack. A false negative 
is when invalid traffic is wrongly allowed to pass through the Zyxel Device. As each network is different, 
false positives and false negatives are common on initial DoS prevention deployment.

To counter this, you could create a ‘monitor profile’ that creates logs, but all actions are disabled. 
Observe the logs over time and try to eliminate the causes of the false alarms. When you’re satisfied that 
they have been reduced to an acceptable level, you could then create an ‘in-line profile’ whereby you 
configure appropriate actions to be taken when a packet matches a policy.

DoS prevention profiles consist of traffic anomaly profiles. To create a new profile, click Add. Type a new 
profile name, enable or disable individual policies and then edit the default log options and actions.

Click Security Policy > DoS Prevention > Profile to view the following screen.

From This is the direction of travel of packets to which an anomaly profile is bound. Traffic 
direction is defined by the zone the traffic is coming from.

Use the From field to specify the zone from which the traffic is coming. Select ZyWALL 
to specify traffic coming from the Zyxel Device itself. 

From LAN means packets traveling from a computer on one LAN subnet to a 
computer on another subnet via the Zyxel Device’s LAN1 zone interfaces. The Zyxel 
Device does not check packets traveling from a LAN computer to another LAN 
computer on the same subnet.

From WAN means packets that come in from the WAN zone and the Zyxel Device 
routes back out through the WAN zone.

Note: Depending on your network topology and traffic load, applying 
every packet direction to an anomaly profile may affect the Zyxel 
Device’s performance.

Anomaly Profile An anomaly profile is a set of anomaly policies with configured activation, log and 
action settings. This field shows which anomaly profile is bound to which traffic 
direction. Select an ADP profile to apply to the entry’s traffic direction. Configure the 
ADP profiles in the ADP profile screens. 

Table 109   Security Policy > DoS Prevention > DoS Prevention Policy
LABEL DESCRIPTION
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Figure 149   Security Policy > ADP > Profile

The following table describes the labels in this screen.

14.4.3  The Dos Prevention Profile Add/Edit Screen
DoS prevention looks for abnormal behavior such as scan or flooding attempts. In the Security Policy > 
DoS Prevention > Profile screen, click the Edit or Add icon to create or edit an existing profile.

Table 110   Security Policy > DoS Prevention > Profile 
LABEL DESCRIPTION
Profile Management Create ADP profiles here and then apply them in the Security Policy > DoS 

Prevention > DoS Prevention Policy screen.

Add Click Add to create a new profile.

Edit Select an entry and click this to be able to modify it. 

Remove Select an entry and click this to delete it. 

Reference Select an entry and click Reference to check which settings use the entry.

Name This is the name of the profile you created. 

Description This is the description of the profile you created. 
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Figure 150   Security Policy > DoS Prevention > Profile > Add/Edit



 Chapter 14 Security Policy

USG FLEX H Series User’s Guide

221

The following table describes the labels in this screen.

Table 111   Security Policy > DoS Prevention > Profile > Add/Edit 
LABEL DESCRIPTION
Name A name is automatically generated that you can edit. The name must be the same 

in the DoS Prevention screens for the same DoS prevention profile. You may use 1-31 
alphanumeric characters, underscores(_), or dashes (-), but the first character 
cannot be a number. This value is case-sensitive. These are valid, unique profile 
names: 

• MyProfile
• mYProfile
• Mymy12_3-4

These are invalid profile names:

• 1mYProfile
• My Profile
• MyProfile?
• Whatalongprofilename123456789012

Description In addition to the name, type additional information to help you identify this DoS 
prevention profile.

Scan/Flood Detection Scan detection, such as port scanning, tries to find attacks where an attacker scans 
device(s) to determine what types of network protocols or services a device 
supports.

Flood detection tries to find attacks that saturate a network with useless data, use up 
all available bandwidth, and so aim to make communications on the network 
impossible.

Sensitivity (Scan 
detection only)

Select a sensitivity level so as to reduce false positives in your network. If you choose 
low sensitivity, then scan thresholds and sample times are set low, so you will have 
fewer logs and false positives; however some traffic anomaly attacks may not be 
detected.

If you choose high sensitivity, then scan thresholds and sample times are set high, so 
most traffic anomaly attacks will be detected; however you will have more logs and 
false positives. 

Block Period Specify for how many seconds the Zyxel Device blocks all packets from being sent 
to the victim (destination) of a detected anomaly attack. Flood Detection applies 
blocking to the destination IP address and Scan Detection applies blocking to the 
source IP address.

Edit (Flood Detection 
only)

Select an entry and click this to be able to modify it. 

Active To turn on an entry, select it and click Activate.

Inactive To turn off an entry, select it and click Inactivate.

Log To edit an item’s log option, select it and use the Log icon. Select whether to have 
the Zyxel Device generate a log (log), log and alert (log alert) or neither (no) when 
traffic matches this anomaly policy. 

Action To edit what action the Zyxel Device takes when a packet matches a policy, select 
the policy and use the Action icon.

None: The Zyxel Device takes no action when a packet matches the policy.

Block: The Zyxel Device silently drops packets that matches the policy. Neither 
sender nor receiver are notified.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the 
entry is inactive.

Name This is the name of the anomaly policy. Click the Name column heading to sort in 
ascending or descending order according to the protocol anomaly policy name.
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14.5  The Session Control Screen
Click Security Policy > Session Control to display the Security Policy Session Control screen. Use this 
screen to limit the number of concurrent NAT/Security Policy sessions a client can use. You can apply a 
default limit for all users and individual limits for specific users, addresses, or both. The individual limit 
takes priority if you apply both.

Figure 151   Security Policy > Session Control

The following table describes the labels in this screen.  

Log These are the log options. To edit this, select an item and use the Log icon.

Action This is the action the Zyxel Device should take when a packet matches a policy. To 
edit this, select an item and use the Action icon. 

Threshold (pkt/sec) (Flood detection only.) Select a suitable threshold level (the number of packets per 
second that match the flood detection criteria) for your network. If you choose a 
low threshold, most traffic anomaly attacks will be detected, but you may have 
more logs and false positives.

If you choose a high threshold, some traffic anomaly attacks may not be detected, 
but you will have fewer logs and false positives. 

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 111   Security Policy > DoS Prevention > Profile > Add/Edit (continued)
LABEL DESCRIPTION

Table 112   Security Policy > Session Control 
LABEL DESCRIPTION
General Settings

Session Control Click to slide the switch to the right to enable session control.

Default 
Session per 
Host

Use this field to set a common limit to the number of concurrent NAT/Security Policy sessions 
each client computer can have. ‘0’ means unlimited.

If only a few clients use peer to peer applications, you can raise this number to improve their 
performance. With heavy peer to peer application use, lower this number to ensure no single 
client uses too many of the available NAT sessions.

Create rules below to apply other limits for specific users or addresses.

Add Click this to create a new entry. Select an entry and click Add to create a new entry after the 
selected entry.
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14.5.1  The Session Control Add/Edit Screen
Click Security Policy > Session Control and the Add or Edit icon to display the Add or Edit screen. Use this 
screen to configure rules that define a session limit for specific users or addresses.

Figure 152   Security Policy > Session Control > Edit

Edit Double-click an entry or select it and click Edit to open a screen where you can modify the 
entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove 
it before doing so.

Activate To turn on an entry, select it and click Activate.

Inactivate To turn off an entry, select it and click Inactivate.

Move to To change a rule’s position in the numbered list, select the rule and click Move to to display a 
field to type a number for where you want to put that rule and press [ENTER] to move the rule 
to the number that you typed.

The ordering of your rules is important as they are applied in order of their priority number.

Status This icon is lit when the entry is active and dimmed when the entry is inactive.

Priority This is the priority of a session limit rule. Rules are applied according to priority number. 

User This is the user name or user group name to which this session limit rule applies.

Source IP This is the IP address of the host to which this session limit rule applies. 

Description This is the information configured to help you identify the rule. 

Limit This is how many concurrent sessions this user or address is allowed to have.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 112   Security Policy > Session Control (continued)
LABEL DESCRIPTION
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The following table describes the labels in this screen.  

Table 113   Security Policy > Session Control > Add/Edit 
LABEL DESCRIPTION
Enable Click to slide the switch to the right to turn on this session limit rule. 

Description Enter information to help you identify this rule. Use up to 60 printable ASCII characters. Spaces 
are allowed. 

User Select a user name or user group to which to apply the rule. The rule is activated only when the 
specified user logs into the system and the rule will be disabled when the user logs out.

Otherwise, select any and there is no need for user logging.

Note: If you specified an IP address (or address group) instead of any in the field 
below, the user’s IP address should be within the IP address range.

Address Select the IPv4/IPv6 source address (range) or address group, including geographic address 
(group) object, to which this rule applies. Select any to apply the rule to all IPv4 source 
addresses.

Session Limit per 
Host

Use this field to set a limit to the number of concurrent NAT/Security Policy sessions this rule’s 
users or addresses can have.

For this rule’s users and addresses, this setting overrides the Default Session per Host setting in 
the general Security Policy Session Control screen.
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14.6  Security Policy Example Applications
Suppose you decide to block LAN users from using IRC (Internet Relay Chat) through the Internet. To do 
this, you would configure a LAN to WAN Security Policy that blocks IRC traffic from any source IP address 
from going to any destination address. You do not need to specify a schedule since you need the 
Security Policy to always be in effect. The following figure shows the results of this policy.

Figure 153   Blocking All LAN to WAN IRC Traffic Example 

Your Security Policy would have the following settings. 

• The first row blocks LAN access to the IRC service on the WAN. 

• The second row is the Security Policy’s default policy that allows all LAN1 to WAN traffic.

The Zyxel Device applies the security policies in order. So for this example, when the Zyxel Device 
receives traffic from the LAN, it checks it against the first policy. If the traffic matches (if it is IRC traffic) 
the security policy takes the action in the policy (drop) and stops checking the subsequent security 
policies. Any traffic that does not match the first security policy will match the second security policy 
and the Zyxel Device forwards it. 

Now suppose you need to let the CEO use IRC. You configure a LAN1 to WAN security policy that allows 
IRC traffic from the IP address of the CEO’s computer. You can also configure a LAN to WAN policy that 
allows IRC traffic from any computer through which the CEO logs into the Zyxel Device with his/her user 
name. In order to make sure that the CEO’s computer always uses the same IP address, make sure it 
either:

Apply Click Apply to save your customized settings and exit this screen.

Cancel Click Cancel to exit this screen without saving.

Table 113   Security Policy > Session Control > Add/Edit (continued)
LABEL DESCRIPTION

Table 114   Blocking All LAN to WAN IRC Traffic Example  
# USER SOURCE DESTINATION SCHEDULE SERVICE ACTION
1 Any Any Any Any IRC Deny

2 Any Any Any Any Any Allow



Chapter 14 Security Policy

USG FLEX H Series User’s Guide

226

• Has a static IP address, 

or 

• You configure a static DHCP entry for it so the Zyxel Device always assigns it the same IP address.

Now you configure a LAN1 to WAN security policy that allows IRC traffic from the IP address of the CEO’s 
computer (172.16.1.7 for example) to go to any destination address. You do not need to specify a 
schedule since you want the security policy to always be in effect. The following figure shows the results 
of your two custom policies.

Figure 154   Limited LAN to WAN IRC Traffic Example   

Your security policy would have the following configuration. 

• The first row allows the LAN1 computer at IP address 172.16.1.7 to access the IRC service on the WAN. 

• The second row blocks LAN1 access to the IRC service on the WAN. 

• The third row is the default policy of allowing all traffic from the LAN1 to go to the WAN.

Alternatively, you configure a LAN1 to WAN policy with the CEO’s user name (say CEO) to allow IRC 
traffic from any source IP address to go to any destination address.

Your Security Policy would have the following settings. 

• The first row allows any LAN1 computer to access the IRC service on the WAN by logging into the Zyxel 
Device with the CEO’s user name. 

• The second row blocks LAN1 access to the IRC service on the WAN. 

Table 115   Limited LAN1 to WAN IRC Traffic Example 1 
# USER SOURCE DESTINATION SCHEDULE SERVICE ACTION
1 Any 172.16.1.7 Any Any IRC Allow

2 Any Any Any Any IRC Deny

3 Any Any Any Any Any Allow

Table 116   Limited LAN1 to WAN IRC Traffic Example 2 
# USER SOURCE DESTINATION SCHEDULE SERVICE ACTION
1 CEO Any Any Any IRC Allow

2 Any Any Any Any IRC Deny

3 Any Any Any Any Any Allow
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• The third row is the default policy of allowing allows all traffic from the LAN1 to go to the WAN.

The policy for the CEO must come before the policy that blocks all LAN1 to WAN IRC traffic. If the policy 
that blocks all LAN1 to WAN IRC traffic came first, the CEO’s IRC traffic would match that policy and the 
Zyxel Device would drop it and not check any other security policies.
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CHAPTER 15
Object

15.1  Address/Geo IP Overview
Address objects can represent a single IP address or a range of IP addresses. Address groups are 
composed of address objects and other address groups. 

• The Address screen (Section 15.1.2 on page 228) provides a summary of all addresses in the Zyxel 
Device. Use the Address Add/Edit screen to create a new address or edit an existing one.

• Use the Address Group summary screen (Section 15.1.3 on page 231) and the Address Group Add/
Edit screen, to maintain address groups in the Zyxel Device.

• Use the Geo IP screen (Section 15.1.4 on page 232) to update the database of country-to-IP address 
mappings and to manually configure country-to-IP address mappings.

15.1.1  What You Need To Know
Address objects and address groups are used in policy routes, security policies, application patrol, 
content filtering, and VPN connection policies. For example, addresses are used to specify where 
content restrictions apply in content filtering. Please see the respective sections for more information 
about how address objects and address groups are used in each one.

Address groups are composed of address objects and address groups. The sequence of members in the 
address group is not important.

15.1.2  Address Summary Screen
The address screens are used to create, maintain, and remove addresses. There are the types of 
address objects:

• HOST - the object uses an IP Address to define a host address

• RANGE - the object uses a range address defined by a Starting IP Address and an Ending IP Address
• Subnet- the object uses a network address defined by a Network IP address and Netmask subnet 

mask.

• INTERFACE IP - the object uses the IP address of one of the Zyxel Device’s interfaces

• INTERFACE SUBNET - the object uses the subnet mask of one of the Zyxel Device’s interfaces

• INTERFACE GATEWAY - the object uses the gateway IP address of one of the Zyxel Device’s interfaces

• GEOGRAPHY - the object uses the IP addresses of a country to represent a country

The Address screen provides a summary of all addresses in the Zyxel Device. To access this screen, click 
Object > Address > Address. Click a column’s heading cell to sort the table entries by that column’s 
criteria. Click the heading cell again to reverse the sort order.
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Figure 155   Object > Address > Address   

The following table describes the labels in this screen. See Section 15.1.2.1 on page 229 for more 
information as well.  

15.1.2.1  IPv4 Address Add/Edit Screen
The Object > Address > Address > Add/Edit screen allows you to create a new address or edit an 
existing one. To access this screen, go to the Address screen (see Section 15.1.2 on page 228), and click 
either the Add icon or an Edit icon in the IPv4 Address Configuration section. 

Table 117   Object > Address > Address 
LABEL DESCRIPTION
IPv4 Address Configuration

Add Click this to create a new entry.

Edit Double-click an entry or select it and click Edit to be able to modify the entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove 
it before doing so.

Reference Select an entry and click Reference to check which settings use the entry.

Name This field displays the configured name of each address object.

Type This field displays the type of each address object. “INTERFACE” means the object uses the 
settings of one of the Zyxel Device’s interfaces.

Address This field displays the IPv4 addresses represented by each address object. If the object’s 
settings are based on one of the Zyxel Device’s interfaces, the name of the interface displays 
first followed by the object’s current address settings.

Reference This displays the number of times an object reference is used in a profile.
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Figure 156   Object > Address > Address > Add/Edit

The following table describes the labels in this screen.

Table 118   Object > Address > Address > Add/Edit
LABEL DESCRIPTION
Name Type the name used to refer to the address. You may use 2-30 single-byte characters, including 

0-9a-zA-Z, underscores(_), or dashes (-), but the first character cannot be a number. This value 
is case-sensitive.

Description Enter the description associated with the zone, if any. You can use 1 to 30 single-byte 
characters, including 0-9a-zA-Z. Special characters are not allowed 

Address Type Select the type of address you want to create.

Note: The Zyxel Device automatically updates address objects that are based on an 
interface’s IP address, subnet, or gateway if the interface’s IP address settings 
change. For example, if you change 1’s IP address, the Zyxel Device 
automatically updates the corresponding interface-based, LAN subnet 
address object.

IP Address This field is only available if the Address Type is HOST. This field cannot be blank. Enter the IP 
address that this address object represents.

Starting IP 
Address

This field is only available if the Address Type is RANGE. This field cannot be blank. Enter the 
beginning of the range of IP addresses that this address object represents.

Ending IP Address This field is only available if the Address Type is RANGE. This field cannot be blank. Enter the end 
of the range of IP address that this address object represents.

Network This field is only available if the Address Type is SUBNET, in which case this field cannot be blank. 
Enter the IP address of the network that this address object represents.

Netmask This field is only available if the Address Type is SUBNET, in which case this field cannot be blank. 
Enter the subnet mask of the network that this address object represents. Use dotted decimal 
format.

Interface If you selected INTERFACE IP, INTERFACE SUBNET, or INTERFACE GATEWAY as the Address Type, 
use this field to select the interface of the network that this address object represents.

Region If you selected GEOGRAPHY as the Address Type, use this field to select a country or continent.

A GEOGRAPHY object uses the data from the country-to-IP/continent-to-IP address database. 
Go to the Object > Address > Geo IP screen to configure the custom country-to-IP/continent-
to-IP address mappings for a GEOGRAPHY object.
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15.1.3  Address Group Summary Screen
The Address Group screen provides a summary of all address groups. To access this screen, click Object 
> Address > Address Group. Click a column’s heading cell to sort the table entries by that column’s 
criteria. Click the heading cell again to reverse the sort order.

Figure 157   Object > Address > Address Group

The following table describes the labels in this screen. See Section 15.1.3.1 on page 231 for more 
information as well.  

15.1.3.1  Address Group Add/Edit Screen
The Address Group Add/Edit screen allows you to create a new address group or edit an existing one. To 
access this screen, go to the Address Group screen (see Section 15.1.3 on page 231), and click either 
the Add icon or an Edit icon in the IPv4 Address Group Configuration section.

Apply Click Apply to save your customized settings and exit this screen.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 118   Object > Address > Address > Add/Edit
LABEL DESCRIPTION

Table 119   Object > Address/Geo IP > Address Group 
LABEL DESCRIPTION
IPv4 Address Group Configuration

Add Click this to create a new entry.

Edit Select an entry and click Edit to be able to modify the entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove 
it before doing so.

Reference Select an entry and click Reference to check which settings use the entry.

Name This field displays the name of each address group.

Description This field displays the description of each address group, if any.

Reference This displays the number of times an object reference is used in a profile.
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Figure 158   IPv4 Address Group > Add 

The following table describes the labels in this screen.  

15.1.4  Geo IP Summary Screen
Use this screen to update the database of country-to-IP and continent-to-IP address mappings and 
manually configure custom country-to-IP and continent-to-IP address mappings in geographic address 
objects. You can then use geographic address objects in security policies to forward or deny traffic to 
whole countries or regions.

Click a column’s heading cell to sort the table entries by that column’s criteria. Click the heading cell 
again to reverse the sort order.

Table 120   IPv4 Address Group > Add 
LABEL DESCRIPTION
Name Enter a name for the address group. You may use 2-30 single-byte characters, including 0-9a-

zA-Z, underscores(_), or dashes (-), but the first character cannot be a number. This value is 
case-sensitive.

Description  You can use 1 to 30 single-byte characters, including 0-9a-zA-Z!”#$%’()*+,-/:;=?@_

&.<>[\]{|}^‘are not allowed. 

Member List The list on the left displays the names of the address and address group objects that have 
been added to the address group. The order of members is not important. Select items fro this 
list that you want to be members and move them to the list on the right.

Move any members you do not want included to the list on the left.

Note: Only objects of the same address type can be added to a address group.
Apply Click Apply to save your customized settings and exit this screen.

Cancel Click Cancel to return the screen to its last-saved settings. 
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Figure 159   Object > Address > Geo IP
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Figure 160   Object > Address > Geo IP > Region vs. Continent
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The following table describes the labels in this screen.

15.1.4.1  Add Custom IPv4 Address to Geography Screen
This screen allows you to create a new geography-to-IP address mapping. To access this screen, go to 
the Geo IP screen (see Section 15.1.4 on page 232), and click the Add icon in the Custom IPv4 to 
Geography Rules section. 

Figure 161   Geo IP > Add

Table 121   Object > Address/Geo IP > Geo IP 
LABEL DESCRIPTION
Country Database Update

Latest Version This is the latest country-to-IP address database version.

Current Version This is the country-to-IP address database version currently on the Zyxel Device.

Update Now Click this to check for the latest country-to-IP address database version. The latest version is 
downloaded to the Zyxel Device and replaces the current version if it is newer. There are logs 
to show the update status.

Auto Update If you want the Zyxel Device to check weekly for the latest country-to-IP address database 
version, select the checkbox, choose a day and time each week and then click Apply. 

Custom IPv4 to 
Geography Rules

Enter an IP address, then click the IPv4 to Geography button to query which country this IP 
address belongs to.

Add Click this to create a new entry.

Edit Select an entry and click Edit to be able to modify the entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove 
it before doing so.

Name This filed displays the name of the entry.

Geolocation This field displays the name of the country or region that is associated with this IP address.

Type This field displays whether this address object is HOST, RANGE or SUBNET.

IPv4 Address This field displays the IPv4/IPv6 addresses represented by the type of address object. 

Region vs. Continent

Region vs. 
Continent

Enter a country or continent name in the Search field to query which continent this country 
belongs to or which countries belong to the continent.
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The following table describes the labels in this screen.

15.2  Service Overview
Use service objects to define TCP applications, UDP applications, and ICMP messages. You can also 
create service groups to refer to multiple service objects in other features. 

• Use the Service screens (Section 15.2.2 on page 238) to view and configure the Zyxel Device’s list of 
services and their definitions. 

• Use the Service Group screens (Section 15.2.2 on page 238) to view and configure the Zyxel Device’s 
list of service groups. 

15.2.1  What You Need to Know

IP Protocols

IP protocols are based on the eight-bit protocol field in the IP header. This field represents the next-level 
protocol that is sent in this packet. This section discusses three of the most common IP protocols.

Computers use Transmission Control Protocol (TCP, IP protocol 6) and User Datagram Protocol (UDP, IP 
protocol 17) to exchange data with each other. TCP guarantees reliable delivery but is slower and more 
complex. Some uses are FTP, HTTP, SMTP, and TELNET. UDP is simpler and faster but is less reliable. Some 
uses are DHCP, DNS, RIP, and SNMP.

TCP creates connections between computers to exchange data. Once the connection is established, 
the computers exchange data. If data arrives out of sequence or is missing, TCP puts it in sequence or 
waits for the data to be re-transmitted. Then, the connection is terminated.

In contrast, computers use UDP to send short messages to each other. There is no guarantee that the 
messages arrive in sequence or that the messages arrive at all.

Table 122   Geo IP > Add 
LABEL DESCRIPTION
Name Enter a name for the address group. You may use 2-30 single-byte characters, including 0-9a-

zA-Z, underscores(_), or dashes (-), but the first character cannot be a number. This value is 
case-sensitive.

Region Select the country or continent that maps to this IP address.

Address Type Select the type of address you want to create. Choices are: HOST, RANGE, CIDR.

IP Address This field is only available if the Address Type is HOST. This field cannot be blank. Enter the IP 
address that this address object represents.

IP Starting 
Address

This field is only available if the Address Type is RANGE. This field cannot be blank. Enter the 
beginning of the range of IP addresses that this address object represents.

IP Ending Address This field is only available if the Address Type is RANGE. This field cannot be blank. Enter the end 
of the range of IP address that this address object represents.

Network / 
Netmask

These fields are only available if the IPv4 Address Type is SUBNET. They cannot be blank. Enter 
the network IP and subnet mask that defines the IPv4 subnet.

Apply Click Apply to save your customized settings and exit this screen.

Cancel Click Cancel to return the screen to its last-saved settings. 
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Both TCP and UDP use ports to identify the source and destination. Each port is a 16-bit number. Some 
port numbers have been standardized and are used by low-level system processes; many others have 
no particular meaning.

Unlike TCP and UDP, Internet Control Message Protocol (ICMP, IP protocol 1) is mainly used to send error 
messages or to investigate problems. For example, ICMP is used to send the response if a computer 
cannot be reached. Another use is ping. ICMP does not guarantee delivery, but networks often treat 
ICMP messages differently, sometimes looking at the message itself to decide where to send it.

Service Objects and Service Groups

Use service objects to define IP protocols.

• TCP applications

• UDP applications

• ICMP messages

• user-defined services (for other types of IP protocols)

These objects are used in policy routes and security policies.

Use service groups when you want to create the same rule for several services, instead of creating 
separate rules for each service. Service groups may consist of services and other service groups. The 
sequence of members in the service group is not important.

Reference

Use Reference in a screen to view which configuration settings reference to the object. 

For example, go to Object > Service. select an entry, then click Reference to open the References 
screen. The References screen displays which settings are using the selected entry.

Figure 162   Reference

This table describes the fields in this screen.

Table 123   References
LABEL DESCRIPTION
Name This identifies the object for which the configuration settings that use it are displayed. Click the 

object’s name to display the object’s configuration screen in the main window.

# This field is a sequential value, and it is not associated with any entry.



Chapter 15 Object

USG FLEX H Series User’s Guide

238

15.2.2  The Service Summary Screen
The Service summary screen provides a summary of all services and their definitions. In addition, this 
screen allows you to add, edit, and remove services.

To access this screen, log in to the Web Configurator, and click Object > Service > Service. Click a 
column’s heading cell to sort the table entries by that column’s criteria. Click the heading cell again to 
reverse the sort order.

Service This is the type of setting that references the selected object. Click a service’s name to display 
the service’s configuration screen in the main window.

Priority If it is applicable, this field displays the referencing configuration item’s position in its list; 
otherwise - displays.

Name This field identifies the configuration item that references the object.

Description If the referencing configuration has a description configured, it displays here.

Refresh Click this to update the information in this screen.

Cancel Click this to close the screen.

Table 123   References
LABEL DESCRIPTION



 Chapter 15 Object

USG FLEX H Series User’s Guide

239

Figure 163   Object > Service > Service

The following table describes the labels in this screen.  

Table 124   Object > Service > Service 
LABEL DESCRIPTION
Add Click this to create a new entry.

Edit Double-click an entry or select it and click Edit to be able to modify the entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove 
it before doing so.

Reference Select an entry and click Reference to check which settings use the entry.

Name This field displays the name of each service.

Content This field displays a description of each service.

Reference This displays the number of times an object reference is used in a profile.
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15.2.2.1  The Service Add/Edit Screen
The Service Add/Edit screen allows you to create a new service or edit an existing one. To access this 
screen, go to the Service screen (see Section 15.2.2 on page 238), and click either the Add icon or an 
Edit icon.

Figure 164   Object > Service > Service > Add/Edit

The following table describes the labels in this screen.  

Table 125   Object > Service > Service > Add/Edit 
LABEL DESCRIPTION
Name Type the name used to refer to the service. You may use 1-30 single-byte characters, including 

0-9a-zA-Z!”#$%’()*+,-/:;=?@_, but the first character cannot be a number. &.<>[\]{|}^‘are not 
allowed. 

This value is case-sensitive.

Description Type the description used to refer to the service. You may use 1-30 single-byte characters, 
including 0-9a-zA-Z!”#$%’()*+,-/:;=?@_, but the first character cannot be a number. 
&.<>[\]{|}^‘are not allowed. 

IP Protocol Select the protocol the service uses. Choices are: TCP, UDP, ICMP, ICMPv6, and User Defined.

Starting Port

Ending Port

This field appears if the IP Protocol is TCP or UDP. Specify the port number(s) used by this service. 
If you fill in one of these fields, the service uses that port. If you fill in both fields, the service uses 
the range of ports.

ICMP Type This field appears if the IP Protocol is ICMP or ICMPv6.

Select the ICMP message used by this service. This field displays the message text, not the 
message number.

IP Protocol 
Number

This field appears if the IP Protocol is User Defined.

Enter the number of the next-level protocol (IP protocol). Allowed values are 1 - 255.

Apply Click Apply to save your customized settings and exit this screen.

Cancel Click Cancel to return the screen to its last-saved settings. 
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15.2.3  The Service Group Summary Screen
The Service Group summary screen provides a summary of all service groups. In addition, this screen 
allows you to add, edit, and remove service groups.

Note: If you want to access the Zyxel Device using HTTP, HTTPS, and/or SSH, you must add 
them in the Object > Service > Service Group > Default_Allow_WAN_To_ZyWALL service 
group, which is used in the WAN_to_Device security policy.

To access this screen, click Object > Service > Service Group.

Figure 165   Object > Service > Service Group   
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The following table describes the labels in this screen. See Section 15.2.3.1 on page 242 for more 
information as well.

15.2.3.1  The Service Group Add/Edit Screen
The Service Group Add/Edit screen allows you to create a new service group or edit an existing one. To 
access this screen, go to the Service Group screen (see Section 15.2.3 on page 241), and click either the 
Add icon or an Edit icon.

Figure 166   Object > Service > Service Group > Add/Edit

Table 126   Object > Service > Service Group 
LABEL DESCRIPTION
Add Click this to create a new entry.

Edit Double-click an entry or select it and click Edit to be able to modify the entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove 
it before doing so.

Reference Select an entry and click Reference to check which settings use the entry.

Name This field displays the name of each service group.

By default, the Zyxel Device uses services starting with “Default_Allow_” in the security policies 
to allow certain services to connect to the Zyxel Device.

Description This field displays the description of each service group, if any.

Reference This displays the number of times an object reference is used in a profile.
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The following table describes the labels in this screen.

15.3  Zone Overview
Set up zones to configure network security and network policies in the Zyxel Device. A zone is a group of 
interfaces and/or VPN tunnels. The Zyxel Device uses zones instead of interfaces in many security and 
policy settings, such as Secure Policies rules, Security Service, and remote management.

Zones cannot overlap. Each Ethernet interface, VLAN interface, bridge interface, PPPoE/PPTP interface 
and VPN tunnel can be assigned to at most one zone. Virtual interfaces are automatically assigned to 
the same zone as the interface on which they run.

Table 127   Object > Service > Service Group > Edit 
LABEL DESCRIPTION
Name Type the name used to refer to the service group. You may use 1-30 single-byte characters, 

including 0-9a-zA-Z!”#$%’()*+,-/:;=?@_, but the first character cannot be a number. 
&.<>[\]{|}^‘are not allowed. 

This value is case-sensitive.

Description Type the description used to refer to the service group. You may use 1-30 single-byte 
characters, including 0-9a-zA-Z!”#$%’()*+,-/:;=?@_, but the first character cannot be a number. 
&.<>[\]{|}^‘are not allowed. 

Member List This list displays the names of the service and service group objects that have been added to 
the service group. The order of members is not important. 

Select items from the list on the left that you want to be members and move them to the list on 
the right. Move any members you do not want included to the list on the left. 

Apply Click Apply to save your customized settings and exit this screen.

Cancel Click Cancel to return the screen to its last-saved settings. 
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Figure 167   Example: Zones

Use the Zone screens (see Section 15.4.2 on page 247) to manage the Zyxel Device’s zones. 

15.3.1  What You Need to Know
Zones effectively divide traffic into three types--intra-zone traffic, inter-zone traffic, and extra-zone 
traffic.

Intra-zone Traffic
• Intra-zone traffic is traffic between interfaces or VPN tunnels in the same zone. For example, in Figure 

167 on page 244, traffic between VLAN 2 and the Ethernet is intra-zone traffic.

Inter-zone Traffic

Inter-zone traffic is traffic between interfaces or VPN tunnels in different zones. For example, in Figure 167 
on page 244, traffic between VLAN 1 and the Internet is inter-zone traffic. This is the normal case when 
zone-based security and policy settings apply.

Extra-zone Traffic
• Extra-zone traffic is traffic to or from any interface or VPN tunnel that is not assigned to a zone. For 

example, in Figure 167 on page 244, traffic to or from computer C is extra-zone traffic. 

• Some zone-based security and policy settings may apply to extra-zone traffic, especially if you can 
set the zone attribute in them to Any or All. See the specific feature for more information.
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15.3.2  The Zone Screen
The Zone screen provides a summary of all zones. In addition, this screen allows you to add, edit, and 
remove zones. To access this screen, click Object > Zone.

Figure 168   Object > Zone

The following table describes the labels in this screen.  

15.3.2.1  Zone Edit
The Zone Edit screen allows you to add or edit a zone. To access this screen, go to the Zone screen (see 
Section 15.4.2 on page 247), and click the Add icon or an Edit icon.

Table 128   Object > Zone 
LABEL DESCRIPTION
User Configuration The Zyxel Device comes with pre-configured system default zones that you cannot 

delete. You can create your own zones by clicking Add.

Add Click this to create a new, user-configured zone.

Edit Double-click an entry or select it and click Edit to open a screen where you can modify 
the entry’s settings. 

Remove To remove a user-configured trunk, select it and click Remove. The Zyxel Device 
confirms you want to remove it before doing so.

Reference Select an entry and click Reference to check which settings use the entry.

Name This field displays the name of the zone.

Members This field displays the names of the interfaces that belong to each zone.

Description This field displays the description of the zone.

Reference This field displays the number of times an Object Reference is used in a policy.
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Figure 169   Object > Zone > Add   

The following table describes the labels in this screen.  

15.4  Schedule Overview 
Use schedules to set up one-time and recurring schedules for policy routes, security policies, application 
patrol, and content filtering. The Zyxel Device supports one-time and recurring schedules. One-time 

Table 129   Object > Zone > Add/Edit 
LABEL DESCRIPTION
Name For a system default zone, the name is read only.

For a user-configured zone, type the name used to refer to the zone. You may use 2-30 
single-byte characters, including 0-9a-zA-Z_.-, but the first character cannot be a number. 
This value is case-sensitive.

Description Enter the description associated with the zone, if any. You can use 1 to 30 single-byte 
characters, including 0-9a-zA-Z!”#$%’()*+,-/:;=?@_

&.<>[\]{|}^‘are not allowed. 

Member List The list on the left displays the interfaces and VPN tunnels that do not belong to any zone. 
Select the interfaces and VPN tunnels that you want to add to the zone you are editing, 
and click the right arrow button to add them.

The list on the right displays the interfaces and VPN tunnels that belong to the zone. Select 
any interfaces that you want to remove from the zone, and click the left arrow button to 
remove them.

Apply Click Apply to save your customized settings and exit this screen.

Cancel Click Cancel to return the screen to its last-saved settings. 
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schedules are effective only once, while recurring schedules usually repeat. Both types of schedules are 
based on the current date and time in the Zyxel Device. 

Note: Schedules are based on the Zyxel Device’s current date and time.

• Use the Schedule summary screen (Section 15.4.2 on page 247) to see a list of all schedules in the 
Zyxel Device. 

• Use the One-Time Schedule Add/Edit screen (Section 15.4.2.1 on page 248) to create or edit a one-
time schedule.

• Use the Recurring Schedule Add/Edit screen (Section 15.4.2.2 on page 250) to create or edit a 
recurring schedule.

• Use the Schedule Group screen (Section 15.4.3 on page 251) to merge individual schedule objects as 
one object.

15.4.1  What You Need to Know

One-time Schedules

One-time schedules begin on a specific start date and time and end on a specific stop date and time. 
One-time schedules are useful for long holidays and vacation periods.

Recurring Schedules

Recurring schedules begin at a specific start time and end at a specific stop time on selected days of 
the week (Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, and Saturday). Recurring schedules 
always begin and end in the same day. Recurring schedules are useful for defining the workday and off-
work hours.

15.4.2  The Schedule Screen
The Schedule screen provides a summary of all schedules in the Zyxel Device. To access this screen, click 
Object > Schedule.

Figure 170   Object > Schedule
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The following table describes the labels in this screen. See Section 15.4.2.1 on page 248 and Section 
15.4.2.2 on page 250 for more information as well.  

15.4.2.1  The One-Time Schedule Add/Edit Screen
The One-Time Schedule Add/Edit screen allows you to define a one-time schedule or edit an existing 
one. To access this screen, go to the Schedule screen (see Section 15.4.2 on page 247), and click either 
the Add icon or an Edit icon in the One Time section.

Table 130   Object > Schedule 
LABEL DESCRIPTION
One Time

Add Click this to create a new entry.

Edit Double-click an entry or select it and click Edit to be able to modify the entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove 
it before doing so.

Reference Select an entry and click Reference to check which settings use the entry.

Name This field displays the name of the schedule, which is used to refer to the schedule.

Start Day / 
Time

This field displays the date and time at which the schedule begins.

Stop Day / 
Time

This field displays the date and time at which the schedule ends.

Reference This displays the number of times an object reference is used in a profile.

Recurring

Add Click this to create a new entry.

Edit Double-click an entry or select it and click Edit to be able to modify the entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove 
it before doing so.

Reference Select an entry and click Reference to check which settings use the entry.

Name This field displays the name of the schedule, which is used to refer to the schedule.

Start Time This field displays the time at which the schedule begins.

Stop Time This field displays the time at which the schedule ends.

Reference This displays the number of times an object reference is used in a profile.
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Figure 171   Object > Schedule > Edit (One Time)

The following table describes the labels in this screen. 

Table 131   Object > Schedule > Edit (One Time) 
LABEL DESCRIPTION
Configuration

Name Type the name used to refer to the one-time schedule. You may use 2-30 single-byte 
characters, including 0-9a-zA-Z, underscores(_), or dashes (-), but the first character cannot be 
a number. This value is case-sensitive.

Description Type a description used to identify the one-time schedule. You may use 1-30 single-byte 
characters, including 0-9a-zA-Z’()+,/:=?;!*#@$_%-”

Day Time

Start Specify the year, month, and day when the schedule begins.

• Year - 1900 - 2999
• Month - 1 - 12
• Day - 1 - 31 (it is not possible to specify illegal dates, such as February 31.)

Specify the hour and minute when the schedule begins.

• Hour - 1-12 AM/PM
• Minute - 0 - 59

Stop Specify the year, month, and day when the schedule ends.

• Year - 1900 - 2999
• Month - 1 - 12
• Day - 1 - 31 (it is not possible to specify illegal dates, such as February 31.)

Specify the hour and minute when the schedule ends.

• Hour - 1-12 AM/PM
• Minute - 0 - 59

Apply Click Apply to save your customized settings and exit this screen.

Cancel Click Cancel to return the screen to its last-saved settings. 
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15.4.2.2  The Recurring Schedule Add/Edit Screen
The Recurring Schedule Add/Edit screen allows you to define a recurring schedule or edit an existing 
one. To access this screen, go to the Schedule screen (see Section 15.4.2 on page 247), and click either 
the Add icon or an Edit icon in the Recurring section.

Figure 172   Object > Schedule > Edit (Recurring)

The Year, Month, and Day columns are not used in recurring schedules and are disabled in this screen. 
The following table describes the remaining labels in this screen. 

Table 132   Object > Schedule > Edit (Recurring) 
LABEL DESCRIPTION
Configuration

Name Type the name used to refer to the recurring schedule. You may use 2-30 single-byte 
characters, including 0-9a-zA-Z, underscores(_), or dashes (-), but the first character cannot be 
a number. This value is case-sensitive.

Description Type a description used to identify the one-time schedule. You may use 1-30 single-byte 
characters, including 0-9a-zA-Z’()+,/:=?;!*#@$_%-”

Date Time

StartTime Specify the hour and minute when the schedule begins each day. Then, select each day of 
the week the recurring schedule is effective.

• Hour - 1-12 AM/PM
• Minute - 0 - 59

StopTime Specify the hour and minute when the schedule ends each day. Then, select each day of the 
week the recurring schedule is effective.

• Hour - 1-12 AM/PM
• Minute - 0 - 59

Apply Click Apply to save your customized settings and exit this screen.

Cancel Click Cancel to return the screen to its last-saved settings. 
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15.4.3  The Schedule Group Screen
The Schedule Group screen provides a summary of all groups of schedules in the Zyxel Device. To 
access this screen, click Object > Schedule > Schedule Group.

Figure 173   Object > Schedule > Schedule Group 

The following table describes the fields in the above screen. 

15.4.3.1  The Schedule Group Add/Edit Screen
The Schedule Group Add/Edit screen allows you to define a schedule group or edit an existing one. To 
access this screen, go to the Schedule screen (see), and click either the Add icon or an Edit icon in the 
Schedule Group section.

Table 133   Object > Schedule > Schedule Group 
LABEL DESCRIPTION
Configuration

Add Click this to create a new entry.

Edit Double-click an entry or select it and click Edit to be able to modify the entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove 
it before doing so.

Reference Select an entry and click Reference to check which settings use the entry.

Name This field displays the name of the schedule group, which is used to refer to the schedule.

Description This field displays the description of the schedule group.

Members This field lists the members in the schedule group. Each member is separated by a comma.

Reference This displays the number of times an object reference is used in a profile.
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Figure 174   Schedule > Schedule Group > Add

The following table describes the fields in the above screen.

Table 134   Object > Schedule > Schedule Group > Add
LABEL DESCRIPTION
Group Members

Name Type the name used to refer to the recurring schedule. You may use 2-30 single-byte 
characters, including 0-9a-zA-Z, underscores(_), or dashes (-), but the first character cannot be 
a number. This value is case-sensitive.

Description Enter a description of the service group, if any. You can use 1 to 30 single-byte characters, 
special characters and spaces are allowed.

Member List This list displays the names of the service and service group objects that have been added to 
the service group. The order of members is not important. 

Select items from the list on the left that you want to be members and move them to the list on 
the right. Move any members you do not want included to the list on the left. 

Apply Click Apply to save your customized settings and exit this screen.

Cancel Click Cancel to return the screen to its last-saved settings. 
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CHAPTER 16
Application Patrol

16.1  Overview
Application patrol provides a convenient way to manage the use of various applications on the 
network. It manages general protocols (for example, HTTP and FTP) and instant messenger (IM), peer-to-
peer (P2P), Voice over IP (VoIP), and streaming (RSTP) applications. You can even control the use of a 
particular application’s individual features (like text messaging, voice, video conferencing, and file 
transfers).

If a license has expired, you will see a reminder in this screen. You need to renew the license in order to 
keep using the feature. Click Buy Now to go to Marketplace to purchase a new license. Click See 
Details to go to the Zyxel web page to find more information on licenses for your Zyxel Device. 

16.1.1  What You Can Do in this Chapter
• Use the App Patrol summary screen (see Section 16.2 on page 254) to manage the application patrol 

profiles. You can also view license registration and signature information. 

• Use the App Patrol Add/Edit screens (see Section 16.2.1 on page 256 & Section  on page 256) to set 
actions for application categories and for specific applications within the category.

16.1.2   What You Need to Know
If you want to use a service, make sure both the Security Policy and application patrol allow the 
service’s packets to go through the Zyxel Device.

Note: The Zyxel Device checks secure policies before it checks application patrol rules for 
traffic going through the Zyxel Device.

Application patrol examines every TCP and UDP connection passing through the Zyxel Device and 
identifies what application is using the connection. Then, you can specify whether or not the Zyxel 
Device continues to route the connection. Traffic not recognized by the application patrol signatures is 
ignored.

Application Profiles & Policies

An application patrol profile is a group of categories of application patrol signatures. For each profile, 
you can specify the default action the Zyxel Device takes once a packet matches a signature (forward, 
drop, or reject a service’s connections and/or create a log alert).

Use policies to link profiles to traffic flows based on criteria such as source zone, destination zone, source 
address, destination address, schedule, user. 
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Classification of Applications

There are two ways the Zyxel Device can identify the application. The first is called auto. The Zyxel 
Device looks at the IP payload (OSI level-7 inspection) and attempts to match it with known patterns for 
specific applications. Usually, this occurs at the beginning of a connection, when the payload is more 
consistent across connections, and the Zyxel Device examines several packets to make sure the match 
is correct. Before confirmation, packets are forwarded by App Patrol with no action taken. The number 
of packets inspected before confirmation varies by signature.

Note: The Zyxel Device allows the first eight packets to go through the security policy, 
regardless of the application patrol policy for the application. The Zyxel Device 
examines these first eight packets to identify the application.

The second approach is called service ports. The Zyxel Device uses only OSI level-4 information, such as 
ports, to identify what application is using the connection. This approach is available in case the Zyxel 
Device identifies a lot of “false positives” for a particular application.

Custom Ports for SIP and the SIP ALG

Configuring application patrol to use custom port numbers for SIP traffic also configures the SIP ALG to 
use the same port numbers for SIP traffic. Likewise, configuring the SIP ALG to use custom port numbers 
for SIP traffic also configures application patrol to use the same port numbers for SIP traffic. 

16.2  Application Patrol Profile
Use the application patrol screens to customize action and log settings for a group of application patrol 
signatures. You then link a profile to a policy. Use this screen to create an application patrol profile, and 
view signature information. It also lists the details about the signature set the Zyxel Device is using. 

Note: You must register for the AppPatrol signature service (at least the trial) before you can 
use it. 

A profile is an application object(s) or application group(s) that has customized action and log settings.

Click Security Service > App Patrol to open the following screen.

Click the Application Patrol icon for more information on the Zyxel Device’s security features.
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Figure 175   Security Service > App Patrol

The following table describes the labels in this screen.

Table 135   Security Service > App Patrol 
LABEL DESCRIPTION
Collect Statistics

Enable Enable to have the Zyxel Device collect app patrol statistics. All of the statistics are erased 
if you restart the Zyxel Device or click Flush Data in Security Statistics > App Patrol.

Analyze All Traffic Enable to have the Zyxel Device collect app patrol statistics from all Zyxel Device traffic.

Disable to have the Zyxel Device only collect app patrol statistics from the traffic that 
matches the policy control rules with app patrol profiles applied. For example, if you 
create an app patrol profile and apply it to the policy control rule LAN_Outgoing, the Zyxel 
Device will only collect app patrol statistics from the traffic that matches the policy control 
rule LAN_Outgoing. 

Add Click this to create a new entry. Select an entry and click Add to create a new entry after 
the selected entry.

Edit Select an entry and click Edit to open a screen where you can modify the entry’s settings. 

Remove Select an entry and click Remove to delete the selected entry.

Reference Select an entry and click Reference to check which settings use the entry.

Name This displays the name of the profile created.

Description This displays the description of the App Patrol Profile.

Reference This displays the number of times an object reference is used in a profile.

Action Click this icon to apply the entry to a policy control rule.

Go to the Security Policy > Policy Control screen to check the result.

Signature Information The following fields display information on the current signature set that the Zyxel Device is 
using.

Current Version This field displays the App Patrol signature set version number.
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16.2.1  Application Patrol Profile > Add/Edit - Application Management
Use this screen to configure profile settings. Click Security Service > App Patrol > Add/Edit to open the 
following screen.

Figure 176   Security Service > App Patrol > Add/Edit > Application Management

The following table describes the labels in this screen.

Released Date This field displays the date and time the set was released.

Update Signatures Click this link to go to the screen you can use to download signatures from the update 
server. 

Table 135   Security Service > App Patrol 
LABEL DESCRIPTION

Table 136   Security Service > App Patrol > Add/Edit > Application Management
LABEL DESCRIPTION
General Settings

Name Type the name of the profile. You may use 1-31 alphanumeric characters, underscores(_), 
or dashes (-), but the first character cannot be a number. This value is case-sensitive. These 
are valid, unique profile names: 

• MyProfile
• mYProfile
• Mymy12_3-4

These are invalid profile names:

• 1mYProfile
• My Profile
• MyProfile?
• Whatalongprofilename123456789012

Description Type a description for the profile rule to help identify the purpose of rule. You may use 1-31 
alphanumeric characters, underscores (_), or dashes (-), but the first character cannot be 
a number. This value is case-sensitive. This field is optional. 
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16.3  Example: Block an Application
In this example, you want to block clients on the Zyxel Device LAN from accessing a specific application 
(for example, TikTok). You also want to receive a log and an alert when traffic going out from the LAN 
tries to access TikTok. 

Create an App Patrol profile that includes TikTok,. Then apply it to the LAN_Outgoing security policy. 
Clients on the Zyxel Device LAN will be blocked from accessing TikTok.

Add Click Add to create a new profile.

Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.

Save Changes Click this icon to save the changes in this row.

Cancel Changes Click this icon to cancel the changes in this row. 

Log Select whether to have the Zyxel Device generate a log (log), log and alert (log alert) or 
neither (no) by default when traffic matches a signature in this category.

Action Select the default action for all signatures in this category.

forward - the Zyxel Device routes packets that matches these signatures.

drop - the Zyxel Device silently drops packets that matches these signatures without 
sending a TCP RST or ICMP host unreachable message to both the sender and receiver.

reject - the Zyxel Device drops packets that matches these signatures and sends a TCP RST 
or ICMP host unreachable message to both the sender and receiver.

Priority This field is a sequential value showing the number of the profile. The ordering of your 
profiles is important as profiles are applied in sequence.

Category This field displays the category type of the application. 

Application This field displays the application name or numbers of applications included in the policy.

Log Select whether to have the Zyxel Device generate a log (log), log and alert (log alert) or 
neither (no) by default when traffic matches a signature in this category. 

Action Select the default action for all signatures in this category.

forward - the Zyxel Device routes packets that matches these signatures.

drop - the Zyxel Device silently drops packets that matches these signatures without 
notification.

reject - the Zyxel Device drops packets that matches these signatures and sends 
notification.

Apply Click Apply to save your settings to the Zyxel Device.

Cancel Click Cancel to return to the profile summary page without saving any changes.

Table 136   Security Service > App Patrol > Add/Edit > Application Management
LABEL DESCRIPTION
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Figure 177   App Patrol Tutorial Example

This example uses the parameters listed below. 

1 Go to Security Service > App Patrol and click Add.

2 In the following screen, enter the profile name using the parameter given in Table 137 on page 258. 
Click Add under Application Management to open the Add Application screen.

3 Search for TikTok in Category and Application and select the checkbox. Set Log to Log Alert and Action 
to Reject. Click Add to save your changes.

Table 137   App Patrol Profile Configuration Example
PROFILE NAME APPLICATION ACTION LOG
BlockMedia TikTok Reject Log Alert

Table 138   Security Policy Configuration Example
TO FROM LOG APP PATROL PROFILE
WAN LAN By Profile BlockMedia
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4 Click Apply to save the app patrol profile.
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5 Go to Security Policy > Policy Control. Select LAN_Outgoing then click Edit.

6 Set Application Patrol to BlockMedia and Log to by profile. Click Apply to save your changes.



 Chapter 16 Application Patrol

USG FLEX H Series User’s Guide

261

7 You can check the result in the Policy Control screen. Mouse-over the icon under the Action column to 
check that the BlockMedia profile has been applied to the LAN_Outgoing security policy. You can also 
check the logs in Log & Report > Log / Events. The Zyxel Device will create logs if the clients on the Zyxel 
Device LAN try to access TikTok.
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CHAPTER 17
Content Filtering

17.1  Overview
Use the content filter feature to control access to specific web sites or web content. 

If a license has expired, you will see a reminder in this screen. You need to renew the license in order to 
keep using the feature. Click Buy Now to go to Marketplace to purchase a new license. Click See 
Details to go to the Zyxel web page to find more information on licenses for your Zyxel Device. 

17.1.1  What You Can Do in this Chapter
• Use the Content Filtering screens (Section 17.2 on page 266) to set up web content filtering profiles.

• Use Content Filtering Allow List (Section 17.2.2 on page 281) to create a common list of good 
(allowed) web site addresses.

• Use Content Filtering Block List (Section 17.2.3 on page 282) to create a common list of bad (blocked) 
web site addresses.

• Use Content Filtering Blocked URL keywords (Section 17.2.4 on page 283) to create a common list of 
bad (blocked) URL keywords.

17.1.2  What You Need to Know

HTTP(S) Traffic Scan

The HTTP(S) Traffic Scan allows the Zyxel Device to block access to specific websites, by inspecting the 
URL or Server Name Indication (SNI) that the user’s web browser sends to the web server.

HTTP(S) Traffic Scanning Process

1 The Zyxel Device Content Filter detects an HTTP(S) connection, and inspects the website sent.

2 If the website contains prohibited material, the HTTP(S) request is redirected to a block page.

Note: If the user’s web browser is using encryption, then you must enable SSL Inspection for 
HTTP(S) Traffic Scan to work.

Content Filtering Policies

A content filter policy allows you to do the following.

• Use schedule objects to define when to apply a content filter profile.
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• Use address and/or user/group objects to define to whose web access to apply the content filter 
profile.

• Apply a content filter profile that you have custom-tailored. 

Content Filtering Profiles

A content filtering profile conveniently stores your custom settings for the following features.

• Category-based Blocking

The Zyxel Device can block access to particular categories of web site content, such as pornography 
or racial intolerance.

• Customize Web Site Access 

You can specify URLs to which the Zyxel Device blocks access. You can alternatively block access to 
all URLs except ones that you specify. You can also have the Zyxel Device block access to URLs that 
contain particular keywords. 

HTTP(S) Traffic Scanning Configuration Guidelines

When the Zyxel Device receives an HTTP request, the content filter searches for a policy that matches 
the source address and time (schedule). The content filter checks the policies in order (based on the 
policy numbers). When a matching policy is found, the content filter allows or blocks the request 
depending on the settings of the filtering profile specified by the policy. Some requests may not match 
any policy. The Zyxel Device allows the request if the default policy is not set to block. The Zyxel Device 
blocks the request if the default policy is set to block.

HTTPS Domain Filter

HTTPS Domain Filter works with the Content Filter category feature to identify HTTPS traffic and take 
appropriate action. SSL Inspection identifies HTTPS traffic for all Security Service traffic and has higher 
priority than HTTPS Domain Filter. HTTPS Domain Filter only identifies keywords in the domain name of an 
URL and matches it to a category. For example, if the keyword is 'picture' and the URL is http://
www.google.com/picture/index.htm, then HTTPS Domain Filter cannot identify 'picture' because that 
keyword in not in the domain name 'www.google.com'. However, SSL Inspection can identify 'picture' in 
the URL http://www.google.com/picture/index.htm. 

Keyword Blocking URL Checking

The Zyxel Device checks the URL’s domain name (or IP address) and file path separately when 
performing keyword blocking. 

The URL’s domain name or IP address is the characters that come before the first slash in the URL. For 
example, with the URL www.zyxel.com.tw/news/pressroom.php, the domain name is 
www.zyxel.com.tw.

The file path is the characters that come after the first slash in the URL. For example, with the URL 
www.zyxel.com.tw/news/pressroom.php, the file path is news/pressroom.php.

Since the Zyxel Device checks the URL’s domain name (or IP address) and file path separately, it will not 
find items that go across the two. For example, with the URL www.zyxel.com.tw/news/pressroom.php, 
the Zyxel Device would find “tw” in the domain name (www.zyxel.com.tw). It would also find “news” in 
the file path (news/pressroom.php) but it would not find “tw/news”.
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DNS Domain Scan

The DNS Domain Scan allows the Zyxel Device to block access to specific websites by inspecting DNS 
queries made by users on your network. If the website in the DNS query contains prohibited material, 
then the Zyxel Device replies to the DNS query with a IP address that points to the block page. Unlike the 
HTTP(S) Traffic Scan, the DNS Domain Scan works if the user is using TLS 1.3 with ESNI.

DNS Domain Scan Process

1 A user enters a URL into their web browser.

2 The user’s computer sends a DNS query for the URL.

3 The DNS Domain Scan inspects the website in the DNS query packet.

If the website contains prohibited material, the DNS reply is redirected to a block page.Finding Out More

4 See Section 17.3 on page 285 for content filtering background/technical information.

External Category-Based Content Filtering Server

When you register for and enable the external content filtering service, your Zyxel Device accesses an 
external database that has millions of web sites categorized based on content. You can have the Zyxel 
Device block, block and/or log access to web sites based on these categories. 

External Content Filtering Server Lookup Procedure

The content filtering lookup process is described below. 

Figure 178   Content Filtering Lookup Procedure

1 A computer behind the Zyxel Device tries to access a web site.
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2 The Zyxel Device looks up the web site in its cache. If an attempt to access the web site was made in the 
past, a record of that web site’s category will be in the Zyxel Device’s cache. The Zyxel Device blocks, 
blocks and logs or just logs the request based on your configuration. 

3 If the Zyxel Device has no record of the web site, it queries the external content filtering database.

4 The external content filtering server sends the category information back to the Zyxel Device, which 
then blocks and/or logs access to the web site based on the settings in the content filter profile. The web 
site’s address and category are then stored in the Zyxel Device’s content filter cache.

17.2  Content Filtering General Screen
Click Security Services > Content Filtering > General to open the Content Filtering screen. Use this screen 
to enable HTTP(S), DNS domain scanning, test website categories and view / create content filter 
policies. 

Figure 179   Security Service > Content Filtering_General
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The following table describes the labels in this screen.  

Table 139   Security Service > Content Filtering > General 
LABEL DESCRIPTION
For HTTP(S) traffic scan

Enable Select this check box to have the Zyxel Device block HTTPS web pages using the 
cloud category service.

In an HTTPS connection, the Zyxel Device can extract the Server Name Indication 
(SNI) from a client request, check if it matches a category in the cloud content filter 
and then take appropriate action. The keyword match is for the domain name only. 

Enable Block Page Use this field to have the Zyxel Device display a warning page instead of a blank 
page when an HTPPS connection is redirected.

Denied Access 
Message

Enter a message to be displayed when content filter blocks access to a web page. 
Use up to 127 characters (0-9a-zA-Z;/?:@&=+$\.-_!~*'()%,”). For example, “Access to 
this web page is not allowed. Please contact the network administrator”.

It is also possible to leave this field blank if you have a URL specified in the Redirect URL 
field. In this case if the content filter blocks access to a web page, the Zyxel Device 
just opens the web page you specified without showing a denied access message.

Redirect URL Enter the URL of the web page to which you want to send users when their web 
access is blocked by content filter. The web page you specify here opens in a new 
frame below the denied access message. 

Use “http://” or “https://” followed by up to 262 characters (0-9a-zA-Z;/?:@&=+$\.-
_!~*'()%). For example, http://192.168.1.17/blocked access.

For DNS Domain scan

Enable DNS Domain 
scan

Select this to have the Zyxel Device inspect DNS queries made by users on your 
network.

Blocked Domain This is the URL of the web page to which you want to send users when their web 
access is blocked by DNS content filtering. The web page you specify here opens in a 
new frame below the denied access message.

Select default to send users to the default web page when their web access is 
blocked by DNS content filter.

Select custom-defined to send users to the web page you set when their web access 
is blocked by DNS content filter. Use “http://” followed by up to 255 characters (0-9 a-
z A-Z;/?:@&=+$\.-_!~*'()%) in quotes. For example, http://192.168.2.17/blocked 
access.

Category Server is 
unavailable

Select Pass to allow users to access any requested web page if the external content 
filtering database is unavailable. 

Select Block to block access to any requested web page if the external content 
filtering database is unavailable. 

The following are possible causes for the external content filtering server not being 
available:

• There is no response from the external content filtering server within the time 
period specified in the Content Filter Server Unavailable Timeout field.

• The Zyxel Device is not able to resolve the domain name of the external content 
filtering database.

• There is an error response from the external content filtering database. This can be 
caused by an expired content filtering registration (External content filtering’s 
license key is invalid”).

Select Log to record attempts to access web pages that occur when the external 
content filtering database is unavailable.

Collect Statistics Enable to have the Zyxel Device collect content filtering statistics. All of the statistics 
are erased if you restart the Zyxel Device or click Flush Data in Security Statistics > 
Content Filter.
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17.2.1  Content Filtering Add Profile
Click Security Service > Content Filtering > Add or Edit to open the following screen.

Test Web Site Category

URL to test Enter a web site URL in the text box.

When content filtering is active, you should see the web page’s category. The query 
fails if content filtering is not active.

Content Filterilg can query a category by full URL string (for example, http://
www.google.com/picture/index.html), but HTTPS domain filter can only query a 
category by domain name (www.google.com), so the category may be different in 
the query result. URL to test displays both results in the test.

If you think the category is 
incorrect, click this link to 
submit a request to review 
it.

Click this link to see the category recorded in the Zyxel Device’s content filtering 
database for the web page you specified (if the database has an entry for it).

Profile Management

Add Click Add to create a new content filter rule.

Edit Click Edit to make changes to a content filter rule.

Remove Click Remove the delete a content filter rule.

Reference Select an entry and click Reference to check which settings use the entry.

Name This column lists the names of the content filter profile rule.

Description This column lists the description of the content filter profile rule.

Reference This shows the number of references this profile uses.

Action Click this icon to apply the entry to a policy control rule.

Go to the Security Policy > Policy Control screen to check the result.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 139   Security Service > Content Filtering > General (continued)
LABEL DESCRIPTION
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Figure 180   Security Service > Content Filter > Add Profile (General & Managed Categories)

The following table describes the labels in this part of the screen. 

Table 140   Security Service > Content Filtering > Add ProfileGeneral & Managed Categories) 
LABEL DESCRIPTION
Name Enter a descriptive name for this content filtering profile name. You may use 1-31 

alphanumeric characters, special characters -_@$./ are allowed, but the first 
character cannot be a number. This value is case-sensitive.

Description Enter a description for the content filtering profile rule to help identify the purpose 
of rule. You may use 1-31 alphanumeric characters, underscores(_), or dashes (-), 
but the first character cannot be a number. This value is case-sensitive.

This field is optional.

Action Select pass to allow users to access web pages that match the other categories 
that you select below. 

Select block to prevent users from accessing web pages that match the other 
categories that you select below. When external database content filtering 
blocks access to a web page, it displays the denied access message that you 
configured in the Content Filter General screen along with the category of the 
blocked web page.
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The following table describes the managed categories. 

Log A log at the alert level is a log for serious events that may need more immediate 
attention. For example, you may want to know right away if there are clients in 
your networks that try to access adult topics or drugs related web pages.

Set the action to block. Then select log to have the Zyxel Device generate logs at 
the info level or select log alert to have the Zyxel Device generate logs at the alert 
level.

Select no if you don’t want the Zyxel Device to generate logs.

Log allowed traffic Enable to generate logs when users access web pages that match the categories 
you allow.

SSL V3 or previous version 
Connection

Drop Select this to have the Zyxel Device block HTTPS web pages using SSLS V3 or a 
previous version.

Drop Log A log at the alert level is a log for serious events that may need more immediate 
attention. For example, you may want to know right away if there are clients in 
your networks that try to access adult topics or drugs related web pages.

When the Zyxel Device blocks HTTPS web pages using SSL V3 or a previous version,

• Select no to not generate logs.
• Select log to have the Zyxel Device generate logs at the info level.
• Select log alert to have the Zyxel Device generate logs at the alert level.

Managed Categories These are categories of web pages based on their content. Select categories in 
this section to control access to specific types of Internet content.

You must have the Category Service content filtering license to filter these 
categories. See the next table for category details.

Select All Categories Select this check box to restrict access to all site categories listed below.

Clear All Categories Select this check box to clear the selected categories below.

Apply Click Apply to save your changes back to the Zyxel Device.

Reset Click Reset to exit this screen without saving your changes.

Table 141   Managed Category Descriptions 
CATEGORY DESCRIPTION
Adult Topics Web pages that contain content or themes that are generally considered 

unsuitable for children.

Alcohol Web pages that mainly sell, promote, or advocate the use of alcohol, such as beer, 
wine, and liquor. 

This category also includes cocktail recipes and home-brewing instructions.

Anonymizing Utilities Web pages that result in anonymous web browsing without the explicit intent to 
provide such a service. 

This category includes URL translators, web-page caching, and other utilities that 
might function as anonymizers, but without the express purpose of bypassing filtering 
software.

This category does not include text translation.

Art Culture Heritage Web pages that contain virtual art galleries, artist sites (including sculpture and 
photography), museums, ethnic customs, and country customs.

This category does not include online photograph albums.

Table 140   Security Service > Content Filtering > Add ProfileGeneral & Managed Categories) 
LABEL DESCRIPTION
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Auctions Classifieds Web pages that provide online bidding and selling of items or services. 

This category includes web pages that focus on bidding and sales.

This category does not include classified advertisements such as real estate postings, 
personal ads, or companies marketing their auctions.

Blogs/Wiki Web pages containing dynamic content, which often changes because users can 
post or edit content at any time.

This category covers the risks with dynamic content that might range from harmless 
to offensive.

Business Web pages that provide business-related information, such as corporate overviews 
or business planning and strategies. 

This category also includes information, services, or products that help other 
businesses plan, manage, and market their enterprises, and multi-level marketing.

This category does not include personal pages and web-hosting web pages.

Chat Web pages that provide web-based, real-time social messaging in public and 
private chat rooms. This category includes IRC.

This category does not include instant messaging.

Computing Internet Web pages containing reviews, information, buyer's guides of computers, computer 
parts and accessories, computer software and internet companies, industry news 
and magazines, and pay-to-surf sites.

Consumer Protection Websites that try to rob or cheat consumers. 

Some examples of their activities include selling counterfeit products, selling 
products that were originally provided for free, or improperly using the brand of 
another company. This category also includes sites where many consumers 
reported being cheated or not receiving services.

This category does not include phishing, which tries to perpetrate fraud or theft by 
stealing account information.

Content Server URLs for servers that host images, media files, or JavaScript for one or more sites and 
are intended to speed up content retrieval for existing web servers, such as Apache. 

This category includes domain-level and sub-domain-level URLs that function as 
content servers.

This category does not include:

• Web pages for businesses that provide the content servers
• Web pages that allow users to browse photographs. See the Media Sharing 

category.
• URLs for servers that serve only advertisements. See the Web Ads category.

Controversial Opinions Web pages that contain opinions that are likely to offend political or social 
sensibilities and incite controversy. Much of this content is at the extremes of public 
opinion.

This category does not include opinion or language clearly intended to promote 
hate or discrimination.

Cult Occult Sites relating to non-traditional religious practices considered to be false, 
unorthodox, extremist, or coercive.

Dating Personals Web pages that provide networking for online dating, matchmaking, escort 
services, or introductions to potential spouses.

This category does not include sites that provide social networking that might 
include dating, but are not specific to dating.

Table 141   Managed Category Descriptions (continued)
CATEGORY DESCRIPTION
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Dating Social Networking Web pages that focus on social interaction such as online dating, friendship, school 
reunions, pen-pals, escort services, or introductions to potential spouses.

This category does not include wedding-related content, dating tips, or related 
marketing.

Digital Postcards Web pages that allow people to send and receive digital postcards and greeting 
cards via the Internet.

Discrimination Web pages, which provide information that explicitly encourages the oppression or 
discrimination of a specific group of individuals.

This category does not include jokes and humor, unless the focus of the entire site is 
considered discriminatory.

Drugs Websites that provide information on the purchase, manufacture, and use of illegal 
or recreational drugs.

This category does not include sites with exclusive health or political themes.

Education Reference Web pages devoted to academic-related content such as academic subjects 
(mathematics, history), school or university web pages, and education 
administration pages (school boards, teacher curriculum).

Entertainment Web pages that provide information about cinema, theater, music, television, 
infotainment, entertainment industry gossip-news, and sites about celebrities such as 
actors and musicians. 

This category also includes sites where the content is devoted to providing 
entertainment on the web, such as horoscopes or fan clubs.

Extreme Web pages that provide content considered gory, perverse, or horrific.

Fashion Beauty Web pages that market clothing, cosmetics, jewelry, and other fashion-oriented 
products, accessories, or services. 

This category also includes product reviews, comparisons, and general consumer 
information, and services such as hair salons, tanning salons, tattoo studios, and 
body-piercing studios.

This category does not include fashion-related content such as modeling or 
celebrity fashion unless the site focuses on marketing the product line.

Finance Banking Web pages that provide financial information or access to online financial 
accounts. 

This category includes stock information (but not stock trading), home finance, and 
government-related financial information.

For Kids Web pages that are family-safe, specifically for children of approximate ages ten 
and under.

This category can also be used as an exception to allow web pages that do not 
pose a risk to children, or to access sites that have a primary educational or 
recreational focus for children, but are in other categories such as Games, Humor/
Comics, Recreation/Hobbies, or Entertainment.

Forum Bulletin Boards Web pages that provide access (http://) to Usenet newsgroups or hold discussions 
and post user-generated content, such as real-time message posting for an interest 
group. This category also includes archives of files uploaded to newsgroups.

This category does not include message forums with a business or technical support 
focus.

Gambling Web pages that allow users to wager or place bets online, or provide gambling 
software that allows online betting, such as casino games, betting pools, sports 
betting, and lotteries. 

This category does not include web pages related to gambling that do not allow 
betting online.

Table 141   Managed Category Descriptions (continued)
CATEGORY DESCRIPTION
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Gambling Related Web pages that offer information about gambling, without providing the means to 
gamble.

This category includes casino-related web pages that do not offer online gambling, 
gambling links, tips, sports picks, lottery results, and horse, car, or boat racing.

Game Cartoon Violence Web pages that provide fantasy or fictitious representations of violence within the 
context of games, comics, cartoons, or graphic novels.

This category includes images and textual descriptions of physical assaults or hand-
to-hand combat, and grave injury and destruction caused by weapons or 
explosives.

Games Web pages that offer online games and related information such as cheats, codes, 
demos, emulators, online contests or role-playing games, gaming clans, game 
manufacturer sites, fantasy or virtual sports leagues, and other gaming sites without 
chances of profit.

This category includes gaming consoles.

General News Web pages that provide online news media, such as international or regional news 
broadcasting and publication.

This category includes portal sites that provide news content.

Government Military Web pages that contain content maintained by governmental or military 
organizations, such as government branches or agencies, police departments, fire 
departments, civil defense, counter-terrorism organizations, or supranational 
organizations, such as the United Nations or the European Union.

This category includes military and veterans’ medical facilities.

Gruesome Content Web pages with content that can be considered tasteless, gross, shocking, or 
gruesome.

This category does not include web pages with content pertaining to physical 
assault.

Health Web pages that cover all health-related information and health care services.

This category does not include cosmetic surgery, marketing/selling 
pharmaceuticals, or animal-related medical services.

Historical Revisionism Web pages that denounce, or offer different interpretations of, significant historical 
facts, such as holocaust denial.

This category does not include all re-examination of historical facts, only historical 
events that are highly sensitive.

History Web pages that provide content about historical facts.

This category includes content suitable for higher education, but the Education 
category includes content for primary education. For example, a site with Holocaust 
photographs might be offensive, but have academic value.

Humor Comics Web pages that provide comical or funny content.

This category includes sites with jokes, sketches, comics, and satire pages. This 
category might also include graphic novel content, which is often associated with 
comics.

Illegal UK Web pages that contain child sexual abuse content hosted anywhere in the world, 
and criminally obscene and incitement to racial hatred content hosted in the UK.

Table 141   Managed Category Descriptions (continued)
CATEGORY DESCRIPTION
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Incidental Nudity Web pages that contain non-pornographic images of the bare human body like 
those in classic sculpture and paintings, or medical images.

This category enables you to allow or block sites in order to address cultural or 
geographic differences in opinion about nudity. For example, you can use this 
category to block access to nudity, but allow access when nudity is not the primary 
focus of a site, such as news sites or major portals.

Information Security Web pages that legitimately provide information about data protection. This 
category includes detailed information for safeguarding business or personal data, 
intellectual property, privacy, and infrastructure on the Internet, private networks, or 
in other bandwidth services such as telecommunications.

This category does not include:

• Legitimate information security companies and security software providers, such 
as virus protection companies.

• Sites that intend to exploit security or teach how to bypass security.

Information Security New Web pages that legitimately provide information about data protection. This 
category includes detailed information for safeguarding business or personal data, 
intellectual property, privacy, and infrastructure on the Internet, private networks, or 
in other bandwidth services such as telecommunications.

This category does not include:

• Legitimate information security companies and security software providers, such 
as virus protection companies.

• Sites that intend to exploit security or teach how to bypass security.

Instant Messaging Web pages that provide software for real-time communication over a network 
exclusively for users who joined a member’s contact list or an instant-messaging 
session.

Most instant-messaging software includes features such as file transfer, PC-to-PC 
phone calls, and can track when other people log on and off.

Interactive Web 
Applications

Web pages that provide access to live or interactive web applications, such as 
browser-based office suites and groupware. This category includes sites with 
business, academic, or individual focus.

This category does not include sites providing access to interactive web 
applications that do not take critical user data or offer security risks, such as Google 
Maps.

Internet Radio TV Web pages that provide software or access to continuous audio or video 
broadcasting, such as Internet radio, TV programming, or podcasting.

Quick downloads and shorter streams that consume less bandwidth are in the 
Streaming Media or Media Downloads categories.

Internet Services Web pages that provide services for publication and maintenance of Internet sites 
such as web design, domain registration, Internet Service Providers, and broadband 
and telecommunications companies that provide web services.

This category includes web utilities such as statistics and access logs, and web 
graphics like clip art.

Job Search Web pages related to a job search including sites concerned with resume writing, 
interviewing, changing careers, classified advertising, and large job databases. This 
category also includes corporate web pages that list job openings, salary 
comparison sites, temporary employment, and company job-posting sites.

This category does not include make-money-at-home sites.

Table 141   Managed Category Descriptions (continued)
CATEGORY DESCRIPTION
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Major Global Religions Web pages with content about religious topics and information related to major 
religions. This category includes sites that cover religious content such as discussion, 
beliefs, non-controversial commentary, articles, and information for local 
congregations such as a church or synagogue homepage.

The religions in this category are Baha'i, Buddhism, Chinese Traditional, Christianity, 
Hinduism, Islam, Jainism, Judaism, Shinto, Sikhism, Tenrikyo, Zoroastrianism.

Marketing Merchandising Web pages that promote individual or business products or services on the web, but 
do not sell their products or services online. 

This category includes websites that are generally a company overview, describing 
services or products that cannot be purchased directly from these sites. Examples 
include automobile manufacturer sites, wedding photography services, or graphic 
design services.

This category does not include:

• Other categories that imply marketing such as Alcohol, Auctions/Classifieds, 
Drugs, Finance/Banking, Mobile Phone, Online Shopping, Real Estate, School 
Cheating Information, Software/Hardware, Stock Trading, Tobacco, Travel, and 
Weapons.

• Sites that market their services only to other businesses. See the Business 
category.

• Sites that rob or cheat consumers. See the Consumer Protection category.

Media Downloads Web pages that provide audio or video files for download such as MP3, WAV, AVI, 
and MPEG formats. The files are saved to, and played from, the user’s computer.

This category does not include audio or video files that are played directly through a 
browser window. See the Streaming Media category.

Media Sharing Web pages that allow users to upload, search for, and share media files and 
photographs, such as online photograph albums.

Messaging Examples include text messaging to mobile phones, PDAs, fax machines, and 
internal website user-to-user messaging or site-to-site messaging.

This category does not include real-time chat or instant messaging, or message 
posts that can be viewed by anyone but the intended recipient.

Mobile Phone Web pages that sell media, software, or utilities for mobile phones that can be 
downloaded and delivered to mobile phones.

Examples include ringtones, logos/skins, games, screen-savers, text-based tunes, 
and software for SMS, MMS, WAP, and other mobile phone protocols.

Moderated Bulletin boards, chat rooms, search engines, or web mail sites that are monitored by 
an individual or group who has the authority to block messages or content 
considered inappropriate.

This category does not include sites with posted rules against offensive content. See 
the Forum/Bulletin Boards category.

Motor Vehicles Websites for manufacturers and dealerships of consumer transportation vehicles, 
such as cars, vans, trucks, SUVs, motorcycles, and scooters. This category also 
includes sites that provide product marketing, reviews, comparisons, pricing 
information, auto fairs, auto expos, and general consumer information about motor 
vehicles.

This category does not include automotive accessories, mechanics, auto-body 
shops, and recreational hobby pages. This category does not include sites that 
provide business-to-business-only content regarding motor vehicles.

Non Profit Advocacy NGO Web pages from charitable or educational groups that fulfill a stated mission, 
benefiting the larger community, such as clubs, lobbies, communities, non-profit 
organizations, labor unions, and advocacy groups.

Examples are Masons, Elks, Boy and Girl Scouts, or Big Brothers.

Table 141   Managed Category Descriptions (continued)
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Nudity Web pages that have non-pornographic images of the bare human body. This 
category includes classic sculpture and paintings, artistic nude photographs, some 
naturism pictures, and detailed medical illustrations.

This category does not include high-profile sites where nudity is not a concern for 
visitors. See the Incidental Nudity category.

Online Shopping Web pages that sell products or services online.

Web pages selling a broad range of products might pose a risk to users by offering 
access to items that are normally in other categories such as Pornography, 
Weapons, Nudity, or Violence. Web pages selling such content exclusively are in 
their respective categories.

P2P File Sharing Web pages that allow the exchange of files between computers and users for 
business or personal use, such as downloadable music.

P2P clients allow users to search for and exchange files from a peer-user network. 
They often include spyware or real-time chat capabilities. This category includes 
BitTorrent web pages.

Parked Domain Web pages that once served content, but their domains have been sold or 
abandoned and are no longer registered.

Parked domains do not host their own content, but usually redirect users to a 
generic page that states the domain name is for sale, or redirect users to a generic 
search engine and portal page, some of which provide valid search engine results.

Personal Network Storage Web pages that allow users to upload folders and files to an online network server in 
order to backup, share, edit, or retrieve files or folders from any web browser.

Personal Pages Personal home pages that share a common domain such as those hosted by ISPs, 
university/education servers, or free web page hosts.

This category also includes unique domains that contain personal information, such 
as a personal home page. This category does not include home pages of public 
figures.

Pharmacy Web pages that provide reviews, descriptions, and market or sell prescription-based 
drugs, over-the-counter drugs, birth control, or dietary supplements.

Politics Opinion Web pages covering political parties, individuals in political life, and opinion on 
various topics.

This category might also cover laws and political opinion about drugs. This category 
includes URLs for political parties, political campaigning, and opinions on various 
topics, including political debates.

Pornography Web pages that contain materials intended to be sexually arousing or erotic.

This category includes fetish pages, animation, cartoons, stories, and illegal 
pornography.

Portal Sites Web pages that serve as major gateways or directories to content on the web.

Many portal sites also provide a variety of internal site features or services such as 
search engines, email, news, and entertainment. Mailing list sites with a variety of 
content are in this category.

This category does not include sites with topic-specific content.

Potential Criminal Activities Web pages that provide instructions to commit illegal or criminal activities.

Instructions include committing murder or suicide, sabotage, bomb-making, lock-
picking, service theft, evading law enforcement, or spoofing drug tests. This 
category might also include information on how to distribute illegal content, 
perpetrate fraud, or consumer scams.

This category does not include computer-related fraud.

Table 141   Managed Category Descriptions (continued)
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Potential Hacking 
Computer Crime

Web pages that provide instructions, or otherwise enable, fraud, crime, or malicious 
activity that is computer-oriented.

This category includes web pages related to computer crime include malicious 
hacking information or tools that help individuals gain unauthorized access to 
computers and networks (root kits, kiddy scripts). This category also includes other 
areas of electronic fraud such as dialer scams and illegal manipulation of electronic 
devices.

This category does not include illegal software.

Potential Illegal Software Web pages, which the filter believes offer information to potentially ‘pirated’ or 
illegally distribute software or electronic media, such as copyrighted music or film, 
distribution of illegal license key generators, software cracks, and serial numbers.

This category does not include peer-to-peer web pages.

Private IP Addresses Sites that are private IP addresses as defined in RFC 1918, that is, hosts that do not 
require access to hosts in other enterprises (or require just limited access) and whose 
IP address may be ambiguous between enterprises but are well defined within a 
certain enterprise.

Profanity Web pages that contain crude, vulgar, or obscene language or gestures.

Professional Networking Web pages that provide social networking exclusively for professional or business 
purposes.

This category includes sites that provide personal or group profiles, and enable their 
members to interact through real-time communication, message posting, public 
bulletins, and media sharing. This category also contains alumni sites that have a 
networking function.

This category does not include social networking sites where the focus might vary, 
but include friendship, dating, or professional focuses.

Provocative Attire Web pages with pictures that include alluring or revealing attire, lingerie and 
swimsuits, or supermodel or celebrity photograph collections, but do not involve 
nudity.

This category does not include sites with swimwear or similar attire that is not 
intended to be provocative. For example, Olympic swimming sites are not in this 
category.

Public Information Web pages that provide general reference information such as public service 
providers, regional information, transportation schedules, maps, or weather reports.

PUPs Web pages that contain Potentially Unwanted Programs (PUPs).

PUPs are often made for a beneficial purpose but they alter the security of a 
computer or the computer user’s privacy. Computer users who are concerned 
about security or privacy might want to be informed about this software, and in 
some cases, they might want to remove this software from their computers.

Real Estate Web pages that provide commercial or residential real estate services and 
information.

Service and information includes sales and rental of living space or retail space and 
guides for apartments, housing, and property, and information on appraisal and 
brokerage. This category includes sites that allow you to browse model homes.

This category does not include content related to personal finance, such as credit 
applications.

Table 141   Managed Category Descriptions (continued)
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Recreation Hobbies Web pages for recreational organizations and facilities that include content 
devoted to recreational activities and hobbies.

This category includes information about public swimming pools, zoos, fairs, festivals, 
amusement parks, recreation guides, hiking, fishing, bird watching, or stamp 
collecting.

This category does not include activities that need no active participation, such as 
watching a movie or reading celebrity gossip.

Religion Ideology Web pages with content related to religious topics and beliefs in human spirituality 
that are not within the major religions.

This category includes religious discussion, beliefs, articles, and information for local 
congregations or groups such as a church homepage, unless the site is already in 
the Major Global Religions category. This category also includes comparative 
religion, or sites that include religions and ideologies.

This category does not include astrology and horoscope sites

Remote Access Web pages that provide remote access to a program, online service, or an entire 
computer system.

Although remote access is often used legitimately to run a computer from a remote 
location, it creates a security risk, such as backdoor access. Backdoor access, 
written by the original programmer, allows the system to be controlled by another 
party without the user's knowledge.

Reserved This category is reserved for future use.

Residential IP Addresses IP addresses (and any domains associated with them) that access the Internet by 
DSL modems or cable modems.

Because this content is not generally intended for Internet access via HTTP, access to 
the Internet through these IP addresses can indicate suspicious behavior. This 
behavior might be related to malware located on the home computer or 
homegrown gateways set up to allow anonymous Internet access.

Resource Sharing Web pages that harness idle or unused computer resources to focus on a common 
task.

The task can be on a company or an international basis. Well known examples are 
the SETI program and the Human Genome Project, which use the idle time of 
thousands of volunteered computers to analyze data.

Restaurants Web pages that provide information about restaurants, bars, catering, take-out and 
delivery, including online ordering.

This category includes sites that provide information about location, hours, prices, 
menus and related dietary information. This category also includes restaurant guides 
and reviews, and cafes and coffee shops.

This category does not include groceries, wholesale food, non-profit and charitable 
food organizations, or bars that do not focus on serving food.

School Cheating 
Information

Web pages that promote plagiarism or cheating by providing free or fee-based 
term papers, written essays, or exam answers.

This category does not include sites that offer student help, discuss literature, films, or 
books, or other content that is often the subject of research papers.

Search Engines Web pages that provide search results that enable users to find information on the 
Internet based on key words.

This category does not include site-specific search engines.

Table 141   Managed Category Descriptions (continued)
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Sexual Materials Web pages that describe or depict sexual acts, but are not intended to be arousing 
or erotic.

Examples of sexual materials include sex education, sexual innuendo, humor, or sex 
related merchandise.

This category does not include web pages with content intended to arouse.

Shareware Freeware Web pages that are repositories of downloadable copies of shareware and 
freeware.

This category does not include subscription-based software.

Social Networking Web pages that enable social networking for a variety of purposes, such as 
friendship, dating, professional, or topics of interest.

These sites provide personal or group profiles and enable interaction among their 
members through real-time communication, message posting, public bulletins, and 
media sharing.

This category does not include sites that are exclusive to dating, matchmaking, or a 
specific professional networking focus.

Software Hardware Web pages related to computing software and hardware, including vendors, 
product marketing and reviews, deployment and maintenance of software and 
hardware, and software updates and add-ons such as scripts, plug-ins, or drivers. 
Hardware includes computer parts, accessories, and electronic equipment used 
with computers and networks.

This category includes the marketing of software and hardware, and magazines 
focused on software or hardware product reviews or industry trends.

Sports Web pages related to professional or organized recreational sports.

This category includes sporting news, events, and information such as playing tips, 
strategies, game scores, or player trades.

This category does not include fantasy leagues, sports centers, athletic clubs, fitness 
or martial arts clubs, and non-league billiards, darts, or other such activities.

Stock Trading Web pages that offer purchasing, selling, or trading of shares online.

This category also includes ticker-tape information that enables viewing of real-time 
stock prices and financial spread betting in the stock market. Other betting is in the 
Gambling category.

This category does not include sites that offer information about stocks, but do not 
offer purchasing, selling, or trading of shares.

Streaming Media Web pages that provide streaming media, or contain software plug-ins for 
displaying audio and visual data before the entire file has been transmitted.

This category does not include audio or video files that are downloaded to a user’s 
computer before being played.

Technical Business Forums Web pages with a technical or business focus that provide online message posting 
or real-time chatting, such as technical support or interactive business 
communication.

Although users can post any type of content, these forums tend to present less risk of 
containing offensive content.

Sites that offer a variety of forums with themes, including technical and business 
content, are only in the categories of Forum/Bulletin Boards or Chat.

Table 141   Managed Category Descriptions (continued)
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Technical Information Web pages that provide computing information with an educational focus in areas 
such as Information Technology, computer programming, and certification.

Examples include Linux user groups, UNIX commands, software tutorials, or 
dictionaries of technical terms. Most sites in this category might be subdirectories of 
larger domains. For example, a software site with a tutorial page is in this category 
only at the tutorial page URL.

This category does not include content about information security.

Text Spoken Only Content that is text or audio only, and does not contain pictures.

This category can be used as an exception to allow explicit text and recorded 
material to be accessed when you want pictures blocked using the Pornography, 
Violence, or Sexual Materials categories. Libraries or universities can use this 
category to prevent the display of offensive graphics in their public facilities.

Text Translators Web pages that allow users to type phrases or a block of text to translate it from one 
language into another.

This category also includes language identifier web pages. URL translation is in the 
Anonymizing Utilities category.

Tobacco Web pages that sell, promote, or advocate the use of tobacco products, tobacco 
paraphernalia, including cigarettes, cigars, pipes, snuff and chewing tobacco.

Travel Web pages that promote personal or business travel, such as hotels, resorts, airlines, 
ground transportation, car rentals, travel agencies, and general tourist and travel 
information.

This category also includes sites for buying tickets or accommodation.

This category does not include personal vacation photographs.

Usenet News Web pages that provide access (http://) to Usenet newsgroups and archives of files 
uploaded to newsgroups.

This category also includes online groups that offer similar community-oriented 
content posting.

Violence Web pages that contain real or lifelike images or text that portray, describe, or 
advocate physical assaults against people, animals, or institutions, such as 
depictions of war, suicide, mutilation, or dismemberment.

Visual Search Engine Web pages that provide image-specific search results such as thumbnail pictures.

This category does not include sites that offer site-specific visual search engines.

Weapons Web pages that provide information about buying, making, modifying, or using 
weapons, such as guns, knives, swords, paintball guns, and ammunition, explosives, 
and weapon accessories.

This category also includes sites that contain content for: weapons for personal or 
military use, homemade weapons, non-lethal weapons such as mace, pepper 
spray, or Taser guns, weapons facilities, such as shooting ranges, and government or 
military oriented weapons.

This category does not include political action groups, such as the NRA.

Web Ads Web pages that provide advertisement-hosting or programs that create 
advertisements.

Examples include links, source code or applets for banners, popups, and other kinds 
of static or dynamically generated advertisements that appear on web pages. This 
category is intended to block advertisements on web pages, not the companies 
that provide the advertisements or advertising services.

This category does not include aggressive advertising adware. See the Spyware/
Adware category.

Table 141   Managed Category Descriptions (continued)
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17.2.2  Content Filtering Profile (Allow List)
Click Security Service > Content Filtering > Add/Edit to open the profile screen and scroll to the Allow List 
part. You can create a common list of good (allowed) web site addresses. Use this part of screen to add 
or remove specific sites from the filter list. 

Figure 181   Security Service > Content Filter> Add/Edit Profile (Allow List)

The following table describes the labels in this part of the screen.  

Web Mail Web pages that enable users to send or receive email through the Internet.

Web Meetings Web pages that host live meetings, video conferences, and interactive 
presentations mainly for businesses.

Web meetings generally include streaming audio and video, and allow data 
transfer or office-oriented application sharing, such as online presentations.

Web Phone Web pages that enable users to make telephone calls via the Internet or obtain 
information or software for this purpose.

Web Phone service is also called Internet Telephony, or VoIP. Web phone service 
includes PC-to-PC, PC-to-phone, and phone-to-phone services connecting via TCP/
IP networks.

Unrated Web pages that cannot be categorized into the categories listed above.

Table 141   Managed Category Descriptions (continued)
CATEGORY DESCRIPTION

Table 142   Security Service > Content Filter > Add/Edit Profile (Allow List) 
LABEL DESCRIPTION
Allow HTTP(S) traffic for allow lists 
only

Select this to have the Zyxel Device only allow access to the web sites listed in 
the allow list.

Log A log at the alert level is a log for serious events that may need more immediate 
attention. For example, you may want to know right away if there are clients in 
your networks that try to access adult topics or drugs related web pages.

Select log to have the Zyxel Device generate logs at the info level or select no if 
you don’t want the Zyxel Device to generate logs.

Add Click this to create a new entry. 

Edit Select an entry and click this to be able to modify it. 

Remove Select an entry and click this to delete it. 
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17.2.3  Content Filtering Profile (Block List)
Click Security Service > Content Filtering > Add/Edit to open the profile screen and scroll to the Block List 
part. You can create a common list of bad (blocked) web site addresses. Use this part of the screen to 
add or remove specific sites from the filtering list.

Figure 182   Security Service > Content Filtering > Add/Edit Profile (Block List) 

The following table describes the labels in this screen.  

Name This column displays the trusted web sites already added.

Enter host names such as www.good-site.com into this text field. Do not enter 
the complete URL of the site – that is, do not include “http://”. All subdomains 
are allowed. For example, entering “zyxel.com” also allows “www.zyxel.com”, 
“partner.zyxel.com”, “press.zyxel.com”, and so on. You can also enter just a top 
level domain. For example, enter .com to allow all .com domains.

Use up to 127 characters (0-9a-z-). The casing does not matter. “*” can be used 
as a wildcard to match any string. The entry must contain at least one “.” or it 
will be invalid.

Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.

Save Changes Click this icon to save the changes in this row.

Cancel Changes Click this icon to cancel the changes in this row. 

Table 142   Security Service > Content Filter > Add/Edit Profile (Allow List) (continued)
LABEL DESCRIPTION

Table 143   Security Service > Content Filtering > Add/Edit Profile (Block List) 
LABEL DESCRIPTION
Log A log at the alert level is a log for serious events that may need more immediate 

attention. For example, you may want to know right away if there are clients in 
your networks that try to access adult topics or drugs related web pages.

Select log to have the Zyxel Device generate logs at the info level or select log 
alert to have the Zyxel Device generate logs at the alert level.

Select no if you don’t want the Zyxel Device to generate logs.

Add Click this to create a new entry. 

Edit Select an entry and click this to be able to modify it. 
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17.2.4  Content Filtering Profile (Blocked URL Keywords)
Click Security Service > Content Filtering > Add/Edit to open the profile screen and scroll to the Blocked 
URL keywords part. You can create a common list of bad (blocked) URL keywords to block web sites 
with URLs that contain certain keywords in the domain name or IP address. Use this part of the screen to 
add or remove specific URL keywords from the filter list.

Figure 183   Security Service > Content Filtering > Add/Edit Profile (Blocked URL keywords) 

Remove Select an entry and click this to delete it. 

Name This list displays the forbidden web sites already added.

Enter host names such as www.bad-site.com into this text field. Do not enter the 
complete URL of the site – that is, do not include “http://”. All subdomains are 
also blocked. For example, entering “bad-site.com” also blocks “www.bad-
site.com”, “partner.bad-site.com”, “press.bad-site.com”, and do on. You can 
also enter just a top level domain. For example, enter .com to block all .com 
domains. 

Use up to 127 characters (0-9a-z-). The casing does not matter. “*” can be used 
as a wildcard to match any string. The entry must contain at least one “.” or it 
will be invalid.

Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.

Save Changes Click this icon to save the changes in this row.

Cancel Changes Click this icon to cancel the changes in this row. 

Table 143   Security Service > Content Filtering > Add/Edit Profile (Block List) (continued)
LABEL DESCRIPTION
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The following table describes the labels in this part of the screen.  

17.2.5  Content Filtering Profile (Test Web Site Category)
Click Security Service > Content Filter > Add/Edit to open the profile screen and scroll to the Test Web 
Site Category part.Use this part of the screen to check which category a web page belongs to.

Table 144   Security Service > Content Filtering > Add/Edit Profile (Blocked URL Keywords)dd/Edit Profile 
(Blocked URL keywords)
LABEL DESCRIPTION
Log A log at the alert level is a log for serious events that may need more immediate 

attention. For example, you may want to know right away if there are clients in 
your networks that try to access adult topics or drugs related web pages.

Select log to have the Zyxel Device generate logs at the info level or select log 
alert to have the Zyxel Device generate logs at the alert level.

Select no if you don’t want the Zyxel Device to generate logs.

Add Click this to create a new entry. 

Edit Select an entry and click this to be able to modify it. 

Remove Select an entry and click this to delete it. 

Name This list displays the forbidden keywords already added.

Enter a keyword or a numerical IP address to block. You can also enter a 
numerical IP address.

Use up to 127 case-sensitive characters (0-9a-zA-Z;/?:@&+=$\.-_!~*()%). “*” can 
be used as a wildcard to match any string. Use “|” to indicate a single wildcard 
character.

For example, enter *Bad_Site* to block access to any web page that includes 
the exact phrase (Bad_Site). This does not block access to web pages that only 
include part of the phrase (such as Bad for example). 

Please note that the Zyxel Device checks the URL’s domain name (or IP address) 
and file path separately when performing keyword blocking; see Section 17.1.2 
on page 263 for more information. 

When the Zyxel Device inspects URL queries made by users on your network, the 
Zyxel Device will check both the URL domain name and file path for keywords 
that are blocked. 

Note: When the Zyxel Device inspects DNS queries made by users on 
your network, the Zyxel Device will only check URL domain name 
for keywords that are blocked, but not the file path.

Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.

Save Changes Click this icon to save the changes in this row.

Cancel Changes Click this icon to cancel the changes in this row. 
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Figure 184   Security Service > Content Filtering > Add/Edit Profile (Test Web Site Category) 

The following table describes the labels in this part of the screen.

17.3  Content Filtering Example: Block LAN Users
This example shows you how to block LAN users from using a remote WAN application such as 
TeamViewer.

Client C1 on the Zyxel Device LAN uses computer A. Client C2 on the WAN uses computer B. Computer 
A and computer B are connected to the TeamViewer server (S). Client C1 could access computer B 
using TeamViewer. Client C2 could access computer A using TeamViewer. TeamViewer only works if 
computer A and computer B are both connected to the TeamViewer server (S).

Table 145   Security Service > Content Filtering > Add/Edit Profile (Test Web Site Category)
LABEL DESCRIPTION
Test Web Site Category

URL to test Enter a web site URL in the text box.

When content filtering is active, you should see the web page’s category. The 
query fails if content filtering is not active.

Content Filterilg can query a category by full URL string (for example, http://
www.google.com/picture/index.html), but HTTPS domain filter can only query a 
category by domain name (www.google.com), so the category may be 
different in the query result. URL to test displays both results in the test.

If you think the category is 
incorrect, click this link to submit 
a request to review it.

Click this link to see the category recorded in the Zyxel Device’s content filtering 
database for the web page you specified (if the database has an entry for it).

Apply Click Apply to save your screen changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 
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Figure 185   Content Filter Tutorial Example

You want to block all LAN clients from using TeamViewer. Create a Content Filtering profile that includes 
the remote access category. Create a Content Filtering block list rule with TeamViewer as the keyword. 
Then apply the profile to the LAN_Outgoing security policy.

All LAN clients are now blocked from using TeamViewer.

This example uses the parameters listed below.

1 Go to Security Service > Content Filtering and click Add.

2 Configure the profile settings using the parameters given in Table 146 on page 286.

Table 146   Content Filtering Profile Configuration Example
PROFILE NAME ACTION LOG MANAGED CATEGORIES
NoRemoteAccess Block Log Alert Remote Access

Table 147   Block List Configuration Example
LOG BLOCK LIST KEYWORD
Log Alert *.*teamviewer*.*

Table 148   Security Policy Configuration Example
TO FROM LOG CONTENT FILTERING PROFILE
WAN LAN By Profile NoRemoteAccess
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3 Select the Remote Access checkbox under Managed Categories.

4 Set the block list log action to log alert.

5 Click Add to add a block list rule using the parameters given in Table 147 on page 286.
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6 Click Apply to save your changes.

7 Go to Security Policy > Policy Control. Select LAN_Outgoing then click Edit.

8 Set Content Filter to NoRemoteAccess and Log to by profile. Click Apply to save your changes.
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9 You can check the result in the Policy Control screen. Mouse-over the icon under the Action column to 
check that the NoRemoteAccess profile has been applied to the LAN_Outgoing security policy. You can 
also check the logs in Log & Report > Log / Events. The Zyxel Device will create logs if the clients on the 
Zyxel Device LAN try to access TeamViewer.
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CHAPTER 18
Reputation Filter 

18.1  Overview
Use the Reputation Filter screens to configure settings for IP Reputation, DNS Threat Filter and URL Threat 
filtering.

If a license has expired, you will see a reminder in this screen. You need to renew the license in order to 
keep using the feature. Click Buy Now to go to Marketplace to purchase a new license. Click See 
Details to go to the Zyxel web page to find more information on licenses for your Zyxel Device. 

The following table shows the number of entries allowed in each screen.

18.1.1  What You Need to Know

IP Reputation

IP reputation checks the reputation of an IP address from a database. An IP address with bad 
reputation associates with suspicious activities, such as spam, virus, and/or phishing. The Zyxel Device will 
respond when there are packets coming from an IPv4 address with bad reputation. Supported formats 
are:

• Single IP 4.4.4.4

• CIDR 192.168.1.0/32

• IP range (1.2.3.4-1.2.3.100)

Table 149   Number of Entries Allowed Comparison Table
SCREEN NUMBER OF ENTRIES ALLOWED
IP Reputation > Allow List 256

IP Reputation > Block List 256

IP Reputation > SecuReporter Allow List 1000

DNS Threat Filter > Allow List 1024

DNS Threat Filter > Block List 1024

DNS Threat Filter > SecuReporter Allow List 1000

URL Threat Filter > Allow List 256

URL Threat Filter > Block List 256

URL Threat Filter > SecuReporter Allow List 1000
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DNS Threat Filter

DNS threat filtering inspects DNS queries made by clients on your network and compares the queries 
against a database of blocked or allowed Fully Qualified Domain Names (FQDNs). The Zyxel Device DNS 
Threat Filter will either drop the DNS query or reply to the user with a fake DNS response. URL Threat Filter 

URL threat filtering compares access to specific URLs against a database of blocked or allowed sites. 
Sites on the database are sorted into categories such as:

URL Threat Filter

Supported formats are:

• hostname (www.google.com)

• URL http - check full url (http://xxx.yyy.zzz/qqq/wwww)

• URL https - only check hostname) (https://xxx.yyy.zzz/qqq/wwww)

Allow List

An allow list is a list of entries that will bypass the related feature filtering, and are permitted to pass 
through the Zyxel Device. You can also create allow lists in SecuReporter and view them in the Zyxel 
Device.

Block List

A block  list is a list of entries that will bypass the related feature filtering, but are not permitted to pass 
through the Zyxel Device.

18.1.2  What You Can Do in this Chapter
• Use the IP Reputation screen (Section 18.2 on page 292) to enable IP reputation and specify what 

action the Zyxel Device takes when any IP address with bad reputation is detected.

• Use the DNS Threat Filter screen (Section 18.3 on page 299) to allow the Zyxel Device to inspect DNS 
queries made by clients on your network and specify what action the Zyxel Device takes when a DNS 
query packet contains an FQDN with a bad reputation.

• Use the URL Threat Filter screen (Section 18.4 on page 304) to enable URL Threat filtering and specify 
what action the Zyxel Device takes when any suspicious activity is detected.

18.2  IP Reputation Screen
Use this screen to enable IP reputation and specify the action the Zyxel Device takes when it detects a 
suspicious activity or a connection attempt to or from an IPv4 address with bad reputation.

The priority for IP Reputation checking is as follows:

• Anonymizers • Browser Exploits • Malicious Downloads

• Malicious Sites • Phishing • Spam URLs 

• Spyware Adware Keyloggers
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1 Allow List

2 SecuReporter Allow List

3 Block List

4 External Block List

5 Local Zyxel Device Signatures 

Click Security Service > Reputation Filter > IP Reputation to display the configuration screen as shown 
next.

Figure 186   Security Service > Reputation Filter > IP Reputation 

The following table describes the labels in this screen.

Table 150   Security Service > Reputation Filter > IP Reputation
LABEL DESCRIPTION
IP Blocking

Enable Select this option to turn on IP blocking on the Zyxel Device. Otherwise, clear it.

Action Set what action the Zyxel Device takes when packets come from or go to an IPv4 address 
with bad reputation.

pass: Select this action to have the Zyxel Device allow the packet to go through.

block: Select this action to have the Zyxel Device deny the packets and send a TCP RST to 
both the sender and receiver when a packet comes from an IPv4 address with bad 
reputation. 
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Threat Level 
Threshold

Select the threshold threat level to which the Zyxel Device will take action (high, medium 
and above, Low and above).

The threat level is determined by the IP reputation engine. It grades IPv4 addresses.

• high: An IPv4 address that scores 0 to 20 points.
• medium and above: An IPv4 address that scores 0-60 points.
• Low and above: An IPv4 address that scores 0-80 points.

Log These are the log options:

no: Do not create a log when the packet comes from or goes to an IPv4 address with bad 
reputation.

log: Create a log on the Zyxel Device when the packet comes from or goes to an IPv4 
address with bad reputation.

log alert: An alert is an emailed log for more serious events that may need more immediate 
attention. Select this option to have the Zyxel Device send an alert when the packet comes 
from or goes to an IPv4 address with bad reputation.

Statistics Enable to have the Zyxel Device collect IP reputation statistics. All of the statistics are erased 
if you restart the Zyxel Device or click Flush Data in Security Statistics > Reputation Filter > IP 
Reputation.

Types of Cyber 
Threats Coming From 
The Internet

Select the categories of packets that come from or go to the Internet and are known to 
pose a security threat to users or their computers.

Anonymous 
Proxies

These are sites and proxies that act as an intermediary for surfing to other websites in an 
anonymous fashion, whether to circumvent Web filtering or for other reasons. 

Denial of Service These are sites that issue Denial of Service (DoS) attacks, such as DoS, DDoS, SYN flood, and 
anomalous traffic detection.

DoS attacks can flood your Internet connection with invalid packets and connection 
requests, using so much bandwidth and so many resources that Internet access becomes 
unavailable. The goal of DoS attacks is not to steal information, but to disable a device or 
network on the Internet.

A Distributed Denial of Service (DDoS) attack is one in which multiple compromised systems 
attack a single target, thereby causing denial of service for users of the targeted system.

SYN flood is an attack that attackers flood SYN packets to a server in TCP handshakes, and 
not respond with ACK packets on purpose. This keeps the server waiting for attackers’ 
responses to establish TCP connections, and make the server unavailable.

Anomalous traffic detection could be malicious activities, such as malware outbreaks or 
hacking attempts.

Exploits These are sites that distribute exploits or exploit kits to infect website visitors’ devices. Exploits 
include shellcode, root kits, worms, or viruses that download additional malware to infect 
devices. An exploit kit consists of different exploits.

Negative 
Reputation

These are sites that have bad reputation and associate with suspicious activities, such as 
spam, virus, and/or phishing.

Scanners These are sites that run unauthorized system vulnerabilities scan to look for vulnerabilities in 
website visitors’ devices.

Spam Sources These are sites that have been promoted through spam techniques. 

Table 150   Security Service > Reputation Filter > IP Reputation
LABEL DESCRIPTION
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18.2.1  IP Reputation Allow List
Use this to create allow list entries. The Zyxel Device will allow packets coming from the Internet and 
going out from the local network that match the listed IPv4 addresses. 

Click Security Service > Reputation Filter > IP Reputation (Allow List) to display the configuration screen 
as shown next.

TOR Proxies These are sites that act as the exit nodes in a Tor (The Onion Router) network.

Tor is a service that keep users anonymous in the Internet and make users’ Internet activities 
untraceable. Tor hides user’s real IP addresses by encrypting data and transmitting the 
encrypted data in a chain of selected nodes acting as intermediaries. Each node can only 
decrypt the data sent from the node before it. The first node that receives the encrypted 
data is called the entry node. The last node is the last intermediary that the encrypted data 
will go through before it arrives at the destination.

Web Attacks These are sites that launch web attacks, such as SQL injection, cross site scripting, iframe 
injection, and brute force attack.

SQL injection (SQLI) is an attack that attackers insert malicious SQL (Structured Query 
Language) code into a web application database query. Attackers can then access, add, 
modify, or delete data in users’ databases.

Cross site scripting (XSS) is an attack that attackers injects malicious scripts to websites or 
web applications in the form of HTML or JavaScript code. The scripts execute when users 
visit the infected web page or perform the infected web applications. XSS will cause failures 
to encrypt traffic, cookie stealing, identity impersonation, and phishing.

Iframe injection is an attack that attackers injects malicious iframe (inline frame) tags to 
websites. The malicious iframe tag downloads malware to the devices of the infected 
websites’ visitors, and steal users’ sensitive information. An iframe tag is an HTML tag that is 
used to embed contents from another source in a website, but attackers misuse this feature.

Brute force attack is an attack that attackers attempt to gain access to websites or device 
via a succession of different passwords.

Phishing These are sites that are used for deceptive or fraudulent purposes (e.g. phishing), such as 
stealing financial or other user account information. These sites are most often designed to 
appear as legitimate sites in order to mislead users into entering their credentials. 

Types of Cyber 
Threats Coming From 
The Internet And 
Local Networks

These are packets that come from or go to the Internet and local networks and are known 
to pose a security threat to users or their computers. 

Botnets A botnet is a network consisting of computers that are infected with malware and remotely 
controlled. The infected computers will contact and wait for instructions from a command 
and control (C&C) server. An attacker can control the botnet by setting up a C&C server 
and then sending commands to the infected computers. Alternatively, a peer-to-peer 
network approach is used. The infected computer scans and communicates with the peer 
devices in the same botnet to share commands or malware sent by the C&C server. These 
are botnet sites including command-and-control (C&C) servers.

Test IP Threat Category

IP to test Enter an IPv4 address of a website, and click the Query button to check if the website 
associates with suspicious activities that could pose a security threat to users or their 
computers.

Apply Click Apply to save your changes. 

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 150   Security Service > Reputation Filter > IP Reputation
LABEL DESCRIPTION
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Figure 187   Security Service > Reputation Filter > IP Reputation (Allow List)     

The following table describes the labels in this part of the screen. 

18.2.2  IP Reputation Block List
Use this to create block list entries. The Zyxel Device will block packets coming from the Internet and 
going out from the local network that match the listed IPv4 addresses. 

Click Security Service > Reputation Filter > IP Reputation (Block List) to display the configuration screen 
as shown next.

Table 151   Security Services > Reputation Filter > IP Reputation (Allow List) 
LABEL DESCRIPTION
Enable Select this to bypass checking by this feature (if enabled) and automatically allow:

• incoming packets that come from the listed IPv4 addresses.
• outgoing packets that go to the listed IPv4 addresses.

Log Select log if you want the Zyxel Device to create a log recording when there are 
incoming or outgoing packets that come from or go to the listed IPv4 addresses.

Select no if you don’t want the Zyxel Device to create a log.

Add Click this to create a new entry.

Edit Select an entry and click this to be able to modify it.

Remove Select an entry and click this to delete it.

Active To turn on an entry, select it and click Active.

Inactive To turn off an entry, select it and click Inactive.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the entry is 
inactive. 

IPv4 Address Enter an IPv4 address that will bypass IP Reputation filtering. 

Description Enter a description for this profile.

Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.

Save Changes Click this icon to save the changes in this row.

Cancel Changes Click this icon to cancel the changes in this row. 
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Figure 188   Security Service > Reputation Filter > IP Reputation (Block List)     

The following table describes the labels in this part of the screen.

18.2.3  IP Reputation SecuReporter Allow List
Use this to view SecuReporter allow list entries. To remove an items from this list, you must go to 
SecuReporter. The Zyxel Device will allow packets coming from the Internet and going out from the local 
network that match the listed IPv4 addresses. 

Click Security Service > Reputation Filter > IP Reputation (SecuReporter Allow List) to display the 
configuration screen as shown next.

Table 152   Security Services > Reputation Filter > IP Reputation (Block List) 
LABEL DESCRIPTION
Enable Select this to bypass checking by this feature (if enabled) and automatically block:

• incoming packets coming from the listed IPv4 addresses.
• outgoing packets going to the listed IPv4 addresses.

Log Select log if you want the Zyxel Device to create a log recording when there are 
incoming or outgoing packets that come from or go to the listed IPv4 addresses.

Select no if you don’t want the Zyxel Device to create a log.

Add Click this to create a new entry.

Edit Select an entry and click this to be able to modify it.

Remove Select an entry and click this to delete it.

Active To turn on an entry, select it and click Active.

Inactive To turn off an entry, select it and click Inactive.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the entry is 
inactive.

IPv4 Address Enter an IPv4 address that will be blocked without processing IP Reputation filtering. 

Description Enter a description for this profile.

Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.

Save Changes Click this icon to save the changes in this row.

Cancel Changes Click this icon to cancel the changes in this row. 
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Figure 189   Security Service > Reputation Filter > IP Reputation (SecuReporter Allow List)     

The following table describes the labels in this screen.  

Table 153   Security Services > Reputation Filter > IP Reputation (SecuReporter Allow List) 
LABEL DESCRIPTION
IPv4 Address This read-only table displays the SecuReporter allow list entries.

SecuReporter Allow 
List Information

The Zyxel Device synchronizes with SecuReporter periodically (every 10 minutes at the 
time of writing). 

Last Sync Time This field displays the date and time the Zyxel Device last checked for new SecuReporter 
allow list entries.

Last Update Time This field displays the date and time the Zyxel Device last updated SecuReporter allow list 
entries.

Status This field displays the status of SecuReporter allow list entries: Success, Parse message 
error, HTTP error, Connection timeout and Error. If an error is received, make sure the Zyxel 
Device has Internet access and can connect to the SecuReporter portal. 

Signature Information The following fields display information on the current signature set that the Zyxel Device is 
using.

Current Version This field displays the IP Reputation signature set version number. This number gets larger 
as the set is enhanced.

Release Date This field displays the date and time the set was released.

Update Signatures Click this link to go to the screen you can use to download signatures from the update 
server. 

Apply Click Apply to save your changes. 

Cancel Click Cancel to return the screen to its last-saved settings. 
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18.3  DNS Threat Filter Screen
A Domain Name System (DNS) server records mappings of FQDN (Fully Qualified Domain Names) to IP 
addresses. A FQDN consists of a host and domain name. For example, www.zyxel.com is a fully qualified 
domain name, where “www” is the host, “zyxel” is the second-level domain, and “com” is the top level 
domain.

DNS threat filtering inspects DNS queries made by clients on your network and compares the queries 
against a database of blocked or allowed Fully Qualified Domain Names (FQDNs). 

If a user attempts to connect to a suspect site, where the DNS query packet contains an FQDN with a 
bad reputation, then a DSN query is sent from the user’s computer and detected by the DNS Threat 
Filter.

The Zyxel Device DNS Threat Filter will either drop the DNS query or reply to the user with a fake DNS 
response using the default dnsft.cloud.zyxel.com IP address (where the user will see a “Web Page 
Blocked!” page) or a custom IP address.

The following types of DNS queries are allowed by the Zyxel Device:

• Type “A” for IPv4 addresses

The Zyxel Device replies with a DNS server error for the following types of DNS queries:

• Type “NS” (Name Server) to get information about the authoritative name server

• Type “MX” (Mail eXchange) to request information about the mail exchange server for a specific DNS 
domain name.

• Type “CNAME” (Canonical Names) that specifies a domain name that has to be queried in order to 
resolve the original DNS query

• Type “PTR” (Pointer) that specifies a reverse query (requesting the FQDN corresponding to the IP 
address you provided)

• Type “SOA” (Start Of zone Authority) used when transferring zones

The priority for DNS Threat Filter checking is as follows:

1 Allow List

2 SecuReporter Allow List

3 Block List

4 External Block List

5 Cloud Query Cache

6 Cloud Query

Click Security Service > Reputation Filter > DNS Threat Filter to display the configuration screen as shown 
next.
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Figure 190   Security Service > Reputation Filter > DNS Threat Filter

The following table describes the labels in this screen.

Table 154   Security Service > Reputation Filter > DNS Threat Filter
LABEL DESCRIPTION
DNS Threat Filter

Enable Select this option to turn on DNS threat filtering on the Zyxel Device. Otherwise, clear it. 
Action and Log settings apply to DNS query packets triggered by the security threat 
categories. 

Action Set what action the Zyxel Device takes when there is a DNS query packet containing an 
FQDN with a bad reputation.

redirect: Select this action to have the Zyxel Device reply with a DNS reply packet 
containing a default or custom-defined IP address. 

pass: Select this action to have the Zyxel Device allow the DNS query packet and not reply 
with a DNS reply packet containing a default or custom-defined IP address.

Log These are the log options:

no: Do not create a log when there is a DNS query packet containing an FQDN with a bad 
reputation.

log: Create a log on the Zyxel Device when there is a DNS query packet containing an 
FQDN with a bad reputation.

log alert: An alert is an emailed log for more serious events that may need more immediate 
attention. Select this to have the Zyxel Device send an alert when there is a DNS query 
packet containing an FQDN with a bad reputation.

Redirect IP Select this action to have the Zyxel Device reply with a DNS reply packet containing a 
default or custom-defined IP address when a DNS query packet contains an FQDN with a 
bad reputation. The default IP is the dnsft.cloud.zyxel.com IP address. If you select custom-
defined IP, then enter a valid IPv4 address in the text box. 
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18.3.1  DNS Threat Filter Allow List
Use this to create allow list entries. The Zyxel Device will not reply with a DNS reply packet containing a 
default or custom-defined IP address when a DNS query packet contains an FQDN in the allow list. 

Click Security Service > Reputation Filter > DNS Threat Filter (Allow List) to display the configuration 
screen as shown next.

Action When 
detecting 
malform DNS 
packets 

Set what action the Zyxel Device takes when there is an abnormal DNS query packet. A DNS 
packet is defined as malformed when: 

• The number of entries in the question count field in the DNS header is 0
• An error occurs when parsing the domain name in the question field
• The length of the domain name exceeds 255 characters.

pass: Select this action to have the Zyxel Device allow the DNS query packet through the 
Zyxel Device. 

drop: Select this action to have the Zyxel Device discard the abnormal DNS query packet

Select Log to create a log on the Zyxel Device when there is an abnormal DNS query 
packet.

Statistics Enable to have the Zyxel Device collect DNS threat filter statistics. All of the statistics are 
erased if you restart the Zyxel Device or click Flush Data in Security Statistics > Reputation 
Filter > DNS Threat Filter.

Security Threat 
Categories

Select the categories of FQDNs that may pose a security threat to network devices behind 
the Zyxel Device. 

Anonymizers Sites and proxies that act as an intermediary for surfing to other Web sites in an anonymous 
fashion, whether to circumvent Web filtering or for other reasons. 

Browser Exploits Sites that contain browser exploits. A browser exploit is any content that forces a web 
browser to perform operations that you do not explicitly intend.

Malicious 
Downloads

Sites that have been identified as containing malicious downloads or malware harmful to a 
user's computer.

Malicious Sites Sites that install unwanted software on a user's computer with the intent to enable third-
party monitoring or make system changes without the user's consent. 

Phishing Sites that are used for deceptive or fraudulent purposes, such as stealing financial or other 
user account information. These sites are most often designed to appear as legitimate sites 
in order to mislead users into entering their credentials. 

Spam URLs Sites that have been promoted through spam techniques. 

Spyware Adware 
Keyloggers

Sites that contain spyware, adware or keyloggers.

• Spyware is a program installed on your computer, usually without your explicit 
knowledge, that captures and transmits personal information or Internet browsing habits 
and details to companies. Companies use this information to analyze browsing habits, 
to gather marketing data, and to sell your information to others.

• Key logger programs try to capture and steal your passwords and watch and record 
everything you do on your computer.

• Adware programs typically display blinking advertisements or pop-up windows when 
you perform a certain action. Adware programs are often installed in exchange for 
another service, such as the right to use a program without paying for it.

Test Domain Name Category

Domain name to 
test

Enter an FQDN and click the Query button to check if the domain name is associated with 
suspicious activities that could pose a security threat to users or their computers.

Apply Click Apply to save your changes. 

Reset Click Reset to return the screen to its last-saved settings. 

Table 154   Security Service > Reputation Filter > DNS Threat Filter
LABEL DESCRIPTION
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Figure 191   Security Service > Reputation Filter > DNS Threat Filter (Allow List)     

The following table describes the labels in this screen.  

18.3.2  DNS Threat Filter Block List
Use this to create block list entries. The Zyxel Device will reply with a DNS reply packet containing a 
default or custom-defined IP address when a DNS query packet contains an FQDN in the block list. For 
matched items in the block list, the action is always Redirect IP and log is always log alert.

Click Security Service > Reputation Filter > DNS Threat Filter (Block List) to display the configuration 
screen as shown next.

Table 155   Security Service > Reputation Filter > DNS Threat Filter (Allow List) 
LABEL DESCRIPTION
Enable Select this check box and the Zyxel Device will not reply with a DNS reply packet 

containing a default or custom-defined IP address when a DNS query packet contains an 
FQDN in the white list.

Add Click this to create a new entry. To add an FQDN, type a Fully-Qualified Domain Name 
(FQDN) of a web site. An FQDN starts with a host name and continues all the way up to 
the top-level domain name. For example, www.zyxel.com.tw is a fully qualified domain 
name, where “www” is the host, “zyxel” is the third-level domain, “com” is the second-
level domain, and “tw” is the top level domain. Underscores are not allowed. Use "*." as a 
prefix in the FQDN for a wildcard domain name (for example, *.example.com).

Edit Select an entry and click this to be able to modify it.

Remove Select an entry and click this to delete it.

Active To turn on an entry, select it and click Active.

Inactive To turn off an entry, select it and click Inactive.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the entry is 
inactive.

Allow List Enter an IP address (with CIDR or a range) or a domain name (wildcard permitted) that 
will be allowed without DNS Threat filtering.

Description Enter a description for this profile.

Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.

Save Changes Click this icon to save the changes in this row.

Cancel Changes Click this icon to cancel the changes in this row. 
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Figure 192   Security Service > Reputation Filter > DNS Threat Filter (Block List)

The following table describes the labels in this screen.

18.3.3  DNS Threat Filter SecuReporter Allow List
Use this to view SecuReporter allow list entries. To remove an items from this list, you must go to 
SecuReporter. The Zyxel Device will not reply with a DNS reply packet containing a default or custom-
defined IP address when a DNS query packet contains an FQDN in the allow list. 

Click Security Service > Reputation Filter > DNS Threat Filter _SecuReporter Allow List to display the 
configuration screen as shown next.

Table 156   Security Service > Reputation Filter > DNS Threat Filter (Block List) 
LABEL DESCRIPTION
Block List

Enable Select this check box and the Zyxel Device will reply with a DNS reply packet containing a 
default or custom-defined IP address when a DNS query packet contains an FQDN in the 
black list.

Add Click this to create a new entry. To add an FQDN, type a Fully-Qualified Domain Name 
(FQDN) of a web site. An FQDN starts with a host name and continues all the way up to 
the top-level domain name. For example, www.zyxel.com.tw is a fully qualified domain 
name, where “www” is the host, “zyxel” is the third-level domain, “com” is the second-
level domain, and “tw” is the top level domain. Underscores are not allowed. Use "*." as a 
prefix in the FQDN for a wildcard domain name (for example, *.example.com).

Edit Select an entry and click this to be able to modify it.

Remove Select an entry and click this to delete it.

Active To turn on an entry, select it and click Active.

Inactive To turn off an entry, select it and click Inactive.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the entry is 
inactive.

Block List Enter an IP address (with CIDR or a range) or a domain name (wildcard permitted) that 
will be blocked without DNS Threat filtering.

Description Enter a description for this profile.

Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.

Save Changes Click this icon to save the changes in this row.

Cancel Changes Click this icon to cancel the changes in this row. 
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Figure 193   Security Service > Reputation Filter > DNS Threat Filter_SecuReporter Allow List     

The following table describes the labels in this screen.  

18.4  URL Threat Filter Screen
The Zyxel Device will access the Cloud Query database, that has millions of web sites categorized based 
on content. You can have the Zyxel Device allow, block, warn and/or log access to web sites or hosts 
based on these categories.

The priority for URL Threat checking is as follows:

1 Allow List

2 SecuReporter Allow List

3 Block List

4 External Block List

Table 157   Security Services > Reputation Filter > DNS Threat Filter_SecuReporter Allow List 
LABEL DESCRIPTION
Allow List This read-only table displays the SecuReporter allow list entries.

SecuReporter Allow 
List Information

Last Sync Time This field displays the date and time the Zyxel Device last checked for new SecuReporter 
allow list entries.

Last Update Time This field displays the date and time the Zyxel Device last updated SecuReporter allow list 
entries.

Status This field displays the status of SecuReporter allow list entries: Success, Parse message 
error, HTTP error, Connection timeout and Error. If an error is received, make sure the Zyxel 
Device has Internet access and can connect to the SecuReporter portal. 

Apply Click Apply to save your changes. 

Cancel Click Cancel to return the screen to its last-saved settings. 
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5 Cloud Query Cache

6 Cloud Query

Use this screen to enable URL Threat filtering and specify the action the Zyxel Device takes when it 
detects a suspicious activity or a connection attempt to or from a site in a selected category.

Click Security Service > Reputation Filter > URL Threat Filter to display the configuration screen as shown 
next. 

Figure 194   Security Service > Reputation Filter > URL Threat Filter

The following table describes the labels in this screen.

Table 158   Security Service > Reputation Filter > URL Threat Filter
LABEL DESCRIPTION
URL Blocking

Enable Select this option to turn on URL blocking on the Zyxel Device.

Action Set what action the Zyxel Device takes when it detects a connection attempt to or from the 
web pages of the specified categories.

block: Select this action to have the Zyxel Device block access to the web pages that 
match the categories that you select above. 

pass: Select this action to have the Zyxel Device allow access to the web pages that match 
the categories that you select above.
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Log These are the log options:

• no: Do not create a log when it detects a connection attempt to or from the web 
pages of the specified categories.

• log: Create a log on the Zyxel Device when it detects a connection attempt to or from 
the web pages of the specified categories.

• log alert: An alert is an emailed log for more serious events that may need more 
immediate attention. Select this option to have the Zyxel Device send an alert when a 
connection matches web pages of the specified categories.

Statistics Enable to have the Zyxel Device collect URL threat filter statistics. All of the statistics are 
erased if you restart the Zyxel Device or click Flush Data in Security Statistics > Reputation 
Filter > URL Threat Filter.

Message to display when a site is blocked

Denied Access 
Message

Enter a message to be displayed when the URL Threat filter blocks access to a web page. 
Use up to 127 characters (0-9a-zA-Z;/?:@&=+$\.-_!~*'()%,”). For example, “Access to this 
web page is not allowed. Please contact the network administrator”.

It is also possible to leave this field blank if you have a URL specified in the Redirect URL field. 
In this case if the URL Threat filter blocks access to a web page, the Zyxel Device just opens 
the web page you specified without showing a denied access message.

Redirect URL Enter the URL of the web page to which you want to send users when their web access is 
blocked by the URL Threat filter. The web page you specify here opens in a new frame 
below the denied access message. 

Use “http://” or “https://” followed by up to 262 characters (0-9a-zA-Z;/?:@&=+$\.-_!~*'()%). 
For example, http://192.168.1.17/blocked access.

Security Threat 
Categories

Select the categories of web pages that may pose a security threat to network devices 
behind the Zyxel Device. 

Anonymizers Sites and proxies that act as an intermediary for surfing to other Web sites in an anonymous 
fashion, whether to circumvent Web filtering or for other reasons. 

Browser Exploits Sites that contain browser exploits. A browser exploit is any content that forces a web 
browser to perform operations that you do not explicitly intend.

Malicious 
Downloads

Sites that have been identified as containing malicious downloads or malware harmful to a 
user's computer.

Malicious Sites Sites that install unwanted software on a user's computer with the intent to enable third-
party monitoring or make system changes without the user's consent. 

Phishing Sites that are used for deceptive or fraudulent purposes, such as stealing financial or other 
user account information. These sites are most often designed to appear as legitimate sites 
in order to mislead users into entering their credentials. 

Spam URLs Sites that have been promoted through spam techniques. 

Spyware Adware 
Keyloggers

Sites that contain spyware, adware or keyloggers.

• Spyware is a program installed on your computer, usually without your explicit 
knowledge, that captures and transmits personal information or Internet browsing habits 
and details to companies. Companies use this information to analyze browsing habits, 
to gather marketing data, and to sell your information to others.

• Key logger programs try to capture and steal your passwords and watch and record 
everything you do on your computer.

• Adware programs typically display blinking advertisements or pop-up windows when 
you perform a certain action. Adware programs are often installed in exchange for 
another service, such as the right to use a program without paying for it.

Test URL Threat 
Category

URL to test Enter a URL using http://domain or https://domain and click the Query button to check if 
the domain belongs to a URL threat category.

Table 158   Security Service > Reputation Filter > URL Threat Filter
LABEL DESCRIPTION
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18.4.1  URL Threat Filter Allow List
Use this to create allow list entries. The Zyxel Device will allow incoming packets from the listed IPv4 
addresses and URLs. 

Click Security Service > Reputation Filter > URL Threat Filter (Allow List) to display the configuration screen 
as shown next.

Figure 195   Security Service > Reputation Filter > URL Threat Filter (Allow List)     

The following table describes the labels in this screen.  

Apply Click Apply to save your changes. 

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 158   Security Service > Reputation Filter > URL Threat Filter
LABEL DESCRIPTION

Table 159   Security Service > Reputation Filter > URL Threat Filter_Allow List 
LABEL DESCRIPTION
Enable Select this to bypass checking by this feature (if enabled) and automatically allow 

packets from the listed IPv4 addresses and URLs.

Log These are the log options:

• no: Do not create a log when the Zyxel Device detects a connection attempt to or 
from the web pages of the specified categories listed in the allow list.

• log: Create a log on the Zyxel Device when it detects a connection attempt to or 
from the web pages of the specified categories listed in the allow list.

Add Click this to create a new entry.

Remove Select an entry and click this to delete it.

Allow List Enter an IP address (with CIDR or a range) or a domain name (wildcard permitted) that 
will be allowed without URL Threat filtering.

Description Enter a description for this profile.

Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.

Save Changes Click this icon to save the changes in this row.

Cancel Changes Click this icon to cancel the changes in this row. 
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18.4.2  URL Threat Filter Block List
Use this to create block list entries. The Zyxel Device will block incoming packets from the listed URLs. 

Click Security Service > Reputation Filter > URL Threat Filter (Block List) to display the configuration screen 
as shown next. 

Figure 196   Security Service > Reputation Filter > URL Threat Filter (Block List)

The following table describes the labels in this screen.  

18.4.3  URL Threat Filter SecuReporter Allow List
Use this to view SecuReporter allow list entries. To remove an items from this list, you must go to 
SecuReporter. The Zyxel Device will allow packets coming from the Internet and going out from the local 
network that match the listed URLs. 

Table 160   Security Service > Reputation Filter > URL Threat Filter_Block List 
LABEL DESCRIPTION
Enable Select this to bypass checking by this feature (if enabled) and automatically block 

packets from the listed IPv4 addresses and URLs.

Log These are the log options:

• no: Do not create a log when it detects a connection attempt to or from the web 
pages of the specified categories listed in the block list.

• log: Create a log on the Zyxel Device when it detects a connection attempt to or 
from the web pages of the specified categories listed in the block list.

• log alert: An alert is an emailed log for more serious events that may need more 
immediate attention. Select this option to have the Zyxel Device send an alert when a 
connection matches web pages of the specified categories listed in the block list.

Add Click this to create a new entry.

Remove Select an entry and click this to delete it.

Block List Enter an IP address (with CIDR or a range) or a domain name (wildcard permitted) that 
will be blocked without URL Threat filtering.

Description Enter a description for this profile.

Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.

Save Changes Click this icon to save the changes in this row.

Cancel Changes Click this icon to cancel the changes in this row. 
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Click Security Service > Reputation Filter > URL Threat Filter _SecuReporter Allow List to display the 
configuration screen as shown next.

Figure 197   Security Service > Reputation Filter > URL Threat Filter_SecuReporter Allow List     

The following table describes the labels in this screen.  

Table 161   Security Services > Reputation Filter > URL Threat Filter_SecuReporter Allow List 
LABEL DESCRIPTION
Allow List This read-only table displays the SecuReporter allow list entries.

SecuReporter Allow 
List Information

Last Sync Time This field displays the date and time the Zyxel Device last checked for new SecuReporter 
allow list entries.

Last Update Time This field displays the date and time the Zyxel Device last updated SecuReporter allow list 
entries.

Status This field displays the status of SecuReporter allow list entries: Success, Parse message 
error, HTTP error, Connection timeout and Error. If an error is received, make sure the Zyxel 
Device has Internet access and can connect to the SecuReporter portal. 

Apply Click Apply to save your changes. 

Cancel Click Cancel to return the screen to its last-saved settings. 
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CHAPTER 19
Anti-Malware 

19.1  Overview
Malware is short for malicious software, such as computer viruses, worms and spyware. The Zyxel Device 
anti-malware feature protects your connected network from malware by scanning traffic coming in 
from the WAN and going out from the WAN. The traffic scanned by the Zyxel Device may include FTP 
traffic and email with attachments. 

Figure 198   Zyxel Device Anti-Malware Example   

The Zyxel Device queries the Defend Center database by sending the file’s has value (A) and receiving 
the scan results (B) through the Defend Center (DC)

Figure 199   Cloud Query
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Viruses, Worms, and Spyware

A computer virus is a type of malicious software designed to corrupt and/or alter the operation of other 
legitimate programs. A worm is a self-replicating virus. Spyware infiltrates your device to secretly gather 
information, such as your network activity, passwords, bank details, and so on.

The following describes a simple life cycle of malware. 

1 A computer gets a copy of malware from a source such as the Internet, email, file sharing or any 
removable storage media. The malware is harmless until the execution of an infected program. 

2 The malware spreads to other files and programs on the computer. 

3 The infected files are unintentionally sent to another computer thus starting the spread of the malware. 

4 Once the malware is spread through the network, the number of infected networked computers can 
grow exponentially. 

Types of Malware

The following table describes some of the common malware. 

Hash Value

A hash function is an algorithm that maps data of arbitrary size to data of fixed size. The value returned 
by a hash function is a hash value. Hash values can be used to identify if the contents of a file have 
changed. At the time of writing, the MD5 (Message Digest 5) hash algorithm is supported.

Anti-Malware Scan Process

Before going through the Anti-Malware scan, the Zyxel Device first identifies the packets sent by the 
following four major protocols with corresponding standard ports:

• FTP (File Transfer Protocol)

• HTTP (Hyper Text Transfer Protocol)

Table 162   Common Malware Types 
TYPE DESCRIPTION
File Infector This is a small program that embeds itself in a legitimate program. A file infector is able to 

copy and attach itself to other programs that are executed on an infected computer. 

Boot Sector Virus This type of virus infects the area of a hard drive that a computer reads and executes 
during startup. The virus causes computer crashes and to some extend renders the infected 
computer inoperable. 

Macro Virus Macro viruses or Macros are small programs that are created to perform repetitive actions. 
Macros run automatically when a file to which they are attached is opened. Macros 
spread more rapidly than other types of viruses as data files are often shared on a network. 

Email Virus Email viruses are malicious programs that spread through email. 

Polymorphic Virus A polymorphic virus (also known as a mutation virus) tries to evade detection by changing 
a portion of its code structure after each execution or self replication. This makes it harder 
for an anti-malware scanner to detect or intercept it. 

A polymorphic virus can also belong to any of the virus types discussed above. 
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• SMTP (Simple Mail Transfer Protocol) 

• POP3 (Post Office Protocol version 3)

The Zyxel Device records the orders of packets in TCP connection-oriented sessions to check for 
matching malware signatures. The order of non-setup packets such as SYN, ACK and FIN is ignored.

Anti-Malware Scanning Procedure:

1 The Zyxel Device uses Cloud Query to forward the file’s MD5 hash value to Defend Center. 

2 If the MD5 hash value is incorrect, then the last packet of the file is removed. The file is still forwarded to 
the receiver, but they will not be able to open it. You can configure to receive an alert or log when this 
happens. 

Note: The receiver is not notified if a file is modified by the Zyxel Device. If the file cannot be 
used, the receiver should contact the Zyxel Device administrator to confirm if the Zyxel 
Device modified the file by checking the logs.

File Scanning Cloud Query Supported File Types

At the time of writing, the following file types are supported: 

Notes About the Zyxel Device Anti-Malware

The following lists important notes about the Zyxel Device’s anti-malware feature:

1 Zyxel’s anti-malware feature can detect polymorphic malware (see Section 19.1 on page 310). 

2 When malware is detected, a log is created or an alert message is sent to the administrator depending 
on your log settings. 

3 Changes to the Zyxel Device’s anti-malware settings only affect new sessions, not sessions that already 
existed before you applied the changed settings.

4 Enabling Cloud Query may affect file transfer speeds.

5 The Zyxel Device does not scan the following file/traffic types:

• Simultaneous downloads of a file using multiple connections. For example, when you use FlashGet 
to download sections of a file simultaneously. 

Table 163   File Scanning Cloud Query Supported File Types
• 7z Archive (7z) • AVI Video (avi) • BMP Image (bmp) • BZ2 Archive (bz2)

• Executables (exe) • Macromedia Flash 
Data (swf)

• GIF Image (gif) • GZ Archive (gz)

• JPG Image (jpg) • MOV Video (mov) • MP3 Audio (mp3) • MPG Video (mpg)

• MS Office 
Document (doc...)

• PDF Document 
(pdf)

• PNG Image (png) • RAR Archive (rar)

• RM Video (rm) • RTF Document (rtf) • TIFF Image (tif) • WAV Audio (wav)

• ZIP Archive (zip)
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• Encrypted traffic. This could be password-protected files or VPN traffic where the Zyxel Device is not 
the endpoint (pass-through VPN traffic). 

• Traffic through custom (non-standard) ports. The Zyxel Device scans whatever port number is 
specified for FTP in the ALG screen.

Finding Out More
• See Section 19.5 on page 319 for anti-malware background information.

19.1.1  What You Can Do in this Chapter
• Use the Anti-Malware screen (Section 19.2 on page 313) to turn anti-malware on or off. In addition, 

you can set up anti-malware blocked and allowed lists to bypass anti-malware checking. 

• Use the Allow List screen (Section 19.3 on page 315) to specify the file or encryption pattern to allow in 
order to avoid false positives.

• Use the Block List screen (Section 19.4 on page 317) to specify the file or encryption pattern that you 
want to block. 

19.2  Anti-Malware Screen
Click Security Service > Anti-Malware to display the configuration screen as shown next.

If a license has expired, you will see a reminder in this screen. You need to renew the license in order to 
keep using the feature. Click Buy Now to go to Marketplace to purchase a new license. Click See 
Details to go to the Zyxel web page to find more information on licenses for your Zyxel Device. 

Click the Anti-Malware icon for more information on the Zyxel Device’s security features.

Note: See Section  on page 100 for more information on the subscription services for the two 
types of security packs.

Note: If Destroy infected file is disabled and log is set to no, the Zyxel Device will still perform 
the scan but will not do anything else. It is recommended to enable at least one of the 
two functions.

If Destroy infected file is disabled, any malicious file found can still be 
executed by the end user after it is forwarded. The administrator would 
have to inform the user if there is an infected file.
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Figure 200   Security Service > Anti-Malware 

The following table describes the labels in this screen.

Table 164   Security Service > Anti-Malware 
LABEL DESCRIPTION
General Setting

Enable Click to activate the anti-malware feature to protect your connected network from 
infection and the installation of malicious software. 

Collect Statistics Click to have the Zyxel Device collect anti-malware statistics. All of the statistics are erased if 
you restart the Zyxel Device or click Flush Data in Security Statistics > Anti-Malware.

Scan and detect 
EICAR test virus

Click to have the Zyxel Device check for an EICAR test file and treat it in the same way as a 
real malware file.

The EICAR test file is a standardized test file for signature based anti-malware scanners. 
When the scanner detects the EICAR file, it responds in the same way as if it found real 
malware. The EICAR file can also be compressed to test whether the anti-malware software 
can detect it in a compressed file. The test string consists of the following human-readable 
ASCII characters.

X5O!P%@AP[4\PZX54(P^)7CC)7}$EICAR-STANDARD-ANTIVIRUS-TEST-FILE!$H+H*

File size limit Set the limit of the file size the Zyxel Device anti-malware will scan. A file that exceeds the file 
size you set here will pass without been scanned by the Zyxel Device anti-malware. 

Destroy infected file When you select this check box, if a malware signature is matched, the Zyxel Device 
overwrites the infected portion of the file with zeros before being forwarded to the user. The 
uninfected portion of the file will pass through unmodified.
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19.3  The Allow List Screen
A allow list allows you to specify an MD5 hash or file pattern to ignore in order to avoid false positives. 
False positives occur when a non-infected file matches a malware signature.

Enter a file or encryption pattern that would cause the Zyxel Device to allow this file.

Click Security Service > Anti-Malware > Allow List to display the following screen. Use Add to put a new 
entry in the list or Edit to change an existing one or Remove to delete an existing entry.

Figure 201   Security Service > Anti-Malware > Allow List

Log These are the log options:

• no: Do not create a log when a packet matches a signature.
• log: Create a log on the Zyxel Device when a packet matches a signature.
• log alert: An alert is an emailed log for more serious events that may need more 

immediate attention. Select this option to have the Zyxel Device send an alert when a 
packet matches a signature(s).

File Type for Scan File types that can be checked by the Zyxel Device are listed here. Note that the files on this 
list are currently bypassed. To use this feature on a specific file type, click this file type and 
then click the right arrow button.

See available file types in Table 163 on page 312.

Apply Click Apply to save your changes. 

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 164   Security Service > Anti-Malware (continued)
LABEL DESCRIPTION
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The following table describes the fields in this screen.

Table 165   Security Service > Anti-Malware > Allow List
LABEL DESCRIPTION
Enable Allow List Select this to bypass checking by this feature (if enabled) and automatically allow incoming 

files with names or hash value (MD5 Hash) that match the white list patterns.

Log These are the log options:

• no: Do not create a log when a packet matches a signature.
• log: Create a log on the Zyxel Device when a packet matches a signature.

MD5 Hash Configure the settings to automatically allow incoming files with MD5 Hash value that match 
the patterns you set. An MD5 hash can consist of 32 alpha-numerical characters.

Add Click this to create a new entry.

Remove Select an entry and click this to delete it. 

Active To turn on an entry, select it and click Active.

Inactive To turn off an entry, select it and click Inactive.

Column ( ) Click the column icon to select the fields you want to show in the table. Uncheck the 
checkbox if you want to hide a field in the table.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the entry is 
inactive.

Value This field displays the hash pattern of the entry.

Enter the hash pattern for this entry. Specify a pattern to identify the names of files that the 
Zyxel Device should not scan for viruses.

Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.

Save Changes Click this icon to save the changes in this row.

Cancel 
Changes

Click this icon to cancel the changes in this row. 

File Name Pattern Configure the settings to automatically allow incoming files with names that match the 
patterns you set.

Add Click this to create a new entry.

Remove Select an entry and click this to delete it. 

Active To turn on an entry, select it and click Active.

Inactive To turn off an entry, select it and click Inactive.

Column ( ) Click the column icon to select the fields you want to show in the table. Uncheck the 
checkbox if you want to hide a field in the table.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the entry is 
inactive.
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19.4  The Block List Screen
A block list allows you to specify a specific MD5 hash or file pattern that you want to block. 

Enter a file or encryption pattern that would cause the Zyxel Device to log and then destroy this file.

Click Security Service > Anti-Malware > Block List to display the following screen. Use Add to put a new 
entry in the list or Edit to change an existing one or Remove to delete an existing entry.

Name This field displays the file pattern of the entry.

Enter the file pattern for this entry. Specify a pattern to identify the names of files that the Zyxel 
Device should not scan for viruses.

• Use up to 80 characters. Alphanumeric characters, underscores (_), dashes (-), question 
marks (?) and asterisks (*) are allowed.

• A question mark (?) lets a single character in the file name vary. For example, use “a?.zip” 
(without the quotation marks) to specify aa.zip, ab.zip and so on. 

• Wildcards (*) let multiple files match the pattern. For example, use “*a.zip” (without the 
quotation marks) to specify any file that ends with “a.zip”. A file named “testa.zip would 
match. There could be any number (of any type) of characters in front of the “a.zip” at 
the end and the file name would still match. A file named “test.zipa” for example would 
not match. 

• A * in the middle of a pattern has the Zyxel Device check the beginning and end of the 
file name and ignore the middle. For example, with “abc*.zip”, any file starting with “abc” 
and ending in “.zip” matches, no matter how many characters are in between.

• The whole file name has to match if you do not use a question mark or asterisk. 
• If you do not use a wildcard, the Zyxel Device checks up to the first 80 characters of a file 

name.

Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.

Save Changes Click this icon to save the changes in this row.

Cancel 
Changes

Click this icon to cancel the changes in this row. 

Table 165   Security Service > Anti-Malware > Allow List
LABEL DESCRIPTION
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Figure 202   Security Service > Anti-Malware > Block List

The following table describes the fields in this screen.

Table 166   Security Services > Anti-Malware > Block/Allow List > Block List
LABEL DESCRIPTION
Enable Block List Select this to bypass checking by this feature (if enabled) and automatically block incoming 

files with names or hash value (MD5 Hash) that match the block list patterns.

Log These are the log options:

• no: Do not create a log when a packet matches a signature.
• log: Create a log on the Zyxel Device when a packet matches a signature.

MD5 Hash Configure the settings to automatically block incoming files with MD5 Hash value that match 
the patterns you set. An MD5 hash can consist of 32 alpha-numerical characters.

Add Click this to create a new entry.

Remove Select an entry and click this to delete it. 

Active To turn on an entry, select it and click Active.

Inactive To turn off an entry, select it and click Inactive.

Column ( ) Click the column icon to select the fields you want to show in the table. Clear the check box 
if you want to hide a field in the table.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the entry is 
inactive.

Value This field displays the hash pattern of the entry.

Enter the hash pattern for this entry. Specify a pattern to identify the names of files that the 
Zyxel Device should not scan for viruses.

Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.
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19.5  Anti-Malware Technical Reference

Types of Anti-Malware Scanner 

The section describes two types of anti-malware scanner: host-based and network-based. 

Save Changes Click this icon to save the changes in this row.

Cancel 
Changes

Click this icon to cancel the changes in this row. 

File Name Pattern Configure the settings to automatically block incoming files with names that match the 
patterns you set.

Add Click this to create a new entry.

Remove Select an entry and click this to delete it. 

Active To turn on an entry, select it and click Active.

Inactive To turn off an entry, select it and click Inactive.

Column ( ) Click the column icon to select the fields you want to show in the table. Uncheck the 
checkbox if you want to hide a field in the table.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the entry is 
inactive.

Value This field displays the file pattern of the entry.

Enter the file pattern for this entry. Specify a pattern to identify the names of files that the Zyxel 
Device should not scan for viruses.

• Use up to 80 characters. Alphanumeric characters, underscores (_), dashes (-), question 
marks (?) and asterisks (*) are allowed.

• A question mark (?) lets a single character in the file name vary. For example, use “a?.zip” 
(without the quotation marks) to specify aa.zip, ab.zip and so on. 

• Wildcards (*) let multiple files match the pattern. For example, use “*a.zip” (without the 
quotation marks) to specify any file that ends with “a.zip”. A file named “testa.zip would 
match. There could be any number (of any type) of characters in front of the “a.zip” at 
the end and the file name would still match. A file named “test.zipa” for example would 
not match. 

• A * in the middle of a pattern has the Zyxel Device check the beginning and end of the 
file name and ignore the middle. For example, with “abc*.zip”, any file starting with “abc” 
and ending in “.zip” matches, no matter how many characters are in between.

• The whole file name has to match if you do not use a question mark or asterisk. 
• If you do not use a wildcard, the Zyxel Device checks up to the first 80 characters of a file 

name.

Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.

Save Changes Click this icon to save the changes in this row.

Cancel 
Changes

Click this icon to cancel the changes in this row. 

Table 166   Security Services > Anti-Malware > Block/Allow List > Block List
LABEL DESCRIPTION
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A host-based anti-malware (HAM) scanner is often software installed on computers and/or servers on 
the network. It inspects files for malware patterns as they are moved in and out of the drive. However, 
host-based anti-malware scanners cannot eliminate all malware for a number of reasons:

• HAM scanners are slow in stopping malware threats through real-time traffic (such as from the 
Internet). 

• HAM scanners may reduce computing performance as they also share resources (such as CPU time) 
on the computer for file inspection. 

• You have to update the malware signatures and/or perform malware scans on all computers on the 
network regularly.

Note: The Zyxel Device does not support host-based anti-malware (HAM).

A network-based anti-malware (NAM) scanner is often deployed as a dedicated security device (such 
as your Zyxel Device) on the network edge. NAM scanners inspect real-time data traffic (such as email 
messages or web) that tends to bypass HAM scanners. The following lists some of the benefits of NAM 
scanners. 

• NAM scanners stop malware threats at the network edge before they enter or exit a network. 

• NAM scanners reduce computing loading on computers as the read-time data traffic inspection is 
done on a dedicated security device.
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CHAPTER 20
Sandbox 

20.1  Overview
Zyxel sandbox is a security mechanism which provides a safe environment to separate running 
programs from your network and host devices. Files with unknown or untrusted programs and codes are 
uploaded to the cloud. These files are executed within an isolated virtual machine (VM) to monitor and 
analyze the zero-day malware and advanced persistent threats (APTs). The zero-day malware refers to 
malware that is unknown to any software vendor or developer. It is dangerous because there is no 
available defenses against it at the time of discovery.

The zero-day malware and APTs may evade the Zyxel Device’s detection, such as anti-malware. Results 
of cloud sandbox are sent from the server to the Zyxel Device.

After checking the received files against its local cache, the Zyxel Device sandbox uploads a copy of 
the files for inspection if the files are not recorded in the local cache. The scan result from the cloud is 
added to the Zyxel Device cache and used for future inspection. When a file with malicious or suspicious 
code is detected, the Zyxel Device takes specific actions on the threats.

By default, the Zyxel Device sandbox forwards all files that have not been checked before to the clients 
behind the Zyxel Device. 

Note: The scan results will be removed from the Zyxel Device cache after the Zyxel Device 
restarts. When the scan results stored reach the limit, new scan results automatically 
overwrite existing scan results, starting with the oldest scan result first.

Figure 203   Zyxel Sandbox Inspection

20.1.1  What You Need to Know
The Zyxel Device forwards files that are not recorded in the local cache to the client behind the Zyxel 
Device before sandbox has completed checking. The scan result will display in Log & Report > Log/
Events. We suggest you to inform your client not to open the file until sandbox has completed checking. 
If the client already opened it, then please urge the client to run an up-to-date anti-malware scanner.
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If the receiver of a suspect file cannot open a file, sandbox may have already modified the file by 
deleting the infected portion. Please check the logs and let the receiver know if this is so.

Sandbox can only check the types of files listed under File Submission Options in the Sandbox screen. If 
you disabled Scan and detect EICAR test virus in the Anti-Malware screen, then EICAR test files will be 
sent to sandbox.

To use the sandbox, you need to register your Zyxel Device and activate the service license at NCC, 
and then turn on the sandbox function on the Zyxel Device. See Chapter 6 on page 100 for more 
information about registration and service licenses.

20.2  Sandbox Screen
Click Security Service > Sandbox to display the configuration screen as shown next. 

If a license has expired, you will see a reminder in this screen. You need to renew the license in order to 
keep using the feature. Click Buy Now to go to Marketplace to purchase a new license. Click See 
Details to go to the Zyxel web page to find more information on licenses for your Zyxel Device. 

Use this screen to enable sandbox and specify the actions the Zyxel Device takes when malicious or 
suspicious files are detected.
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Figure 204   Security Service > Sandbox

The following table describes the labels in this screen.

Table 167   Security Service > Sandbox 
LABEL DESCRIPTION
General

Enable Sandbox Select this option to turn on sandbox if you have a license and have activated it on the 
Zyxel Device. Otherwise, deselect it.

Collect Statistics Enable to have the Zyxel Device collect sandbox statistics, such as the time, type and name 
of the files scanned. The statistics collected will display in Security Statistics > Sandbox. All of 
the statistics are erased if you restart the Zyxel Device or click Flush Data in Security Statistics 
> Sandbox.

Action For Malicious 
File

Specify whether the Zyxel Device deletes (destroy) or forwards (allow) malicious files. 
Malicious files are files given a high score for malware characteristics by the cloud. You can 
check the medium score for malware characteristics given by the cloud in the logs.

Log For Malicious File These are the log options for malicious files:

• no: Do not create a log when a malicious file is detected.
• log: Create a log on the Zyxel Device when a malicious file is detected.
• log alert: An alert is an emailed log. Select this option to have the Zyxel Device send an 

alert when a malicious file is detected.
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Action For Suspicious 
File

Specify whether the Zyxel Device deletes (destroy) or forwards (allow) suspicious files. 
Suspicious files are files given a medium score for malware characteristics by the cloud. You 
can check the medium score for malware characteristics given by the cloud in the logs.

Log For Suspicious 
File

These are the log options for suspicious files:

no: Do not create a log when a suspicious file is detected.

log: Create a log on the Zyxel Device when a suspicious file is detected.

log alert: An alert is an emailed log for more serious events that may need more immediate 
attention. Select this option to have the Zyxel Device send an alert when a suspicious file is 
detected.

File Submission 
Options

Specify the type of files to be sent for sandbox inspection.

• Executables (exe): An executable file is a file that contains a program or application 
which your computer can run

• MS Office Document (doc...): This category includes Microsoft Word files, Microsoft Excel 
files and Microsoft PowerPoint files. MS Office Document are files that are created using 
software developed by Microsoft.

• Macromedia Flash Data (swf): A flash file (.swf) is a file that contains animations, 
multimedia elements or games. A flash file is often embedded into a web page.

• PDF Document (pdf): A Portable Document Format (PDF) file is a file that maintains the 
presentation and formatting of documents across different platform and devices.

• RTF Document (rtf): A Rich Text Format (RTF) file is a file that allows you to create text with 
different formats, such as bold or italics.

• ZIP Archive (zip): A zip file is a file used to compress multiple files together into a single 
file. A zip file can reduce the overall size of a collection of files.

Apply Click Apply to save your changes. 

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 167   Security Service > Sandbox (continued)
LABEL DESCRIPTION
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CHAPTER 21
IPS 

21.1  Overview
This chapter introduces packet inspection IPS (Intrusion Prevention System), custom signatures, and 
updating signatures. An IPS system can detect malicious or suspicious packets and respond 
instantaneously by rejecting or dropping the packets. The Zyxel Device IPS protects your network against 
network-based intrusions. 

21.1.1  What You Can Do in this Chapter
• Use the Security Service > IPS screen (Section 21.2 on page 326) to view registration and signature 

information. 

• Use the Security Service > IPS > Allow List screen (Section 21.3 on page 334) to list signatures that will 
be exempted from IPS inspection. 

21.1.2  What You Need To Know

Packet Inspection Signatures

A signature is a pattern of malicious or suspicious packet activity. You can specify an action to be taken 
if the system matches a stream of data to a malicious signature. You can change the action in the 
profile screens. Packet inspection examine OSI (Open System Interconnection) layer-4 to layer-7 packet 
contents for malicious data. Generally, packet inspection signatures are created for known attacks 
while anomaly detection looks for abnormal behavior.

Rate Based Signatures

While IPS signatures have the Zyxel Device respond instantaneously, Rate Based Signatures are IPS 
signatures that allow the Zyxel Device to just respond after a number of occurrences (Count) within a 
certain time period (Period) you set.
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Figure 205   IPS Signatures Example

Figure 206   Rate Based Signatures Example

Applying Your IPS Configuration

Changes to the Zyxel Device’s IPS settings affect new sessions, but not the sessions that already existed 
before you applied the new settings.

21.1.3  Before You Begin
Register for a trial IPS license in the Licenses screen. This gives you access to free signature updates. This 
is important as new signatures are created as new attacks evolve. When the trial license expires, 
purchase and enter a license key using the same screens to renew the license.

21.2  The IPS Screen
An IPS profile is a set of packet inspection signatures. 

Click Security Service > IPS to open this screen. Use this screen to view signature information.
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If a license has expired, you will see a reminder in this screen. You need to renew the license in order to 
keep using the feature. Click Buy Now to go to Marketplace to purchase a new license. Click See 
Details to go to the Zyxel web page to find more information on licenses for your Zyxel Device. 

Note: You must register for the IPS signature service (at least the trial) before you can use it. 
See the Licensing screens. 
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Figure 207   Security Service > IPS
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The following table describes the fields in this screen. 

Table 168   Security Service > IPS  
LABEL DESCRIPTION
General Settings

Enable Click the switch to the right to activate the IPS feature which detects and prevents 
malicious or suspicious packets and responds instantaneously.

Statistics Click the switch to the right to have the Zyxel Device collect IPS statistics. All of the 
statistics are erased if you restart the Zyxel Device or click Flush Data in Security Statistics 
> IPS.

Scan Mode

Prevention Select this to have the Zyxel Device perform a user-specified action when a stream of 
data matches a malicious signature.

Detection Select this to have the Zyxel Device only create a log message when a stream of data 
matches a malicious signature.

Query Signatures  

Name Type the name or part of the name of the signature(s) you want to find.

Signature ID Type the ID or part of the ID of the signature(s) you want to find.

Advanced Settings Configure these settings for more advanced queries.

Severity Search for signatures by severity level(s). Hold down the [Ctrl] key if you want to make 
multiple selections.

These are the severities as defined in the Zyxel Device. The number in brackets is the 
number you use if using commands.

Severe (16): These denote attacks that try to run arbitrary code or gain system privileges. 

High (8): These denote known serious vulnerabilities or attacks that are probably not 
false alarms. 

Medium (4): These denote medium threats, access control attacks or attacks that could 
be false alarms.

Low (2): These denote mild threats or attacks that could be false alarms.

Very-Low (1): These denote possible attacks caused by traffic such as Ping, trace route, 
ICMP queries etc.

Classification Search for signatures by attack type(s) (see Table 169 on page 331). 

Platform Search for signatures created to prevent intrusions targeting specific operating 
system(s). 

Service Search for signatures by IPS service group(s). See Table 170 on page 333 for group 
details. 

Action Search for signatures by the response the Zyxel Device takes when a packet matches a 
signature.

Activation Search for activated and/or inactivated signatures here.

Log Search for signatures by log option here. 

Query Result The results are displayed in a table showing the Status, SID, Name, Severity, 
Classification, Platform, Service, Log, and Action criteria as selected in the search. Click 
the SID column header to sort search results by signature ID.

Rate Based Signature IPS signatures identify traffic packets with suspicious malicious patterns. The Zyxel Device 
can then respond instantaneously according to the action you define.

If you do not want the Zyxel Device to respond instantaneously for each suspicious 
packet detected, use rate based signatures to only respond after a number of 
occurrences (Count) within a certain time period (Period). See Section 21.1.2 on page 
325 for more information on rate based signatures.
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Edit Select an entry and click Edit to modify the entry’s settings.

Active To turn on an entry, select it and click Activate.

Inactive To turn off an entry, select it and click Inactivate.

Log To edit an item’s log option, select it and use the Log icon. Select whether to have the 
Zyxel Device generate a log (log), log and alert (log alert) or neither (no) when a packet 
matches a signature.

Action To edit what action the Zyxel Device takes when a packet matches a signature, select 
the entry and use the Action icon.

none: Select this action to have the Zyxel Device take no action when a packet 
matches a signature.

drop: Select this action to have the Zyxel Device silently drop a packet that matches a 
signature. Neither sender nor receiver are notified.

reject: Select this action to have the Zyxel Device send a reset to both the sender and 
receiver when a packet matches the signature. If it is a TCP attack packet, the Zyxel 
Device will send a packet with a ‘RST’ flag to the receiver and sender. If it is an ICMP or 
UDP attack packet, the Zyxel Device will send an ICMP unreachable packet.

# This is the entry’s index number in the list.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the entry is 
inactive.

SID SID is the signature ID that uniquely identifies a signature. Click the SID header to sort 
signatures in ascending or descending order. 

Name This is the name of your rate-based signature. The name is the type of attack the Zyxel 
Device can identify.

Severity This field displays signatures by severity level(s). Hold down the [Ctrl] key if you want to 
make multiple selections.

These are the severities as defined in the Zyxel Device. The number in brackets is the 
number you use if using commands.

Severe (5): These denote attacks that try to run arbitrary code or gain system privileges. 

High (4): These denote known serious vulnerabilities or attacks that are probably not 
false alarms. 

Medium (3): These denote medium threats, access control attacks or attacks that could 
be false alarms.

Low (2): These denote mild threats or attacks that could be false alarms.

Very-Low (1): These denote possible attacks caused by traffic such as Ping, trace route, 
ICMP queries etc.

Classification This field displays signatures by attack types (see Table 169 on page 331). 

Platform This field displays signatures created to prevent intrusions targeting specific operating 
system(s). Hold down the [Ctrl] key if you want to make multiple selections.

Service This field displays signatures by IPS service group(s). See Table 170 on page 333 for group 
details.Hold down the [Ctrl] key if you want to make multiple selections.

Log This fields displays the log action the Zyxel Device takes when a packet matches a 
signature. 

log- The Zyxel Device generates a log.

log an alert- The Zyxel Device generates a log and alerts the users.

no- The Zyxel Device will neither generate a log nor alert the users.

Table 168   Security Service > IPS  (continued)
LABEL DESCRIPTION
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Classifications

This table describes attack Classifications as categorized in the Zyxel Device.  

Action This field displays the response the Zyxel Device takes when a packet matches a 
signature. Hold down the [Ctrl] key if you want to make multiple selections.

none: Select this action to have the Zyxel Device take no action when a packet 
matches a signature.

drop: Select this action to have the Zyxel Device silently drop a packet that matches a 
signature. Neither sender nor receiver are notified.

reject: Select this action to have the Zyxel Device send a reset to both the sender and 
receiver when a packet matches the signature. If it is a TCP attack packet, the Zyxel 
Device will send a packet with a ‘RST’ flag to the receiver and sender. If it is an ICMP or 
UDP attack packet, the Zyxel Device will send an ICMP unreachable packet.

Period (sec) Type the length of time in seconds the event should occur a Count number of times to 
trigger an IPS Action.

For example, Count is set to 5, and Period is set to 60. If the Zyxel Device detects more 
than 5 occurrences of malicious traffic in less than 60 seconds, then an IPS Action is 
triggered.

Count Type the number of security events that need to occur within the defined Period in order 
to trigger an IPS Action. The allowed range is 1 to 300.

Block Period This field displays the time period the attacker’s IP will be blocked. 

Click on the number in this column to set the value from 0 to 86400 seconds. 0 means 
that the IP will not be blocked.

Signature Information The following fields display information on the current signature set that the Zyxel Device 
is using.

Current Version This field displays the IPS signature set version number. This number gets larger as the set 
is enhanced.

Update Signatures Click this link to go to the screen you can use to download signatures from the update 
server. 

Table 169   Attack Classifications 
POLICY TYPE DESCRIPTION
Any Any attack includes all other kinds of attacks that are not specified in the policy such as 

password, spoof, hijack, phishing, and close-in.

Misc Miscellaneous attacks takes advantage of vulnerable computer networks and web 
servers by forcing cache servers or web browsers into disclosing user-specific information 
that might be sensitive and confidential. The most common type of Misc. attacks are 
HTTP Response Smuggling, HTTP Response Splitting and JSON Hijacking.

Web-Attacks Web attacks refer to attacks on web servers such as IIS (Internet Information Services).

Buffer Overflow A buffer overflow occurs when a program or process tries to store more data in a buffer 
(temporary data storage area) than it was intended to hold. The excess information can 
overflow into adjacent buffers, corrupting or overwriting the valid data held in them. 

Intruders could run codes in the overflow buffer region to obtain control of the system, 
install a backdoor or use the victim to launch attacks on other devices.

Table 168   Security Service > IPS  (continued)
LABEL DESCRIPTION
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Backdoor/Trojan Horse A backdoor (also called a trapdoor) is hidden software or a hardware mechanism that 
can be triggered to gain access to a program, online service or an entire computer 
system. A Trojan horse is a harmful program that is hidden inside apparently harmless 
programs or data.

Although a virus, a worm and a Trojan are different types of attacks, they can be 
blended into one attack. For example, W32/Blaster and W32/Sasser are blended attacks 
that feature a combination of a worm and a Trojan.

Access Control Access control refers to procedures and controls that limit or detect access. Access 
control attacks try to bypass validation checks in order to access network resources such 
as servers, directories, and files.

P2P Peer-to-peer (P2P) is where computing devices link directly to each other and can 
directly initiate communication with each other; they do not need an intermediary. A 
device can be both the client and the server. In the Zyxel Device, P2P refers to peer-to-
peer applications such as e-Mule, e-Donkey, BitTorrent, iMesh, etc. 

IM IM (Instant Messenger) refers to chat applications. Chat is real-time, text-based 
communication between two or more users via networks-connected computers. After 
you enter a chat (or chat room), any room member can type a message that will 
appear on the monitors of all the other participants. 

Virus/Worm A computer virus is a small program designed to corrupt and/or alter the operation of 
other legitimate programs. A worm is a program that is designed to copy itself from one 
computer to another on a network. A worm’s uncontrolled replication consumes system 
resources, thus slowing or stopping other tasks.

BotNet A Botnet is a number of Internet computers that have been set up to forward 
transmissions including spam or viruses to other computers on the Internet though their 
owners are unaware of it. It is also a collection of Internet-connected programs 
communicating with other similar programs in order to perform tasks and participate in 
distributed Denial-Of-Service attacks. 

DoS-DDoS The goal of Denial of Service (DoS) attacks is not to steal information, but to disable a 
device or network on the Internet. 

A Distributed Denial of Service (DDoS) attack is one in which multiple compromised 
systems attack a single target, thereby causing denial of service for users of the targeted 
system.

Scan A scan describes the action of searching a network for an exposed service. An attack 
may then occur once a vulnerability has been found. Scans occur on several network 
levels.

A network scan occurs at layer-3. For example, an attacker looks for network devices 
such as a router or server running in an IP network.

A scan on a protocol is commonly referred to as a layer-4 scan. For example, once an 
attacker has found a live end system, he looks for open ports. 

A scan on a service is commonly referred to a layer-7 scan. For example, once an 
attacker has found an open port, say port 80 on a server, he determines that it is a HTTP 
service run by some web server application. He then uses a web vulnerability scanner (for 
example, Nikto) to look for documented vulnerabilities.

File Transfer File transfer is a protocol to transfer files over the Internet. An attack may then occur if 
you’re transferring files over an unsecured connection. Personal data stored in the files 
uploaded can also be easily accessed by attackers if these files are not encrypted.

Mail A Mail or email bombing attack involves sending several thousand identical messages to 
an electronic mailbox in order to overflow it, making it unusable.

Stream Media A Stream Media attack occurs when a malicious network node downloads an 
overwhelming amount of media stream data that could potentially exhaust the entire 
system. This method allows users to send small requests messages that result in the 
streaming of large media objects, providing an opportunity for malicious users to exhaust 
resources in the system with little effort expended on their part.

Table 169   Attack Classifications (continued)
POLICY TYPE DESCRIPTION
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IPS Service Groups

An IPS service group is a set of related packet inspection signatures.

21.2.1  Query Example
This example shows a search with these criteria:

• Severity: Severe

• Classification Type: Misc

• Platform: Windows

• Service: Any

• Actions: Any

Tunnel A Tunneling attack involves sending IPv6 traffic over IPv4, slipping viruses, worms and 
spyware through the network using secret tunnels. This method infiltrates standard 
security measures through IPv6 tunnels, passing through IPv4 undetected. An external 
signal then triggers the malware to spring to life and wreak havoc from inside the 
network.

ACL This attack is a violation of an ACL (Access Control List) rule. These are packet filter rules 
that check source, destination IP addresses / ports, and routing information in the 
packet.

Table 170   IPS Service Groups  
WEB_PHP WEB_MISC WEB_IIS WEB_FRONTPAGE 

WEB_CGI WEB_ATTACKS TFTP TELNET 

SQL SNMP SMTP RSERVICES 

RPC POP3 POP2 P2P 

ORACLE NNTP NETBIOS MYSQL 

MISC_EXPLOIT MISC_DDOS MISC_BACKDOOR MISC 

IMAP IM ICMP FTP 

FINGER DNS n/a

Table 169   Attack Classifications (continued)
POLICY TYPE DESCRIPTION
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Figure 208   Query Example Search

21.3  The Allow List Screen
Use this screen to exempt packets with these signatures from IPS inspection. The Zyxel Device will 
exclude incoming packets with the listed signature(s) from being intercepted and inspected.

Click Security Services > IPS > Allow List to display the following screen. Use Add to put a new item in the 
list or Edit to change an existing one or Remove to delete an existing entry.
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Figure 209   Security Service > IPS > Allow List

The following table describes the fields in this screen.

21.4  IPS Technical Reference
This section contains some background information on IPS.

Host Intrusions

The goal of host-based intrusions is to infiltrate files on an individual computer or server in with the goal of 
accessing confidential information or destroying information on a computer. 

You must install a host IPS directly on the system being protected. It works closely with the operating 
system, monitoring and intercepting system calls to the kernel or APIs in order to prevent attacks as well 
as log them. 

Disadvantages of host IPSs are that you have to install them on each device (that you want to protect) 
in your network and due to the necessarily tight integration with the host operating system, future 
operating system upgrades could cause problems. 

Table 171   Security Service > IPS > Allow List 
LABEL DESCRIPTION
Rule Summary

Add Click this to create a new entry.

Edit Select an entry and click this to be able to modify it. 

Remove Select an entry and click this to delete it. 

# This is the entry’s index number in the list.

Signature ID This field displays the signature ID of this entry.

Signature Name This field displays the signature name of this entry.
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Network Intrusions

Network-based intrusions have the goal of bringing down a network or networks by attacking 
computer(s), switch(es), router(s) or modem(s). If a LAN switch is compromised for example, then the 
whole LAN is compromised. Host-based intrusions may be used to cause network-based intrusions when 
the goal of the host virus is to propagate attacks on the network, or attack computer/server operating 
system vulnerabilities with the goal of bringing down the computer/server. Typical “network-based 
intrusions” are SQL slammer, Blaster, Nimda MyDoom etc.

Note: The Zyxel Device IPS protects your network against network-based intrusions. 
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CHAPTER 22
IP Exception

22.1  Overview
IP Exception allows incoming IP packets to bypass specific security services based on the packet’s 
source or destination address. Bypassing a security service means the security service does not intercept 
nor inspect the packet. 

For example, 192.168.100.100 is a trusted LAN computer. Add the IP address of the LAN computer to 
Source in IP Exception so the Zyxel Device will not perform security checking on traffic coming from this 
computer.

Figure 210   IP Exception Bypass Source Example

You can also add a trusted destination to bypass security checking. For example, 2.2.2.2 is a trusted web 
site. Add the IP address of the trusted web site to Destination in IP Exception so the Zyxel Device will not 
perform security checking when you access the web site to save resources.

Figure 211   IP Exception Bypass Destination Example

IP Exception supports bypassing the following security services:
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• Anti-Malware 

• URL Threat Filter

• IPS (Intrusion Prevention System)

• IP Reputation.

• DNS Threat Filter

22.2  The IP Exception Screen
Use this screen to view the IP exception list for the specified services. The Zyxel Device will not inspect 
incoming packets that match the listed source and destination IP address(es) with the specified 
services.

Click Security Service > IP Exception to display the following screen. Use Add to put a new entry in the list 
or Edit to change an existing one or Remove to delete an existing entry.

Figure 212   Security Service > IP Exception

The following table describes the fields in this screen.

Table 172   Security Service > IP Exception 
LABEL DESCRIPTION
Configuration

Add Click this to create a new entry.

Edit Select an entry and click this to be able to modify it. 

Remove Select an entry and click this to delete it. 

# This is the entry’s index number in the list.

Name This field displays the descriptive name of this entry.

IPv4 Source This field displays the source IP address (or address object) of incoming traffic. It displays any if 
there is no restriction on the source IP address.

IPv4 Destination This field displays the destination IP address (or address object) of incoming traffic. It displays 
any if there is no restriction on the destination IP address.

Service to Bypass This field displays which services will not inspect matched packets.

Log This field displays if the Zyxel Device will generate a log when the incoming traffic is in the 
exception list.
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22.2.1  The IP Exception Add/Edit Screen
Use this screen to add or edit entries of IPv4 address in the IP exception list.

Click Security Service > IP Exception > Add/Edit to display the following screen.

Figure 213   Security Service > IP Exception > Add/Edit

The following table describes the fields in this screen.

Table 173   Security Service > IP Exception > Add/Edit 
LABEL DESCRIPTION
Name Enter a descriptive name of this entry. You may use 2-31 alphanumeric characters, 

underscores (_), or dashes (-), but the first character cannot be a number. This value is case-
sensitive.

Source Select any or an address object of the source IP address for this entry. Select any so there’s no 
restriction on the source IP address.

Destination Select any or an address object of the destination IP address for this entry. Select any so 
there’s no restriction on the destination IP address.

Log The Zyxel Device does not inspect packets with the selected service if you select Yes. The 
Zyxel Device will also generate a log when the incoming traffic is in th exception list. 
Otherwise, select No.

Service to Bypass Selected services do not inspect packets that match source/destination criteria above. Non-
selected services do inspect packets that match source/destination criteria above. 

Apply Click Apply to save your customized settings and exit this screen.

Cancel Click Cancel to return the screen to its last-saved settings.
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22.3  Example: Bypass a Website
You often access a website 1.1.1.1 that you are sure is safe. Every time you access the website, the 
packets sent by the website will be inspected by the Zyxel Device security services, such as anti-
malware, content filter, reputation filter and app patrol.

This not only causes your web browser to take more time to load the website, but also takes up more 
Zyxel Device resources than necessary.

For example, you create an IP Exception profile for the website 1.1.1.1. IP exception allows incoming IP 
packets from the website 1.1.1.1 (A) to bypass specific security services. Bypassing a security service 
means the security service does not intercept nor inspect the packet.

Figure 214   Bypass Security Services Flow

This example uses the parameters given below.

1 Go to Object > Address > Address and click Add.

Table 174   Address Object Configuration Example
NAME ADDRESS TYPE IP ADDRESS
TrustedWebsite Host 1.1.1.1

Table 175   IP Exception Configuration Example
NAME SOURCE DESTINATION LOG SERVICES TO BYPASS
ForTrustedWebsite TrustedWebsite Any No Anti-Malware

URL Threat filter

IPS

IP Reputation

DNS Threat Filter
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2 Configure the settings using the parameters given in Table 174 on page 340. Click Apply to save your 
changes.

3 Go to Security Service > IP Exception and click Add.

4 Configure the settings using the parameters given in Table 175 on page 340. Click Apply to save your 
changes.
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CHAPTER 23
SSL Inspection

23.1  Overview
Secure Socket Layer (SSL) traffic, such as https://www.google.com/HTTPS, FTPs, POP3s, SMTPs, etc. is 
encrypted, and cannot be inspected using Security Service profiles such as App Patrol, Web Filtering, 
Intrusion Prevention System (IPS), or Anti-Malware. The Zyxel Device uses SSL Inspection to decrypt SSL 
traffic, sends it to the Security Service engines for inspection, then encrypts traffic that passes inspection 
and forwards it to the destination server, such as Google.

An example process is shown in the following figure. User U sends a HTTPS request (SSL) to destination 
server D, via the Zyxel Device, Z. The traffic matches an SSL Inspection profile in a security policy, so the 
Zyxel Device decrypts the traffic using SSL Inspection. The decrypted traffic is then inspected by the 
Security Service profiles in the same security profile that matched the SSL Inspection profile. If all is OK, 
then the Zyxel Device re-encrypts the traffic using SSL Inspection and forwards it to the destination server 
D. SSL traffic could be in the opposite direction for other examples.

Figure 215   SSL Inspection Overview

23.1.1  What You Can Do in this Chapter
• Use the Security Service > SSL Inspection > Profile screen (Section 23.2 on page 343) to view SSL 

Inspection profiles. Click the Add or Edit icon in this screen to configure the CA certificate, action and 
log in an SSL Inspection profile.

• Use the Security Service > SSL Inspection > Exclude List screens (Section 23.3 on page 348) to create a 
whitelist of destination servers to which traffic is passed through uninspected.

• Use the Security Service > SSL Inspection > Certificate Update screens (Section 23.4 on page 350) to 
update the latest certificates of servers using SSL connections to the Zyxel Device network
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23.1.2  What You Need To Know
SSL Inspection supports the following TLS protocols and encryption algorithms

• TLS1.0 AES-CBC

• TLS1.2 AES-CBC/AES-GCM

• TLS 1.3

SSL Inspection does not support the following:

• Compression Support

• Client Authentication

23.1.3  What You Can Do in this Chapter
• See Object > Certificate > My Certificates for information on creating certificates on the Zyxel 

Device.

• See Security Statistics > SSL Inspection to get usage data and easily add a destination server to the 
whitelist of exclusion servers. 

• See Security Policy > Policy Control > Policy to bind an SSL Inspection profile to a traffic flow(s). 

23.1.4  Before You Begin
• If you don’t want to use the default Zyxel Device certificate, then create a new certificate in Object > 

Certificate > My Certificates.

• Decide what destination servers to which traffic is sent directly without inspection. This may be a 
matter of privacy and legality regarding inspecting an individual’s encrypted session, such as 
financial websites. This may vary by locale.

23.2  The SSL Inspection Profile Screen
An SSL Inspection profile is a template with pre-configured certificate, action and log.

Click Security Service > SSL Inspection > Profile to open this screen. 
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Figure 216   Security Service > SSL Inspection > Profile
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The following table describes the fields in this screen. 

Table 176   Security Service > SSL Inspection > Profile  
LABEL DESCRIPTION
General Settings

Server Signed 
Certificate Key 
Mode

With SSL inspection, the Zyxel Device acts as a 'man-in-the-middle' between a client and 
a remote server, when the client and server are communicating using an SSL-encrypted 
session. Every time the client and server send data to each other, the Zyxel Device 
decrypts the sender’s encrypted data, scans the plain data for threats, re-encrypts the 
data, and then sends the encrypted data to the receiver. 

• For outgoing sessions from the client to the remote server, the Zyxel Device creates a 
virtual server to decrypt data and a virtual client to re-encrypt data. 

• For incoming sessions from the remote server to the client, the Zyxel Device creates a 
virtual client to decrypt data, and a virtual server to re-encrypt data.

To perform SSL Inspection for clients using SSL (HTTPS, SSH, SMTP) through the Zyxel 
Device, the Zyxel Device must check that the server’s certificate with corresponding 
public key are valid and were issued by a Certificate Authority (CA) listed in the Zyxel 
Device's list of trusted CAs. According to the selected key mode RSA 1024, RSA 2048, 
ECDSA-RSA-1024 or ECDSA-RSA-2048, the Zyxel Device will construct the corresponding 
self-signed certificate for the virtual server.

RSA is a public-key cryptosystem used for data encryption or signing messages. For data 
encryption, the encryption key is public and the decryption key is private. For signing 
messages, the signing key is private and the verification key is public. Elliptic Curve 
Cryptography (ECC) is a public-key cryptosystem based on elliptic curve theory, and 
more efficient than RSA. ECC allows smaller keys compared to RSA to provide 
equivalent security. For example, a 224-bit elliptic curve public key should provide 
comparable security to a 2048-bit RSA public key.

• ECDSA-RSA-1024 indicates Zyxel Device support for clients that support both ECDSA-
256 and RSA-1024 with ECDSA-256 having higher priority, that is ECDSA-256 is used by 
the virtual server, if a client supports both ECDSA-256 and RSA-1024.

• ECDSA-RSA-2048 indicates Zyxel Device support for clients that support both ECDSA-
256 and RSA-2048 with ECDSA-256 having higher priority, that is ECDSA-256 is used by 
the virtual server, if a client supports both ECDSA-256 and RSA-2048.

Select a mode that the client’s browser, FTP client, or mail client supports. The Zyxel 
Device will use different keys (cryptosystems) for each client according to the client’s 
support list.

For example, if there are three clients behind a Zyxel Device with the following key 
mode support:

• Client 1 - RSA-1024
• Client 2 - RSA-2048 and RSA-1024
• Client 3 - ECDSA-256 and RSA-2048.

If you set the key mode to ECDSA-RSA-1024, then the following will be used by each 
client:

• Client 1 - RSA-1024 
• Client 2 - RSA-1024 
• Client 3 - ECDSA-256.

If you set the key mode to ECDSA-RSA-2048, then the following will be used by each 
client:

• Client 1 - sessions will not be processed (pass) by SSL inspection 
• Client 2 - RSA-2048 
• Client 3 - ECDSA-256.

Statistics Enable this to have the Zyxel Device collect SSL inspection statistics. 

Profile Management

Add Click Add to create a new profile.
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23.2.1  Add/Edit SSL Inspection Profiles
Click Security Service > SSL Inspection > Profile > Add to create a new profile or select an existing profile 
and click Edit to change its settings.

Figure 217   Security Service > SSL Inspection > Profile > Add / Edit 

Edit Select an entry and click this to be able to modify it. 

Remove Select an entry and click this to delete it. 

References Select an entry and click References to open a screen that shows which settings use the 
entry.

Action Click this icon to apply the entry to a policy control rule.

Go to the Security Policy > Policy Control screen to check the result.

# This is the entry’s index number in the list.

Name This displays the name of the profile.

Description This displays the description of the profile.

CA Certificate This displays the CA certificate being used in this profile.

Reference This displays the number of times an object reference is used in a profile.

Table 176   Security Service > SSL Inspection > Profile  (continued)
LABEL DESCRIPTION
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The following table describes the fields in this screen.  

Table 177   Security Service > SSL Inspection > Profile > Add/Edit 
LABEL DESCRIPTION
Name This is the name of the profile. You may use 1-31 alphanumeric characters, underscores(_), or 

dashes (-), but the first character cannot be a number. This value is case-sensitive. These are 
valid, unique profile names:

• MyProfile

• mYProfile

• Mymy12_3-4

These are invalid profile names:

• 1mYProfile

• My Profile

• MyProfile?

• Whatalongprofilename123456789012
Description Enter additional information about this SSL Inspection entry. You can enter up to 60 characters 

(0-9a-zA-Z’()+:=?;!*#@$_%-”). The first character must be a letter.

CA Certificate This contains the default certificate and the certificates created in Object > Certificate > My 
Certificates. Choose the certificate for this profile.

SSL/TLS version

Minimum 
Support

SSL / TLS connections using versions lower than this setting are blocked. 

Log These are the log options for unsupported traffic that matches traffic bound to this policy:

• no: Select this option to have the Zyxel Device create no log for unsupported traffic that 
matches traffic bound to this policy.

• log: Select this option to have the Zyxel Device create a log for unsupported traffic that 
matches traffic bound to this policy

• log alert: An alert is an emailed log for more serious events that may need more immediate 
attention. They also appear in red in the Log & Report > Log/Events screen. Select this option 
to have the Zyxel Device send an alert for unsupported traffic that matches traffic bound to 
this policy.

Unsupported suit

Action SSL Inspection supports these cipher suites:

• DES
• 3DES
• AES

Select to pass or block unsupported traffic (such as other cipher suites, compressed traffic, 
client authentication requests, and so on) that matches traffic bound to this policy here.

Log These are the log options for unsupported traffic that matches traffic bound to this policy:

• no: Select this option to have the Zyxel Device create no log for unsupported traffic that 
matches traffic bound to this policy.

• log: Select this option to have the Zyxel Device create a log for unsupported traffic that 
matches traffic bound to this policy

• log alert: An alert is an emailed log for more serious events that may need more immediate 
attention. They also appear in red in the Log & Report > Log/Events screen. Select this option 
to have the Zyxel Device send an alert for unsupported traffic that matches traffic bound to 
this policy.

Untrusted cert 
chain
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23.3  Exclude List Screen
There may be privacy and legality issues regarding inspecting a user's encrypted session. The legal issues 
may vary by locale, so it's important to check with your legal department to make sure that it’s OK to 
intercept SSL traffic from your Zyxel Device users.

To ensure individual privacy and meet legal requirements, you can configure an exclusion list to exclude 
matching sessions to destination servers. This traffic is not intercepted and is passed through 
uninspected.

Click Security Services > SSL Inspection > Exclude List to display the following screen. Use Add to put a 
new item in the list or Edit to change an existing one or Remove to delete an existing entry.

Action A certificate chain is a certification process that involves the following certificates between the 
SSL/TLS server and a client. A certificate chain will fail if one of the following certificates is not 
correct.

• A certificate owned by a user
• The certificate signed by a certification authority
• A root certificate

Select to pass, inspect, or block an untrusted certification chain.

Log These are the log options for unsupported traffic that matches traffic bound to this policy:

• no: Select this option to have the Zyxel Device create no log for unsupported traffic that 
matches traffic bound to this policy.

• log: Select this option to have the Zyxel Device create a log for unsupported traffic that 
matches traffic bound to this policy

• log alert: An alert is an emailed log for more serious events that may need more immediate 
attention. They also appear in red in the Log & Report > Log/Events  screen. Select this 
option to have the Zyxel Device send an alert for unsupported traffic that matches traffic 
bound to this policy.

Apply Click Apply to save your settings to the Zyxel Device, and return to the profile summary page.

Reset Click Reset to return to the profile summary page without saving any changes.

Table 177   Security Service > SSL Inspection > Profile > Add/Edit (continued)
LABEL DESCRIPTION
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Figure 218   Security Service > SSL Inspection > Exclude List 

The following table describes the fields in this screen.

Table 178   Security Service > SSL Inspection > Exclude List 
LABEL DESCRIPTION
General Settings

Enable Logs for 
Exclude List

Click this to create a log for traffic that bypasses SSL Inspection. 

Exclude List 
Address Settings

Use this part of the screen to create, edit, or delete items in the SSL Inspection exclusion list.

Add Click this to create a new entry.

Edit Select an entry and click this to be able to modify it. 

Remove Select a row and click this to delete it. 

Content SSL traffic to a server to be excluded from SSL Inspection is identified by its certificate. Identify 
the certificate in one of the following ways:

• The Common Name (CN) of the certificate. The common name of the certificate can be 
created in the System > Certificate > My Certificates screen. 

• Type an IPv4 address. For example, type 192.168.1.35
• Type an IPv4 in CIDR notation. For example, type 192.168.1.1/24
• Type an IPv4 address range. For example, type 192.168.1.1-192.168.1.35
• Type an email address. For example, type abc@zyxel.com.tw
• Type a DNS name or a common name (wildcard char: '*', escape char: '\'). Use up to 127 

case-insensitive characters (0-9a-zA-Z`~!@#$%^&*()-_=+[]{}\|;:',.<>/?). ‘*’ can be used as 
a wildcard to match any string. Use ‘\*’ to indicate a single wildcard character.

Apply Click Apply to save your settings to the Zyxel Device.

Cancel Click Cancel to return to the profile summary page without saving any changes.
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23.4  Certificate Update Screen
Use this screen to update the latest certificates of servers using SSL connections to the Zyxel Device 
network. User U sends an SSL request to destination server D (1), via the Zyxel Device, Z. D replies (2); Z 
intercepts the response from D and checks if the certificate has been previously signed. Z then replies to 
D (3) and also to U (4). D’s latest certificate is stored at myZyxel (M) along with other server certificates 
and can be downloaded to the Zyxel Device.

Figure 219   SSL Inspection Certificate Update Overview

Click Security Services > SSL Inspection > Certificate Update to display the following screen. 

Figure 220   Security Services > SSL Inspection > Certificate Update
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The following table describes the fields in this screen.

23.5  Install a CA Certificate in a Browser
Certificates used in SSL Inspection profiles should be installed in user web browsers. Do the following 
steps to install a certificate in a computer with a Windows operating system (PC). First, save the 
certificate to your computer.

1 Run the certificate manager using certmgr.msc.

2 Go to Trusted Root Certification Authorities > Certificates.

Table 179   Security Services > SSL Inspection > Certificate Update 
LABEL DESCRIPTION
Certificate Information

Current Version This displays the current certificate set version.

Released Date This field displays the date and time the current certificate set was released.

Certificate Update You should have Internet access and have activated SSL Inspection on the Zyxel 
Device at NCC.

Update Now Click this button to download the latest certificate set (Windows, MAC OS X, and 
Android) from the Zyxel cloud server and update it on the Zyxel Device.

Auto Update Select this to automatically have the Zyxel Device update the certificate set when a 
new one becomes available on the Zyxel cloud server.

Apply Click Apply to save your settings to the Zyxel Device.

Cancel Click Cancel to return to the profile summary page without saving any changes.
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3 From the main menu, select Action > All Tasks > Import and run the Certificate Import Wizard to install 
the certificate on the PC.
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23.5.0.1  Firefox Browser
If you’re using a Firefox browser, in addition to the above you need to do the following to import a 
certificate into the browser.

Click Tools > Options > Advanced > Encryption > View Certificates, click Import and enter the filename 
of the certificate you want to import. See the browser's help for further information.
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CHAPTER 24
External Block Lists 

24.1  Overview
Use these screens to use block IP, FQDN or URL list entries stored in a file on a web server that supports 
HTTP or HTTPS and is reachable from the Zyxel Device. The Zyxel Device will bypass checking by this 
feature (if enabled) and block incoming and outgoing packets from the block list entries in this file. In this 
way, different Zyxel Devices can use the same block list. 

The external block list file must be in text format (*.txt) with each entry separated by a new line.

24.1.1  IP Reputation External Block List Screen
External block list entries can consist of single IPv4 / IPv6 IP addresses, IP address ranges, CIDR (Classless 
Inter-Domain Routing entries such as 192.168.1.1/24, 2001:7300:3500::1/64. These are some examples for 
your reference only:

• Single IP 4.4.4.4

• CIDR 192.168.1.0/32

• IP range (1.2.3.4-1.2.3.100)

If the external block list file contains any invalid entries, the Zyxel Device will not use the file.

The external block list file can contain up to 50,000 entries. A warning message displays when the 
maximum is reached.

Go to Security Services > External Block List > IP Reputation to display the following screen.

If a license has expired, you will see a reminder in this screen. You need to renew the license in order to 
keep using the feature. Click Buy Now to go to Marketplace to purchase a new license. Click See 
Details to go to the Zyxel web page to find more information on licenses for your Zyxel Device. 
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Figure 221   Security Services > External Block List > IP Reputation     

The following table describes the labels in this screen.  

Table 180   Security Services > External Block List > IP Reputation 
LABEL DESCRIPTION
Enable Select this to have the Zyxel Device block packets that come from the listed addresses in 

the block list file on the server.

Profile Management

Add Click this to create a new IP reputation external block list profile entry.

Remove Select an entry and click this to delete it.

Name Enter an identifying name for the block list file. You can use alphanumeric and ()+/
:=?!*#@$_%- characters, and it can be up to 60 characters long.

Source Enter the exact file name, path and IP address of the server containing the block list file. 

For example, http://172.16.107.20/blocklist-files/myip-ebl.txt

The server must be reachable from the Zyxel Device. 

Description Enter a description of the block list file. You can use alphanumeric and ()+/:=?!*#@$_%- 
characters, and it can be up to 60 characters long.
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24.1.2  DNS / URL Threat Filter External Block List Screen
Use this screen to use block list entries stored in a file on a web server that supports HTTP or HTTPS. The 
Zyxel Device will block incoming and outgoing packets from the block list entries in this file. Supported 
formats are:

• hostname (www.google.com)

• URL http - check full url (http://xxx.yyy.zzz/qqq/wwww)

• URL https - only check hostname (https://xxx.)

Please note the following:

• The external block list file must be in text format (*.txt) with each entry separated by a new line. 

• External block list entries can consist of a complete URL or a hostname and may contain wildcards. 
There are some examples for your reference only:

• https://www.zyxel.com/products_services/smb.shtml?t=s (complete URL)

• www.zyxel.com (hostname)

Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.

Save Changes Click this icon to save the changes in this row.

Cancel Changes Click this icon to cancel the changes in this row. 

Signature Update New IP reputation signatures can be downloaded to the Zyxel Device periodically if you 
have subscribed for the IP reputation signatures service.

You need to create a Zyxel account, register your Zyxel Device and then subscribe for IP 
reputation service in order to be able to download new signatures (see the Registration 
screens).

Schedule signature updates for a day and time when your network is least busy to 
minimize disruption to your network. 

Update Now Click this to have the Zyxel Device immediately check for new signatures. If new 
signatures are found, they are then downloaded to the Zyxel Device.

Auto Update Click this to have the Zyxel Device automatically check for new signatures regularly at the 
time and day specified. You should select a time when your network is not busy for 
minimal interruption.

Every N Hours Select this to have the Zyxel Device check for new signatures every specified number of 
hours (N).

Daily Select this to have the Zyxel Device check for new signatures every day at the specified 
time (am/pm). The time format is the 12 hour clock. 

Weekly Select this option to have the Zyxel Device check for new signatures once a week on the 
day and at the time (am/pm) specified.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 180   Security Services > External Block List > IP Reputation (continued)
LABEL DESCRIPTION
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• *.zyxel.* (hostname with wildcards)

• If the external block list file contains any invalid entries, the Zyxel Device will not use the file.

• The external block list file can contain up to 50,000 entries. A warning message displays when the 
maximum is reached.

Figure 222   Security Services > External Block List > DNS / URL Threat Filter     

The following table describes the labels in this screen. 

Table 181   Security Services > External Block List > DNS / URL Threat Filter  
LABEL DESCRIPTION
Enable Select this check box to have the Zyxel Device automatically block packets that come 

from the listed addresses in the block list file on the server.

Profile Management

Add Click this to create a new DNS/URL threat filter external block list entry.

Remove Select an entry and click this to delete it.

Name Enter an identifying name for the block list file. You can use alphanumeric and ()+/
:=?!*#@$_%- characters, and it can be up to 60 characters long.

Source Enter the exact file name, path and IP address of the server containing the block list file. 

For example, http://172.16.107.20/blocklist-files/myip-ebl.txt

The server must be reachable from the Zyxel Device. 

Description Enter a description of the block list file. You can use alphanumeric and ()+/:=?!*#@$_%- 
characters, and it can be up to 60 characters long.
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Edit Select an entry and click this icon to modify it.

Remove Select an entry and click this icon to delete it.

Save Changes Click this icon to save the changes in this row.

Cancel Changes Click this icon to cancel the changes in this row. 

Signature Update New IP reputation signatures can be downloaded to the Zyxel Device periodically if you 
have subscribed for the IP reputation signatures service.

You need to create a Zyxel account, register your Zyxel Device and then subscribe for IP 
reputation service in order to be able to download new signatures (see the Registration 
screens).

Schedule signature updates for a day and time when your network is least busy to 
minimize disruption to your network. 

Update Now Click this to have the Zyxel Device immediately check for new signatures. If new 
signatures are found, they are then downloaded to the Zyxel Device.

Auto Update Click this to have the Zyxel Device automatically check for new signatures regularly at the 
time and day specified. You should select a time when your network is not busy for 
minimal interruption.

Every N Hours Select this to have the Zyxel Device check for new signatures every specified number of 
hours (N).

Daily Select this to have the Zyxel Device check for new signatures every day at the specified 
time (am/pm). 

Weekly Select this option to have the Zyxel Device check for new signatures once a week on the 
day and at the time (am/pm) specified.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 181   Security Services > External Block List > DNS / URL Threat Filter  (continued)
LABEL DESCRIPTION
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CHAPTER 25
User & Authentication

25.1  User/Group Overview
This section describes how to set up user accounts, user groups, and user settings for the Zyxel Device. 
You can also set up rules that control when users have to log in to the Zyxel Device before the Zyxel 
Device routes traffic for them. 

• The User screen (see Section 25.1.2 on page 360) provides a summary of all user accounts.

• The Group screen (see Section 25.1.4 on page 365) provides a summary of all user groups. In addition, 
this screen allows you to add, edit, and remove user groups. User groups may consist of access users 
and other user groups. You cannot put admin users in user groups.

• The Setting screen (see Section 25.1.5 on page 367) controls default settings, login settings, lockout 
settings, and other user settings for the Zyxel Device. You can also use this screen to specify when 
users must log in to the Zyxel Device before it routes traffic for them.

25.1.1  What You Need To Know

User Account

A user account defines the privileges of a user logged into the Zyxel Device. User accounts are used in 
security policies and application patrol, in addition to controlling access to configuration and services in 
the Zyxel Device.

User Types

These are the types of user accounts the Zyxel Device uses.  

Table 182   Types of User Accounts 
TYPE ABILITIES LOGIN METHOD(S)
Admin Users

admin Change the Zyxel Device settings (web, CLI) WWW, SSH, FTP, Console

viewer Look at the Zyxel Device settings (web, CLI)

Perform basic diagnostics (CLI)

WWW, SSH, Console

Access Users

user Access network services WWW

ext-user Extent user account WWW
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Ext-User Accounts

Set up an ext-user account if the user is authenticated by an external server and you want to set up 
specific policies for this user in the Zyxel Device. If you do not want to set up policies for this user, you do 
not have to set up an ext-user account.

All ext-user users should be authenticated by an external server, such as AD, LDAP or RADIUS. If the Zyxel 
Device tries to use the local database to authenticate an ext-user, the authentication attempt always 
fails. (This is related to AAA servers and authentication methods, which are discussed in those chapters in 
this guide.)

Note: If the Zyxel Device tries to authenticate an ext-user using the local database, the 
attempt always fails.

Once an ext-user user has been authenticated, the Zyxel Device tries to get the user type (see Table 182 
on page 359) from the external server. If the external server does not have the information, the Zyxel 
Device sets the user type for this session to User.

For the rest of the user attributes, such as reauthentication time, the Zyxel Device checks the following 
places, in order.

1 User account in the remote server.

2 User account (Ext-User) in the Zyxel Device.

3 Default user account for AD users (ad-users), LDAP users (ldap-users) or RADIUS users (radius-users) in 
the Zyxel Device.

User Groups

User groups may consist of user accounts or other user groups. Use user groups when you want to create 
the same rule for several user accounts, instead of creating separate rules for each one.

Note: You cannot put access users and admin users in the same user group.

Note: You cannot put the default admin account into any user group.

The sequence of members in a user group is not important.

25.1.2  User/Group User Summary Screen
The User screen provides a summary of all user accounts. To access this screen, click User & 
Authentication > User/Group > User.
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Figure 223   User & Authentication > User/Group > User

The following table describes the labels in this screen.

Table 183   User & Authentication > User/Group > User 
LABEL DESCRIPTION
Add Click this to create a new entry.

Edit Double-click an entry or select it and click Edit to open a screen where you can modify the 
entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove 
it before doing so.

Local 
Administrator

Use this table to view and configure the Zyxel Device admin accounts.

Name This field displays the user name of each user.

User Type This field displays the admin accounts the Zyxel Device uses. Admin accounts are users that 
can look at and change the configuration of the Zyxel Device

Description This field displays the description for each user.

Created Date This field displays the date the account is created.

This field displays - if the account is created before the Zyxel Device upgrades firmware to 
version 5.10 or later.

Password 
Changed 
Date

This field displays the last time the user changed the account password.

Reference This displays the number of times an object reference is used in a profile.

User Use this table to configure the Zyxel Device:

• User accounts.
• Ext-user accounts.

Name This field displays the user name of each user.

User Type This field displays the types of user accounts the Zyxel Device uses: 

• user - this user has access to the Zyxel Device’s services and can also browse user-mode 
commands (CLI).

• ext-user - this user account is maintained in a remote server, such as RADIUS or LDAP. See 
Ext-User Accounts on page 360 for more information about this type.

Description This field displays the description for each user.

Created Date This field displays the date the account is created.
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25.1.3  User Add/Edit Screen
The User Add/Edit General screen allows you to create a new user account or edit an existing one. 

25.1.3.1  Rules for User Names
Enter a user name from 1 to 30 characters.

The user name can only contain the following characters:

• Alphanumeric A-z 0-9 (there is no unicode support)

• _ [underscores] 

• - [dashes]

• . [period]

• @ [at]

The first character must be alphabetical (A-Z a-z), an underscore (_), or a dash (-). Other limitations on 
user names are:

• User names are case-sensitive. If you enter a user 'bob' but use 'BOB' when connecting via CIFS or FTP, 
it will use the account settings used for 'BOB' not ‘bob’.

• User names have to be different than user group names.

To access this screen, go to the User screen, and click either the Add icon or an Edit icon.

Password 
Changed 
Date

This field displays the last time the user changes the account password.

Reference This displays the number of times an object reference is used in a profile.

Table 183   User & Authentication > User/Group > User (continued)
LABEL DESCRIPTION
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Figure 224   User & Authentication > User/Group > User > Add/Edit (Local Administrator)
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Figure 225   User & Authentication > User/Group > User > Add/Edit (User)

The following table describes the labels in this screen.

Table 184   User & Authentication > User/Group > User > Add/Edit
LABEL DESCRIPTION
User Name Type the user name for this user account. You may use 1-30 alphanumeric characters, 

periods (.), at (@), underscores(_), or dashes (-), but the first character cannot be a number. 
This value is case-sensitive. User names have to be different than user group names, and 
some words are reserved. See Section 25.1.3.1 on page 362.

User Type Select the type of user account the Zyxel Device uses for the Local Administrator account 
from the drop-down list box.

• Admin- this user can configure the Zyxel Device settings using the web configurator or 
CLI.

• Viewer- this user can only view the Zyxel Device settings using the web configurator and 
perform basic diagnostics for troubleshooting using the command line interface (CLI).

Select the type of user account the Zyxel Device uses for the User account from the drop-
down list box: 

• User - this user has access to the Zyxel Device’s services and can also browse user-mode 
commands (CLI).

• Extent User - this user account is maintained on a remote server, such as RADIUS or LDAP. 
See Ext-User Accounts on page 360 for more information about this type.

Password This field is not available if you select the Extent User type.

Enter a password consists of 4 to 63 characters for this user account, including 0-9a-zA-
Z’(){}<>^‘+/:!*#@&=$\.~%,|;-”

Retype This field is not available if you select the Extent User type.
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25.1.4  User/Group Group Summary Screen
User groups consist of access users and other user groups. You cannot put admin users in user groups. 
The Group screen provides a summary of all user groups. In addition, this screen allows you to add, edit, 
and remove user groups. To access this screen, login to the Web Configurator, and click User & 
Authentication > User/Group > Group.

Figure 226   User & Authentication > User/Group > Group

Description Enter the description of each user, if any. You can use 1 to 30 single-byte characters, 
including 0-9a-zA-Z!”#$%’()*+,-/:;=?@_

&.<>[\]{|}^‘are not allowed. Default descriptions are provided. 

Email Type one or more valid email addresses for this user so that email messages can be sent to 
this user if required. A valid email address must contain the @ character. For example, this is 
a valid email address: abc@example.com. 

Mobile Number Type a valid mobile telephone number for this user so that SMS messages can be sent to this 
user if required. A valid mobile telephone number can be up to 20 characters in length, 
including the numbers 1~9 and the following characters in the square brackets [+*#()-].

Authentication 
Timeout Settings

If you want the system to use default settings, select Use Default Settings. If you want to set 
authentication timeout to a value other than the default settings, select Use Manual Settings 
then fill your preferred values in the fields that follow.

Lease Time If you select Use Default Settings in the Authentication Timeout Settings field, the default 
lease time is shown.

If you select Use Manual Settings, you need to enter the number of minutes this user has to 
renew the current session before the user is logged out. You can specify 1 to 1440 minutes. 
You can enter 0 to make the number of minutes unlimited. Admin users renew the session 
every time the main screen refreshes in the Web Configurator. Access users can renew the 
session by clicking the Renew button on their screen. If you allow access users to renew time 
automatically (see Section 25.1.5 on page 367), the users can select this check box on their 
screen as well. In this case, the session is automatically renewed before the lease time 
expires.

Reauthentication 
Time

If you select Use Default Settings in the Authentication Timeout Settings field, the default 
reauthentication time is shown.

If you select Use Manual Settings, you need to type the number of minutes this user can be 
logged into the Zyxel Device in one session before the user has to log in again. You can 
specify 1 to 1440 minutes. You can enter 0 to make the number of minutes unlimited. Unlike 
Lease Time, the user has no opportunity to renew the session without logging out.

Enable Two-Factor 
Authentication for 
Admin Access

This field is available when you are editing a local administrator account.

Enable this to require double-layer security to access a secured network behind the Zyxel 
Device via the Web Configurator.

Apply Click Apply to save your customized settings and exit this screen.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 184   User & Authentication > User/Group > User > Add/Edit
LABEL DESCRIPTION
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The following table describes the labels in this screen. See Section 25.1.4.1 on page 366 for more 
information as well.

25.1.4.1  Group Add/Edit Screen
The Group Add/Edit screen allows you to create a new user group or edit an existing one. To access this 
screen, go to the Group screen, and click either the Add icon or an Edit icon.

Figure 227   User & Authentication > User/Group > Group > Add

The following table describes the labels in this screen.  

Table 185   User & Authentication > User/Group > Group 
LABEL DESCRIPTION
Add Click this to create a new entry.

Edit Double-click an entry or select it and click Edit to open a screen where you can modify the 
entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove 
it before doing so. Removing a group does not remove the user accounts in the group.

Group Name This field displays the name of each user group.

Description This field displays the description for each user group.

Members This field lists the members in the user group. Each member is separated by a comma.

Reference This displays the number of times an object reference is used in a profile.

Table 186   User & Authentication > User/Group > Group > Add 
LABEL DESCRIPTION
Name Type the name for this user group. You may use 2-30 alphanumeric characters, 

underscores(_), or dashes (-), but the first character cannot be a number. This value is case-
sensitive. User group names have to be different than user names.

Description Enter the description of the user group, if any. You can use up to 60 characters, punctuation 
marks, and spaces.
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25.1.5  User/Group Setting Screen
The Setting screen controls default settings, login settings, lockout settings, and other user settings for the 
Zyxel Device. You can also use this screen to specify when users must log in to the Zyxel Device before it 
routes traffic for them.

To access this screen, login to the Web Configurator, and click User & Authentication > User/Group > 
Setting.

Figure 228   User & Authentication > User/Group > Setting

Member List This list displays the names of the users and user groups that have been added to the user 
group. The order of members is not important. 

Select items from the list on the left that you want to be members and move them to the list on 
the right. Move any members you do not want included to the list on the left. 

Apply Click Apply to save your customized settings and exit this screen.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 186   User & Authentication > User/Group > Group > Add (continued)
LABEL DESCRIPTION
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The following table describes the labels in this screen.  

Table 187   User & Authentication > User/Group > Setting 
LABEL DESCRIPTION
User Default Settings

Default Authentication Timeout 
Settings

These authentication timeout settings are used by default when you create a 
new user account. They also control the settings for any existing user accounts 
that are set to use the default settings. You can still manually configure any user 
account’s authentication timeout settings.

Edit Select an entry and click this icon to modify it.

Save Changes Click this icon to save the changes in this row.

Cancel Changes Click this icon to cancel the changes in this row. 

User Type These are the kinds of user account the Zyxel Device supports.

• admin - this user can look at and change the configuration of the Zyxel 
Device

• user - this user has access to the Zyxel Device’s services but cannot look at 
the configuration

• ext-user - this user account is maintained in a remote server, such as RADIUS 
or LDAP. See Ext-User Accounts on page 360 for more information about this 
type.

• viewer - this user can look at the configuration of the Zyxel Device

Lease Time This is the default lease time in minutes for each type of user account. It defines 
the number of minutes the user has to renew the current session before the user 
is logged out.

Admin users renew the session every time the main screen refreshes in the Web 
Configurator. Access users can renew the session by clicking the Renew button 
on their screen. If you allow access users to renew time automatically (see 
Section 25.1.5 on page 367), the users can select this check box on their screen 
as well. In this case, the session is automatically renewed before the lease time 
expires.

To edit the lease time, enter the number of minutes this type of user account has 
to renew the current session before the user is logged out. You can specify 1 to 
1440 minutes. You can enter 0 to make the number of minutes unlimited. 

Reauthentication Time This is the default reauthentication time in minutes for each type of user 
account. It defines the number of minutes the user can be logged into the Zyxel 
Device in one session before having to log in again. Unlike Lease Time, the user 
has no opportunity to renew the session without logging out.

To edit the reauthentication time, enter the number of minutes this type of user 
account can be logged into the Zyxel Device in one session before the user has 
to log in again. You can specify 1 to 1440 minutes. You can enter 0 to make the 
number of minutes unlimited. 

Miscellaneous Settings

Auto renew lease time Enable to let access users renew lease time automatically.

Admin User Type Login Security

Force change password

Enable

Enable to force local admin type users to change their password after the 
specified period of time when they log into the Zyxel Device.

Period Enter how often users must change their password when they log into the Zyxel 
Device. You can choose from once a day to once a year.

User Logon Settings
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25.2  User Authentication Overview
This section describes how to set up AAA server and two-factor authentication.

• Use the AAA Server screen (see Section 25.3 on page 371) to configure the default authentication 
server (Local/LDAP/AD/RADIUS) to use for user authentication.

• Use the Two-factor Authentication screen (see Section 25.4 on page 379) to have double-layer 
security for local users to access a secured network behind the Zyxel Device.

25.2.1  What You Need To Know

AAA Servers Supported by the Zyxel Device

The following lists the types of authentication server the Zyxel Device supports. 

Limit simultaneous admin 
logons enable

Enable to set a limit on the number of simultaneous logins by admin users. If you 
do not select this, admin users can login as many times as they want at the 
same time using the same or different IP addresses.

Maximum number per 
admin account

Type the maximum number of simultaneous logins by each admin user. 

Limit the simultaneous 
access logons enable

Select this check box if you want to set a limit on the number of simultaneous 
logins by non-admin users. If you do not select this, access users can login as 
many times as they want as long as they use different IP addresses.

Maximum number per 
access account

Type the maximum number of simultaneous logins by each access user. 

Reach maximum number 
per account

Set the action the Zyxel Device will take when the limit you set for the numbers 
of simultaneous logins by admin users or non-admin users has exceeded.

Select Block to have the Zyxel Device block any accounts that try to log in.

Select Remove previous user and login to have the Zyxel Device remove the 
most recently login account

User Lockout Settings

Enable logon retry limit 
enable

Enable to set a limit on the number of times each user can login unsuccessfully 
(for example, wrong password) before the IP address is locked out for a 
specified amount of time.

Maximum retry count This field is effective when Enable logon retry limit is checked. Type the 
maximum number of times each user can login unsuccessfully before the IP 
address is locked out for the specified lockout period. The number must be 
between 1 and 99.

Lockout period This field is effective when Enable logon retry limit is checked. Type the number 
of minutes the user must wait to try to login again, if logon retry limit is enabled 
and the maximum retry count is reached. This number must be between 1 and 
65,535 (about 45.5 days).

Apply Click Apply to save the changes. 

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 187   User & Authentication > User/Group > Setting (continued)
LABEL DESCRIPTION
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• Local user database 

The Zyxel Device uses the built-in local user database to authenticate administrative users logging into 
the Zyxel Device’s Web Configurator or network access users logging into the network through the 
Zyxel Device. You can also use the local user database to authenticate VPN users. 

• Directory Service (LDAP/AD) 

LDAP (Lightweight Directory Access Protocol)/AD (Active Directory) is a directory service that is both 
a directory and a protocol for controlling access to a network. The directory consists of a database 
specialized for fast information retrieval and filtering activities. You create and store user profile and 
login information on the external server.

• RADIUS

RADIUS (Remote Authentication Dial-In User Service) authentication is a popular protocol used to 
authenticate users by means of an external or built-in RADIUS server. RADIUS authentication allows 
you to validate a large number of users from a central location. 

Directory Structure

The directory entries are arranged in a hierarchical order much like a tree structure. Normally, the 
directory structure reflects the geographical or organizational boundaries. The following figure shows a 
basic directory structure branching from countries to organizations to organizational units to individuals. 

Figure 229   Basic Directory Structure 

Distinguished Name (DN) 

A DN uniquely identifies an entry in a directory. A DN consists of attribute-value pairs separated by 
commas. The leftmost attribute is the Relative Distinguished Name (RDN). This provides a unique name 
for entries that have the same “parent DN” (“cn=domain1.com, ou=Sales, o=MyCompany” in the 
following examples). 

cn=domain1.com, ou = Sales, o=MyCompany, c=US
cn=domain1.com, ou = Sales, o=MyCompany, c=JP

Base DN 

A base DN specifies a directory. A base DN usually contains information such as the name of an 
organization, a domain name and/or country. For example, o=MyCompany, c=UK where o means 
organization and c means country. 
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Bind DN 

A bind DN is used to authenticate with an LDAP/AD server. For example a bind DN of cn=zywallAdmin 
allows the Zyxel Device to log into the LDAP/AD server using the user name of zywallAdmin. The bind 
DN is used in conjunction with a bind password. When a bind DN is not specified, the Zyxel Device will try 
to log in as an anonymous user. If the bind password is incorrect, the login will fail.

25.3  AAA Server Overview 
You can use an AAA (Authentication, Authorization, Accounting) server to control access to your 
network. A Zyxel Device AAA server can be a Windows Active Directory (AD), a Lightweight Directory 
Access Protocol (LDAP) server or a RADIUS server, Use the AAA Server screens to create and manage 
objects that contain settings for using AAA servers. You can use AAA server objects in configuring IPSec 
VPN and SSL VPN rules.

Use RADIUS, AD and LDAP servers to authenticate users instead of (or in addition to) an internal Zyxel 
Device user database that is limited to the memory capacity of the Zyxel Device. In essence, AAA 
servers allow you to authenticate a large number of users from a central location.

Figure 230   AAA Server Network Example

25.3.1  AAA Server Configuration
Use the AAA Server screen to manage AD servers, LDAP servers and RADIUS servers the Zyxel Device can 
use in authenticating users. 

Click User & Authentication > AAA Server to display the following screen. 
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Figure 231   User & Authentication > AAA Server 

The following table describes the labels in this screen.

Table 188   User & Authentication > AAA Server 
LABEL DESCRIPTION
Add Click this to create a new entry.

Edit Double-click an entry or select it and click Edit to open a screen where you can modify the 
entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove 
it before doing so.

References Select an entry and click References to open a screen that shows which settings use the entry.

Join Domain Select an entry and click Join Domain to open a screen where you can add the AD server to 
the same domain as the Zyxel Device for central authentication management. See Section 
25.3.3 on page 375 for more information.

Note: The Zyxel Device can only be joined to one AD domain at a time. Adding a 
new AD domain will replace existing domain associations.

Note: Ensure that the Domain Zone Forwarder configuration in the System > DNS & 
DDNS > DNS screen is correct before joining a domain.
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25.3.2  Add an AD Server
Click User & Authentication > AAA Server > AD Server Summary > Add to display the following screen. 
Use this screen to create a new AD server entry or edit an existing one. 

Figure 232   User & Authentication > AAA Server > AD Server Summary > Add

Remove From 
Domain

Select an entry and click Remove From Domain to remove the entry from the same domain as 
the Zyxel Device. 

The AD server is not isolated if it is not in the same domain as the Zyxel Device. You may do this 
for non-central authentication management such as when managing the Zyxel Device 
through NCC.

Name This field displays the name of the AD, LDAP or RADIUS server.

Server Address This is the address of the AD, LDAP or RADIUS server.

Domain Name This is the domain name of the AD, LDAP or RADIUS server.

Reference This is the number of times the entry is used in other settings.

Table 188   User & Authentication > AAA Server 
LABEL DESCRIPTION
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The following table describes the labels in this screen.  

Table 189   User & Authentication > AAA Server > AD Server Summary > Add 
LABEL DESCRIPTION
Configuration

Name Enter a descriptive name for identification purposes. Use up to 31 single-byte characters, 
including 0-9a-zA-Z_-.

Description Enter the description of each server, if any. The value cannot exceed 61 characters. Valid 
characters are [0-9][a-z][A-Z]['()+,/:=?;!*#@$_%-"].

Server Settings

Server Address Enter the IPv4 address of the AD server.

Backup Server 
Address

If the AD server has a backup server, enter its address here.

Port Specify the port number on the AD or LDAP server to which the Zyxel Device sends 
authentication requests. Enter a number between 1 and 65535. 

This port number should be the same on all AD server(s) in this group. 

Use SSL Select Use SSL to establish a secure connection to the AD server(s) from the Zyxel Device.

Search time limit Specify the timeout period (between 1 and 300 seconds) before the Zyxel Device disconnects 
from the AD server. In this case, user authentication fails. 

Search timeout occurs when either the user information is not in the AD server(s) or the AD 
server(s) is down.

Case-sensitive User 
Names

Select this if the AD server checks the case of usernames.

Server Authentication

Domain Name Enter the domain name to which AD server belongs. The Zyxel Device uses this to access the 
AD server.

User Name Enter the user name that the Zyxel Device uses to access the AD server.

Password Enter the password that the Zyxel Device uses to access the AD server. 

Retype to Confirm Retype your new password for confirmation.

Advanced Settings

User Attributes

Search Base An Active Directory server has a hierarchical structure for user account entries. The search base 
is where the search starts for user account entries. This can help to make the authentication 
procedure faster. To limit the search to begin in a container beneath the root of the domain, 
you must specify the fully-qualified name of the container in comma-delimited form. Start with 
the name of the base container and progress to the root of the domain. The search string is not 
case-sensitive; you can use either uppercase or lowercase letters. The entry cannot exceed 
128 characters. Valid characters are [0-9][a-z][A-Z][_(){}<>^`+/:!*#@&=$. ~%,;].

Login Name 
Attribute

Enter the type of identifier the users are to use to log in. For example “name” or “email address”

Alternative Login 
Name Attribute

If there is a second type of identifier that the users can use to log in, enter it here. For example 
“name” or “email address”. 

Group 
Membership 
Attribute

An AD server defines attributes for its accounts. Enter the name of the attribute that the Zyxel 
Device is to check to determine to which group a user belongs. The value for this attribute is 
called a group identifier; it determines to which group a user belongs. You can add ext-group-
user user objects to identify groups based on these group identifier values. 

For example you could have an attribute named “memberOf” with values like “sales”, “RD”, 
and “management”. Then you could also create a ext-group-user user object for each group. 
One with “sales” as the group identifier, another for “RD” and a third for “management”.

Configuration Validation



 Chapter 25 User & Authentication

USG FLEX H Series User’s Guide

375

25.3.3  Join an AD Domain
Click User & Authentication > AAA Server > Join AD Domain to display the following screen. Use the Join 
AD Domain screen to add the AD server to the same domain as the Zyxel Device for central authentication 
management.

Figure 233   User & Authentication > AAA Server > AD server > Join AD Domain  

The following table describes the labels in this screen.

User Name Enter an existing user account in this server to validate the above settings. Click the Test button 

Apply Click Apply to save the changes. 

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 189   User & Authentication > AAA Server > AD Server Summary > Add (continued)
LABEL DESCRIPTION

Table 190   User & Authentication > AAA Server > AD server > Join AD Domain 
LABEL DESCRIPTION
Associated AD 
Server Object

This field shows the name of the AD server object.

AD Domain 
Name

This field shows the Zyxel Device domain name you want the AD server to join.

NetBIOS Domain 
Name

Type the NetBIOS name that the AD server uses to identify the Zyxel Device. This field is optional. 
NetBIOS packets are TCP or UDP packets that enable a computer to connect to and 
communicate with a LAN which allows local computers to find computers on the remote 
network and vice versa. The name must begin with a letter and cannot exceed 15 characters. 
Valid characters are [0-9][a-z][A-Z][_-.].

User Name Enter the user name for the Zyxel Device to access the AD server. The value must be 1 to 20 
characters long. Valid characters are [0-9][a-z][A-Z][_(){}<>[]^`+/:!*#@&=$\?.~%,|;-'" ].
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25.3.4  Add an LDAP Server
Click User & Authentication > AAA Server > LDAP Server Summary > Add to display the following screen. 
Use this screen to create a new LDAP server entry or edit an existing one. 

Figure 234   User & Authentication > AAA Server > LDAP Server Summary > Add

Password Enter the password associated with the user name.  The value must be 4 to 63 characters long. 
Valid characters are [0-9][a-z][A-Z][_(){}<>^`+/:!*#@&=$\?.~%,|;-'"].

Retype to 
Confirm

Retype the password you entered in the Password field to confirm.

Apply Click Apply to save the changes. 

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 190   User & Authentication > AAA Server > AD server > Join AD Domain 
LABEL DESCRIPTION
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The following table describes the labels in this screen.  

Table 191   User & Authentication > AAA Server > LDAP Server Summary > Add 
LABEL DESCRIPTION
Configuration

Name Enter a descriptive name for identification purposes. Use up to 31 single-byte characters, 
including 0-9a-zA-Z_-.

Description Enter the description of each server, if any. Use up to 61 single-byte characters, including 0-9a-
zA-Z'()+,/:=?;!*#@$_%-".

Server Settings

Server Address Enter the IPv4 address of the LDAP server.

Backup Server 
Address

If the LDAP server has a backup server, enter its address here.

Port Specify the port number on the LDAP server to which the Zyxel Device sends authentication 
requests. Enter a number between 1 and 65535. 

This port number should be the same on all LDAP server(s) in this group. 

Base DN A base DN is the point from where a server will search for users. The entry cannot exceed 128 
characters. Valid characters are [0-9][a-z][A-Z][_(){}<>^`+/:!*#@&=$. ~%,;].

Use SSL Select Use SSL to establish a secure connection to the LDAP server(s).

Search time limit Specify the timeout period (between 1 and 300 seconds) before the Zyxel Device disconnects 
from the LDAP server. In this case, user authentication fails. 

Search timeout occurs when either the user information is not in the LDAP server(s) or the LDAP 
server(s) is down. 

Case-sensitive User 
Names

Select this if you want configure your username as case-sensitive.

Server Authentication

Bind DN A bind DN is an object that you bind to inside LDAP to give you permission to make changes. 
The entry cannot exceed 128 characters. Valid characters are [0-9][a-z][A-Z][_(){}<>^`+/
:!*#@&=$. ~%,;]. 

Password Enter the password that the Zyxel Device uses to access the LDAP server.

Retype to Confirm Retype your new password for confirmation.

Advanced Settings

User Attributes

Login Name 
Attribute

Enter the type of identifier the users are to use to log in. For example “name” or “email 
address”. 

Alternative Login 
Name Attribute

If there is a second type of identifier that the users can use to log in, enter it here. For example 
“name” or “email address”. 

Group 
Membership 
Attribute

A LDAP server defines attributes for its accounts. Enter the name of the attribute that the Zyxel 
Device is to check to determine to which group a user belongs. The value for this attribute is 
called a group identifier; it determines to which group a user belongs. You can add ext-group-
user user objects to identify groups based on these group identifier values. 

For example you could have an attribute named “memberOf” with values like “sales”, “RD”, 
and “management”. Then you could also create a ext-group-user user object for each group. 
One with “sales” as the group identifier, another for “RD” and a third for “management”.

Apply Click Apply to save the changes. 

Cancel Click Cancel to return the screen to its last-saved settings. 
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25.3.5  Add a RADIUS Server 
Click User & Authentication > AAA Server > RADIUS Server Summary > Add to display the following 
screen. Use this screen to create a new RADIUS server entry or edit an existing one. 

Figure 235   User & Authentication > AAA Server > RADIUS Server Summary > Add 

The following table describes the labels in this screen.  

Table 192   User & Authentication > AAA Server > RADIUS Server Summary > Add 
LABEL DESCRIPTION
Name Enter a descriptive name for identification purposes. Use up to 30 single-byte characters, 

including 0-9a-zA-Z_-.

Description Enter the description of each server, if any. Use up to 61 single-byte characters, including 0-9a-
zA-Z'()+,/:=?;!*#@$_%-".

Server Address Enter the IPv4 address or FQDN of the RADIUS server.

Authentication 
Port

Specify the port number on the RADIUS server to which the Zyxel Device sends authentication 
requests. Enter a number between 1 and 65535. 

Backup Server 
Address

If the RADIUS server has a backup server, enter its address here.
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25.4  Two-Factor Authentication Overview
Use two-factor authentication to have double-layer security for local users in the Zyxel Device database 
to access the Zyxel Device or a secured network behind the Zyxel Device via a VPN tunnel. 

Backup 
Authentication 
Port

Specify the port number on the RADIUS server to which the Zyxel Device sends authentication 
requests. Enter a number between 1 and 65535. 

Key Enter a password (up to 63 single-byte characters, including 0-9a-zA-Z_(){}<>^`+/
:!*#@&=$\?.~%,|;-) as the key to be shared between the external authentication server and 
the Zyxel Device. Your password will be encrypted when you configure this field. 

The key is not sent over the network. This key must be the same on the external authentication 
server and the Zyxel Device. 

Change of 
Authorization

The external RADIUS server can change its authentication policy and send CoA (Change of 
Authorization) or RADIUS Disconnect messages in order to terminate the subscriber’s service.

Select this option to allow the Zyxel Device to disconnect wireless clients based on the 
information (such as client’s user name and MAC address) specified in CoA or RADIUS 
Disconnect messages sent by the RADIUS server.

Server Address Enter the IPv4 address or Fully-Qualified Domain Name (FQDN) of the RADIUS accounting 
server.

Accounting Port Specify the port number on the RADIUS server to which the Zyxel Device sends accounting 
information. Enter a number between 1 and 65535.

Backup Server 
Address

If the RADIUS server has a backup accounting server, enter its address here.

Backup 
Accounting Port

Specify the port number on the RADIUS server to which the Zyxel Device sends accounting 
information. Enter a number between 1 and 65535.

Key Enter a password (up to 15 alphanumeric characters) as the key to be shared between the 
external authentication server and the Zyxel Device. 

The key is not sent over the network. This key must be the same on the external authentication 
server and the Zyxel Device. 

Timeout Specify the timeout period (between 1 and 300 seconds) before the Zyxel Device disconnects 
from the RADIUS server. In this case, user authentication fails. 

Search timeout occurs when either the user information is not in the RADIUS server or the 
RADIUS server is down. 

NAS IP Address Type the IP address of the NAS (Network Access Server).

NAS Identifier If the RADIUS server requires the Zyxel Device to provide the Network Access Server identifier 
attribute with a specific value, enter it here.

Case-sensitive 
User Names

Select this if you want configure your username as case-sensitive.

Group 
Membership 
Attribute

A RADIUS server defines attributes for its accounts. Select the name and number of the 
attribute that the Zyxel Device is to check to determine to which group a user belongs. If it does 
not display, select user-defined and specify the attribute’s number. 

This attribute’s value is called a group identifier; it determines to which group a user belongs.

Apply Click Apply to save the changes. 

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 192   User & Authentication > AAA Server > RADIUS Server Summary > Add (continued)
LABEL DESCRIPTION
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The first layer is the Zyxel Device’s login user name / password and the second layer is using the Google 
Authenticator app. 

Note: The user must download and set up the Google Authenticator app first. 

This section introduces how two-factor authentication works.

Admin Access Via the Web Configurator or SSH

1 A local admin user connects to the Zyxel Device through the Web Configurator or SSH.

2 The Zyxel Device requests the admin user’s user-name and password from the local Zyxel Device 
database in order to authenticate this admin user.

3 If all credentials are correct, then the Zyxel Device requests the Google Authenticator code.

4 The admin user must enter the authorization code within a specified deadline (Valid Time).

5 If the authorization is correct and received on time, then the admin user can log into Zyxel Device. If the 
authorization deadline has expired, then the admin user has to log in again. If authorization credentials 
are incorrect or the code was not received, then the admin user should contact the network 
administrator. 

25.4.0.1  Two-factor Authentication Pre-configuration
Before configuration, you must:

• Set up the user’s user-name and password in the local Zyxel Device database.

• Enable Two-factor Authentication in User & Authentication > User/Group > User > Edit > Two-factor 
Authentication for a specific user 

• Enable Two-factor Authentication in User & Authentication > User Authentication > Two-factor 
Authentication for the Zyxel Device

• Enable HTTP, HTTPS and/or SSH in System > Settings > Administration Settings.

• Add HTTP, HTTPS and/or SSH in the Object > Service > Service Group > Default_Allow_WAN_To_ZyWALL 
service group. This service group defines the default services allowed in the WAN_to_Device security 
policy.

Two-Factor authentication will fail under the following conditions: 

• The user’s credentials are not in the in the local Zyxel Device database.

• You omit any of the pre-configuration items. Make sure to perform all pre-configuration items. 

• Authorization times out. Extend the Valid Time in User & Authentication > User Authentication > Two-
factor Authentication > VPN Access.

• You are unable to access Google Authenticator (you lost your phone or uninstalled the app). Log in 
using one of the backup codes. 

• You get a Google Authenticator verification error. You must enter the code within the time displayed 
in Google Authenticator. The time on your cellphone and the time on the Zyxel Device must be the 
same.
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Google Authenticator Settings

The following is a list of specifications and limitations on using Google Authenticator for two-factor 
authentication.

• Users authenticated by external servers, such as AD (Windows Active Directory), LDAP (Lightweight 
Directory Access Protocol), or RADIUS are not supported.

• A user must setup Google Authenticator on their mobile device before they can successfully 
authenticate with the Zyxel Device.

• Verification code length: 6 digits.

• Maximum verification code failed attempts: 3

• Backup code length: 8 digits

25.4.1  User Authentication Two-Factor Authentication
Use this screen to configure double-layer security for local users to access the Zyxel Device or a secured 
network behind the Zyxel Device via a VPN tunnel. 

Go to User & Authentication > User Authentication > Two-factor Authentication and configure the 
following screen as shown.

Figure 236   User & Authentication > User Authentication > Two-factor Authentication 
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The following table describes the labels in this screen. 

Table 193   User & Authentication > User Authentication > Two-factor Authentication
LABEL DESCRIPTION
Enable Enable this to require double-layer security to access the Zyxel Device via the Web 

Configurator or SSH.

Valid Time Enter the maximum time (in minutes) within which the user must enter the key received in 
Google Authenticator.

Two-factor 
Authentication 
for Services

Select which services require Two-Factor Authentication for the admin user. You must select at 
least one.

• Web
• SSH

VPN Access

Enable Enable this to require double-layer security to access a secured network behind the Zyxel 
Device via a VPN tunnel.

Valid time Enter the maximum time (in minutes) within which the user must enter the key received in 
Google Authenticatorl in order to get authorization for access to a secured network behind the 
Zyxel Device via a VPN tunnel.

Two-factor 
Authentication 
for Services

Select which types of VPN tunnels require Two-Factor Authentication for the admin user. You 
must select at least one. You should have configured the VPN tunnel first.

• SSL VPN Access
• IPSec VPN Access

Delivery Settings Use this section to configure how to send the VPN link.

Authorize Link 
URL Address

Configure the link that the user will receive. The user must be able to access the link.

• http/https: you must enable HTTP or HTTPS in System > Settings 
• From Interface/User-Defined: select the Zyxel Device WAN interface (ge3/4) or select User-

Defined and then enter an IP address or domain name.

Authorized Port Configure a port between 1 and 65535 that is not in use by other services.

Use this port for two-factor authentication of VPN clients to access the network behind the Zyxel 
Device. VPN clients do not need to change the port number on their devices, because the link 
to access the network behind the Zyxel Devices will contain the new port number. 

You must configure a security policy to allow access to this port from the WAN.

Apply Click Apply to save the changes. 

Cancel Click Cancel to return the screen to its last-saved settings. 
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CHAPTER 26
System

26.1  Overview
Use the system screens to configure general Zyxel Device settings. 

26.1.1  What You Can Do in this Chapter
• Use the System > Settings screen (see Section 26.2 on page 383) to configure the Zyxel Device basic 

system settings.

• Use the System > DNS & DDNS screen (see Section 26.3 on page 389) to configure the Zyxel Device 
DNS and DDNS settings.

• Use the System > SNMP screen (see Section 26.4 on page 403) to configure the Zyxel Device SNMP 
settings.

• Use the System > Notification screen (see Section 26.5 on page 408) to configure a mail server to 
receive reports and notification emails.

• For an overview of certificates, see Section 26.6 on page 410.

• Use the System > My Certificates screen (see Section 26.7 on page 412) to generate self-signed 
certificates or certification requests.

• Use the Trusted Certificates screens (see Section 26.8 on page 420) to save CA certificates and trusted 
remote host certificates to the Zyxel Device. The Zyxel Device trusts any valid certificate that you have 
imported as a trusted certificate. It also trusts any valid certificate signed by any of the certificates 
that you have imported as a trusted certificate. 

• Use the System > Advanced screen (see Section 26.9 on page 424) to view UDP and ICMP timeout 
settings on your Zyxel Device and to enable or disable ARP spoofing prevention, device insight, and 
LLDP functions.

See each section for related background information and term definitions.

26.2  Settings
Use the Settings screen to configure the hostname, system time, the Zyxel Device connection settings 
and language settings.

26.2.1  System Settings
Use this section to configure the Zyxel Device host name. A host name is the unique name by which a 
device is known on a network.
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26.2.2  System Time
Use this section to configure the Zyxel Device time settings. For effective scheduling and logging, the 
Zyxel Device system time must be accurate. The Zyxel Device’s Real Time Chip (RTC) keeps track of the 
time and date. There is also a software mechanism to set the time manually or get the current time and 
date from an external server.

To change your Zyxel Device’s time based on your local time zone and date, go to System > Settings > 
System Time. You can manually set the Zyxel Device’s time and date or have the Zyxel Device get the 
date and time from a time server.

To manually set the Zyxel Device date and time.

1 Go to System > Settings > System Time.

2 Select Manual in the Time field. Then enter or select the Zyxel Device’s time and date.

3 In the Timezone field, select your timezone from the list.

4 Click Apply.

To get the Zyxel Device date and time from a time server

1 Go to System > Settings > System Time.

2 Select Auto Sync in the Time and Timezone field.

3 Click Apply.

26.2.3  Administration Settings
Use this section to configure secure and insecure connection of the Zyxel Device coming in from the 
WAN. HTTPS and SSH access are secure. HTTP access is not secure. 

Note: To allow the Zyxel Device to be accessed from a specified computer using a service, 
make sure you do not have a service control rule or to-Zyxel Device security policy rule 
to block that traffic. 

To stop a service from accessing the Zyxel Device, slide the switch to the left in the corresponding 
service screen to disable the service. 

System Timeout

There is a lease timeout for administrators. The Zyxel Device automatically logs you out if the 
management session remains idle for longer than this timeout period. The management session does 
not time out when a statistics screen is polling. 

Each user is also forced to log in the Zyxel Device for authentication again when the reauthentication 
time expires. 

You can change the timeout settings in the User/Group screens.
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HTTPS

You can set the Zyxel Device to use HTTP or HTTPS (HTTPS adds security) for Web Configurator sessions.

HTTPS (HyperText Transfer Protocol over Secure Socket Layer, or HTTP over SSL) is a web protocol that 
encrypts and decrypts web pages. Secure Socket Layer (SSL) is an application-level protocol that 
enables secure transactions of data by ensuring confidentiality (an unauthorized party cannot read the 
transferred data), authentication (one party can identify the other party) and data integrity (you know if 
data has been changed). 

It relies upon certificates, public keys, and private keys.

HTTPS on the Zyxel Device is used so that you can securely access the Zyxel Device using the Web 
Configurator. The SSL protocol specifies that the HTTPS server (the Zyxel Device) must always 
authenticate itself to the HTTPS client (the computer which requests the HTTPS connection with the Zyxel 
Device), whereas the HTTPS client only should authenticate itself when the HTTPS server requires it to do 
so (enable Authenticate Client Certificates in the Administration Settings screen). Authenticate Client 
Certificates is optional and if selected means the HTTPS client must send the Zyxel Device a certificate. 
You must apply for a certificate for the browser from a CA that is a trusted CA on the Zyxel Device.

Please refer to the following figure.

1 HTTPS connection requests from an SSL-aware web browser go to port 443 (by default) on the Zyxel 
Device’s web server.

2 HTTP connection requests from a web browser go to port 80 (by default) on the Zyxel Device’s web 
server.

Figure 237   HTTP/HTTPS Implementation

Note: If you disable HTTP in the Administration Settings screen, then the Zyxel Device blocks all 
HTTP connection attempts.

SSH

You can use SSH (Secure SHell) to securely access the Zyxel Device’s command line interface. 

SSH is a secure communication protocol that combines authentication and data encryption to provide 
secure encrypted communication between two hosts over an unsecured network. In the following 
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figure, computer A on the Internet uses SSH to securely connect to the WAN port of the Zyxel Device for 
a management session.

Note: To allow an SSH connection to the Zyxel Device, add SSH in the Object > Service > 
Service Group > Default_Allow_WAN_To_ZyWALL service group which defines the 
default services allowed in the WAN_to_Device security policy.

Figure 238   SSH Communication Over the WAN Example

Your Zyxel Device supports SSH version 2 using RSA authentication and four encryption methods (AES, 
3DES, Archfour, and Blowfish). The SSH server is implemented on the Zyxel Device for management using 
port 22 (by default). 

You must install an SSH client program on a client computer (Windows or Linux operating system) that is 
used to connect to the Zyxel Device over SSH.

FTP

You can upload and download the Zyxel Device’s firmware and configuration files using FTP. To use this 
feature, your computer must have an FTP client.

Device Insight

Use Device Insight to collect status and basic information of the clients connected to the Zyxel Device 
internal interfaces or IPSec VPN; see Section 5.13 on page 90 for more information.

26.2.4  Settings
Use this section to select a display language for the Zyxel Device’s Web Configurator screens.

Click System > Settings to open the following screen.
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Figure 239   System > Settings
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The following table describes the labels in this screen. 

Table 194   System Settings 
LABEL DESCRIPTION
System Settings

Host Name Enter a descriptive name to identify your Zyxel Device device. This name can be up to 30 
alphanumeric characters long. Spaces are not allowed, but dashes (-) underscores (_) and 
periods (.) are accepted.

System Time

Current Time This field displays the present date and time of your Zyxel Device.

Time Select Auto Sync to have the Zyxel Device get the time and date from the time server. The Zyxel 
Device requests time and date settings from the time server under the following circumstances.

• When the Zyxel Device starts up.
• When you click Apply after selecting Auto Sync in this screen.
• 24-hour intervals after starting up.

Select Manual to enter or select the time and date manually. When you enter the time and 
date settings manually, the Zyxel Device uses the new settings once you click Apply.

Timezone Select Auto Sync for the Zyxel Device to automatically get its timezone.

Select Manual to choose the timezone of your location. This will set the time difference between 
your timezone and Greenwich Mean Time (GMT).

Administration 
Settings

HTTP Enable Enable to allow access to the Zyxel Device using HTTP connections.

HTTP Port The HTTP server listens on port 80 by default. If you change the HTTP port to a different number 
on the Zyxel Device, for example 8080, then you must notify people who need to access the 
Zyxel Device Web Configurator to use “http://Zyxel Device IP Address:8080” as the URL.

If you choose a port already in use, you will see a port conflict message telling you to choose 
another port. 

Redirect to 
HTTPS

Enable this to redirect all HTTP connection requests to the HTTPS server to allow only secure Web 
Configurator access.

HTTPS Enable Enable to allow access to the Zyxel Device Web Configurator using secure HTTPS connections.

HTTPS Port The HTTPS server listens on port 443 by default. If you change the HTTPS port to a different 
number on the Zyxel Device, for example 8443, then you must notify people who need to 
access the Zyxel Device Web Configurator to use “https://Zyxel Device IP Address:8443” as the 
URL.
If you choose a port already in use, you will see a port conflict message telling you to choose 
another port. 

Authenticate 
Client 
Certificates

Enable this to require the SSL client to authenticate itself to the Zyxel Device by sending the 
Zyxel Device a certificate. To do that the SSL client must have a CA-signed certificate from a 
CA that has been imported as a trusted CA on the Zyxel Device. 

Server 
Certificate

Select a certificate the HTTPS server (the Zyxel Device) uses to authenticate itself to the HTTPS 
client. You must have certificates already configured in the My Certificates screen.

SSH Enable Enable to allow access to the Zyxel Device using SSH connections.

SSH Port The SSH port is 22 by default. You may change the server port number for a service if needed, 
however you must use the same port number in order to use that service for remote 
management.

If you choose a port already in use, you will see a port conflict message telling you to choose 
another port. 
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26.3  DNS & DDNS
DNS (Domain Name System) is for mapping a domain name to its corresponding IP address and vice 
versa. The DNS server is extremely important because without it, you must know the IP address of a 
machine before you can access it. 

Server 
Certificate

Select a certificate whose corresponding private key is to be used to identify the Zyxel Device 
for SSH connections. You must have certificates already configured in the My Certificates 
screen.

FTP Enable Enable to allow access to the Zyxel Device using FTP connections.

TLS required Enable to use FTP over TLS (Transport Layer Security) to encrypt communication. This implements 
TLS as a security mechanism to secure FTP clients and servers.

FTP Port The FTP port is 21 by default. You may change the server port number for a service if needed, 
however you must use the same port number in order to use that service for remote 
management.

If you choose a port already in use, you will see a port conflict message telling you to choose 
another port. 

Server 
Certificate

Select a certificate whose corresponding private key is to be used to identify the Zyxel Device 
for FTP connections. You must have certificates already configured in the My Certificates 
screen.

Display

Language Select a display language for the Zyxel Device’s web configurator screens. The web 
configurator screens will display in the new language after you click Apply.

User LED The USER LED is located at the front panel of the Zyxel Device. Use this LED to check one of the 
following:

• Admin account login status.
• User IP address locked out status.
• License status.
• New firmware available for update.

Event Select how you want the USER LED to behave.

• Select Admin login (green on) if you want the USER LED to be steady green when there are 
admin accounts logged into the Zyxel Device.

• Select User Lockout (amber on) if you want the USER LED to be steady amber when a user IP 
address is locked out of the Zyxel Device. A user IP address will be locked out when the user 
has logged into the Zyxel Device unsuccessfully (for example, wrong password) for more 
than three times.

• Select License Expired (amber on) if you want the USER LED to be steady amber when a 
Zyxel Device service license has expired.

• Select New Firmware Available (green blinking) if you want the USER LED to blink green 
when there is new firmware available for upload.

• Select Off to turn off the USER LED.

Device Insight Enable Device Insight to collect status and basic information of the clients connected to the 
Zyxel Device internal interfaces or IPSec VPN.

Apply Click Apply to save your changes to the Zyxel Device.

Reset Click Reset to return the screen to its last-saved settings. 

Table 194   System Settings (continued)
LABEL DESCRIPTION
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Similarly, Dynamic DNS (DDNS) maps a domain name to a dynamic IP address. As a result, anyone can 
use the domain name to contact you (in NetMeeting, CU-SeeMe, etc.) or to access your FTP server or 
Web site, regardless of the current (dynamic) IP address.

Note: You must have a public WAN IP address to use Dynamic DNS.

You must set up a dynamic DNS account with a supported DNS service provider before you can use 
Dynamic DNS services with the Zyxel Device. When registration is complete, the DNS service provider 
gives you a password or key. At the time of writing, the Zyxel Device supports the following DNS service 
providers. See the listed websites for details about the DNS services offered by each. 

Note: Record your DDNS account’s user name, password, and domain name to use to 
configure the Zyxel Device.

After you configure the Zyxel Device, it automatically sends updated IP addresses to the DDNS service 
provider, which helps redirect traffic accordingly.

26.3.1  DNS Server Address Assignment
The Zyxel Device can get the DNS server addresses in the following ways.

• The ISP tells you the DNS server addresses, usually in the form of an information sheet, when you sign 
up. If your ISP gives you DNS server addresses, manually enter them in the DNS server fields.

• If your ISP dynamically assigns the DNS server IP addresses (along with the Zyxel Device’s WAN IP 
address), set the DNS server fields to get the DNS server address from the ISP. 

• You can manually enter the IP addresses of other DNS servers.

26.3.2  The DNS Screen
Click System > DNS & DDNS > DNS to change your Zyxel Device’s DNS settings. Use the DNS screen to 
configure the Zyxel Device to use a DNS server to resolve domain names for Zyxel Device system 
features like VPN, DDNS and the time server. You can also configure the Zyxel Device to accept or 
discard DNS queries. Use the Network > Interface screens to configure the DNS server information that 
the Zyxel Device sends to the specified DHCP client devices.

A name query begins at a client computer and is passed to a resolver, a DNS client service, for 
resolution. The Zyxel Device can be a DNS client service. The Zyxel Device can resolve a DNS query 
locally using cached Resource Records (RR) obtained from a previous query (and kept for a period of 
time). If the Zyxel Device does not have the requested information, it can forward the request to DNS 
servers. This is known as recursion.

Table 195   DDNS Service Providers 
PROVIDER SERVICE TYPES SUPPORTED WEBSITE
DynDNS Dynamic DNS, Static DNS, and Custom DNS www.dyndns.com

Dynu Basic, Premium www.dynu.com

No-IP No-IP www.no-ip.com

Peanut Hull Peanut Hull www.oray.cn 

3322 3322 Dynamic DNS, 3322 Static DNS www.3322.org

Selfhost Selfhost selfhost.de
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The Zyxel Device can ask a DNS server to use recursion to resolve its DNS client requests. If recursion on 
the Zyxel Device or a DNS server is disabled, they cannot forward DNS requests for resolution.

A Domain Name Server (DNS) amplification attack is a kind of Distributed Denial of Service (DDoS) 
attack that uses publicly accessible open DNS servers to flood a victim with DNS response traffic. An 
open DNS server is a DNS server which is willing to resolve recursive DNS queries from anyone on the 
Internet.

In a DNS amplification attack, an attacker sends a DNS name lookup request to an open DNS server 
with the source address spoofed as the victim’s address. When the DNS server sends the DNS record 
response, it is sent to the victim. Attackers can request as much information as possible to maximize the 
amplification effect. 

Configure the Security Option Control section in the System > DNS & DDNS > DNS screen if you suspect 
the Zyxel Device is being used (either by hackers or by a corrupted open DNS server) in a DNS 
amplification attack. 
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Figure 240   System > DNS & DDNS > DNS  

The following table describes the labels in this screen.  

Table 196   System > DNS & DDNS > DNS
LABEL DESCRIPTION
Address/PTR 
Record

This record specifies the mapping of a Fully-Qualified Domain Name (FQDN) to an IP address. 
An FQDN consists of a host and domain name. For example, www.zyxel.com.tw is a fully 
qualified domain name, where “www” is the host, “zyxel” is the third-level domain, “com” is 
the second-level domain, and “tw” is the top level domain.

Add Click this to create a new entry.

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to 
remove it before doing so. Note that subsequent entries move up by one when you take this 
action.
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Edit icon Double-click an entry or select it to display an Edit icon that allows you to modify the entry’s 
settings. 

Hostname This is the name of the host.

Domain This is the host’s fully qualified domain name.

IP Address This is the IP address of a host.

CNAME Record This record specifies an alias for a FQDN. Use this record to bind all subdomains with the same 
IP address as the FQDN without having to update each one individually, which increases 
chance for errors. See CNAME Record (Section 26.3.5 on page 395) for more details.

Add Click this to create a new entry.

Edit Double-click an entry or select it and click Edit to be able to modify the entry’s settings.

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to 
remove it before doing so. Note that subsequent entries move up by one when you take this 
action.

Hostname This is the name of the host.

Domain This is the host’s fully qualified domain name.

Alias Name This displays the alias name.

MX Record (for My 
FQDN)

A MX (Mail eXchange) record identifies a mail server that handles the mail for a particular 
domain.

Add Click this to create a new entry.

Edit Double-click an entry or select it and click Edit to be able to modify the entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to 
remove it before doing so. Note that subsequent entries move up by one when you take this 
action.

Hostname This is the name of the host.

Domain This is the domain name where the mail is destined for.

IP/FQDN This is the IP address or Fully-Qualified Domain Name (FQDN) of a mail server that handles the 
mail for the domain specified in the field above.

Domain Zone 
Forwarder

This specifies a DNS server’s IP address. The Zyxel Device can query the DNS server to resolve 
domain zones for features like VPN, DDNS and the time server.

When the Zyxel Device needs to resolve a domain zone, it checks it against the domain zone 
forwarder entries in the order that they appear in this list. 

Add Click this to create a new entry. Select an entry and click Add to create a new entry after the 
selected entry.

Edit Double-click an entry or select it and click Edit to be able to modify the entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to 
remove it before doing so. Note that subsequent entries move up by one when you take this 
action.

Move To change an entry’s position in the numbered list, select the method and click Move to 
display a field to type a number for where you want to put it and press [ENTER] to move the 
rule to the number that you typed.

Priority This is the index number of the domain zone forwarder record. The ordering of your rules is 
important as rules are applied in sequence. 

A hyphen (-) displays for the default domain zone forwarder record. The default record is not 
configurable. The Zyxel Device uses this default record if the domain zone that needs to be 
resolved does not match any of the other domain zone forwarder records.

Table 196   System > DNS (continued)& DDNS > DNS
LABEL DESCRIPTION
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26.3.3  Address/PTR Record 
An address record contains the mapping of a Fully-Qualified Domain Name (FQDN) to an IP address. 

The Zyxel Device allows you to configure address records about the Zyxel Device itself or another 
device. This way you can keep a record of DNS names and addresses that people on your network may 
use frequently. If the Zyxel Device receives a DNS query for an FQDN for which the Zyxel Device has an 
address record, the Zyxel Device can send the IP address in a DNS response without having to query a 
DNS name server.

A PTR (pointer) record is also called a reverse record or a reverse lookup record. It is a mapping of an IP 
address to a domain name.

26.3.4  Adding an Address/PTR Record 
Click the Add icon in the Address/PTR Record table to add an IPv4 address/PTR record.

Figure 241   System > DNS & DDNS > DNS > Address/PTR Record > Add

Domain A domain zone is a fully qualified domain name without the host. For example, zyxel.com.tw 
is the domain zone for the www.zyxel.com.tw fully qualified domain name.

A “*” means all domain zones. 

Type This displays whether the DNS server IP address is assigned by the ISP dynamically through a 
specified interface or configured manually (User-defined).

DNS Server This is the IP address of a DNS server. This field displays N/A if you have the Zyxel Device get a 
DNS server IP address from the ISP dynamically but the specified interface is not active.

Query Via This is the interface through which the Zyxel Device sends DNS queries to the entry’s DNS 
server. If the Zyxel Device connects through a VPN tunnel, tunnel displays.

Security Option 
Control

Click the arrow in the Advanced Settings field to display this part of the screen. There are two 
control policies: Default Action and Customize Action.

Query 
Recursion

This displays if the Zyxel Device is allowed or denied to forward DNS client requests to DNS 
servers for resolution.

Additional Info 
from Cache

This displays if the Zyxel Device is allowed or denied to cache Resource Records (RR) 
obtained from previous DNS queries. 

Source Address These are the object addresses used in the control policy. RFC1918 refers to private IP address 
ranges. It can be modified in Object > Address.

Table 196   System > DNS (continued)& DDNS > DNS
LABEL DESCRIPTION
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The following table describes the labels in this screen.

26.3.5  CNAME Record
A Canonical Name Record or CNAME record is a type of resource record in the Domain Name System 
(DNS) that specifies that the domain name is an alias of another, canonical domain name. This allows 
users to set up a record for a domain name which translates to an IP address, in other words, the domain 
name is an alias of another. This record also binds all the subdomains to the same IP address without 
having to create a record for each, so when the IP address is changed, all subdomain’s IP address is 
updated as well, with one edit to the record. 

For example, the domain name zyxel.com is hooked up to a record named A which translates it to 
11.22.33.44. You also have several subdomains, like mail.zyxel.com, ftp.zyxel.com and you want this 
subdomain to point to your main domain zyxel.com. Edit the IP Address in record A and all subdomains 
will follow automatically. This eliminates chances for errors and increases efficiency in DNS 
management.

26.3.6  Adding a CNAME Record
Click the Add icon in the CNAME Record table to add a record. Use “*.” as a prefix for a wildcard 
domain name. For example *.zyxel.com.

Figure 242   System > DNS & DDNS > DNS > CNAME Record > Add

Table 197   System > DNS & DDNS > DNS > Address/PTR Record > Add
LABEL DESCRIPTION
Hostname Enter the hostname of a server.

Domain Type a Fully-Qualified Domain Name (FQDN) of a server. An FQDN starts with a host name 
and continues all the way up to the top-level domain name. For example, www.zyxel.com.tw 
is a fully qualified domain name, where “www” is the host, “zyxel” is the third-level domain, 
“com” is the second-level domain, and “tw” is the top level domain. Underscores are not 
allowed.

Use "*." as a prefix in the FQDN for a wildcard domain name (for example, *.example.com).

IP Address Enter the IP address of the host in dotted decimal notation.

Save changes Click the Save changes icon to save your customized settings and exit this screen. 

Cancel changes Click the Cancel changes icon to exit this screen without saving.
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The following table describes the labels in this screen.

26.3.7  MX Record 
A MX (Mail eXchange) record indicates which host is responsible for the mail for a particular domain, 
that is, controls where mail is sent for that domain. If you do not configure proper MX records for your 
domain or other domain, external email from other mail servers will not be able to be delivered to your 
mail server and vice versa. Each host or domain can have only one MX record, that is, one domain is 
mapping to one host.

26.3.8  Adding a MX Record 
Click the Add icon in the MX Record table to add a MX record.

Figure 243   System > DNS & DDNS > DNS > MX Record Add

The following table describes the labels in this screen. 

Table 198   System > DNS & DDNS > DNS > CNAME Record > Add
LABEL DESCRIPTION
Hostname Enter the hostname of a server.

Domain Type a Fully-Qualified Domain Name (FQDN) of a server. An FQDN starts with a host 
name and continues all the way up to the top-level domain name. For example, 
www.zyxel.com.tw is a fully qualified domain name, where “www” is the host, “zyxel” 
is the third-level domain, “com” is the second-level domain, and “tw” is the top level 
domain. Underscores are not allowed.

Use "*." as a prefix in the FQDN for a wildcard domain name (for example, 
*.example.com).

Alias name Enter an Alias Name. Use "*." as a prefix in the Alias name for a wildcard domain 
name (for example, *.example.com).

Save changes Click the Save changes icon to save your customized settings and exit this screen. 

Cancel changes Click the Cancel changes icon to exit this screen without saving.

Table 199   System > DNS & DDNS > MX Record > Add 
LABEL DESCRIPTION
Hostname Enter the hostname of a server.

Domain Enter the domain name where the mail is destined for.

IP/FQDN Enter the IP address or Fully-Qualified Domain Name (FQDN) of a mail server that handles the 
mail for the domain specified in the field above.

Save changes Click the Save changes icon to save your customized settings and exit this screen. 

Cancel changes Click the Cancel changes icon to exit this screen without saving.
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26.3.9  Domain Zone Forwarder 
A domain zone forwarder contains a DNS server’s IP address. The Zyxel Device can query the DNS server 
to resolve domain zones for features like VPN, DDNS and the time server. A domain zone is a fully 
qualified domain name without the host. For example, zyxel.com.tw is the domain zone for the 
www.zyxel.com.tw fully qualified domain name. 

26.3.10  Adding a Domain Zone Forwarder 
Click the Add icon in the Domain Zone Forwarder table to add a domain zone forwarder record.

Figure 244   System > DNS & DDNS > DNS > Domain Zone Forwarder > Add

The following table describes the labels in this screen. 

Table 200   System > DNS & DDNS > DNS > Domain Zone Forwarder > Add 
LABEL DESCRIPTION
Domain A domain zone is a fully qualified domain name without the host. For example, zyxel.com.tw is 

the domain zone for the www.zyxel.com.tw fully qualified domain name. For example, 
whenever the Zyxel Device receives needs to resolve a zyxel.com.tw domain name, it can 
send a query to the recorded name server IP address.

Enter * if all domain zones are served by the specified DNS server(s). 

Type This displays whether the DNS server IP address is assigned by the ISP dynamically through a 
specified interface or configured manually (User-defined).

DNS Server Select DNS Server(s) from ISP if your ISP dynamically assigns DNS server information. You also 
need to select an interface through which the ISP provides the DNS server IP address(es). The 
interface should be activated and set to be a DHCP client. The fields below display the (read-
only) DNS server IP address(es) that the ISP assigns. N/A displays for any DNS server IP address 
fields for which the ISP does not assign an IP address.

Select Public DNS Server if you have the IP address of a DNS server. Enter the DNS server's IP 
address in the field to the right. The Zyxel Device must be able to connect to the DNS server 
without using a VPN tunnel. The DNS server could be on the Internet or one of the Zyxel 
Device’s local networks. You cannot use 0.0.0.0. 

Select Private DNS Server if you have the IP address of a DNS server to which the Zyxel Device 
connects through a VPN tunnel. Enter the DNS server's IP address in the field to the right. You 
cannot use 0.0.0.0.

Query Via Use the Query Via field to select the interface through which the Zyxel Device sends DNS 
queries to a DNS server. 

Save changes Click the Save changes icon to save your customized settings and exit this screen. 

Cancel changes Click the Cancel changes icon to exit this screen without saving.
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26.3.11  Security Option Control
Configure the Security Option Control section in the System > DNS & DDNS > DNS screen if you suspect 
the Zyxel Device is being used by hackers in a DNS amplification attack.

One possible strategy would be to deny Query Recursion and Additional Info from Cache in the default 
policy and allow Query Recursion and Additional Info from Cache only from trusted DNS servers 
identified by address objects and added as members in the customized policy.

26.3.12  Editing a Security Option Control
Use this screen to change allow or deny actions for Query Recursion and Additional Info from Cache.

Figure 245   System > DNS & DDNS > DNS > Security Option Control

The following table describes the labels in this screen. 

Table 201   System > DNS & DDNS > DNS > Security Option Control
LABEL DESCRIPTION
Query Recursion Choose if the Zyxel Device is allowed or denied to forward DNS client requests to DNS servers 

for resolution. This can apply to specific open DNS servers using the address objects in a 
customized rule.

Additional Info 
from Cache

Choose if the Zyxel Device is allowed or denied to cache Resource Records (RR) obtained 
from previous DNS queries.

Source Address This field displays address objects created in Object > Address. Select one or more address 
object(s) to have it (them) to apply to this rule. For example, you could specify an open DNS 
server suspect of sending compromised resource records by adding an address object for 
that server to the member list.

Apply Click Apply to save your customized settings and exit this screen. 

Cancel Click Cancel to return the screen to its last-saved settings. 
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26.3.13  The DDNS Screen
The DDNS screen provides a summary of all DDNS domain names and their configuration. In addition, 
this screen allows you to add new domain names, edit the configuration for existing domain names, and 
delete domain names. Click System > DNS & DDNS > DDNS to open the following screen.

Figure 246   System > DNS & DDNS > DDNS

The following table describes the labels in this screen.

Table 202   System > DNS & DDNS > DDNS 
LABEL DESCRIPTION
Add Click this to create a new entry.

Edit Double-click an entry or select it and click Edit to open a screen where you can modify 
the entry’s settings. 

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to 
remove it before doing so.

Activate To turn on an entry, select it and click Activate.

Inactivate To turn off an entry, select it and click Inactivate.

Status This icon is lit when the entry is active and dimmed when the entry is inactive.

Profile Name This field displays the descriptive profile name for this entry.

DDNS Type This field displays which DDNS service you are using.

Domain Name This field displays each domain name the Zyxel Device can route.

Primary Interface/IP This field displays the interface to use for updating the IP address mapped to the domain 
name followed by how the Zyxel Device determines the IP address for the domain name.

from interface - The IP address comes from the specified interface.

auto detected -The DDNS server checks the source IP address of the packets from the 
Zyxel Device for the IP address to use for the domain name.

custom - The IP address is static.
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26.3.14  The DDNS Add/Edit Screen
The DDNS Add/Edit screen allows you to add a domain name to the Zyxel Device or to edit the 
configuration of an existing domain name. Click System > DNS & DDNS > DDNS and then an Add or Edit 
icon to open this screen.

Backup Interface/IP This field displays the alternate interface to use for updating the IP address mapped to the 
domain name followed by how the Zyxel Device determines the IP address for the domain 
name. The Zyxel Device uses the backup interface and IP address when the primary 
interface is disabled, its link is down or its connectivity check fails.

from interface - The IP address comes from the specified interface.

auto detected -The DDNS server checks the source IP address of the packets from the 
Zyxel Device for the IP address to use for the domain name.

custom - The IP address is static.

Apply Click this button to save your changes to the Zyxel Device. 

Cancel Click this button to return the screen to its last-saved settings. 

Table 202   System > DNS & DDNS > DDNS (continued)
LABEL DESCRIPTION
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Figure 247   System > DNS & DDNS > DDNS > Add/Edit

The following table describes the labels in this screen. 

Table 203   System > DNS & DDNS > DDNS > Add/Edit 
LABEL DESCRIPTION
Enable Profile Slide the switch to the right to use this DDNS entry.

Profile Name When you are adding a DDNS entry, type a descriptive name for this DDNS entry in the 
Zyxel Device. You may use 1-31 alphanumeric characters, underscores(_), or dashes (-), 
but the first character cannot be a number. This value is case-sensitive.

This field is read-only when you are editing an entry.

DDNS Type Select the type of DDNS service you are using. 

Select User custom to create your own DDNS service and configure the DYNDNS Server, 
URL, and Additional DDNS Options fields below.

HTTPS Enable this to encrypt traffic using SSL (port 443), including traffic with username and 
password, to the DDNS server. Not all DDNS providers support this option.
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Username Type the user name used when you registered your domain name. You can use up to 31 
alphanumeric characters and (:_.-@). Spaces are not allowed.

For a Dynu DDNS entry, this user name is the one you use for logging into the service, not 
the name recorded in your personal information in the Dynu website.

Password Type the password provided by the DDNS provider. You can use up to 64 alphanumeric 
characters and the underscore. Spaces are not allowed.

Your password will be encrypted when you configure this field. 

Retype to Confirm Type the password again to confirm it.

DDNS Settings

Domain Type the domain name you registered. You can use up to 255 characters.

Primary Address Use these fields to set how the Zyxel Device determines the IP address that is mapped to 
your domain name in the DDNS server. The Zyxel Device uses the Backup Address if the 
interface specified by these settings is not available. 

Interface Select the interface to use for updating the IP address mapped to the domain name. 
Select Any to let the domain name be used with any interface.

IP Address The options available in this field vary by DDNS provider.

Interface -The Zyxel Device uses the IP address of the specified interface. This option 
appears when you select a specific interface in the Primary Binding Address Interface 
field.

Auto - If the interface has a dynamic IP address, the DDNS server checks the source IP 
address of the packets from the Zyxel Device for the IP address to use for the domain 
name. You may want to use this if there are one or more NAT routers between the Zyxel 
Device and the DDNS server.

Note: The Zyxel Device may not determine the proper IP address if there is an 
HTTP proxy server between the Zyxel Device and the DDNS server.

Custom IP - If you have a static IP address, you can select this to use it for the domain 
name. The Zyxel Device still sends the static IP address to the DDNS server.

Custom IP This field is only available when the IP Address is Custom. Type the IP address to use for the 
domain name.

Backup Address Use these fields to set an alternate interface to map the domain name to when the 
interface specified by the Primary Interface settings is not available.

Interface Select the interface to use for updating the IP address mapped to the domain name. 
Select Any to let the domain name be used with any interface. Select None to not use a 
backup address.

IP Address The options available in this field vary by DDNS provider.

Interface -The Zyxel Device uses the IP address of the specified interface. This option 
appears when you select a specific interface in the Backup Binding Address Interface 
field.

Auto -The DDNS server checks the source IP address of the packets from the Zyxel Device 
for the IP address to use for the domain name. You may want to use this if there are one or 
more NAT routers between the Zyxel Device and the DDNS server.

Note: The Zyxel Device may not determine the proper IP address if there is an 
HTTP proxy server between the Zyxel Device and the DDNS server.

Custom - If you have a static IP address, you can select this to use it for the domain name. 
The Zyxel Device still sends the static IP address to the DDNS server.

Table 203   System > DNS & DDNS > DDNS > Add/Edit (continued)
LABEL DESCRIPTION
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26.4  SNMP 
Simple Network Management Protocol is a protocol used for exchanging management information 
between network devices. Your Zyxel Device supports SNMP agent functionality, which allows a 
manager station to manage and monitor the Zyxel Device through the network. The Zyxel Device 
supports SNMP version one (SNMPv1), version two (SNMPv2c) and version 3 (SNMPv3). The next figure 
illustrates an SNMP management operation.   

Custom IP This field is only available when the IP Address is Custom. Type the IP address to use for the 
domain name.

DYNDNS Server Type the IP address of the server that will host the DDSN service.

URL Type the URL that can be used to access the server that will host the DDSN service.

Additional DDNS 
Options

These are the options supported at the time of writing:

• dyndns_system to specify the DYNDNS Server type - for example, dyndns@dyndns.org
• ip_server_name which should be the URL to get the server’s public IP address - for 

example, http://myip.easylife.tw/

Advanced Settings Click the arrow in the Advanced Settings field to show the following options.

Enable Wildcard Enable the wildcard feature to alias subdomains to be aliased to the same IP address as 
your (dynamic) domain name. This feature is useful if you want to be able to use, for 
example, www.yourhost.dyndns.org and still reach your hostname.

Mail Exchanger DynDNS can route email for your domain name to a mail server (called a mail exchanger). 
For example, DynDNS routes email for john-doe@yourhost.dyndns.org to the host record 
specified as the mail exchanger.

If you are using this service, type the host record of your mail server here. Otherwise leave 
the field blank.

See www.dyndns.org for more information about mail exchangers.

Backup Mail 
Exchanger

Select this check box if you are using DynDNS’s backup service for email. With this service, 
DynDNS holds onto your email if your mail server is not available. Once your mail server is 
available again, the DynDNS server delivers the mail to you. See www.dyndns.org for more 
information about this service.

Apply Click this button to save your changes to the Zyxel Device. 

Cancel Click this button to return the screen to its last-saved settings. 

Table 203   System > DNS & DDNS > DDNS > Add/Edit (continued)
LABEL DESCRIPTION
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Figure 248   SNMP Management Model

An SNMP managed network consists of two main types of component: agents and a manager. 

An agent is a management software module that resides in a managed device (the Zyxel Device). An 
agent translates the local management information from the managed device into a form compatible 
with SNMP. The manager is the console through which network administrators perform network 
management functions. It executes applications that control and monitor managed devices. 

The managed devices contain object variables/managed objects that define each piece of 
information to be collected about a device. Examples of variables include such as number of packets 
received, node port status etc. A Management Information Base (MIB) is a collection of managed 
objects. SNMP allows a manager and agents to communicate for the purpose of accessing these 
objects.

SNMP itself is a simple request/response protocol based on the manager/agent model. The manager 
issues a request and the agent returns responses using the following protocol operations:

• Get - Allows the manager to retrieve an object variable from the agent. 

• GetNext - Allows the manager to retrieve the next object variable from a table or list within an agent. 
In SNMPv1, when a manager wants to retrieve all elements of a table from an agent, it initiates a Get 
operation, followed by a series of GetNext operations. 

• Set - Allows the manager to set values for object variables within an agent. 

• Trap - Used by the agent to inform the manager of some events.

26.4.1  SNMPv3 and Security
SNMPv3 enhances security for SNMP management using authentication and encryption. SNMP 
managers can be required to authenticate with agents before conducting SNMP management 
sessions.
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Security can be further enhanced by encrypting the SNMP messages sent from the managers. 
Encryption protects the contents of the SNMP messages. When the contents of the SNMP messages are 
encrypted, only the intended recipients can read them. 

26.4.2  Supported MIBs
The Zyxel Device supports MIB II that is defined in RFC-1213 and RFC-1215. The Zyxel Device also supports 
private MIBs (zywall.mib and zyxel-zywall-ZLD-Common.mib) to collect information about CPU and 
memory usage and VPN total throughput. The focus of the MIBs is to let administrators collect statistical 
data and monitor status and performance. You can download the Zyxel Device’s MIBs from 
www.zyxel.com.

26.4.3  SNMP Traps
The Zyxel Device will send traps to the SNMP manager when any one of the following events occurs.

26.4.4  Configuring SNMP
To change your Zyxel Device’s SNMP settings, click System > SNMP tab. The screen appears as shown. 
Use this screen to configure your SNMP settings, including from which zones SNMP can be used to 
access the Zyxel Device. You can also specify from which IP addresses the access can come.

Table 204   SNMP Traps 
OBJECT LABEL OBJECT ID DESCRIPTION
Cold Start 1.3.6.1.6.3.1.1.5.1 This trap is sent when the Zyxel Device is turned on or 

an agent restarts.

linkDown 1.3.6.1.6.3.1.1.5.3 This trap is sent when the Ethernet link is down.

linkUp 1.3.6.1.6.3.1.1.5.4 This trap is sent when the Ethernet link is up.

authenticationFailure 1.3.6.1.6.3.1.1.5.5 This trap is sent when an SNMP request comes from 
non-authenticated hosts.

vpnTunnelDisconnected 1.3.6.1.4.1.890.1.6.22.2.3 This trap is sent when an IPSec VPN tunnel is 
disconnected.

vpnTunnelName 1.3.6.1.4.1.890.1.6.22.2.2.1.1 This trap is sent along with the 
vpnTunnelDisconnected trap. This trap carries the 
disconnected tunnel’s IPSec SA name.

vpnIKEName 1.3.6.1.4.1.890.1.6.22.2.2.1.2 This trap is sent along with the 
vpnTunnelDisconnected trap. This trap carries the 
disconnected tunnel’s IKE SA name.

vpnTunnelSPI 1.3.6.1.4.1.890.1.6.22.2.2.1.3 This trap is sent along with the 
vpnTunnelDisconnected trap. This trap carries the 
security parameter index (SPI) of the disconnected 
VPN tunnel.
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Figure 249   System > SNMP

The following table describes the labels in this screen.  

Table 205   System > SNMP 
LABEL DESCRIPTION
SNMP Enable this to allow to access the Zyxel Device using this service.

Server Port The SSH port is 161 by default. You may change the server port number for a service if 
needed, however you must use the same port number in order to use that service for 
remote management.

Trap

Destination Type the IP address of the station to send your SNMP traps to.

Community Type the trap community, which is the password sent with each trap to the SNMP manager. 
The default is public and allows all requests.

SNMP V1

SNMP V2C Select the SNMP version for the Zyxel Device. The SNMP version on the Zyxel Device must 
match the version on the SNMP manager. 

SNMP Community
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26.4.5  Add SNMP V3 User
Click Add under SNMP V3 User Configuration in System > SNMP to create an SNMPv3 user for 
authentication with managers using SNMP v3. Use the username and password of the login accounts 
you specify in this screen to create accounts on the SNMP v3 manager.

Community 1/2 Type the trap community, which is the password sent with each trap to the SNMP manager. 
The default is public and allows all requests.

Community 1/2 
Authorization

Select the access rights to the trap community.

• read-write: The associated user can create and edit the trap community.
• read-only: The associated user can only read the trap community.

SNMPV3 Select the SNMP version for the Zyxel Device. The SNMP version on the Zyxel Device must 
match the version on the SNMP manager. SNMPv3 (RFCs 3413 to 3415) provides secure 
access by authenticating and encrypting data packets over the network. The Zyxel Device 
uses your login password as the SNMPv3 authentication and encryption passphrase. 

Note: Your login password must consist of at least 8 printable characters for 
SNMPv3. An error message will display if your login password has fewer 
characters.

Add Click this to create a new entry. Select an entry and click Add to create a new entry after 
the selected entry.

Edit Double-click an entry or select it and click Edit to be able to modify the entry’s settings.

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to 
remove it before doing so. Note that subsequent entries move up by one when you take this 
action.

User This displays the name of the user object to be sent to the SNMP manager along with the 
SNMP v3 trap.

Authentication This displays the authentication algorithm used for this entry. MD5 (Message Digest 5) and 
SHA (Secure Hash Algorithm) are hash algorithms used to authenticate SNMP data. SHA 
authentication is generally considered stronger than MD5, but is slower. 

Privacy This displays the encryption method for SNMP communication from this user. Methods 
available are:

• DES - Data Encryption Standard is a widely used (but breakable) method of data 
encryption. It applies a 56-bit key to each 64-bit block of data.

• AES - Advanced Encryption Standard is another method for data encryption that also 
uses a secret key. AES applies a 128-bit key to 128-bit blocks of data.

Apply Click Apply to save your changes back to the Zyxel Device. 

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 205   System > SNMP (continued)
LABEL DESCRIPTION
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Figure 250   System > SNMP V3 > Add

The following table describes the labels in this screen. 

26.5  Notification
Use these screens to configure the mail server settings and alert settings.

Table 206   System > SNMPV3 > Add  
LABEL DESCRIPTION
User Specify the username of a login account on the Zyxel Device. The associated password is 

used in authentication algorithms and encryption methods.

Password Enters a password consists of eight characters.

User 
Authentication

Select an authentication algorithm. MD5 (Message Digest 5) and SHA (Secure Hash 
Algorithm) are hash algorithms used to authenticate SNMP data. SHA authentication is 
generally considered stronger than MD5, but is slower. 

Privacy Specify the encryption method for SNMP communication from this user. You can choose one 
of the following:

• DES - Data Encryption Standard is a widely used (but breakable) method of data 
encryption. It applies a 56-bit key to each 64-bit block of data.

• AES - Advanced Encryption Standard is another method for data encryption that also 
uses a secret key. AES applies a 128-bit key to 128-bit blocks of data.

Group Select the access rights to MIBs:

• read-write - The associated user can create and edit the MIBs on the Zyxel Device, except 
the user account.

• read-only - The associated user can only collect information from the Zyxel Device.

Apply Click Apply to save your changes back to the Zyxel Device. 

Cancel Click Cancel to return the screen to its last-saved settings. 
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26.5.1  Mail Server
Use this screen to configure a mail server so you can receive reports and notification emails such as 
when your password is about to expire. After you configure the screen, you can test the settings in 
Maintenance > Diagnostics > Network Tool and then select Test Email Server. See Log & Report > Email 
Daily Report to configure what reports to send and to whom.

Click System > Notification > Mail Server to display the following screen.

Figure 251   System > Notification > Mail Server

The following table describes the labels in this screen. 

Table 207   System > Notification > Mail Server 
LABEL DESCRIPTION
Mail Server Type the name or IP address of the outgoing SMTP server.

Port Enter the same port number here as is on the mail server for mail traffic.

TLS Security Enable this if the mail server uses Transport Layer Security (TLS) for encrypted communications 
between the mail server and the Zyxel Device. 

STARTTLS Enable this if the mail server uses SSL or TLS for encrypted communications between the mail 
server and the Zyxel Device. 

Authenticate 
Server

Enable this if the Zyxel Device authenticates the mail server in the TLS handshake.

Mail From Type the email address from which the outgoing email is delivered. This address is used in 
replies.

SMTP 
Authentication

Select this check box if it is necessary to provide a user name and password to the SMTP server.
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26.6  Certificate Overview
The Zyxel Device can use certificates (also called digital IDs) to authenticate users. Certificates are 
based on public-private key pairs. A certificate contains the certificate owner’s identity and public key. 
Certificates provide a way to exchange public keys for use in authentication. 

26.6.1  What You Need to Know
When using public-key cryptology for authentication, each host has two keys. One key is public and can 
be made openly available. The other key is private and must be kept secure. 

These keys work like a handwritten signature (in fact, certificates are often referred to as “digital 
signatures”). Only you can write your signature exactly as it should look. When people know what your 
signature looks like, they can verify whether something was signed by you, or by someone else. In the 
same way, your private key “writes” your digital signature and your public key allows people to verify 
whether data was signed by you, or by someone else. This process works as follows.

1 Tim wants to send a message to Jenny. He needs her to be sure that it comes from him, and that the 
message content has not been altered by anyone else along the way. Tim generates a public key pair 
(one public key and one private key). 

2 Tim keeps the private key and makes the public key openly available. This means that anyone who 
receives a message seeming to come from Tim can read it and verify whether it is really from him or not. 

3 Tim uses his private key to sign the message and sends it to Jenny.

4 Jenny receives the message and uses Tim’s public key to verify it. Jenny knows that the message is from 
Tim, and that although other people may have been able to read the message, no-one can have 
altered it (because they cannot re-sign the message with Tim’s private key).

5 Additionally, Jenny uses her own private key to sign a message and Tim uses Jenny’s public key to verify 
the message.

The Zyxel Device uses certificates based on public-key cryptology to authenticate users attempting to 
establish a connection, not to encrypt the data that you send after establishing a connection. The 
method used to secure the data that you send through an established connection depends on the 
type of connection. For example, a VPN tunnel might use the triple DES encryption algorithm.

User Name This box is effective when you select the SMTP Authentication check box. Type the user name 
to provide to the SMTP server when the log is emailed. Use up to 30 characters, including 0-9a-
zA-Z@._-

Password This box is effective when you select the SMTP Authentication check box. Type a password to 
provide to the SMTP server when the log is emailed. Use 4 to 63 characters, including 0-9a-zA-
Z‘~!@#$%^&*()_+={}|\;:”<>’./

Retype to 
Confirm

Type the password again to make sure that you have entered is correctly.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 207   System > Notification > Mail Server (continued)
LABEL DESCRIPTION
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The certification authority uses its private key to sign certificates. Anyone can then use the certification 
authority’s public key to verify the certificates.

A certification path is the hierarchy of certification authority certificates that validate a certificate. The 
Zyxel Device does not trust a certificate if any certificate on its path has expired or been revoked. 

Certification authorities maintain directory servers with databases of valid and revoked certificates. A 
directory of certificates that have been revoked before the scheduled expiration is called a CRL 
(Certificate Revocation List). The Zyxel Device can check a peer’s certificate against a directory server’s 
list of revoked certificates. The framework of servers, software, procedures and policies that handles keys 
is called PKI (public-key infrastructure).

Advantages of Certificates

Certificates offer the following benefits.

• The Zyxel Device only has to store the certificates of the certification authorities that you decide to 
trust, no matter how many devices you need to authenticate. 

• Key distribution is simple and very secure since you can freely distribute public keys and you never 
need to transmit private keys.

Self-signed Certificates

You can have the Zyxel Device act as a certification authority and sign its own certificates.

Factory Default Certificate

The Zyxel Device generates its own unique self-signed certificate when you first turn it on. This certificate 
is referred to in the GUI as the factory default certificate. 

Certificate File Formats

Any certificate that you want to import has to be in one of these file formats:

• Binary X.509: This is an ITU-T recommendation that defines the formats for X.509 certificates.

• PEM (Base-64) encoded X.509: This Privacy Enhanced Mail format uses lowercase letters, uppercase 
letters and numerals to convert a binary X.509 certificate into a printable form.

• Binary PKCS#7: This is a standard that defines the general syntax for data (including digital signatures) 
that may be encrypted. A PKCS #7 file is used to transfer a public key certificate. The private key is not 
included. The Zyxel Device currently allows the importation of a PKS#7 file that contains a single 
certificate. 

• PEM (Base-64) encoded PKCS#7: This Privacy Enhanced Mail (PEM) format uses lowercase letters, 
uppercase letters and numerals to convert a binary PKCS#7 certificate into a printable form.

• Binary PKCS#12: This is a format for transferring public key and private key certificates. The private key 
in a PKCS #12 file is within a password-encrypted envelope. The file’s password is not connected to 
your certificate’s public or private passwords. Exporting a PKCS #12 file creates this and you must 
provide it to decrypt the contents when you import the file into the Zyxel Device. 

Note: Be careful not to convert a binary file to text during the transfer process. It is easy for this 
to occur since many programs use text files by default. 
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26.6.2  Verifying a Certificate
Before you import a trusted certificate into the Zyxel Device, you should verify that you have the correct 
certificate. You can do this using the certificate’s fingerprint. A certificate’s fingerprint is a message 
digest calculated using the MD5 or SHA1 algorithm. The following procedure describes how to check a 
certificate’s fingerprint to verify that you have the actual certificate. 

1 Browse to where you have the certificate saved on your computer. 

2 Make sure that the certificate has a “.cer” or “.crt” file name extension.

3 Double-click the certificate’s icon to open the Certificate window. Click the Details tab and scroll down 
to the Thumbprint Algorithm and Thumbprint fields.

Figure 252   Certificate Details 

4 Use a secure method to verify that the certificate owner has the same information in the Thumbprint 
Algorithm and Thumbprint fields. The secure method may very based on your situation. Possible 
examples would be over the telephone or through an HTTPS connection. 

26.7  My Certificates
Click System > My Certificates to open the My Certificates screen. This is the Zyxel Device’s summary list 
of certificates and certification requests.
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Figure 253   System > My Certificates      

The following table describes the labels in this screen. 

Table 208   System > My Certificates 
LABEL DESCRIPTION
Add Click this to go to the screen where you can have the Zyxel Device generate a certificate or 

a certification request.

Edit Double-click an entry or select it and click Edit to open a screen with an in-depth list of 
information about the certificate.

Remove The Zyxel Device keeps all of your certificates unless you specifically delete them. Uploading 
a new firmware or default configuration file does not delete your certificates. To remove an 
entry, select it and click Remove. The Zyxel Device confirms you want to remove it before 
doing so. Subsequent certificates move up by one when you take this action.

Reference Select an entry and click Reference to check which settings use the entry.

Import Click Import to open a screen where you can save the certificate of a certification authority 
that you trust, from your computer to the Zyxel Device.

Export Click this and the following screen will appear.

Type the selected certificate’s password and save the selected certificate to your computer.

Figure 254   Export a Certificate

Name This field displays the name used to identify this certificate. It is recommended that you give 
each certificate a unique name. 

Type This field displays what kind of certificate this is. 

REQ represents a certification request and is not yet a valid certificate. Send a certification 
request to a certification authority, which then issues a certificate. Use the My Certificate 
Import screen to import the certificate and replace the request.

SELF represents a self-signed certificate. 

CERT represents a certificate issued by a certification authority.
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26.7.1  The My Certificates Add Screen
Click System > My Certificates and then the Add icon to open the following screen. Use this screen to 
have the Zyxel Device create a self-signed certificate, enroll a certificate with a certification authority or 
generate a certification request.

If you configured the My Certificate > Add screen to have the Zyxel Device enroll a certificate and the 
certificate enrollment is not successful, you will not see the certificate you configured in the My 
Certificates screen after you click Apply. Make sure that the certification authority information is correct 
and that your Internet connection is working properly if you want the Zyxel Device to enroll a certificate 
online.

Subject This field displays identifying information about the certificate’s owner, such as CN (Common 
Name), OU (Organizational Unit or department), O (Organization or company) and C 
(Country). It is recommended that each certificate have unique subject information. 

Issuer This field displays identifying information about the certificate’s issuing certification authority, 
such as a common name, organizational unit or department, organization or company and 
country. With self-signed certificates, this is the same information as in the Subject field.

Valid From This field displays the date that the certificate becomes applicable. 

Valid To This field displays the date that the certificate expires. The text displays in red and includes an 
Expired! message if the certificate has expired.

Table 208   System > My Certificates (continued)
LABEL DESCRIPTION
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Figure 255   System > My Certificates > Add
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The following table describes the labels in this screen. 

Table 209   System > My Certificates > Add 
LABEL DESCRIPTION
Name Type a name to identify this certificate. You can use up to 31 alphanumeric and 

;‘~!@#$%^&()_+[]{}’,.=- characters.

Subject Information Use these fields to record information that identifies the owner of the certificate. You do 
not have to fill in every field, although you must specify a Host IP Address, Host Domain 
Name, or E-Mail. The certification authority may add fields (such as a serial number) to the 
subject information when it issues a certificate. It is recommended that each certificate 
have unique subject information.

Select a radio button to identify the certificate’s owner by IP address, domain name or 
email address. Type the IP address (in dotted decimal notation), domain name or email 
address in the field provided. The domain name or email address is for identification 
purposes only and can be any string.

A domain name can be up to 30 characters. You can use alphanumeric characters and 
periods.

An email address can be up to 63 characters. You can use alphanumeric characters, the 
hyphen, the @ symbol, periods and the underscore.

Organizational Unit Identify the organizational unit or department to which the certificate owner belongs. You 
can use up to 31 characters. You can use alphanumeric characters, the hyphen and the 
underscore.

Organization Identify the company or group to which the certificate owner belongs. You can use up to 
31 characters. You can use alphanumeric characters, the hyphen and the underscore.

Town (City) Identify the town or city where the certificate owner is located. You can use up to 31 
characters. You can use alphanumeric characters, the hyphen and the underscore.

State (Province) Identify the state or province where the certificate owner is located. You can use up to 31 
characters. You can use alphanumeric characters, the hyphen and the underscore.

Country Enter a two-letter country code to Identify the nation where the certificate owner is 
located. 

Key Type This sets the certificate’s encryption algorithm and signature hash algorithm.

Encryption algorithms:

• RSA: Rivest, Shamir and Adleman public-key algorithm.
• DSA: Digital Signature Algorithm public-key algorithm.
• ECDSA: Elliptic Curve Digital Signature Algorithm.

Signature hash algorithms:

• SHA256
• SHA384
• SHA512

RSA and SHA256 are less secure but more compatible with different clients and 
applications. ECDSA and SHA512 are the more secure but less compatible.

Key Length Select a number from the drop-down list box to determine how many bits the key should 
use (256 to 384). The longer the key, the more secure it is. A longer key also uses more PKI 
storage space. ECDSA keys are significant shorter than RSA and DSA keys, while offering 
equal or higher security.

LifeTimes Select how long the certificate is valid. It can be valid from 1 to 10 years.

Extended Key Usage

Server Authentication Select this to have Zyxel Device generate and store a request for server authentication 
certificate.

Client Authentication Select this to have Zyxel Device generate and store a request for client authentication 
certificate.
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26.7.2  The My Certificates Edit Screen
Click System > My Certificates and then the Edit icon to open the My Certificate Edit screen. You can 
use this screen to view in-depth certificate information and change the certificate’s name. 

IKE Intermediate Select this to have Zyxel Device generate and store a request for IKE Intermediate 
authentication certificate.

Create a self-signed 
certificate

Select this to have the Zyxel Device generate the certificate and act as the Certification 
Authority (CA) itself. This way you do not need to apply to a certification authority for 
certificates.

Create a certification 
request and save it 
locally for later 
manual enrollment

Select this to have the Zyxel Device generate and store a request for a certificate. Use the 
My Certificate Details screen to view the certification request and copy it to send to the 
certification authority.

Copy the certification request from the My Certificate Details screen (see Section 26.7.2 
on page 417) and then send it to the certification authority.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 209   System > My Certificates > Add (continued)
LABEL DESCRIPTION
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Figure 256   System> My Certificates > Edit     

The following table describes the labels in this screen.

Table 210   System > My Certificates > Edit 
LABEL DESCRIPTION
Name This field displays the identifying name of this certificate. You can use up to 31 alphanumeric 

and ;‘~!@#$%^&()_+[]{}’,.=- characters.

Version This field displays the X.509 version number. 

Serial Number This field displays the certificate’s identification number given by the certification authority 
or generated by the Zyxel Device.

Subject This field displays information that identifies the owner of the certificate, such as Common 
Name (CN), Organizational Unit (OU), Organization (O), State (ST), and Country (C).

Issuer This field displays identifying information about the certificate’s issuing certification 
authority, such as Common Name, Organizational Unit, Organization and Country. 

With self-signed certificates, this is the same as the Subject Name field.

“none” displays for a certification request. 
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26.7.3  The My Certificates Import Screen 
Click System > Certificate > My Certificates > Import to open the Import Certificates screen. Follow the 
instructions in this screen to save an existing certificate to the Zyxel Device. 

Note: You can import a certificate that matches a corresponding certification request that 
was generated by the Zyxel Device. You can also import a certificate in PKCS#12 
format, including the certificate’s public and private keys.

The certificate you import replaces the corresponding request in the My Certificates screen.

You must remove any spaces from the certificate’s filename before you can import it.

Signature Algorithm This field displays the type of algorithm that was used to sign the certificate. The Zyxel 
Device uses rsa-pkcs1-sha1 (RSA public-private key encryption algorithm and the SHA1 
hash algorithm). Some certification authorities may use rsa-pkcs1-md5 (RSA public-private 
key encryption algorithm and the MD5 hash algorithm).

Valid From This field displays the date that the certificate becomes applicable. “none” displays for a 
certification request. 

Valid To This field displays the date that the certificate expires. The text displays in red and includes 
an Expired! message if the certificate has expired. “none” displays for a certification 
request. 

Key Algorithm This field displays the type of algorithm that was used to generate the certificate’s key pair 
(the Zyxel Device uses RSA encryption) and the length of the key set in bits (1024 bits for 
example).

Subject Alternative 
Name

This field displays the certificate owner‘s IP address (IP), domain name (DNS) or email 
address (EMAIL). 

Key Usage This field displays for what functions the certificate’s key can be used. For example, 
“DigitalSignature” means that the key can be used to sign certificates and 
“KeyEncipherment” means that the key can be used to encrypt text.

Extended Key Usage This field displays how the Zyxel Device generates and stores a request for server 
authentication, client authentication, or IKE Intermediate authentication certificate.

Basic Constraint This field displays general information about the certificate. For example, Subject Type=CA 
means that this is a certification authority’s certificate and   “Path Length Constraint=1” 
means that there can only be one certification authority in the certificate’s path. This field 
does not display for a certification request. 

PEM Encoded 
Format

This read-only text box displays the certificate or certification request in Privacy Enhanced 
Mail (PEM) format. PEM uses lowercase letters, uppercase letters and numerals to convert a 
binary certificate into a printable form.

You can copy and paste a certification request into a certification authority’s web page, 
an email that you send to the certification authority or a text editor and save the file on a 
management computer for later manual enrollment.

You can copy and paste a certificate into an email to send to friends or colleagues or you 
can copy and paste a certificate into a text editor and save the file on a management 
computer for later distribution (via external storage device for example).

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 210   System > My Certificates > Edit (continued)
LABEL DESCRIPTION
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Figure 257   System > Certificate > My Certificates > Import

The following table describes the labels in this screen.  

26.8  Trusted Certificates
Click System > Certificate > Trusted Certificates to open the Trusted Certificates screen. This screen 
displays a summary list of certificates that you have set the Zyxel Device to accept as trusted. The Zyxel 
Device also accepts any valid certificate signed by a certificate on this list as being trustworthy; thus you 
do not need to import any certificate that is signed by one of these certificates. 

Table 211   System > Certificate > My Certificates > Import 
LABEL DESCRIPTION
File Path Type in the location of the file you want to upload in this field or click Browse to find it.

You cannot import a certificate with the same name as a certificate that is already in the Zyxel 
Device.

Browse Click Browse to find the certificate file you want to upload. 

Password This field only applies when you import a binary PKCS#12 format file. Type the file’s password that was 
created when the PKCS #12 file was exported. 

OK Click OK to save the certificate on the Zyxel Device.
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Figure 258   System > Certificate > Trusted Certificates 

The following table describes the labels in this screen.  

Table 212   System > Certificate > Trusted Certificates 
LABEL DESCRIPTION
PKI Storage Space 
in Use

This bar displays the percentage of the Zyxel Device’s PKI storage space that is currently in 
use. When the storage space is almost full, you should consider deleting expired or 
unnecessary certificates before adding more certificates.

Edit Double-click an entry or select it and click Edit to open a screen with an in-depth list of 
information about the certificate.

Remove The Zyxel Device keeps all of your certificates unless you specifically delete them. Uploading a 
new firmware or default configuration file does not delete your certificates. To remove an 
entry, select it and click Remove. The Zyxel Device confirms you want to remove it before 
doing so. Subsequent certificates move up by one when you take this action.

Import Click Import to open a screen where you can save the certificate of a certification authority 
that you trust, from your computer to the Zyxel Device.

Export Click this and the following screen will appear.

Type the selected certificate’s password and save the selected certificate to your computer.

Figure 259   Export a Certificate

Name This field displays the name used to identify this certificate. 

Subject This field displays identifying information about the certificate’s owner, such as CN (Common 
Name), OU (Organizational Unit or department), O (Organization or company) and C 
(Country). It is recommended that each certificate have unique subject information.

Issuer This field displays identifying information about the certificate’s issuing certification authority, 
such as a common name, organizational unit or department, organization or company and 
country. With self-signed certificates, this is the same information as in the Subject field.

Valid From This field displays the date that the certificate becomes applicable. 

Valid To This field displays the date that the certificate expires. The text displays in red and includes an 
Expired! message if the certificate has expired.
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26.8.1  The Trusted Certificates Edit Screen
Click System > Certificate > Trusted Certificates > Edit icon to open the Trusted Certificates Edit screen. 
Use this screen to view in-depth information about the certificate.

Figure 260   System > Certificate > Trusted Certificates > Edit 

The following table describes the labels in this screen.  

Table 213   System > Certificate > Trusted Certificates > Edit 
LABEL DESCRIPTION
Certification Path Click the Refresh button to have this read-only text box display the end entity’s certificate 

and a list of certification authority certificates that shows the hierarchy of certification 
authorities that validate the end entity’s certificate. If the issuing certification authority is 
one that you have imported as a trusted certificate, it may be the only certification 
authority in the list (along with the end entity’s own certificate). The Zyxel Device does not 
trust the end entity’s certificate and displays “Not trusted” in this field if any certificate on 
the path has expired or been revoked.

Refresh Click Refresh to display the certification path.

Name This field displays the identifying name of this certificate.
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26.8.2  The Trusted Certificates Import Screen 
Click System > Certificate > Trusted Certificates > Import to open the Import Trusted Certificates screen. 
Follow the instructions in this screen to save a trusted certificate to the Zyxel Device.

Note: You must remove any spaces from the certificate’s filename before you can import the 
certificate.

Type This field displays general information about the certificate. CA-signed means that a 
Certification Authority signed the certificate. Self-signed means that the certificate’s owner 
signed the certificate (not a certification authority). X.509 means that this certificate was 
created and signed according to the ITU-T X.509 recommendation that defines the formats 
for public-key certificates.

Version This field displays the X.509 version number. 

Serial Number This field displays the certificate’s identification number given by the certification authority.

Subject This field displays information that identifies the owner of the certificate, such as Common 
Name (CN), Organizational Unit (OU), Organization (O) and Country (C).

Issuer This field displays identifying information about the certificate’s issuing certification 
authority, such as Common Name, Organizational Unit, Organization and Country. 

With self-signed certificates, this is the same information as in the Subject Name field.

Signature Algorithm This field displays the type of algorithm that was used to sign the certificate. Some 
certification authorities use rsa-pkcs1-sha1 (RSA public-private key encryption algorithm 
and the SHA1 hash algorithm). Other certification authorities may use rsa-pkcs1-md5 (RSA 
public-private key encryption algorithm and the MD5 hash algorithm).

Valid From This field displays the date that the certificate becomes applicable. The text displays in red 
and includes a Not Yet Valid! message if the certificate has not yet become applicable.

Valid To This field displays the date that the certificate expires. The text displays in red and includes 
an Expiring! or Expired! message if the certificate is about to expire or has already expired.

Key Algorithm This field displays the type of algorithm that was used to generate the certificate’s key pair 
(the Zyxel Device uses RSA encryption) and the length of the key set in bits (1024 bits for 
example).

Subject Alternative 
Name

This field displays the certificate’s owner‘s IP address (IP), domain name (DNS) or email 
address (EMAIL).

Key Usage This field displays for what functions the certificate’s key can be used. For example, 
“DigitalSignature” means that the key can be used to sign certificates and 
“KeyEncipherment” means that the key can be used to encrypt text.

Extended Key Usage This field displays the method that the Zyxel Device generates and stores a request for server 
authentication, client authentication, or IKE Intermediate authentication certificate.

Basic Constraint This field displays general information about the certificate. For example, Subject Type=CA 
means that this is a certification authority’s certificate and   “Path Length Constraint=1” 
means that there can only be one certification authority in the certificate’s path.

Certificate in PEM 
(Base-64) Encoded 
Format

This read-only text box displays the certificate or certification request in Privacy Enhanced 
Mail (PEM) format. PEM uses lowercase letters, uppercase letters and numerals to convert a 
binary certificate into a printable form.

You can copy and paste the certificate into an email to send to friends or colleagues or 
you can copy and paste the certificate into a text editor and save the file on a 
management computer for later distribution (via external storage device for example).

Table 213   System > Certificate > Trusted Certificates > Edit (continued)
LABEL DESCRIPTION
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Figure 261   System > Certificate > Trusted Certificates > Import

The following table describes the labels in this screen. 

26.9  Advanced
Click System > Advanced to open the Advanced screen. Use this screen to view UDP and ICMP timeout 
settings on your Zyxel Device and to enable or disable ARP spoofing prevention, device insight, and 
LLDP functions.

Table 214   System > Certificate > Trusted Certificates > Import 
LABEL DESCRIPTION
File Path Type in the location of the file you want to upload in this field or click Browse to find it.

You cannot import a certificate with the same name as a certificate that is already in the Zyxel 
Device.

Browse Click Browse to find the certificate file you want to upload. 

OK Click OK to save the certificate on the Zyxel Device.
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Figure 262   System > Advanced

The following table describes the labels in this screen. 

Table 215   System > Advanced 
LABEL DESCRIPTION
System Parameters

Name This field displays the name of the system parameter.

• UDP Timeout: After the UDP client sends a request to the server, if there is no response from 
the server within this set time, the Zyxel Device ends the UDP connection.

• UDP Timeout Stream: The UDP client sends a request to the server and receives a response, 
but the connection is interrupted. If there is no further response from the server within this set 
time, the Zyxel Device ends the UDP connection

• ICMP Timeout: This shows how long the Zyxel Device waits before considering the ICMP 
connection attempt a failure.

Description This field displays the description of the system information.

Value This field displays the value of the system information. Click the Edit icon to modify the value.

Additional Features

Enabled Click this switch to enable or disable the feature. When the switch turns green, the function is 
enabled.

Name This field displays the name of the feature.

• ARP Spoofing Prevention: Enable this feature to prevent and create a log on the Zyxel 
Device when there is a fake ARP message that failed the ARP verification.

• Device Insight: Enable this feature to collect status and basic information of the clients 
connected to the Zyxel Device.

• LLDP: Link Layer Discovery Protocol (LLDP, IEEE 802.1AB) is a Layer 2 protocol that allows 
network devices to advertise their identity and capabilities on a LAN. Enable this feature to 
allow your Zyxel Device to share its identity and capabilities on the local network.

Description This field displays what the feature does.
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CHAPTER 27
Log and Report 

27.1  Overview
Use these screens to configure daily reporting and log settings. 

27.1.1  What You Can Do In this Chapter
• Use the Log/Events screen (Section 27.2 on page 426) to view the Zyxel Device log messages.

• Use the Log Settings screen (Section 27.3 on page 430) to specify settings for recording log messages 
and alerts and storing them on a connected USB storage device.

• Use the SecuReporter screen (Section 27.4 on page 432) to enable SecuReporter logging on your 
Zyxel Device, see license status, type, expiration date and access a link to the SecuReporter web 
portal. The SecuReporter web portal collects and analyzes logs from your Zyxel Device in order to 
identify anomalies, alert on potential internal/ external threats, and report on network usage.

• Use the Email Daily Report screen (Section 27.5 on page 434) to start or stop traffic collection and 
view reports on traffic passing through the Zyxel Device.

27.2  Log/Events Screen
To access this screen, click Log & Report > Log/Events. The log is displayed on the following screen.

Note: When a log reaches the maximum number of log messages, new log messages 
automatically overwrite existing log messages, starting with the oldest existing log 
message first.

• The maximum possible number of log messages in the Zyxel Device varies by model.

Events that generate an alert (as well as a log message) display in red. Regular logs display in black. 
Click a column’s heading cell to sort the table entries by that column’s criteria. Click the heading cell 
again to reverse the sort order. The Web Configurator saves the filter settings if you leave the Log/Events 
screen and return to it later.
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Figure 263   Log & Report > Log/Events

The following table describes the labels in this screen.

Table 216   Log & Report > Log/Events  
LABEL DESCRIPTION
Category Select the type of log you want to display from this list box. 

Refresh Click this button to update the information on the screen.

Clear Log Click this button to clear the whole log, regardless of what is currently displayed on the 
screen.

Export Click this button to download logs of the chosen category to your computer in Excel 
(format (.xlsx).
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SecuReporter The following category of logs show a SecuReporter icon . Click this icon 
to view more historical logs in SecuReporter. You should already have a SecuReporter 
account.

• Anti-Malware
• Application Patrol
• Content Filter
• DNS Threat Filter
• IP Reputation
• IPS
• Sandbox
• URL Threat Filter

Search Type a keyword to look for in the Message, Source, Destination and Note fields. If a 
match is found in any field, the log message is displayed. You can use up to 63 
alphanumeric characters and the underscore, as well as punctuation marks ()’ ,:;?! +-*/
= #$% @ ; the period, double quotes, and brackets are not allowed. 

Filter Click this icon to display specific types of logs. Select a type or type a keyword 
depending on the filter chosen. 

Source Address This displays when you show the filter. Type the source IP address of the incoming 
packet that generated the log message. Do not include the port in this filter.

Destination Address This displays when you show the filter. Type the IP address of the destination of the 
incoming packet when the log message was generated. Do not include the port in this 
filter.

Source Interface This displays when you show the filter. Type the source interface of the incoming packet 
that generated the log message. 

Destination Interface This displays when you show the filter. Type the interface of the destination of the 
incoming packet when the log message was generated. 

Protocol This displays when you show the filter. Select a service protocol whose log messages 
you would like to see. 

Reset Click Reset to return the screen to its last-saved settings. 

# This field is a sequential value, and it is not associated with a specific log message.

Time This field displays the time the log message was recorded.

Table 216   Log & Report > Log/Events  (continued)
LABEL DESCRIPTION
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Pri This displays when you show the filter. Select the priority of log messages to display. The 
log displays the log messages with this priority or higher. Choices are: emerg, alert, crit, 
error, warn, notice, and info, from highest priority to lowest priority.

Category This field displays the log that generated the log message. It is the same value used in 
the Category field above.

Message This field displays the reason the log message was generated. The text “[count=x]”, 
where x is a number, appears at the end of the Message field if log consolidation is 
turned on and multiple entries were aggregated to generate into this one.

Src. IP This field displays the source IP address in the event that generated the log message.

Src. Port This field displays the source port number in the event that generated the log message.

Dst. IP This field displays the destination IP address of the event that generated the log 
message.

Dst. Port This field displays the destination port number of the event that generated the log 
message.

Note This field displays any additional information about the log message.

Action This field displays whether packets were dropped, blocked or if no action was taken as 
a result of the log. It should correspond to the action configured in Security Policy > 
Policy Control. 

Table 216   Log & Report > Log/Events  (continued)
LABEL DESCRIPTION
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27.2.1  Log Details
Double-click a log entry to display details on the log. The below is an example.

27.3  Log Settings Screen
The Log Settings screen control log messages. A log message stores the information for viewing or 
regular emailing later.

The Zyxel Device provides a system log and supports email profiles and remote syslog servers. Use the 
email profiles to mail log messages to the specific destinations. You can also have the Zyxel Device store 
system logs on a connected USB storage device. The other two logs are stored on specified syslog 
servers.

Note: Only connect one USB device. It must allow writing (it cannot be read-only) and use the 
FAT16, FAT32, EXT2, or EXT3 file system.

To access this screen, click Log & Report > Log Settings.
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Figure 264   Log & Report > Log Settings

The following table describes the labels in this screen.

Table 217   Log & Report > Log Settings 
LABEL DESCRIPTION
Log Category 
Setting

Select which events you want to log by Category. There are three choices:

disable- do not log any information from this category

normal- create log messages and alerts from this category

debug- create log messages, alerts, and debugging information from this category; the Zyxel 
Device does not email debugging information, however, even if this setting is selected.

Log Consolidation Enable this to activate log consolidation. Log consolidation aggregates multiple log 
messages that arrive within the specified Consolidation Interval. In Log Category Setting, the 
Count field is the number of original log messages when multiple log messages were 
aggregated.

Consolidation 
Interval

Type how often, in seconds, to consolidate log information. If the same log message appears 
multiple times, it is aggregated into one log message in the Count field in Log Category 
Setting.
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27.4  SecuReporter
SecuReporter is a security analytics portal that collects and analyzes logs from SecuReporter-licensed 
Zyxel Devices in order to identify anomalies, alert on potential internal / external threats, and report on 
network usage. You need to buy a license for SecuReporter for your Zyxel Device and register it at NCC.

If a license has expired, you will see a reminder in this screen. You need to renew the license in order to 
keep using the feature. Click Buy Now to go to Marketplace to purchase a new license. Click See 
Details to go to the Zyxel web page to find more information on licenses for your Zyxel Device. 

Enable USB 
Storage

Enable this if you want to use the connected USB device(s).

Log Keep Duration Set a number of days (1 to 365) that the Zyxel Device keeps the log.

Remote Server 1/2

Active Enable this to send log information according to the information in this section. 

Log Format This field displays the format of the log information. It is read-only.

Syslog - Zyxel’s Vantage Report, syslog-compatible format.

CEF/Syslog - Common Event Format, syslog-compatible format.

Server Address Type the server name or the IP address of the syslog server to which to send log information.

Server Port Type the service port number used by the remote server.

Log Facility Select a log facility. The log facility allows you to log the messages to different files in the 
syslog server. Please see the documentation for your syslog program for more information.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 217   Log & Report > Log Settings (continued)
LABEL DESCRIPTION
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Figure 265   SecuReporter Application Scenario 

How to activate and enable SecuReporter

1 If SecuReporter Service Status does not display Activated, you have to log in to NCC and activate the 
SecuReporter license for this Zyxel Device. The Zyxel Device must be able to communicate with the NCC 
server. 

2 After the SecuReporter license is activated, go back to the Log & Report > SecuReporter screen, and 
select the categories of logs that you want this Zyxel Device to send to the SecuReporter portal. 

3 Slide the switch to the right under General Settings to enabled SecuReporter. Do not go to the 
SecuReporter portal until after you have enabled SecuReporter on this Zyxel Device and applied the 
settings. You can also see license status, type, expiration date.

4 Click Apply and wait.
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How to add this Zyxel Device to SecuReporter

1 Log in to the SecuReporter portal.

2 Go to More > Organization & Devices, click Add Organization to create an organization.

3 Add this Zyxel Device to the organization you created using the hyper link under Unclaimed.

Click Log & Report > SecuReporter to open the following screen.

Figure 266   Log & Report > SecuReporter

The following table describes the labels in this screen.

27.5  Email Daily Report
Use the Email Daily Report screen to start or stop data collection and view various statistics about traffic 
passing through your Zyxel Device. Click the Mail Server link under Note to set up the mail server in the 
Notification screen.

Note: Data collection may decrease the Zyxel Device’s traffic throughput rate.

Table 218   Log & Report > SecuReporter  
LABEL DESCRIPTION
Enable This must be enabled to have SecuReporter collect and analyze logs from this Zyxel 

Device. Click SecuReporter tutorial video to go to YouTube to see related configuration 
videos.

It’s selected by default if you have activated a SecuReporter license.

Categories Select the categories of logs that you want this Zyxel Device to send to SecuReporter for 
analysis and trend spotting. You need an active license for the Security categories.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 
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Click Log & Report > Email Daily Report to display the following screen. Configure this screen to have the 
Zyxel Device email you system statistics at the specified time.

Figure 267   Log & Report > Email Daily Report 

The following table describes the labels in this screen. 

Table 219   Log & Report > Email Daily Report 
LABEL DESCRIPTION
Enable Email Daily 
Report

Select this to send reports by email every day. 

Reset All Counters Click this to discard all report data and start all of the counters over at zero. 

E-mail Subject Type the subject line for outgoing email from the Zyxel Device. 

Type a string using up to 60 of these characters [a-zA-Z0-9’()+,./:=?;!#@$_%-].

E-mail From Type the email address from which the outgoing email is sent.

E-mail To Type the email address (or addresses) to which the outgoing email is delivered.

Send Report Now Click this button to have the Zyxel Device send the daily email report immediately. Check your 
spam mail folder if you cannot receive the report.
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27.5.1  Example Reports
The following screens are an example of a email daily report.

Figure 268   Email Daily Report: System Resource Usage

Figure 269   Email Daily Report- Licensing

Reset counters 
after sending 
report successfully

Select Reset counters after sending report successfully if you only want to see statistics for a 24 
hour period.

Report Items Select the information to include in the report. Types of information include System Resource 
Usage, Traffic Statistics, Security Services and System Information.

Schedule Select the time of the day the report is emailed.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings. 

Table 219   Log & Report > Email Daily Report (continued)
LABEL DESCRIPTION
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Figure 270   Email Daily Report: Threat Report

Figure 271   Email Daily Report: DHCP Table
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CHAPTER 28
File Manager

28.1  Overview
Configuration files define the Zyxel Device’s settings. You can apply a configuration file without the Zyxel 
Device restarting. You can store multiple configuration files on the Zyxel Device. You can edit 
configuration files in a text editor and upload them to the Zyxel Device. Configuration files use a .conf 
extension.

28.1.1  What You Can Do in this Chapter
• Use the Configuration File screen (see Section 28.2 on page 439) to store and name configuration 

files. You can also download configuration files from the Zyxel Device to your computer and upload 
configuration files from your computer to the Zyxel Device.

• Use the Firmware Package screen (see Section 28.3 on page 443) to check your current firmware 
version and upload firmware to the Zyxel Device.

28.1.2  What you Need to Know 

Configuration Files

When you apply a configuration file, the Zyxel Device uses the factory default settings for any features 
that the configuration file does not include. Other settings do not change.

The Zyxel Device applies configuration files in the following way:

• Reset to default configuration.

• Go into CLI Configuration mode.

• Run the commands in the configuration file.

28.1.3  Configuration File Flow at Restart
You can manually restart the Zyxel Device through a management interface or by physically turning the 
power off and back on. 

The Zyxel Device restarts automatically when you upload new firmware. 

The Zyxel Device always checks for errors in any configuration file when rebooting. The Zyxel Device 
generates a log for any errors. 

• If there is not a startup-config.conf when you restart the Zyxel Device, the Zyxel Device uses the 
system-default.conf configuration file with the Zyxel Device’s default settings. The Zyxel Device will 
apply the system-default.conf when it boots without a startup-config.conf, even if you have a 
lastgood.conf.
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• If there is a startup-config.conf, the Zyxel Device checks it for errors and applies it if there are no errors. 
The Zyxel Device also copies it to the lastgood.conf configuration file as a back up file. 

• If there is an error in startup-config.conf, the Zyxel Device generates a log and copies startup-
config.conf to startup-config-bad.conf and then tries the existing lastgood.conf configuration file. 

• If there isn’t a lastgood.conf configuration file or it also has an error, the Zyxel Device applies the 
system-default.conf configuration file.

Figure 272   Zyxel Device Start-up Flow

28.2  The Configuration File Screen
Click Maintenance > Firmware/File Manager> Configuration File to open the Configuration File screen. 

Use the Configuration screen to store, run, and name configuration files. You can also download 
configuration files from the Zyxel Device to your computer and upload configuration files from your 
computer to the Zyxel Device.

Once your Zyxel Device is configured and functioning properly, it is highly recommended that you back 
up your configuration file before making further configuration changes. The backup configuration file 
will be useful in case you need to return to your previous settings. 
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Figure 273   Maintenance > Firmware/File Manager > Configuration File 

Do not turn off the Zyxel Device while configuration file upload is in 
progress.

The following table describes the labels in this screen.  

Table 220   Maintenance > Firmware/File Manager > Configuration File 
LABEL DESCRIPTION
Configuration

Rename Use this button to change the label of a configuration file on the Zyxel Device. You can only 
rename manually saved configuration files. You cannot rename the lastgood.conf, system-
default.conf and startup-config.conf files. 

You cannot rename a configuration file to the name of another configuration file in the Zyxel 
Device. 

Click a configuration file’s row to select it and click Rename to open the Rename File screen. 

Specify the new name for the configuration file. Use up to 63 characters (including a-zA-Z0-
9;‘~!@#$%^&()_+[]{}’,.=-). 

Click OK to save the renamed label or click ( ) to close the screen without saving the 
renamed label.

Remove Click a configuration file’s row to select it and click Remove to delete it from the Zyxel Device. 
You can only delete manually saved configuration files. You cannot delete the system-
default.conf, startup-config.conf and lastgood.conf files.

A pop-up window asks you to confirm that you want to delete the configuration file. Click OK 
to delete the configuration file or click Close to close the screen without deleting the 
configuration file.
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Download Click a configuration file’s row to select it and click Download to save the configuration into 
your computer.

Copy Use this button to save a duplicate of a configuration file on the Zyxel Device. 

Click a configuration file’s row to select it and click Copy to open the Copy File screen. 

Specify a name for the duplicate configuration file. Use up to 63 characters (including a-zA-Z0-
9;‘~!@#$%^&()_+[]{}’,.=-). 

Click OK to save the duplicate or click ( ) to close the screen without saving a duplicate of 
the configuration file.

Apply Use this button to have the Zyxel Device use a specific configuration file.

Click a configuration file’s row to select it and click Apply to have the Zyxel Device use that 
configuration file. The following screen displays. Click OK to have the Zyxel Device start 
applying the configuration file or click Cancel to close the screen.
Apply a Configuration File

Email Use this button to have the Zyxel Device send the selected configuration file to the configured 
email addresses.

Click a configuration file’s row to select it and click Email to have the Zyxel Device mail that 
configuration file. The following screen displays.

E-mail Subject Enter a email subject text with 1-60 characters. It may consist of letters, numbers, and the 
following special characters: ‘()+,./:=?;!*#@$%-

Email To Enter the receiving email address. You and send the configuration file to a maximum of five 
email addresses.

Email 
Content

Enter the backup email body text using 1 to 251 single-byte characters, including 0-9a-zA-
Z!”#$%&’()*+,-./:;<=>@[\]^_‘{|} and spaces are allowed.

? is not allowed.

Table 220   Maintenance > Firmware/File Manager > Configuration File (continued)
LABEL DESCRIPTION
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Send Email Click this to send the email to the email address you configured.

Cancel Click this to close the screen.

Upload Click this to upload a new or previously saved configuration file from your computer to your 
Zyxel Device.

You cannot upload a configuration file named system-default.conf, startup-config.conf or 
lastgood.conf. 

File Path Type in the location of the file you want to upload in this field or click Browse ... to find it.

Browse... Click Browse... to find the .conf file you want to upload. The configuration file must use a 
“.conf” filename extension. You will receive an error message if you try to upload a fie of a 
different format. Remember that you must decompress compressed (.zip) files before you can 
upload them. 

Upload Click Upload to begin the upload process. This process may take up to two minutes. 

Cancel Click this to close the screen.

Test Before applying a configuration file to the Zyxel Device, you can select the file and click Test to 
check if the configuration file has errors.

Configuration Test: Pass - The configuration file is correct.

Configuration Test: Fail - An error was found in the configuration file. Applying a configuration 
file with errors may cause malfunctions in your Zyxel Device.

To see details on errors, download the log file using FTP from /tmp/apply-config-error.log. The 
log file indicates which CLI line had errors. Contact customer support if errors cannot be 
solved.

Note: Make sure startup-config.conf does not have an error before you restart the 
Zyxel Device or upload new firmware.

File Name This column displays the label that identifies a configuration file.

You cannot change the following configuration files their file names. 

The system-default.conf file contains the Zyxel Device’s default settings. Select this file and click 
Apply to reset all of the Zyxel Device settings to the factory defaults. This configuration file is 
included when you upload a firmware package. 

The startup-config.conf file is the configuration file that the Zyxel Device is currently using. If you 
make and save changes during your management session, the changes are applied to this 
configuration file. The Zyxel Device applies configuration changes made in the Web 
Configurator to the configuration file when you click Apply or OK. It applies configuration 
changes made via commands when you use the write command. 

The lastgood.conf is the most recently used (valid) configuration file that was saved when the 
device last restarted. If you upload and apply a configuration file with an error, you can apply 
lastgood.conf to return to a valid configuration.

Size This column displays the size (in KB) of a configuration file.

Last Modified This column displays the date and time that the individual configuration files were last 
changed or saved.

Configure 
Backup Schedule

Backups created by a schedule are given an automatic name by the Zyxel Device. The name 
of a scheduled backup file follows this format: 'backup-yyyy-mm-dd-hh-mm-ss'.conf. To restore 
a configuration file, click Upload to upload the file, then select the file and click Apply to apply 
the file to the Zyxel Device. 

Enable Auto 
Backup

Select the check box to back up the configuration file at a user defined schedule.

Note: After the first backup, the back up only occurs if the configuration file is 
different from the previous backed up configuration file.

Table 220   Maintenance > Firmware/File Manager > Configuration File (continued)
LABEL DESCRIPTION
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28.3   Firmware Management
Use the Firmware Management screen to check your current firmware version and upload firmware to 
the Zyxel Device.

Note: The Web Configurator is the recommended method for uploading firmware. You only 
need to use the command line interface if you need to recover the firmware. See the 
CLI Reference Guide for how to determine if you need to recover the firmware and 
how to recover it.

Find the firmware file in a folder that (usually) uses the system model name with the model code and a 
bin extension. For example, a firmware for USG FLEX 200HP is “100ABEX0b3s1.bin”. 

Note: The Zyxel Device restarts automatically when you upload new firmware. 

28.3.1  Cloud Helper
Cloud Helper lets you know if there is a later firmware available on the Cloud Helper server and lets you 
download it if there is. 

Daily Set the Zyxel Device to back up its configuration file once a day at the specified hour and 
minute.

Weekly Set the Zyxel Device to back up its configuration file once a week on the specified day, at the 
specified hour and minute.

Monthly Set the Zyxel Device to back up its configuration file once a month on the specified day, at the 
a specified hour and minute. 

Note: If the date you select is greater than the number of days in a month, the Zyxel 
Device automatically backs up its configuration file on the last day of the 
month. For example, if you select 31 and the month is February, the Zyxel 
Device backs up its configuration file on day 28 or 29.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings.

Table 220   Maintenance > Firmware/File Manager > Configuration File (continued)
LABEL DESCRIPTION
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Note: Go to NCC, create an account and register your Zyxel Device first. Then you will be 
able to get notifications on new firmware available when you log into the Zyxel Device 
web configurator.

28.3.2  The Firmware Management Screen 
Click Maintenance > Firmware/File Manager > Firmware Management to open the Firmware 
Management screen. 

Note: The Zyxel Device automatically reboots when you upload new firmware.

Table 221   Cloud Helper Firmware Icons
Cloud Firmware

  

Cloud firmware is being downloaded from the Cloud Helper Server. 

Local Firmware

  

Use this if you have already downloaded the latest firmware from the Zyxel website to 
your computer and unzipped it. 

Click the icon and then browse to the location of the unzipped files.

The Zyxel Device will reboot automatically when it finishes uploading.
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Figure 274   Maintenance > Firmware/File Manager > Firmware Management    

The following table describes the labels in this screen.

Table 222   Maintenance > Firmware/File Manager > Firmware Management 
LABEL DESCRIPTION
Status This displays the running firmware status.

Model This is the model name of the device which the firmware is running on.

Version This is the firmware version and the date created. 

Released Date This is the date that the version of the firmware was created. 

Action Click ( ) to upload a firmware from your computer to the Zyxel Device. Click Upload to 
upload the firmware as the running firmware after the Zyxel Device reboots. Your current 
configuration settings will be saved and applied after reboot.

Click ( ) to download a later firmware from the Cloud Helper Server. This icon shows if there 
is a later firmware on the Cloud Helper Server than the running firmware on your Zyxel Device.

Cloud Firmware 
Information

You must register your Zyxel Device at NCC first to use cloud firmware. 

Latest Version This displays the latest firmware version at the Cloud Helper Server. Click Check Now to see if 
there is a later firmware at the Cloud Server.

Release Date This displays the date the latest firmware version was made available.

Release Note The release note contains details of latest firmware version such as new features and bug 
fixes.

Auto Update Slide the switch to the right to have the Zyxel Device automatically check for and download 
new firmware to the standby partition at the time and day specified.

You should select a time when your network is not busy for minimal interruption.

Daily Select this option to have the Zyxel Device check for new firmware every day at the specified 
time. The time format is the 24 hour clock, so ‘0’ means midnight for example. 

Weekly Select this option to have the Zyxel Device check for new firmware once a week on the day 
and at the time specified.

Apply Click Apply to save your changes back to the Zyxel Device.

Cancel Click Cancel to return the screen to its last-saved settings.
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CHAPTER 29
Diagnostics

29.1  Overview
Use the diagnostics screens for troubleshooting.

29.1.1  What You Can Do in this Chapter
• Use the Diagnostics screens (see Section 29.2 on page 446) to generate a file containing the Zyxel 

Device’s configuration and diagnostic information if you need to provide it to customer support 
during troubleshooting.

• Use the Packet Capture screens (see Section 29.3 on page 448) to capture packets going through the 
Zyxel Device.

• Use the CPU / Memory Status screens (see Section 29.4 on page 452) to view the CPU and memory 
performance of various applications on the Zyxel Device.

• Use the System Log screen (see Section 29.4 on page 452) to view the files of diagnostic information 
the Zyxel Device has collected and stored on a connected USB storage device.

• Use the Network Tool screen (see Section 29.6 on page 455) to ping an IP address or trace the route 
packets take to a host.

29.2  The Diagnostics Screens
The Diagnostics screens provide an easy way for you to generate a file containing the Zyxel Device’s 
configuration and diagnostic information. You may need to send this file to customer support for 
troubleshooting.

29.2.1  The Diagnostics Screen
Click Maintenance > Diagnostics > Diagnostics to open the following screen. When you click Collect 
Now, a series of commands are run to display information about the Zyxel Device.

This screen also lists the files of diagnostic information the Zyxel Device has collected and stored on the 
Zyxel Device or in a connected USB storage device. You may need to send these files to customer 
support for troubleshooting.
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Figure 275   Maintenance > Diagnostics > Diagnostics 

The following table describes the labels in this screen.  

Table 223   Maintenance > Diagnostics > Diagnostics 
LABEL DESCRIPTION
Diagnostics Collect Status

Status This field displays the following states the Zyxel Device is in when collecting 
diagnostic data.

• Standby: The Zyxel Device is ready to generate a diagnostic file or has just 
finished generating a diagnostic file.

• Busy on device: The Zyxel Device is generating a diagnostic file containing its 
own configuration and diagnostic information.

Collect Now Click this to have the Zyxel Device run the uploaded script and create a new 
diagnostic file.
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29.3  The Packet Capture Screen
Click Maintenance > Diagnostics > Packet Capture to open the packet capture files screen. This screen 
lists the files of packet captures stored on the Zyxel Device or a connected USB storage device. You can 
download the files to your computer where you can study them using a packet analyzer (also known as 
a network or protocol analyzer) such as Wireshark.

Figure 276   Maintenance > Diagnostics > Packet Capture 

General Setting

Filename This is the name of the most recently created diagnostic file.

Modified Time This is the date and time that the last diagnostic file was created. The format is yyyy-
mm-dd hh:mm:ss.

Size This is the size of the most recently created diagnostic file.

Copy the diagnostic file to 
USB storage

Select this to have the Zyxel Device create an extra copy of the diagnostic file to a 
connected USB storage device. 

Diagnostic files This lists the files of generated diagnostic information stored on the Zyxel Device.

Diagnostic files in USB 
storage

This lists the files of generated diagnostic information stored in a connected USB 
storage device.

Remove Select files and click Remove to delete them from the Zyxel Device or the USB 
storage device.

Download Click a file to select it and click Download to save it to your computer.

# This column displays the number for each file entry. The total number of files that you 
can save depends on the file sizes and the available storage space.

File Name This column displays the label that identifies the file. 

Size This column displays the size (in bytes) of a file.

Modified Time This column displays the date and time that the individual files were saved.

Table 223   Maintenance > Diagnostics > Diagnostics (continued)
LABEL DESCRIPTION
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The following table describes the labels in this screen. 

29.3.1  The Packet Capture Edit Screen
Use this screen to capture network traffic going through the Zyxel Device’s interfaces. Studying these 
packet captures may help you identify network problems. Click Maintenance > Diagnostics > Packet 
Capture > Edit to open the packet capture screen.

Note: New capture files overwrite existing files of the same name. Change the File Suffix field’s 
setting to avoid this.

Table 224   Maintenance > Diagnostics > Packet Capture
LABEL DESCRIPTION
Edit Click this to configure packet capture settings.

Interface This field displays the interface for which to capture packets.

Protocol This field displays the protocol of traffic for which to capture packets.

Host this field displays the host IP address object for which to capture packets.

Host Port This field displays the port number of traffic to capture.

File/Split Size (MB) This field displays the maximum size limit in megabytes for individual packet capture files.

Storage This field displays where the packet capture entry is saved.

Capture Click this button to have the Zyxel Device capture packets according to the settings 
configured in this screen.

You can configure the Zyxel Device while a packet capture is in progress although you cannot 
modify the packet capture settings.

The Zyxel Device’s throughput or performance may be affected while a packet capture is in 
progress.

After the Zyxel Device finishes the capture it saves a separate capture file for each selected 
interface. The total number of packet capture files that you can save depends on the file sizes 
and the available flash storage space. Once the flash storage space is full, adding more 
packet captures will fail.

Remove Select files and click Remove to delete them from the Zyxel Device or the connected USB 
storage device.

Download Click a file to select it and click Download to save it to your computer.

File Name This column displays the label that identifies the file. The file name format is interface name-file 
suffix.cap. 

Size This column displays the size (in bytes) of a configuration file.

Modified Time This column displays the date and time that the individual files were saved.
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Figure 277   Maintenance > Diagnostics > Packet Capture > Edit

The following table describes the labels in this screen.  

Table 225   Maintenance > Diagnostics > Packet Capture > Edit 
LABEL DESCRIPTION
Interfaces Select interfaces for which to capture packets and click the right arrow button to move 

them to the right.

IP Version Select the version of IP for which to capture packets. Select any to capture packets for 
all IP versions.
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Protocol Type Select the protocol of traffic for which to capture packets. Select any to capture 
packets for all types of traffic.

Host IP Select a host IP address object for which to capture packets. Select any to capture 
packets for all hosts. Select User Defined to be able to enter an IP address.

Host Port This field is configurable when you set the IP Type to any, tcp, or udp. Specify the port 
number of traffic to capture.

Continuously capture 
and overwrite old ones

Enable to have the Zyxel Device keep capturing traffic and overwriting old packet 
capture entries when the available storage space runs out.

Captured Packet Files When saving packet captures only to the Zyxel Device’s on board storage, specify a 
maximum limit in megabytes for the total combined size of all the capture files on the 
Zyxel Device. 

When saving packet captures to a connected USB storage device, specify a maximum 
limit in megabytes for each capture file. 

Note: If you have existing capture files and have not selected the 
Continuously capture and overwrite old ones option, you may need to 
set this size larger or delete existing capture files.

The valid range depends on the available on board/USB storage size. The Zyxel Device 
stops the capture and generates the capture file when either the file reaches this size or 
the time period specified in the Duration field expires.

Split threshold Specify a maximum size limit in megabytes for individual packet capture files. After a 
packet capture file reaches this size, the Zyxel Device starts another packet capture file.

Duration Set a time limit in seconds for the capture. The Zyxel Device stops the capture and 
generates the capture file when either this period of time has passed or the file reaches 
the size specified in the File Size field. 0 means there is no time limit.

File Suffix Specify text to add to the end of the file name (before the dot and filename extension) 
to help you identify the packet capture files. Modifying the file suffix also avoids making 
new capture files that overwrite existing files of the same name. 

The file name format is “interface name-file suffix.cap”, for example “vlan2-packet-
capture.cap”.

Number Of Bytes To 
Capture (Per Packet)

Specify the maximum number of bytes to capture per packet. The Zyxel Device 
automatically truncates packets that exceed this size. As a result, when you view the 
packet capture files in a packet analyzer, the actual size of the packets may be larger 
than the size of captured packets.

Save data to onboard 
storage only 

Select this to have the Zyxel Device only store packet capture entries on the Zyxel 
Device. The available storage size is displayed as well.

Note: The Zyxel Device reserves some on board storage space as a buffer.

Table 225   Maintenance > Diagnostics > Packet Capture > Edit (continued)
LABEL DESCRIPTION
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29.4  The CPU / Memory Status Screen
Click Maintenance > Diagnostics > CPU / Memory Status to open the CPU/Memory Status screen. Use 
this screen to view the CPU and memory performance of various applications on the Zyxel Device.

Save data to USB 
storage 

Select this to have the Zyxel Device store packet capture entries only on a USB storage 
device connected to the Zyxel Device if the Zyxel Device allows this. The USB file format 
should be FAT32.

Status:

Unused - the connected USB storage device was manually unmounted by using the 
Remove Now button or for some reason the Zyxel Device cannot mount it.

none - no USB storage device is connected.

service deactivated - USB storage feature is disabled (in System > USB Storage), so the 
Zyxel Device cannot use a connected USB device to store system logs and other 
diagnostic information.

available - you can have the Zyxel Device use the USB storage device. The available 
storage capacity also displays.

Note: The Zyxel Device reserves some USB storage space as a buffer.
Save data to ftp server Select this to have the Zyxel Device store packet capture entries on the defined FTP site. 

The available storage size is displayed as well.

Server Address Type the IP address of the FTP server.

Server Port Type the port this server uses for FTP traffic. The default FTP port is 21.

Name Type the login username to access the FTP server.

Password Type the associated login password to access the FTP server.

Table 225   Maintenance > Diagnostics > Packet Capture > Edit (continued)
LABEL DESCRIPTION
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Figure 278   Maintenance > Diagnostics > CPU / Memory Status    
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The following table describes the labels in this screen.

29.5  The System Log Screen
Click Maintenance > Diagnostics > System Log to open the System Log screen. This screen lists the files of 
diagnostic information the Zyxel Device has collected and stored on a connected USB storage device. 
You may need to send these files to customer support for troubleshooting.

Table 226   Maintenance > Diagnostics > CPU / Memory Status 
LABEL DESCRIPTION
CPU Status

This table displays the applications that use the most Zyxel Device CPU processing.

CPU Usage CPU usage shows how much processing power the Zyxel Device is using. This field displays the 
current percentage usage of a CPU (where n is the number of the CPU) as a percentage of 
total processing power. CPU usage may appear temporarily high when creating graphic-
intensive statistics and reports. You may ignore it, and observe the long-term usage.

# This field is a sequential value, and it is not associated with any entry.

Refresh Click this to update the information in this screen.

CPU This field displays the current CPU utilization percentage for each application used on the Zyxel 
Device.

Application This field displays the name of the application consuming the related processing power on the 
Zyxel Device.

Memory This field displays the current DRAM memory utilization percentage for each application used 
on the Zyxel Device.

Time This field displays each application’s running time in hours - minutes - seconds.

Memory Status

This table displays the applications that use the most Zyxel Device DRAM memory.

Memory Usage Memory usage shows how much DRAM memory the Zyxel Device is using. This field displays the 
current percentage of memory utilization. 

# This field is a sequential value, and it is not associated with any entry.

Memory This field displays the current DRAM memory utilization percentage for each application used 
on the Zyxel Device.

Application This field displays the name of the application consuming the related memory on the Zyxel 
Device.

CPU This field displays the current CPU utilization percentage for each application used on the Zyxel 
Device.

Time This field displays each application’s running time.
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Figure 279   Maintenance > Diagnostics > System Log    

The following table describes the labels in this screen.

29.6  The Network Tool Screen
Use this screen to perform various network tests. 

Click Maintenance > Diagnostics > Network Tool to display this screen. 

Table 227   Maintenance > Diagnostics > System Log 
LABEL DESCRIPTION
Remove Select files and click Remove to delete them from the USB storage device. A pop-up window 

asks you to confirm that you want to delete.

Download Select a file and click Download to save it to your computer.

File Name This column displays the label that identifies the file.

Size This column displays the size (in bytes) of a file.

Modified Time This column displays the date and time that the individual files were saved.
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Figure 280   Maintenance > Diagnostics > Network Tool    

The following table describes the labels in this screen.

Table 228   Maintenance > Diagnostics > Network Tool 
LABEL DESCRIPTION
Network Tool Select a network tool:

• Select NSLOOKUP IPv4 to perform name server lookup for querying the Domain 
Name System (DNS) to get the domain name or IP address mapping.

• Select PING IPv4 to ping the IP address that you entered.
• Select TRACEROUTE IPv4 to run the traceroute function. This determines the path a 

packet takes to the specified computer.

Domain Name or IP 
Address

Type the IP address that you want to use to for the selected network tool.

Advanced Settings

Query Server Enter the IP address of a server to which the Zyxel Device sends queries for NSLOOKUP.

Extension Option Enter the extended option if you want to use an extended ping or traceroute 
command. For example, enter “-c count” (where count is the number of ping 
requests) to set how many times the Zyxel Device pings the destination IP address. Enter 
“-w waittime” (where waittime is a time period in seconds) to set how long the Zyxel 
Device waits for a response to a probe before running another traceroute.

Test Click this button to start the test.

Reset Click this button to return the screen to its last-saved settings. 
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CHAPTER 30
Reboot/ShutDown

30.1  Overview
Use this screen to restart or turn off the Zyxel Device.

30.2  The Reboot/Shutdown Screen
To access this screen, click Maintenance > Reboot/Shutdown. 

When you click Reboot or Shutdown, your current configurations made using the web configurator are 
saved. 

Note: Your current configurations made using the command line interface (CLI) are not 
saved if you didn’t use the copy running startup command to save the current 
configurations as the startup configurations.

Note: If startup-config.conf has an error, the Zyxel Device may restart with an older 
configuration file or the factory default configuration file with all your configurations 
lost. Use Test in Maintenance > Firmware/File Manager > Configuration to check that 
startup-config.conf does not have an error. See Section 28.1.3 on page 438 for details 
on which configuration files are used at start-up.

Click Reboot to reboot the Zyxel Device without turning the power off.

Click Shutdown to prepare the Zyxel Device to turn off. Wait for the PWR/SYS LED to turn off before you 
remove the Zyxel Device power cable.

Figure 281   Maintenance > Reboot/Shutdown
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CHAPTER 31
Troubleshooting

This chapter offers some suggestions to solve problems you might encounter. You can also refer to the 
logs; see Section 27.2 on page 426 for more information.

None of the LEDs turn on.

Make sure that you have the power cord connected to the Zyxel Device and plugged in to an 
appropriate power source. Make sure you have the Zyxel Device turned on. Check all cable 
connections.

If the LEDs still do not turn on, you may have a hardware problem. In this case, you should contact your 
local vendor.

Cannot access the Zyxel Device from the LAN.

• Check the cable connection between the Zyxel Device and your computer or switch. 

• Ping the Zyxel Device from a LAN computer. Make sure your computer’s Ethernet card is installed and 
functioning properly. Also make sure that its IP address is in the same subnet as the Zyxel Device’s.

• In the computer, click Start, (All) Programs, Accessories and then Command Prompt. In the 
Command Prompt window, type “ping” followed by the Zyxel Device’s LAN IP address (192.168.168.1 
is the default) and then press [ENTER]. The Zyxel Device should reply.

If you’ve forgotten the Zyxel Device’s password, use the RESET button. Press the button in for about 7 
seconds (or until the PWR/SYS LED starts to blink), then release it. It returns the Zyxel Device to the default 
configuration with password is 1234, LAN IP address 192.168.168.1. All configuration files, including those 
you saved on the Zyxel Device, will be deleted.

• If you’ve forgotten the Zyxel Device’s IP address, you can use the commands through the CONSOLE 
port to check it. Connect your computer to the CONSOLE port using a console cable. Your computer 
should have a terminal emulation communications program (such as HyperTerminal) set to VT100 
terminal emulation, no parity, 8 data bits, 1 stop bit, no flow control and 115200 bps port speed. 

I cannot access the Internet.

• Check the Zyxel Device’s connection to the Ethernet jack with Internet access. Make sure the Internet 
gateway device (such as a DSL modem) is working properly. 

• Check the WAN interface's status in the Dashboard. Use the installation setup wizard again and make 
sure that you enter the correct settings. Use the same case as provided by your ISP.
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I cannot update the IPS/application patrol/IP reputation signatures.

• Make sure your Zyxel Device has the IPS/application patrol/IP reputation service registered and that 
the license is not expired. Purchase a new license if the license is expired. 

• Make sure your Zyxel Device is connected to the Internet.

I downloaded updated IPS/application patrol/IP reputation signatures. Why has the Zyxel Device 
not re-booted yet?

The Zyxel Device does not have to reboot when you upload new signatures.

My Zyxel Device is not performing the action I set in Security Service > IPS when a stream of data 
matches a malicious signature.

Make sure you set the Zyxel Device to Prevention mode for the Zyxel Device to take action. The Zyxel 
Device only creates log messages in Detection mode and does not take action.

The content filtering category service is not working.

Make sure your Zyxel Device is connected to the Internet. Use the feedback link in the screen to give 
feedback on a link that should or should not be in a certain content filtering category.

I configured security settings but the Zyxel Device is not applying them for certain interfaces.

Many security settings are usually applied to zones. Make sure you assign the interfaces to the 
appropriate zones. When you create an interface, there is no security applied on it until you assign it to 
a zone.

The Zyxel Device is not applying the custom policy route I configured.

The Zyxel Device checks the policy routes in the order that they are listed. So make sure that your 
custom policy route comes before any other routes that the traffic would also match.

The Zyxel Device is not applying the custom security policy I configured.
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The Zyxel Device checks the security policies in the order that they are listed. So make sure that your 
custom security policy comes before any other rules that the traffic would also match.

My rules and settings that apply to a particular interface no longer work.

The interface’s IP address may have changed. To avoid this, create an IP address object based on the 
interface. This way the Zyxel Device automatically updates every rule or setting that uses the object 
whenever the interface’s IP address settings change. For example, if you change LAN1’s IP address, the 
Zyxel Device automatically updates the corresponding interface-based, LAN1 subnet address object.

I cannot set up a PPP interface.

You have to set up an ISP account before you can create a PPPoE or PPTP interface.

I cannot configure a particular VLAN interface on top of an Ethernet interface even though I 
have it configured on top of another Ethernet interface.

Each VLAN interface is created on top of only one Ethernet interface.

The Zyxel Device’s performance slowed down after I configured many new application patrol 
entries.

The Zyxel Device checks the ports and conditions configured in application patrol entries in the order 
they appear in the list. While this sequence does not affect the functionality, you might improve the 
performance of the Zyxel Device by putting more commonly used ports at the top of the list.

The Zyxel Device’s anti-malware scanner cleaned an infected file but now the receiver cannot 
use the file.

If the MD5 hash value is incorrect, then Anti-Malware removes the last packet of the file. The file is still 
forwarded to the receiver, but they will not be able to open it. The receiver is not notified if a file is 
modified by the Zyxel Device. If the file cannot be used, the receiver should contact the Zyxel Device 
administrator to confirm if the Zyxel Device modified the file by checking the logs.

The Zyxel Device sent an alert that a malware-infected file has been found, but the file was still 
forwarded to the user and could still be executed.
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Make sure you enable Destroy Infected File in the Security Services > Anti-Malware screen to modify 
infected files before forwarding the files to the user, preventing them from being executed.

I added a file pattern in the anti-malware allow list, but the Zyxel Device still checks and modifies 
files that match this pattern.

Make sure you enable the anti-malware allow list. If it is already enabled, make sure that the allow list 
entry corresponding to this file pattern is activated.

The Zyxel Device’s performance seems slower after configuring IPS.

Depending on your network topology and traffic load, binding every packet direction to an IPS profile 
may affect the Zyxel Device’s performance. You may want to focus IPS scanning on certain traffic 
directions such as incoming traffic.

IPS is dropping traffic that matches a rule that says no action should be taken.

The Zyxel Device checks all signatures and continues searching even after a match is found. If two or 
more rules have conflicting actions for the same packet, then the Zyxel Device applies the more 
restrictive action (reject-both, reject-receiver or reject-sender, drop, none in this order). If a packet 
matches a rule for reject-receiver and it also matches a rule for reject-sender, then the Zyxel Device will 
reject-both.

The Zyxel Device’s performance seems slower after configuring DoS Prevention.

Depending on your network topology and traffic load, applying an anomaly profile to each and every 
packet direction may affect the Zyxel Device’s performance.

Some of the files I download don’t go through Sandbox even though it is enabled.

The Sandbox feature only applies to certain file types. Check the list in File Submission Options to see if 
the file types you use are included. If they are, make sure you select their corresponding check box.

Sandbox detected a malicious file, but the file still went through the Zyxel Device and is still 
usable.
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Make sure you set your Sandbox settings to destroy malicious files in the Security Services > Sandbox: 
Action For Malicious File drop-down list box.

The Zyxel Device destroyed/dropped a file/email without notifying me.

Make sure you enable logs for your security features, such as in the following screens:

• Security Services > IPS
• Security Services > Anti-Malware
• Security Services > Sandbox
• Security Services > Reputation Filter

The Zyxel Device routes and applies SNAT for traffic from some interfaces but not from others.

The Zyxel Device automatically uses SNAT for traffic it routes from internal interfaces to external 
interfaces. For example, SNAT is used for LAN to WAN traffic. You must manually configure a policy route 
to add routing and SNAT settings for an interface with the Interface Type set to General. You can also 
configure a policy route to override the default routing and SNAT behavior for an interface with the 
Interface Type set to Internal or External.

I cannot get Dynamic DNS to work.

• You must have set up an account for Dynamic DNS service. These are supported at the time of 
writing. 

• Make sure you recorded your DDNS account’s user name, password, and domain name and have 
entered them properly in the Zyxel Device.

• You must have a public WAN IP address to use Dynamic DNS.

• You may need to configure the DDNS entry’s IP Address setting to Auto if the interface has a dynamic 
IP address or there are one or more NAT routers between the Zyxel Device and the DDNS server.

• The Zyxel Device may not determine the proper IP address if there is an HTTP proxy server between the 
Zyxel Device and the DDNS server.
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I cannot get the application patrol to manage FTP traffic.

Make sure you have the FTP ALG enabled in Network > ALG. 

The Zyxel Device keeps resetting the connection.

If an alternate gateway on the LAN has an IP address in the same subnet as the Zyxel Device’s LAN IP 
address, return traffic may not go through the Zyxel Device. This is called an asymmetrical or “triangle” 
route. This causes the Zyxel Device to reset the connection, as the connection has not been 
acknowledged.

You can set the Zyxel Device’s security policy to permit the use of asymmetrical route topology on the 
network (so it does not reset the connection) although this is not recommended since allowing 
asymmetrical routes may let traffic from the WAN go directly to the LAN without passing through the 
Zyxel Device. A better solution is to use virtual interfaces to put the Zyxel Device and the backup 
gateway on separate subnets. See Asymmetrical Routes on page 209 and the chapter about interfaces 
for more information.

I cannot set up an IPSec VPN tunnel to another device.

If the IPSec tunnel does not build properly, the problem is likely a configuration error at one of the IPSec 
routers. Log into both Zyxel IPSec routers and check the settings in each field methodically and slowly. 
Make sure both the Zyxel Device and remote IPSec router have the same security settings for the VPN 
tunnel. It may help to display the settings for both routers side-by-side.

Here are some general suggestions. See also IPSec VPN.

• The system log can often help to identify a configuration problem.

• If you enable NAT traversal, the remote IPSec device must also have NAT traversal enabled. 

• The Zyxel Device and remote IPSec router must use the same authentication method to establish the 
IKE SA.

• Both routers must use the same negotiation mode.

• Both routers must use the same encryption algorithm, authentication algorithm, and DH key group.

• When using pre-shared keys, the Zyxel Device and the remote IPSec router must use the same pre-
shared key.

• The Zyxel Device’s local and peer ID type and content must match the remote IPSec router’s peer 
and local ID type and content, respectively.

• The Zyxel Device and remote IPSec router must use the same active protocol.

• The Zyxel Device and remote IPSec router must use the same encapsulation.

• The Zyxel Device and remote IPSec router must use the same SPI.

• If the sites are/were previously connected using a leased line or ISDN router, physically disconnect 
these devices from the network before testing your new VPN connection. The old route may have 
been learned by RIP and would take priority over the new VPN connection.
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• To test whether or not a tunnel is working, ping from a computer at one site to a computer at the 
other. 
Before doing so, ensure that both computers have Internet access (via the IPSec routers).

• It is also helpful to have a way to look at the packets that are being sent and received by the Zyxel 
Device and remote IPSec router (for example, by using a packet sniffer). 

Check the configuration for the following Zyxel Device features.

• The Zyxel Device does not put IPSec SAs in the routing table. You must create a policy route for each 
VPN tunnel.

• Make sure the To-Zyxel Device security policies allow IPSec VPN traffic to the Zyxel Device. IKE uses 
UDP port 500, AH uses IP protocol 51, and ESP uses IP protocol 50.

• The Zyxel Device supports UDP port 500 and UDP port 4500 for NAT traversal. If you enable this, make 
sure the To-Zyxel Device security policies allow UDP port 4500 too.

• Make sure regular security policies allow traffic between the VPN tunnel and the rest of the network. 
Regular security policies check packets the Zyxel Device sends before the Zyxel Device encrypts 
them and check packets the Zyxel Device receives after the Zyxel Device decrypts them. This 
depends on the zone to which you assign the VPN tunnel and the zone from which and to which 
traffic may be routed.

• If you set up a VPN tunnel across the Internet, make sure your ISP supports AH or ESP (whichever you 
are using).

• If you have the Zyxel Device and remote IPSec router use certificates to authenticate each other, You 
must set up the certificates for the Zyxel Device and remote IPSec router first and make sure they trust 
each other’s certificates. If the Zyxel Device’s certificate is self-signed, import it into the remote IPSec 
router. If it is signed by a CA, make sure the remote IPSec router trusts that CA. The Zyxel Device uses 
one of its Trusted Certificates to authenticate the remote IPSec router’s certificate. The trusted 
certificate can be the remote IPSec router’s self-signed certificate or that of a trusted CA that signed 
the remote IPSec router’s certificate.

• Multiple SAs connecting through a secure gateway must have the same negotiation mode.

The VPN connection is up but VPN traffic cannot be transmitted through the VPN tunnel.

If you have the VPN > IPSec VPN > VPN Connection screen’s Use Policy Route to control dynamic IPSec 
rules option enabled, check the routing policies to see if they are sending traffic elsewhere instead of 
through the VPN tunnels. 

I changed the LAN IP address and can no longer access the Internet.

The Zyxel Device automatically updates address objects based on an interface’s IP address, subnet, or 
gateway if the interface’s IP address settings change. However, you need to manually edit any address 
objects for your LAN that are not based on the interface.

I configured application patrol to allow and manage access to a specific service but access is 
blocked.
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If you want to use a service, make sure the security policy allows Security Service application patrol to 
go through the Zyxel Device.

My two-factor authentication is not working.

Check that match the specifications and limitation in the following list:

•  Ext-users (authenticated by external servers) are not supported.

• You must setup Google Authenticator on their mobile device before you can successfully 
authenticate with the Zyxel Device.

I get a Google Authenticator verification error.

• Check that you enter the right verification code. The verification code should be 6 digits.

• You must enter the code within the time displayed in Google Authenticator.

• You’ve exceeded the maximum verification code failed attempts.

The schedule I configured is not being applied at the configured times. 

Make sure the Zyxel Device’s current date and time are correct. 

I cannot get a certificate to import into the Zyxel Device.

1 For My Certificates, you can import a certificate that matches a corresponding certification request that 
was generated by the Zyxel Device. You can also import a certificate in PKCS#12 format, including the 
certificate’s public and private keys.

2 You must remove any spaces from the certificate’s filename before you can import the certificate.

3 Any certificate that you want to import has to be in one of these file formats:

• Binary X.509: This is an ITU-T recommendation that defines the formats for X.509 certificates.

• PEM (Base-64) encoded X.509: This Privacy Enhanced Mail format uses lowercase letters, uppercase 
letters and numerals to convert a binary X.509 certificate into a printable form.

• Binary PKCS#7: This is a standard that defines the general syntax for data (including digital signatures) 
that may be encrypted. A PKCS #7 file is used to transfer a public key certificate. The private key is not 
included. The Zyxel Device currently allows the importation of a PKS#7 file that contains a single 
certificate. 

• PEM (Base-64) encoded PKCS#7: This Privacy Enhanced Mail (PEM) format uses lowercase letters, 
uppercase letters and numerals to convert a binary PKCS#7 certificate into a printable form.
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• Binary PKCS#12: This is a format for transferring public key and private key certificates.The private key 
in a PKCS #12 file is within a password-encrypted envelope. The file’s password is not connected to 
your certificate’s public or private passwords. Exporting a PKCS #12 file creates this and you must 
provide it to decrypt the contents when you import the file into the Zyxel Device. 

Note: Be careful not to convert a binary file to text during the transfer process. It is easy for this 
to occur since many programs use text files by default. 

I cannot access the Zyxel Device from a computer connected to the Internet.

Check the service control rules and to-Zyxel Device security policies. 

The Zyxel Device’s traffic throughput rate decreased after I started collecting traffic statistics.

Data collection may decrease the Zyxel Device’s traffic throughput rate.

I can only see newer logs. Older logs are missing. 

When a log reaches the maximum number of log messages, new log messages automatically overwrite 
existing log messages, starting with the oldest existing log message first.

I cannot get the firmware uploaded using the commands.

The Web Configurator is the recommended method for uploading firmware. You only need to use the 
command line interface if you need to recover the firmware. See the CLI Reference Guide for how to 
determine if you need to recover the firmware and how to recover it.

My packet capture captured less than I wanted or failed. 

The packet capture screen’s File Size sets a maximum size limit for the total combined size of all the 
capture files on the Zyxel Device, including any existing capture files and any new capture files you 
generate. If you have existing capture files you may need to set this size larger or delete existing capture 
files.

The Zyxel Device stops the capture and generates the capture file when either the capture files reach 
the File Size or the time period specified in the Duration field expires.
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My earlier packet capture files are missing. 

New capture files overwrite existing files of the same name. Change the File Suffix field’s setting to avoid 
this.

My Zyxel Device CPU usage is too high. I see an alert log that says “abnormal TCP flag attack 
detected”.

Your FTP server is in active mode. It is sending too much traffic to the Zyxel Device. Set your FTP server to 
passive mode.

I cannot apply a configuration file.

The configuration file you upload to the Zyxel Device must meet the following requirements:

• The configuration file size cannot be 0.

• The configuration file must be a text file, a JSON file or a XML file. 

• The model name in the configuration file must be the same as the Zyxel Device model you’re 
uploading to.

• Use Test to check the configuration file for errors before applying it to the Zyxel Device.

My Zyxel Device cannot assign correct IP addresses to DHCP clients in my LAN and DMZ.

Make sure your Zyxel Device is the only device with DHCP server enabled in your network.

The clients’ information I collected using Device Insight is not correct. 

Make sure your clients are in the same IP subnet in the LAN/VLAN/DMZ networks behind the Zyxel 
Device. Information from clients that are in different IP subnets in the LAN/VLAN/DMZ networks might not 
be collected correctly.

To report on clients that are wrongly identified, go to Network Status > Device Insight > Feedback.

I cannot remove a client in Network Status > Device Insight. 
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Clients that are blocked cannot be removed. Please make sure to unblock the client you want to 
remove first.

31.1  Reserved System Ports
The Zyxel Device reserves the following system ports. 

Note: You cannot change a service port to a reserved system port.

31.2  Resetting the Zyxel Device
If you cannot access the Zyxel Device by any method, try restarting it by turning the power off and then 
on again. If you still cannot access the Zyxel Device by any method or you forget the administrator 
password(s), you can reset the Zyxel Device to its factory-default settings. 

Note: All configuration files, including those you saved on the Zyxel Device, will be deleted.

Use the following procedure to reset the Zyxel Device to its factory-default settings. This overwrites the 
settings in the startup-config.conf file with the settings in the system-default.conf file. 

Note: This procedure removes the current configuration. 

1 Make sure the PWR/SYS LED is on and not blinking.

2 Press the RESET button and hold it until the PWR/SYS LED begins to blink. (This usually takes about 7 
seconds.)

Table 229   Reserved System Ports
TCP PORTS UDP PORTS
53 53

179 67

830 68

953 500

2601 546

2602 547

2603 1812

2604 1813

2605 3799

2616 4500

5432 5246

7681 5247

7682 18121



Chapter 31 Troubleshooting

USG FLEX H Series User’s Guide

470

3 Release the RESET button, and wait for the Zyxel Device to restart.

You should be able to access the Zyxel Device using the default settings.

31.3  Restarting the Zyxel Device
If startup-config.conf has an error, the Zyxel Device may restart with an older configuration file or the 
factory default configuration file with all your configurations lost. Use Test in Maintenance > Firmware/File 
Manager > Configuration to make sure that startup-config.conf does not have an error. See Section 
28.1.3 on page 438 for details on which configuration files are used at start-up.

31.4  Getting More Troubleshooting Help
Go to support.zyxel.com to find other information on the Zyxel Device.
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APPENDIX A
Customer Support

In the event of problems that cannot be solved by using this manual, you should contact your vendor. If 
you cannot contact your vendor, then contact a ZyXEL office for the region in which you bought the 
device.

For ZyXEL Communication offices, see https://service-provider.zyxel.com/global/en/contact-us for the 
latest information.

For ZyXEL Network offices, see https://www.zyxel.com/index.shtml for the latest information.

Please have the following information ready when you contact an office.

Required Information
• Product model and serial number.

• Warranty Information.

• Date that you received your device.

• Brief description of the problem and the steps you took to solve it.

Corporate Headquarters (Worldwide)

Taiwan
• ZyXEL Communications (Taiwan) Co., Ltd.

• https://www.zyxel.com

Asia

China
• ZyXEL Communications Corporation–China Office

• https://www.zyxel.com/cn/sc

India
• ZyXEL Communications Corporation–India Office

• https://www.zyxel.com/in/en-in

Kazakhstan
• ZyXEL Kazakhstan

• https://www.zyxel.com/ru/ru

https://service-provider.zyxel.com/global/en/contact-us
https://www.zyxel.com/index.shtml
https://www.zyxel.com
https://www.zyxel.com/cn/sc
https://www.zyxel.com/in/en-in
https://www.zyxel.com/ru/ru
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Korea
• ZyXEL Korea Co., Ltd.

• http://www.zyxel.kr/

Malaysia
• ZyXEL Communications Corp.

• https://www.zyxel.com/global/en

Philippines
• ZyXEL Communications Corp.

• https://www.zyxel.com/global/en

Singapore
• ZyXEL Communications Corp.

• https://www.zyxel.com/global/en

Taiwan
• ZyXEL Communications (Taiwan) Co., Ltd.

• https://www.zyxel.com/tw/zh

Thailand
• ZyXEL Thailand Co., Ltd.

• https://www.zyxel.com/th/th

Vietnam
• ZyXEL Communications Corporation–Vietnam Office

• https://www.zyxel.com/vn/vi

Europe

Belarus
• ZyXEL Communications Corp.

• https://www.zyxel.com/ru/ru

Belgium (Netherlands)
• ZyXEL Benelux

• https://www.zyxel.com/nl/nl

• https://www.zyxel.com/fr/fr

Bulgaria
• ZyXEL Bulgaria

http://www.zyxel.kr/
https://www.zyxel.com/global/en
https://www.zyxel.com/global/en
https://www.zyxel.com/global/en
https://www.zyxel.com/tw/zh
https://www.zyxel.com/th/th
https://www.zyxel.com/vn/vi
https://www.zyxel.com/ru/ru
https://www.zyxel.com/nl/nl
https://www.zyxel.com/fr/fr
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• https://www.zyxel.com/bg/bg

Czech Republic
• ZyXEL Communications Czech s.r.o.

• https://www.zyxel.com/cz/cs

Denmark
• ZyXEL Communications A/S

• https://www.zyxel.com/dk/da

Finland
• ZyXEL Communications

• https://www.zyxel.com/fi/fi

France
• ZyXEL France

• https://www.zyxel.com/fr/fr

Germany
• ZyXEL Deutschland GmbH.

• https://www.zyxel.com/de/de

Hungary
• ZyXEL Hungary & SEE

• https://www.zyxel.com/hu/hu

Italy
• ZyXEL Communications Italy S.r.l.

• https://www.zyxel.com/it/it

Norway
• ZyXEL Communications A/S

• https://www.zyxel.com/no/no

Poland
• ZyXEL Communications Poland

• https://www.zyxel.com/pl/pl

Romania
• ZyXEL Romania

• https://www.zyxel.com/ro/ro

https://www.zyxel.com/bg/bg
https://www.zyxel.com/cz/cs
https://www.zyxel.com/dk/da
https://www.zyxel.com/fi/fi
https://www.zyxel.com/fr/fr
https://www.zyxel.com/de/de
https://www.zyxel.com/hu/hu
https://www.zyxel.com/it/it
https://www.zyxel.com/no/no
https://www.zyxel.com/pl/pl
https://www.zyxel.com/ro/ro
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Russian Federation
• ZyXEL Communications Corp.

• https://www.zyxel.com/ru/ru

Slovakia
• ZyXEL Slovakia

• https://www.zyxel.com/sk/sk

Spain
• ZyXEL Iberia

• https://www.zyxel.com/es/es

Sweden
• ZyXEL Communications A/S

• https://www.zyxel.com/se/sv

Switzerland
• Studerus AG

• https://www.zyxel.com/ch/de-ch

• https://www.zyxel.com/fr/fr

Turkey
• ZyXEL Turkey A.S.

• https://www.zyxel.com/tr/tr

UK
• ZyXEL Communications UK Ltd.

• https://www.zyxel.com/uk/en-gb

Ukraine
• ZyXEL Ukraine

• https://www.zyxel.com/ua/uk-ua

South America

Argentina
• ZyXEL Communications Corp.

• https://www.zyxel.com/co/es-co

Brazil
• ZyXEL Communications Brasil Ltda.

https://www.zyxel.com/ru/ru
https://www.zyxel.com/sk/sk
https://www.zyxel.com/es/es
https://www.zyxel.com/se/sv
https://www.zyxel.com/ch/de-ch
https://www.zyxel.com/fr/fr
https://www.zyxel.com/tr/tr
https://www.zyxel.com/uk/en-gb
https://www.zyxel.com/ua/uk-ua
https://www.zyxel.com/co/es-co
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• https://www.zyxel.com/br/pt

Colombia
• ZyXEL Communications Corp.

• https://www.zyxel.com/co/es-co

Ecuador
• ZyXEL Communications Corp.

• https://www.zyxel.com/co/es-co

South America
• ZyXEL Communications Corp.

• https://www.zyxel.com/co/es-co

Middle East

Israel
• ZyXEL Communications Corp.

• https://il.zyxel.com

North America

USA
• ZyXEL Communications, Inc. – North America Headquarters

https://www.zyxel.com/us/en-us

https://www.zyxel.com/br/pt
https://www.zyxel.com/co/es-co
https://www.zyxel.com/co/es-co
https://www.zyxel.com/co/es-co
https://il.zyxel.com
https://www.zyxel.com/us/en-us
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APPENDIX B
Product Features

Please refer to the product datasheet for the latest product features.

Version 1.21 1.21 1.21 1.21 1.21 1.21
Model Name USG FLEX 100H USG FLEX 100HP USG FLEX 200H USG FLEX 200HP USG FLEX 500H USG FLEX 700H
# Of MAC 8 8 8 8 12 14
Interface
VLAN 16 16 32 32 64 128
Virtual (Alias) 4 per interface 4 per interface 4 per interface 4 per interface 4 per interface 4 per interface
PPP Interface Number 8 8 8 12 14
Bridge 4 4 4 4 6 7
LAG 4 4 4 4 4 4
Routing
Static Route Rules 64 64 128 128 300 512
Policy Route Rules 100 100 100 100 300 500
Reserved Sessions for Managed 
Devices

500 500 500 500 500 500

Trunk
Max. Trunk Number (System 
Default)

1 1 1 1 1 1

Max. Trunk Number (User Define) 4 4 4 4 8 8
Max. Member Number Per Trunk 12 12 12 12 24 40
Sessions
Max. TCP Concurrent Sessions 
(Forwarding, NAT/Firewall)

300,000 300,000 600,000 600,000 1,000,000 2,000,000

Session Rate 8,000 8,000 12,000 12,000 20,000 40,000
NAT
Max. Virtual Server Number 64 64 128 128 256 512
Firewall (Secure Policy)
Max Firewall ACL Rule Number = 
Secure Policy Number

500 500 2,000 2,000 5,000 10,000

Max Session Limit per Host Rules 100 100 100 100 100 100
DoS Prevention
Max. DoS Prevention Profile 
Number

32 32 32 32 32 32

Max. DoS Prevention Rule 
Number

20 20 40 40 64 128

User Profile
Max. Local User 64 64 128 128 256 512
Max. Admin User 5 5 5 5 5 10
Max. User Group 16 16 32 32 64 128
Max. User In One User Group 64 64 128 128 256 512
Max. Concurrent Device Login 64 64 200 200 500 2,000
On-Cloud Max. Concurrent 
Device Login

64 64 200 200 500 2,000

Max. Device Insight Entry 192 192 600 600 900 12,000
HTTPd
Max. HTTPd Number 2 2 2 2 2 2
Objects
Address Object 300 300 300 300 500 1,000
Address Group 50 50 50 50 200 400
Max. Address Object In One 
Group

128 128 128 128 128 256

Service Object 200 200 500 500 1,000 1,000
Service Group 50 50 100 100 200 200
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Max. Service Object In One 
Group

64 64 128 128 128 256

Schedule Object 32 32 32 32 32 32
Schedule Group 16 16 16 16 16 16
Max. Schedule Object In One 
Group

24 24 24 24 24 24

Application Object 500 500 500 500 1,000 1,000
Max. LDAP Server Object # 4 4 4 4 8 8
Max. RADIUS Server Object # 4 4 4 4 8 8
Max. AD Server Object # 4 4 4 4 8 8
Max. Auth. Method 4 4 4 4 4 4
VPN
Max. VTI / VPN Tunnels Number 50 50 100 100 300 1,000
Max. Remote Access VPN Tunnel 
Number

25 25 50 50 150 500

SSL VPN
Max. SSL VPN Connections 25 25 50 50 150 500
Max. SSL VPN Network List 8 8 8 8 8 8
SSL VPN Max. Policy 32 32 32 32 64 128
Certificate
Certificate Buffer Size 1024K 1024K 1024K 1024K 1024K 1024K
Built-In Service
A Record 64 64 64 64 128 128
CNAME Record 8 8 8 8 8 8
NS Record (DNS Domain Zone 
Forward)

8 8 16 16 16 16

MX Record 8 8 8 8 8 8
Max. DHCP Network Pool 
(vlan+brg+ethernet)

28 28 44 44 82 147

Max. DHCP Host Pool (Static 
DHCP)

128 128 256 256 512 1,024

Max. DHCP User Defined 
(Custom) Extended Options (per 
Pool Server-Global)

5 5 5 5 5 5

Max. DHCP User Defined 
(Custom) Extended Options (per 
Pool)

5 5 5 5 5 5

Max. DDNS Profiles 10 10 10 10 10 10
DHCP Relay 2 per interface 2 per interface 2 per interface 2 per interface 2 per interface 2 per interface
Max. DHCP Relay Server 4 4 4 4 4 4
Max. DHCP Relay Interface per 
DHCP Relay Server

24 24 40 40 76 142

USB Storage
Device Number 1 1 1 1 1 1
Centralized Log
Log Entries 1,024 1,024 2,048 2,048 2,048 2,048
Debug Log Entries 1,024 1,024 1,024 1,024 1,024 1,024
Admin E-Mail Address 2 2 2 2 2 2
Syslog Server 4 4 4 4 4 4
BWM
Max. BWM Rule 128 128 128 128 128 256
Application Patrol
Max. App Patrol Profile Number 32 32 32 32 64 96
SSL Inspection
Max. SSL Inspection Profile 8 8 8 8 16 16
Max. Exclude List 256 256 256 256 256 256
Content Filtering
Max. Content Filtering Profile 
Number

16 16 16 16 32 32

Forbidden Domain Entry Number 256 per profile 256 per profile 256 per profile 256 per profile 512 per profile 512 per profile
Trusted Domain Entry Number 256 per profile 256 per profile 256 per profile 256 per profile 512 per profile 512 per profile
Keyword Blocking Number 128 per profile 128 per profile 128 per profile 128 per profile 256 per profile 256 per profile
URL Threat Filter

Max. Statistic Number 1024 1024 1024 1024 1024 1024
Max. Allow List Rule 256 256 256 256 256 256
Max. Block List Rule 256 256 256 256 256 256

Version 1.21 1.21 1.21 1.21 1.21 1.21
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IP Reputation

Max. Statistic Number 1024 1024 1024 1024 1024 1024
Max. Allow List Rule 256 256 256 256 256 256
Max. Block List Rule 256 256 256 256 256 256
DNS Threat Filter
Max. Statistic Number 1024 1024 1024 1024 1024 1024
Max. Allow List Rule 256 256 256 256 256 256
Max. Block List Rule 256 256 256 256 256 256
IP Exception
Max. IP Exception Number 64 64 64 64 64 64
Anti-Malware
Max. Statistic Number 1024 1024 1024 1024 1024 1024
Max. Allow List Rule 512 512 512 512 512 512
Max. Block List Rule 512 512 512 512 512 512
Sandboxing

Support protocol HTTP/SMTP/POP3/
FTP

HTTP/SMTP/POP3/
FTP

HTTP/SMTP/POP3/
FTP

HTTP/SMTP/POP3/
FTP

HTTP/SMTP/POP3/
FTP

HTTP/SMTP/
POP3/FTP

Concurrent File Collect 
Capability

64 64 64 64 64 64

Upload File Size Up to 10MB per 
file

Up to 10MB per file Up to 10MB per 
file

Up to 10MB per file Up to 10MB per file Up to 10MB per 
file

Version 1.21 1.21 1.21 1.21 1.21 1.21
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APPENDIX C
Legal Information

Copyright
Copyright © 2024 by Zyxel and/or its affiliates
The contents of this publication may not be reproduced in any part or as a whole, transcribed, stored in a retrieval system, translated into any 
language, or transmitted in any form or by any means, electronic, mechanical, magnetic, optical, chemical, photocopying, manual, or 
otherwise, without the prior written permission of Zyxel and/ or its affiliates.
Published by Zyxel and/or its affiliates. All rights reserved.

Disclaimer
Zyxel does not assume any liability arising out of the application or use of any products, or software described herein. Neither does it convey any 
license under its patent rights nor the patent rights of others. Zyxel further reserves the right to make changes in any products described herein 
without notice. This publication is subject to change without notice.

Regulatory Notice and Statement (Class B)

Model List: USG FLEX 100H, USG FLEX 100HP, USGFLEX 200H, USG FLEX 200HP

United States of America

The following information applies if you use the product within USA area.

FCC Statement
• The device complies with Part 15 of the FCC Rules. Operation is subject to the following two conditions:

(1) This device may not cause harmful interference, and 
(2) This device must accept any interference received, including interference that may cause undesired operation.

• Changes or modifications not expressly approved by the party responsible for compliance could void the user’s authority to operate the 
device.

• This equipment has been tested and found to comply with the limits for a Class B digital device, pursuant to Part 15 of the FCC Rules. These 
limits are designed to provide reasonable protection against harmful interference in a residential installation. 

• This equipment generates, uses, and can radiate radio frequency energy and, if not installed and used in accordance with the instructions, 
may cause harmful interference to radio communications. However, there is no guarantee that interference will not occur in a particular 
installation. 

• If this equipment does cause harmful interference to radio or television reception, which can be determined by turning the equipment off 
and on, the user is encouraged to try to correct the interference by one or more of the following measures:
• Reorient or relocate the receiving antenna 
• Increase the separation between the equipment and receiver 
• Connect the equipment into an outlet on a circuit different from that to which the receiver is connected 
• Consult the dealer or an experienced radio/TV technician for assistance

Canada
The following information applies if you use the product within Canada area

Innovation, Science and Economic Development Canada ICES statement
CAN ICES-003 (B)/NMB-003(B)
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Europe and the United Kingdom

The following information applies if you use the product within the European Union or United Kingdom.

List of National Codes

Safety Warnings
• Do not put the device in a place that is humid, dusty, has extreme temperatures, or that blocks the device ventilation slots. These conditions 

may harm your device.
• Please refer to the device back label, datasheet, box specifications or catalog information for power rating of the device and operating 

temperature.
• There is a remote risk of electric shock from lightning: (1) Do not use the device outside, and make sure all the connections are indoors. (2) Do 

not install or service this device during a thunderstorm.
• Do not expose your device to dampness, dust or corrosive liquids.
• Do not store things on the device.
• Do not obstruct the device ventilation slots as insufficient airflow may harm your device. For example, do not place the device in an 

enclosed space such as a box or on a very soft surface such as a bed or sofa.
• Do not install or service this device during a thunderstorm. There is a remote risk of electric shock from lightning.
• Connect ONLY suitable accessories to the device.
• Do not open the device. Opening or removing the device covers can expose you to dangerous high voltage points or other risks. 
• Only qualified service personnel should service or disassemble this device. Please contact your vendor for further information.
• Make sure to connect the cables to the correct ports.
• Place connected cables carefully so that no one will step on them or stumble over them.
• Disconnect all cables from this device before servicing or disassembling.
• Do not remove the plug and connect it to a power outlet by itself; always attach the plug to the power adaptor first before connecting it to 

a power outlet.
• Do not allow anything to rest on the power adaptor or cord and do NOT place the product where anyone can walk on the power adaptor 

or cord.
• Please use the provided or designated connection cables/power cables/ adaptors. Connect the power adaptor or cord to the right supply 

voltage (for example, 120V AC in North America or 230V AC in Europe). If the power adaptor or cord is damaged, it might cause 
electrocution. Remove the damaged power adaptor or cord from the device and the power source. Do not try to repair the power adaptor 
or cord by yourself. Contact your local vendor to order a new one.

• CAUTION: There is a risk of explosion if you replace the device battery with an incorrect one. Dispose of used batteries according to the 
instructions.  Dispose them at the applicable collection point for the recycling of electrical and electronic devices. For detailed information 
about recycling of this product, please contact your local city office, your household waste disposal service or the store where you 
purchased the product.

• Do not leave a battery in an extremely high temperature environment or surroundings since it can result in an explosion or the leakage of 
flammable liquid or gas.

• Do not subject a battery to extremely low air pressure since it may result in an explosion or the leakage of flammable liquid or gas.

COUNTRY ISO 3166 2 LETTER CODE COUNTRY ISO 3166 2 LETTER CODE

Austria AT Liechtenstein LI

Belgium BE Lithuania LT

Bulgaria BG Luxembourg LU

Croatia HR Malta MT

Cyprus CY Netherlands NL

Czech Republic CZ Norway NO

Denmark DK Poland PL

Estonia EE Portugal PT

Finland FI Romania RO

France FR Serbia RS

Germany DE Slovakia SK

Greece GR Slovenia SI

Hungary HU Spain ES

Iceland IS Sweden SE

Ireland IE Switzerland CH

Italy IT Turkey TR

Latvia LV United Kingdom GB
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• The following warning statements apply, where the disconnect device is not incorporated in the device or where the plug on the power 
supply cord is intended to serve as the disconnect device.
- For a permanently connected device, a readily accessible method to disconnect the device shall be incorporated externally to the 
device;
- For a pluggable device, the socket-outlet shall be installed near the device and shall be easily accessible.

• Complies with 21 CFR 1040.10 and 1040.11 except for conformance with IEC 60825-1 Ed. 3., as described in Laser Notice No. 56, dated May 8, 
2019.

• Conforme à 21 CFR 1040.10 et 1040.11 sauf pour la conformité à la norme CEI 60825-1 Ed. 3., comme décrit dans la notice laser Numéro 56 
du 8 mai 2019.

• Ce produit laser est un produit laser de classe 1 conforme à la norme CEI 60825-1: 2014
• CLASS 1 LASER PRODUCT & “IEC 60825-1:2014”
• CLASS 1 CONSUMER LASER PRODUCT & “EN 50689:2021”
• Caution - Use of controls or adjustments or performance of procedures other than those specified herein may result in hazardous radiation 

exposure.
• Attention - L'utilisation des commandes ou reglages ou l'execution des procedures autres que celles specifiees dans les presents exigences 

peuvent etre la cause d'une exposition a un rayonnement dangereux)

Environment Statement

ErP (Energy-related Products)
Zyxel products put on the EU and United Kingdom markets comply with the requirement of the European Parliament and the Council published 
Directive 2009/125/EC and UK regulation establishing a framework for the setting of ecodesign requirements for energy-related products 
(recast), the so called "ErP Directive (Energy-related Products directive), as well as ecodesign requirements laid down in applicable 
implementation measures. Power consumption has satisfied the regulation requirements which are:
• Network standby power consumption < 8 W (watts), and/or
• Off mode power consumption < 0.5 W (watts), and/or
• Standby mode power consumption < 0.5 W (watts).
(Wireless settings, please refer to the chapter about wireless settings for more detail.)

Disposal and Recycling Information
The symbol below means that according to local regulations your product and/or its battery shall be disposed of separately from domestic 
waste. If this product is end of life, take it to a recycling station designated by local authorities. At the time of disposal, the separate collection of 
your product and/or its battery will help save natural resources and ensure that the environment is sustainable development.

Die folgende Symbol bedeutet, dass Ihr Produkt und/oder seine Batterie gemäß den örtlichen Bestimmungen getrennt vom Hausmüll entsorgt 
werden muss. Wenden Sie sich an eine Recyclingstation, wenn dieses Produkt das Ende seiner Lebensdauer erreicht hat. Zum Zeitpunkt der 
Entsorgung wird die getrennte Sammlung von Produkt und/oder seiner Batterie dazu beitragen, natürliche Ressourcen zu sparen und die Umwelt 
und die menschliche Gesundheit zu schützen.

El símbolo de abajo indica que según las regulaciones locales, su producto y/o su batería deberán depositarse como basura separada de la 
doméstica. Cuando este producto alcance el final de su vida útil, llévelo a un punto limpio. Cuando llegue el momento de desechar el 
producto, la recogida por separado éste y/o su batería ayudará a salvar los recursos naturales y a proteger la salud humana y 
medioambiental.

Le symbole ci-dessous signifie que selon les réglementations locales votre produit et/ou sa batterie doivent être éliminés séparément des ordures 
ménagères. Lorsque ce produit atteint sa fin de vie, amenez-le à un centre de recyclage. Au moment de la mise au rebut, la collecte séparée 
de votre produit et/ou de sa batterie aidera à économiser les ressources naturelles et protéger l'environnement et la santé humaine.

Il simbolo sotto significa che secondo i regolamenti locali il vostro prodotto e/o batteria deve essere smaltito separatamente dai rifiuti domestici. 
Quando questo prodotto raggiunge la fine della vita di servizio portarlo a una stazione di riciclaggio. Al momento dello smaltimento, la raccolta 
separata del vostro prodotto e/o della sua batteria aiuta a risparmiare risorse naturali e a proteggere l'ambiente e la salute umana.

Symbolen innebär att enligt lokal lagstiftning ska produkten och/eller dess batteri kastas separat från hushållsavfallet. När den här produkten når 
slutet av sin livslängd ska du ta den till en återvinningsstation. Vid tiden för kasseringen bidrar du till en bättre miljö och mänsklig hälsa genom att 
göra dig av med den på ett återvinningsställe.

台灣 
安全警告 - 為了您的安全，請先閱讀以下警告及指示 :
• 請勿將此產品接近水、火焰或放置在高溫的環境。
• 避免設備接觸 :

- 任何液體 - 切勿讓設備接觸水、雨水、高濕度、污水腐蝕性的液體或其他水份。
- 灰塵及污物 - 切勿接觸灰塵、污物、沙土、食物或其他不合適的材料。

• 雷雨天氣時，不要安裝或維修此設備。有遭受電擊的風險。



Appendix C Legal Information

USG FLEX H Series User’s Guide

482

• 切勿重摔或撞擊設備，並勿使用不正確的電源變壓器。
• 若接上不正確的電源變壓器會有爆炸的風險。
• 請勿隨意更換產品內的電池。
• 如果更換不正確之電池型式，會有爆炸的風險，請依製造商說明書處理使用過之電池。
• 請將廢電池丟棄在適當的電器或電子設備回收處。
• 請勿將設備解體。
• 請勿阻礙設備的散熱孔，空氣對流不足將會造成設備損害。
• 請使用隨貨提供或指定的連接線 / 電源線 / 電源變壓器，將其連接到合適的供應電壓 ( 如 : 台灣供應電壓 110 伏特 )。
• 假若電源變壓器或電源變壓器的纜線損壞，請從插座拔除，若您還繼續插電使用，會有觸電死亡的風險。
• 請勿試圖修理電源變壓器或電源變壓器的纜線，若有毀損，請直接聯絡您購買的店家，購買一個新的電源變壓器。
• 請勿將此設備安裝於室外，此設備僅適合放置於室內。
• 請勿隨一般垃圾丟棄。
• 請參閱產品背貼上的設備額定功率。
• 請參考產品型錄或是彩盒上的作業溫度。
• 產品沒有斷電裝置或者採用電源線的插頭視為斷電裝置的一部分，以下警語將適用 :

- 對永久連接之設備， 在設備外部須安裝可觸及之斷電裝置；
- 對插接式之設備， 插座必須接近安裝之地點而且是易於觸及的。

About the Symbols
Various symbols are used in this product to ensure correct usage, to prevent danger to the user and others, and to prevent property damage. 
The meaning of these symbols are described below. It is important that you read these descriptions thoroughly and fully understand the 
contents.

Explanation of the Symbols

Viewing Certifications
Go to http://www.zyxel.com to view this product’s documentation and certifications.

Zyxel Limited Warranty
Zyxel warrants to the original end user (purchaser) that this product is free from any defects in material or workmanship for a specific period (the 
Warranty Period) from the date of purchase. The Warranty Period varies by region. Check with your vendor and/or the authorized Zyxel local 
distributor for details about the Warranty Period of this product. During the warranty period, and upon proof of purchase, should the product 
have indications of failure due to faulty workmanship and/or materials, Zyxel will, at its discretion, repair or replace the defective products or 
components without charge for either parts or labor, and to whatever extent it shall deem necessary to restore the product  or components to 
proper operating condition. Any replacement will consist of a new or re-manufactured functionally equivalent product of equal or higher value, 
and will be solely at the discretion of Zyxel. This warranty shall not apply if the product has been modified, misused, tampered with, damaged by 
an act of God, or subjected to abnormal working conditions.

Note
Repair or replacement, as provided under this warranty, is the exclusive remedy of the purchaser. This warranty is in lieu of all other warranties, 
express or implied, including any implied warranty of merchantability or fitness for a particular use or purpose. Zyxel shall in no event be held 
liable for indirect or consequential damages of any kind to the purchaser.
To obtain the services of this warranty, contact your vendor. You may also refer to the warranty policy for the region in which you bought the 
device at https://www.zyxel.com/global/en/support/warranty-information.

Registration
Register your product online at www.zyxel.com to receive email notices of firmware upgrades and related information.

SYMBOL EXPLANATION

Alternating current (AC):

AC is an electric current in which the flow of electric charge periodically reverses direction.

Direct current (DC):

DC if the unidirectional flow or movement of electric charge carriers.

Earth; ground:

A wiring terminal intended for connection of a Protective Earthing Conductor.

Class II equipment:

The method of protection against electric shock in the case of class II equipment is either double insulation or 
reinforced insulation.
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Trademarks
ZyNOS (Zyxel Network Operating System) and ZON (Zyxel One Network) are registered trademarks of Zyxel Communications, Inc. Other 
trademarks mentioned in this publication are used for identification purposes only and may be properties of their respective owners.

Open Source Licenses
This product may contain in part some free software distributed under GPL license terms and/or GPL like licenses.
To request the source code covered under these licenses, please go to: https://www.zyxel.com/form/gpl_oss_software_notice.shtml 

Regulatory Notice and Statement (Class A)

Model List: USG FLEX 500H, USG FLEX 700H 

United States of America

The following information applies if you use the product within USA area.

FCC Statement
• This device complies with Part 15 of the FCC rules. Operation is subject to the following two conditions:
(1) This device may not cause harmful interference.
(2) This device must accept any interference received, including interference that may cause undesired operations.
• Changes or modifications not expressly approved by the party responsible for compliance could void the user’s authority to operate the 

equipment.
• This equipment has been tested and found to comply with the limits for a Class A digital device, pursuant to Part 15 of the FCC Rules. These 

limits are designed to provide reasonable protection against harmful interference in a residential installation. 
• This equipment generates, uses, and can radiate radio frequency energy and, if not installed and used in accordance with the instructions, 

may cause harmful interference to radio communications. However, there is no guarantee that interference will not occur in a particular 
installation. 

• If this equipment does cause harmful interference to radio or television reception, which can be determined by turning the equipment off 
and on, the user is encouraged to try to correct the interference by one or more of the following measures:
• Reorient or relocate the receiving antenna 
• Increase the separation between the equipment and receiver 
• Connect the equipment into an outlet on a circuit different from that to which the receiver is connected 
• Consult the dealer or an experienced radio/TV technician for assistance

Canada
The following information applies if you use the product within Canada area

Innovation, Science and Economic Development Canada ICES statement
CAN ICES-003 (A)/NMB-003(A)

Europe and the United Kingdom

The following information applies if you use the product within the European Union or United Kingdom.

EMC statement
WARNING: This equipment is compliant with Class A of EN55032. In a residential environment this equipment may cause radio interference.
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List of National Codes

Safety Warnings
• Do not put the device in a place that is humid, dusty, has extreme temperatures, or that blocks the device ventilation slots. These conditions 

may harm your device.
• Please refer to the device back label, datasheet, box specifications or catalog information for power rating of the device and operating 

temperature.
• There is a remote risk of electric shock from lightning: (1) Do not use the device outside, and make sure all the connections are indoors. (2) Do 

not install or service this device during a thunderstorm.
• Do not expose your device to dampness, dust or corrosive liquids.
• Do not store things on the device.
• Do not obstruct the device ventilation slots as insufficient airflow may harm your device. For example, do not place the device in an 

enclosed space such as a box or on a very soft surface such as a bed or sofa.
• Do not install or service this device during a thunderstorm. There is a remote risk of electric shock from lightning.
• Connect ONLY suitable accessories to the device.
• Do not open the device. Opening or removing the device covers can expose you to dangerous high voltage points or other risks. 
• Only qualified service personnel should service or disassemble this device. Please contact your vendor for further information.
• Make sure to connect the cables to the correct ports.
• Place connected cables carefully so that no one will step on them or stumble over them.
• Disconnect all cables from this device before servicing or disassembling.
• Do not remove the plug and connect it to a power outlet by itself; always attach the plug to the power adaptor first before connecting it to 

a power outlet.
• Do not allow anything to rest on the power adaptor or cord and do NOT place the product where anyone can walk on the power adaptor 

or cord.
• Please use the provided or designated connection cables/power cables/ adaptors. Connect the power adaptor or cord to the right supply 

voltage (for example, 120V AC in North America or 230V AC in Europe). If the power adaptor or cord is damaged, it might cause 
electrocution. Remove the damaged power adaptor or cord from the device and the power source. Do not try to repair the power adaptor 
or cord by yourself. Contact your local vendor to order a new one.

• CAUTION: There is a risk of explosion if you replace the device battery with an incorrect one. Dispose of used batteries according to the 
instructions.  Dispose them at the applicable collection point for the recycling of electrical and electronic devices. For detailed information 
about recycling of this product, please contact your local city office, your household waste disposal service or the store where you 
purchased the product.

• Do not leave a battery in an extremely high temperature environment or surroundings since it can result in an explosion or the leakage of 
flammable liquid or gas.

• Do not subject a battery to extremely low air pressure since it may result in an explosion or the leakage of flammable liquid or gas.
• The following warning statements apply, where the disconnect device is not incorporated in the device or where the plug on the power 

supply cord is intended to serve as the disconnect device.
- For a permanently connected device, a readily accessible method to disconnect the device shall be incorporated externally to the 
device;
- For a pluggable device, the socket-outlet shall be installed near the device and shall be easily accessible.

• This device must be grounded by qualified service personnel. Never defeat the ground conductor or operate the device in the absence of a 
suitably installed ground conductor. Contact the appropriate electrical inspection authority or an electrician if you are uncertain that 
suitable grounding is available. If your device has an earthing screw (frame ground), connect the screw to a ground terminal using an 
appropriate AWG ground wire. Do this before you make other connections. If your device has no earthing screw, but has a 3-prong power 
plug, make sure to connect the plug to a 3-hole earthed socket.

• When connecting or disconnecting power to hot-pluggable power supplies, if offered with your system, observe the following guidelines:
- Install the power supply before connecting the power cable to the power supply.
- Unplug the power cable before removing the power supply.
- If the system has multiple sources of power, disconnect power from the system by unplugging all power cables from the power supply.

COUNTRY ISO 3166 2 LETTER CODE COUNTRY ISO 3166 2 LETTER CODE

Austria AT Liechtenstein LI

Belgium BE Lithuania LT

Bulgaria BG Luxembourg LU

Croatia HR Malta MT

Cyprus CY Netherlands NL

Czech Republic CZ Norway NO

Denmark DK Poland PL

Estonia EE Portugal PT

Finland FI Romania RO

France FR Serbia RS

Germany DE Slovakia SK

Greece GR Slovenia SI

Hungary HU Spain ES

Iceland IS Sweden SE

Ireland IE Switzerland CH

Italy IT Turkey TR

Latvia LV United Kingdom GB
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• Complies with 21 CFR 1040.10 and 1040.11 except for conformance with IEC 60825-1 Ed. 3., as described in Laser Notice No. 56, dated May 8, 
2019.

• Conforme à 21 CFR 1040.10 et 1040.11 sauf pour la conformité à la norme CEI 60825-1 Ed. 3., comme décrit dans la notice laser Numéro 56 
du 8 mai 2019.

• Ce produit laser est un produit laser de classe 1 conforme à la norme CEI 60825-1: 2014
• CLASS 1 LASER PRODUCT & “IEC 60825-1:2014”
• CLASS 1 CONSUMER LASER PRODUCT & “EN 50689:2021”
• Caution - Use of controls or adjustments or performance of procedures other than those specified herein may result in hazardous radiation 

exposure.
• Attention - L'utilisation des commandes ou reglages ou l'execution des procedures autres que celles specifiees dans les presents exigences 

peuvent etre la cause d'une exposition a un rayonnement dangereux)

Environment Statement

Disposal and Recycling Information
The symbol below means that according to local regulations your product and/or its battery shall be disposed of separately from domestic 
waste. If this product is end of life, take it to a recycling station designated by local authorities. At the time of disposal, the separate collection of 
your product and/or its battery will help save natural resources and ensure that the environment is sustainable development.

Die folgende Symbol bedeutet, dass Ihr Produkt und/oder seine Batterie gemäß den örtlichen Bestimmungen getrennt vom Hausmüll entsorgt 
werden muss. Wenden Sie sich an eine Recyclingstation, wenn dieses Produkt das Ende seiner Lebensdauer erreicht hat. Zum Zeitpunkt der 
Entsorgung wird die getrennte Sammlung von Produkt und/oder seiner Batterie dazu beitragen, natürliche Ressourcen zu sparen und die Umwelt 
und die menschliche Gesundheit zu schützen.

El símbolo de abajo indica que según las regulaciones locales, su producto y/o su batería deberán depositarse como basura separada de la 
doméstica. Cuando este producto alcance el final de su vida útil, llévelo a un punto limpio. Cuando llegue el momento de desechar el 
producto, la recogida por separado éste y/o su batería ayudará a salvar los recursos naturales y a proteger la salud humana y 
medioambiental.

Le symbole ci-dessous signifie que selon les réglementations locales votre produit et/ou sa batterie doivent être éliminés séparément des ordures 
ménagères. Lorsque ce produit atteint sa fin de vie, amenez-le à un centre de recyclage. Au moment de la mise au rebut, la collecte séparée 
de votre produit et/ou de sa batterie aidera à économiser les ressources naturelles et protéger l'environnement et la santé humaine.

Il simbolo sotto significa che secondo i regolamenti locali il vostro prodotto e/o batteria deve essere smaltito separatamente dai rifiuti domestici. 
Quando questo prodotto raggiunge la fine della vita di servizio portarlo a una stazione di riciclaggio. Al momento dello smaltimento, la raccolta 
separata del vostro prodotto e/o della sua batteria aiuta a risparmiare risorse naturali e a proteggere l'ambiente e la salute umana.

Symbolen innebär att enligt lokal lagstiftning ska produkten och/eller dess batteri kastas separat från hushållsavfallet. När den här produkten når 
slutet av sin livslängd ska du ta den till en återvinningsstation. Vid tiden för kasseringen bidrar du till en bättre miljö och mänsklig hälsa genom att 
göra dig av med den på ett återvinningsställe.

 

台灣 
警告使用者
• 這是甲類的資訊產品，在居住的環境中使用時，可能會造成射頻干擾，在這種情況下，使用者會被要求採取某些適當的對策。
• 為避免電磁干擾，本產品不應安裝或使用於住宅環境。

安全警告 – 為了您的安全，請先閱讀以下警告及指示 :
• 請勿將此產品接近水、火焰或放置在高溫的環境。
• 避免設備接觸 :

- 任何液體 - 切勿讓設備接觸水、雨水、高濕度、污水腐蝕性的液體或其他水份。
- 灰塵及污物 - 切勿接觸灰塵、污物、沙土、食物或其他不合適的材料。

• 雷雨天氣時，不要安裝或維修此設備。有遭受電擊的風險。
• 切勿重摔或撞擊設備，並勿使用不正確的電源變壓器。
• 若接上不正確的電源變壓器會有爆炸的風險。
• 請勿隨意更換產品內的電池。
• 如果更換不正確之電池型式，會有爆炸的風險，請依製造商說明書處理使用過之電池。
• 請將廢電池丟棄在適當的電器或電子設備回收處。
• 請勿將設備解體。
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• 請勿阻礙設備的散熱孔，空氣對流不足將會造成設備損害。
• 請使用隨貨提供或指定的連接線 / 電源線 / 電源變壓器，將其連接到合適的供應電壓 ( 如 : 台灣供應電壓 110 伏特 )。
• 假若電源變壓器或電源變壓器的纜線損壞，請從插座拔除，若您還繼續插電使用，會有觸電死亡的風險。
• 請勿試圖修理電源變壓器或電源變壓器的纜線，若有毀損，請直接聯絡您購買的店家，購買一個新的電源變壓器。
• 請勿將此設備安裝於室外，此設備僅適合放置於室內。
• 請勿隨一般垃圾丟棄。
• 請參閱產品背貼上的設備額定功率。
• 請參考產品型錄或是彩盒上的作業溫度。
• 產品沒有斷電裝置或者採用電源線的插頭視為斷電裝置的一部分，以下警語將適用 :

- 對永久連接之設備， 在設備外部須安裝可觸及之斷電裝置；
- 對插接式之設備， 插座必須接近安裝之地點而且是易於觸及的。

About the Symbols
Various symbols are used in this product to ensure correct usage, to prevent danger to the user and others, and to prevent property damage. 
The meaning of these symbols are described below. It is important that you read these descriptions thoroughly and fully understand the 
contents.

Explanation of the Symbols

Viewing Certifications
Go to http://www.zyxel.com to view this product’s documentation and certifications.

Zyxel Limited Warranty
Zyxel warrants to the original end user (purchaser) that this product is free from any defects in material or workmanship for a specific period (the 
Warranty Period) from the date of purchase. The Warranty Period varies by region. Check with your vendor and/or the authorized Zyxel local 
distributor for details about the Warranty Period of this product. During the warranty period, and upon proof of purchase, should the product 
have indications of failure due to faulty workmanship and/or materials, Zyxel will, at its discretion, repair or replace the defective products or 
components without charge for either parts or labor, and to whatever extent it shall deem necessary to restore the product  or components to 
proper operating condition. Any replacement will consist of a new or re-manufactured functionally equivalent product of equal or higher value, 
and will be solely at the discretion of Zyxel. This warranty shall not apply if the product has been modified, misused, tampered with, damaged by 
an act of God, or subjected to abnormal working conditions.

Note
Repair or replacement, as provided under this warranty, is the exclusive remedy of the purchaser. This warranty is in lieu of all other warranties, 
express or implied, including any implied warranty of merchantability or fitness for a particular use or purpose. Zyxel shall in no event be held 
liable for indirect or consequential damages of any kind to the purchaser.
To obtain the services of this warranty, contact your vendor. You may also refer to the warranty policy for the region in which you bought the 
device at https://www.zyxel.com/global/en/support/warranty-information.

Registration
Register your product online at www.zyxel.com to receive email notices of firmware upgrades and related information.

Open Source Licenses
This product may contain in part some free software distributed under GPL license terms and/or GPL like licenses.
To request the source code covered under these licenses, please go to: https://www.zyxel.com/form/gpl_oss_software_notice.shtml 

SYMBOL EXPLANATION

Alternating current (AC):

AC is an electric current in which the flow of electric charge periodically reverses direction.

Direct current (DC):

DC if the unidirectional flow or movement of electric charge carriers.

Earth; ground:

A wiring terminal intended for connection of a Protective Earthing Conductor.

Class II equipment:

The method of protection against electric shock in the case of class II equipment is either double insulation 
or reinforced insulation.
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Index

Symbols

Numbers

1 Gbps   45

10 Gbps   45

100 Mbps   45

2.5 Gbps   45

3322 Dynamic DNS   390

3DES   178

5 Gbps   45

A

AAA
Base DN   370

Bind DN   371

directory structure   370

Distinguished Name, see DN
DN   370

port   378, 379

AAA server   371

and users   360

local user database   370

RADIUS   370, 371, 375

RADIUS group   373, 376, 378

see also RADIUS
access   23

access control attacks   332

access users   359

multiple logins   369

see also users   359

account
user   359, 369

accounting server   371

active protocol   182

AH   182

and encapsulation   182

ESP   182

active sessions   74

AD   370, 371

directory structure   370

Distinguished Name, see DN
port   378, 379

address groups   228

and content filtering   264

address objects   228

and content filtering   264

and NAT   151, 160

and policy routes   150

HOST   228

RANGE   228

SUBNET   228

types of   228, 232

address record   394

admin users   359

multiple logins   369

see also users   359

ADP   216

false negatives   218

false positives   218

inline profile   218

monitor profile   218

Advanced Encryption Standard, see AES
AES   178

AF   146

AH   182

and transport mode   183

alerts
IDP   347, 348

ALG   174

and NAT   174

and policy routes   174

and security policy   174

and trunks   174

FTP   174, 175

H.323   174

see also VoIP pass through   174

SIP   174

Anomaly Detection and Prevention, see ADP
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Anonymizer   301, 306

Anonymous Proxies   294

anti-malware   311

boot sector virus   311

EICAR   314

e-mail
virus   311

file infector   311

file infector virus   311

macro virus   311

malware life cycle   311

malware types   311

mutation virus   311

packet types   311

polymorphic virus   311

scanner types   319

statistics   83

virus   311

worm   311

anti-virus
EICAR   314

e-mail virus   311

polymorphic virus   311

statistics   83, 85

troubleshooting   460, 461

updating signatures   103, 104

Application Layer Gateway, see ALG
application patrol   253

actions   253

and security policy   253

classification   254

exceptions   253

port-less   254

ports   254

service ports   254

troubleshooting   460, 464, 465

asymmetrical routes   209

allowing through the security policy   211

vs virtual interfaces   209

attacks
access control   332

backdoor   332

buffer overflow   331

DoS/DDoS   332

P2P   332

scan   332

trapdoor   332

trojan   332

virus   311, 332

worm   332

authentication
in IPSec   194, 195, 199

server   371

authentication algorithms   178

and active protocol   178

MD5   179

SHA1   179

Authentication Header, see AH
authentication method objects

and users   360

authentication server   409

Authentication, Authorization, Accounting servers, 
see AAA server

authorization server   371

auxiliary interfaces   107

B

backdoor attacks   332

backing up configuration files   439

bandwidth capacity
cable types   46

bandwidth management   253

maximize bandwidth usage   164

see also application patrol   253

Base DN   370

Bind DN   371

BitTorrent   332

Blaster   336

Botnet   295

bridge interfaces   107, 127

and virtual interfaces of members   128

effect on routing table   128

member interfaces   127

bridges   127

Brute Force Attack   295

buffer overflow   331

buffer overflow attacks   331

C

CA
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and certificates   411

CA (Certificate Authority), see certificates
cable types   46

capturing packets   449

CAT 5 cable   46

CAT 5e cable   45

CAT 6 cable   45

CAT 6a cable   45

CAT 7 cable   46

CEF (Common Event Format)   432

certificate
troubleshooting   466

Certificate Authority (CA)
see certificates

Certificate Revocation List (CRL)   411

certificates   410

advantages of   411

and CA   411

and HTTPS   385

and IKE SA   182

certification path   411, 422

expired   411

factory-default   411

file formats   411

not used for encryption   410

revoked   411

self-signed   411, 417

serial number   418, 423

storage space   421

thumbprint algorithms   412

thumbprints   412

used for authentication   410

verifying fingerprints   412

certification requests   417

certifications
viewing   482, 486

check   470

Chrome   23

CLI   22

Reference Guide   2

commands   22

Common Event Format (CEF)   432

computer names   110

computer virus   311

see also virus
configuration

information   446

configuration files   438

at restart   440

backing up   439

downloading   441

editing   438

lastgood.conf   439, 442

managing   439

startup-config.conf   442

startup-config-bad.conf   439

system-default.conf   442

uploading   442

use without restart   438

connection
troubleshooting   464

connection monitor (in SSL)   98

connectivity check   119, 124, 130, 133

contact information   471, 476

content filter
troubleshooting   460

content filtering   263, 264

and address groups   264

and address objects   264

and schedules   263, 264

and user groups   264

and users   264

by category   264, 265

by keyword (in URL)   264

by URL   264

default policy   264

filter list   264

managed web pages   269

policies   263, 264

registration status   102

URL for blocked access   267

cookies   23

copyright   479

Cross Site Scripting   295

current date/time   63, 384

and schedules   246

setting manually   384

time server   384

current user list   98

customer support   471, 476
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D

Data Encryption Standard, see DES
date   384

DDNS
backup mail exchanger   403

mail exchanger   403

service providers   390

troubleshooting   463

DDoS attacks   332

default
security policy behavior   208

Denial of Service (DoS) attacks   332

DES   178

device access
troubleshooting   459

DHCP   109

and DNS servers   110

and interfaces   109

pool   110

static DHCP   110

diagnostics   446

Diffie-Hellman key group   179

DiffServ   146

direct routes   147

directory service
file structure   370

Directory Service (LDAP/AD)   370

disclaimer   479

distance limitation
cable types   46

Distinguished Name (DN)   370

Distributed Denial of Service (DDoS) attacks   332

DN   370

DNS   389

address records   394

domain name forwarders   397

domain name to IP address   394

IP address to domain name   394

Mail eXchange (MX) records   396

pointer (PTR) records   394

DNS Filter   292, 299, 356

Priority   299

types of queries   299

DNS servers   390, 397

and interfaces   110

Domain Name System, see DNS
DoS   294

DoS (Denial of Service) attacks   332

DSCP   148, 150

Dynamic Host Configuration Protocol, see DHCP.
DynDNS   390

DynDNS see also DDNS   390

Dynu   390

E

Edge   23

e-Donkey   332

e-mail
daily statistics report   435

e-Mule   332

Encapsulating Security Payload, see ESP
encapsulation

and active protocol   182

transport mode   182

tunnel mode   182

VPN   182

encryption
IPSec   194, 195, 199

RSA   419

encryption algorithms   178

3DES   178

AES   178

and active protocol   178

DES   178

ESP   182, 195

and transport mode   183

Ethernet interfaces   107

and routing protocols   115, 120

Exploits   294

External Block List
DNS/URL Threat Filter   356

IP Reputation   354

F

false negatives   218

false positives   218, 221, 222
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FCC interference statement   483

file extensions
configuration files   438

shell scripts   438

file manager   438

Firefox   23

firmware
and restart   443

current version   63, 445

getting updated   443

uploading   444

firmware upload
troubleshooting   467

FQDN   394

FTP
ALG   174

signaling port   175

troubleshooting   464

full tunnel mode   201

Fully-Qualified Domain Name, see FQDN

G

Grace Period   19

Guide
CLI Reference   2

Quick Start   2

H

host-based intrusions   335

HTTP
over SSL, see HTTPS
vs HTTPS   385

HTTPS   385

and certificates   385

authenticating clients   385

vs HTTP   385

HyperText Transfer Protocol over Secure Socket Layer, 
see HTTPS

I

ICMP   237

IDP   325

alerts   347, 348

log options   222, 347, 348

service group   333

signatures   325

statistics   82

troubleshooting   460, 462

Iframe Injection   295

IKE SA
aggressive mode   177, 180, 181

and certificates   182

and to-ZyWALL security policy   465

authentication algorithms   178

content   180

Diffie-Hellman key group   179

encryption algorithms   178

IP address, remote IPSec router   177

IP address, Zyxel device   177

local identity   180

main mode   177, 180

NAT traversal   181

negotiation mode   177

peer identity   180

pre-shared key   179

proposal   178

see also VPN
IM (Instant Messenger)   332

iMesh   332

inline profile   218

installation
desktop   54

installation scenarios   54

Instant Messenger (IM)   253, 332

managing   253

interfaces   106

and DNS servers   110

and layer-3 virtualization   106

and NAT   159

and physical ports   106

and policy routes   150

and static routes   153

and zones   106

as DHCP relays   109

as DHCP servers   109

auxiliary, see also auxiliary interfaces.
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backup, see trunks
bridge, see also bridge interfaces.
DHCP clients   109

Ethernet, see also Ethernet interfaces.
gateway   109

general characteristics   106

IP address   108

metric   109

overlapping IP address and subnet mask   109

port groups, see also port groups.
PPPoE/PPTP, see also PPPoE/PPTP interfaces.
prerequisites   108

relationships between   108

static DHCP   110

subnet mask   108

trunks, see also trunks.
Tunnel, see also Tunnel interfaces.
types   106

virtual, see also virtual interfaces.
VLAN, see also VLAN interfaces.
WLAN, see also WLAN interfaces.

Internet access
troubleshooting   459, 465

Internet Control Message Protocol, see ICMP
Internet Protocol Security, see IPSec
Intrusion, Detection and Prevention see IDP   325

intrusions
host   335

network   336

IP policy routing, see policy routes
IP protocols   236

and service objects   237

ICMP, see ICMP
TCP, see TCP
UDP, see UDP

IP Reputation   291

External Black List   299

IP static routes, see static routes
IPSec   176

authentication   194, 195, 199

basic troubleshooting   464

encryption   194, 195, 199

ESP   195

established in two phases   184

local network   176

peer   176

remote IPSec router   176

remote network   176

SA see also IPSec SA   182

see also VPN
tunnel encapsulation   195

IPSec SA
active protocol   182

and security policy   465

and to-ZyWALL security policy   465

authentication algorithms   178

encapsulation   182

encryption algorithms   178

local policy   182

Perfect Forward Secrecy (PFS)   183

proposal   183

remote policy   182

Security Parameter Index (SPI) (manual keys)   183

see also IPSec
see also VPN
transport mode   182

tunnel mode   182

when IKE SA is disconnected   182

IPSec VPN
troubleshooting   464

J

Java
permissions   23

JavaScripts   23

K

key pairs   410

L

lastgood.conf   439, 442

LDAP
and users   360

Base DN   370

Bind DN   371

directory structure   370

Distinguished Name, see DN
DN   370

port   378, 379
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least load first load balancing   135

LED troubleshooting   459

level-4 inspection   254

level-7 inspection   254

licensing   100

load balancing   134

algorithms   135, 139, 140

least load first   135

round robin   135

see also trunks   134

session-oriented   135

spillover   136

weighted round robin   136

local user database   370

log
troubleshooting   467

log options
(IDP)   222, 347, 348

logs
and security policy   214

e-mail profiles   430

log consolidation   431

settings   430

syslog servers   430

system   430

types of   430

M

MAC address
and VLAN   111

Ethernet interface   118, 122

range   62

managed web pages   269

management access
troubleshooting   467

Management Information Base (MIB)   404, 405

managing the device
using SNMP. See SNMP.

maximum distance
cable types   46

MD5   179

Message Digest 5, see MD5
monitor   98

sessions   74

monitor profile
ADP   218

mounting
rack   21, 54

wall   56

My Certificates, see also certificates   412

MyDoom   336

N

NAT   146, 154

ALG, see ALG
and address objects   151

and address objects (HOST)   160

and ALG   174

and interfaces   159

and policy routes   145, 151

and security policy   210

and to-ZyWALL security policy   161

and VPN   181

loopback   155

port forwarding, see NAT
port translation, see NAT
traversal   181

NBNS   110

NetBIOS
Name Server, see NBNS.

network access mode
full tunnel   201

Network Address Translation, see NAT
network-based intrusions   336

Nimda   336

No-IP   390

O

objects   202

AAA server   371

addresses and address groups   228

certificates   410

schedules   246

services and service groups   236

users, user groups   359, 369

ommon   311
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OSI (Open System Interconnection)   325

OSI level-4   254

OSI level-7   254

P

P Reputation
Priority   292

P2P (Peer-to-peer)   332

attacks   332

see also Peer-to-peer
packet

inspection signatures   326

packet capture   449

files   448, 452, 454

troubleshooting   467

packet captures
downloading files   448, 449

Peanut Hull   390

Peer-to-peer (P2P)   332

managing   253

Perfect Forward Secrecy (PFS)
Diffie-Hellman key group   183

performance
troubleshooting   461, 462

PFS (Perfect Forward Secrecy)   183

Phishing   292, 295

pointer record   394

policy routes   144

actions   146

and address objects   150

and ALG   174

and interfaces   150

and NAT   145

and schedules   150

and service objects   237

and trunks   137, 150

and user groups   149, 165, 168

and users   149, 165, 168

and VPN connections   465

benefits   145

criteria   146

overriding direct routes   147

troubleshooting   460

pop-up windows   23

port forwarding, see NAT
port groups   107

port translation, see NAT
power off   457

PPP
troubleshooting   461

PPP interfaces
subnet mask   109

PPPoE   110

and RADIUS   110

PPPoE/PPTP interfaces   107

PPTP
as VPN   110

product registration   482

PTR record   394

Public-Key Infrastructure (PKI)   411

public-private key pairs   410

Q

QoS   145

Quick Start Guide   2

R

rack-mounting   21, 54

RADIUS   370, 371

advantages   371

and PPPoE   110

and users   360

RADIUS server   409

Reference Guide, CLI   2
registration   100

product   482

Relative Distinguished Name (RDN)   370

Remote Authentication Dial-In User Service, see 
RADIUS

remote management
see also service control   384

to-Device security policy   208

remote network   176

reports
anti-virus   83, 85
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daily   435

daily e-mail   435

IDP   82

reputation filter
anonymizers   292

categories   292

spyware adware keyloggers   292

statistics   78

reset   469

RESET button   469

Restart   470

RFC
1631 (NAT)   146

2131 (DHCP)   109

2132 (DHCP)   109

2402 (AH)   182

2406 (ESP)   182, 195

round robin   135

routing
troubleshooting   463

routing protocols
and Ethernet interfaces   115, 120

RSA   419, 423

rubber feet   54

S

sandboxing
action   324

defend center   321

EICAR test files   322

file submission options   324

log   323

securirty mechanism   321

scan attacks   332

scanner types   319

Scanners   294

schedule
troubleshooting   466

schedules   246

and content filtering   263, 264

and current date/time   246

and policy routes   150

and security policy   214

one-time   247

recurring   247

types of   246

screen resolution   23

Secure Hash Algorithm, see SHA1
Secure Socket Layer, see SSL
security associations, see IPSec
security policy   208

actions   214

and ALG   174

and application patrol   253

and IPSec VPN   465

and logs   214

and NAT   210

and schedules   214

and service groups   213

and service objects   237

and services   213

and user groups   214, 224

and users   214, 224

and zones   208, 212

asymmetrical routes   209, 211

global rules   209

priority   211

rule criteria   209

see also to-Device security policy   208

session limits   222

triangle routes   209, 211

troubleshooting   460

security settings
troubleshooting   460

sensitivity level   221

serial number   62

service control   384

and to-ZyWALL security policy   384

and users   384

timeouts   384

service groups   237

and security policy   213

in IDP   333

service objects   236

and IP protocols   237

and policy routes   237

and security policy   237

service subscription status   102

services   236

and security policy   213

session limits   222

sessions   74
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SHA1   179

shell scripts   438

shutdown   457

signature categories
access control   332

backdoor/Trojan   332

buffer overflow   331

DoS/DDoS   332

P2P   332

scan   332

virus/worm   332

Web attack   331

signature ID   330

signatures
IDP   325

updating   100, 201, 356, 358

Simple Network Management Protocol, see SNMP
SIP

ALG   174

SNAT   146

troubleshooting   463

SNMP   22, 403, 404

agents   404

authentication   408

Get   404

GetNext   404

Manager   404

managers   404

MIB   404, 405

network components   404

Set   404

Trap   404

traps   405

version 3 and security   404

versions   403

Source Network Address Translation, see SNAT
Spam Sources   294

Spam URLs   292

spillover (for load balancing)   136

SQL Injection   295

SQL slammer   336

SSH   385, 386

client requirements   386

encryption methods   386

versions   386

SSL   201, 385

access policy   202

connection monitor   98

see also SSL VPN   201

SSL Inspection
Protocols   343

SSL inspection
Server Signed Certificate Keys   345

SSL policy
objects used   202

SSL VPN   201

access policy   202

full tunnel mode   201

see also SSL   201

startup-config.conf   442

if errors   439

missing at restart   438

present at restart   439

startup-config-bad.conf   439

static routes   145

and interfaces   153

metric   153

statistics
anti-virus   83, 85

daily e-mail report   435

IDP   82

status   61

streaming protocols management   253

subscription services
status   102

supported browsers   23

syslog   432

syslog servers, see also logs
system log, see logs
system name   388

system-default.conf   442

T

TCP   236

connections   236

port numbers   237

throughput rate
troubleshooting   467

time   384

to-Device security policy
and remote management   208
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global rules   208

see also security policy   208

Tor   295

to-ZyWALL security policy
and NAT   161

and NAT traversal (VPN)   465

and service control   384

and VPN   465

trademarks   483

Transmission Control Protocol, see TCP
transmission speed

cable types   46

trapdoor attacks   332

triangle routes   209

allowing through the security policy   211

vs virtual interfaces   209

Triple Data Encryption Standard, see 3DES
trojan attacks   332

troubleshooting   446, 459

anti-virus   460, 461

application patrol   460, 464, 465

certificate   466

connection resets   464

content filter   460

DDNS   463

device access   459

firmware upload   467

FTP   464

IDP   460, 462

Internet access   459, 465

IPSec VPN   464

LEDs   459

logs   467

management access   467

packet capture   467

performance   461, 462

policy routes   460

PPP   461

problems   459

routing   463

schedules   466

security policy   460

security settings   460

SNAT   463

throughput rate   467

VLAN   461

VPN   465

trunks   107, 134

and ALG   174

and policy routes   137, 150

member interface mode   140, 141

see also load balancing   134

Trusted Certificates, see also certificates   420

tunnel encapsulation   195

Tunnel interfaces   107

U

UDP   236

messages   236

port numbers   237

updating
anti-virus signatures   103, 104

signatures   100, 201, 356, 358

upgrading
firmware   444

uploading
configuration files   442

firmware   444

URL Threat Filter   292, 304

Priority   304

user authentication   359

external   360

local user database   370

User Datagram Protocol, see UDP
user group objects   359, 369

user groups   359, 360, 369

and content filtering   264

and policy routes   149, 165, 168

and security policy   214, 224

user name
rules   362

user objects   359, 369

user sessions, see sessions
users   359, 369

access, see also access users
admin (type)   359

admin, see also admin users
and AAA servers   360

and authentication method objects   360

and content filtering   264

and LDAP   360

and policy routes   149, 165, 168

and RADIUS   360
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and security policy   214, 224

and service control   384

attributes for Ext-User   360

default lease time   368

default reauthentication time   368

default type for Ext-User   360

Ext-User (type)   360

ext-user (type)   359

groups, see user groups
lease time   365

lockout   369

reauthentication time   365

types of   359

user (type)   359

user names   362

V

Vantage Report (VRPT)   432

ventilation holes   54

virtual interfaces   107

basic characteristics   107

not DHCP clients   109

vs asymmetrical routes   209

vs triangle routes   209

Virtual Private Network, see VPN
virus   332

attack   311, 332

boot sector   311

e-mail   311

file infector   311

macro   311

mutation   311

polymorphic   311

VLAN
advantages   111

and MAC address   111

ID   111

troubleshooting   461

VLAN interfaces   107, 112

and Ethernet interfaces   112, 461

VoIP pass through
see also ALG   174

VPN   176

active protocol   182

and NAT   181

basic troubleshooting   464

IKE SA, see IKE SA
IPSec   176

IPSec SA
proposal   178

security associations (SA)   184

see also IKE SA
see also IPSec   176

see also IPSec SA
troubleshooting   465

VPN connections
and policy routes   465

VPN gateways
and to-ZyWALL security policy   465

VRPT (Vantage Report)   432

W

wall-mounting   56

warranty   482, 486

note   482, 486

Web attack   331

Web Configurator   21

access   23

requirements   23

supported browsers   23

weighted round robin (for load balancing)   136

Windows Internet Naming Service, see WINS.
WINS   110

Wizard Setup   35

WLAN interfaces   107

worm   311, 332

attacks   332

Z

zones   243

and interfaces   243

and security policy   208, 212

and VPN   243

extra-zone traffic   244

inter-zone traffic   244

intra-zone traffic   244

types of traffic   244
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